1 |
# $Id$ |
2 |
|
3 |
Summary: Basic authentication for the Apache web server using an external program |
4 |
Name: mod_auth_external |
5 |
Version: 2.2.8 |
6 |
Release: 4%{?dist} |
7 |
Group: System Environment/Daemons |
8 |
URL: http://unixpapa.com/mod_auth_external.html |
9 |
Source: mod_auth_external-2.2.8.tar.gz |
10 |
Source2: auth_external.conf |
11 |
Patch0: mod_auth_external-config.patch |
12 |
Patch1: mod_auth_external-no_server_uids.patch |
13 |
License: Apache Software License |
14 |
BuildRoot: %{_tmppath}/%{name}-root |
15 |
BuildPrereq: httpd-devel >= 2.0.40-12 |
16 |
Requires: httpd >= 2.0.40 |
17 |
BuildRequires: pam-devel |
18 |
#Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn) |
19 |
|
20 |
%description |
21 |
mod_auth_external can be used to limit access to documents served by a |
22 |
web server by checking data in an external program. |
23 |
|
24 |
%prep |
25 |
%setup -q -n %{name}-%{version} |
26 |
%patch0 -p1 |
27 |
%patch1 -p1 |
28 |
|
29 |
%build |
30 |
%{_sbindir}/apxs -DAPACHE2 -c %{name}.c |
31 |
mv .libs/%{name}.so . |
32 |
%{__strip} -g %{name}.so |
33 |
%{__cc} -o pwauth/pwauth pwauth/pwauth.c -lpam -ldl |
34 |
%{__strip} pwauth/pwauth |
35 |
|
36 |
%install |
37 |
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
38 |
mkdir -p $RPM_BUILD_ROOT%{_docdir}/mod_auth_external-%{version} |
39 |
mkdir -p $RPM_BUILD_ROOT%{_libdir}/httpd/modules |
40 |
mkdir -p $RPM_BUILD_ROOT/etc/pam.d |
41 |
install -m755 %{name}.so $RPM_BUILD_ROOT%{_libdir}/httpd/modules |
42 |
install -m755 pwauth/pwauth $RPM_BUILD_ROOT%{_libdir}/httpd/modules |
43 |
|
44 |
# Install the config file |
45 |
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d |
46 |
install -m 644 $RPM_SOURCE_DIR/auth_external.conf \ |
47 |
$RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/ |
48 |
mv pwauth/README pwauth/README.pwauth |
49 |
if test -f /lib/security/pam_pwdb.so |
50 |
then |
51 |
cat > ${RPM_BUILD_ROOT}/etc/pam.d/pwauth <<EOF |
52 |
#%PAM-1.0 |
53 |
auth required /lib/security/pam_stack.so service=system-auth |
54 |
auth required /lib/security/pam_nologin.so |
55 |
account required /lib/security/pam_stack.so service=system-auth |
56 |
EOF |
57 |
else |
58 |
cat > ${RPM_BUILD_ROOT}/etc/pam.d/pwauth <<EOF |
59 |
#%PAM-1.0 |
60 |
auth include system-auth |
61 |
auth required pam_nologin.so |
62 |
account include system-auth |
63 |
EOF |
64 |
fi |
65 |
|
66 |
%clean |
67 |
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
68 |
|
69 |
%files |
70 |
%defattr(-,root,root) |
71 |
%doc README INSTALL pwauth/README.pwauth |
72 |
%config %attr(0444,root,root) /etc/pam.d/pwauth |
73 |
%attr(04550,root,www) %{_libdir}/httpd/modules/pwauth |
74 |
%{_libdir}/httpd/modules/*.so |
75 |
%config(noreplace) %{_sysconfdir}/httpd/conf.d/*.conf |
76 |
|
77 |
%changelog |
78 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
79 |
- Clean up spec so package can be built by koji/plague |
80 |
|
81 |
* Thu Mar 22 2007 Charlie Brady <charlieb@e-smith.com> 2.2.8-4 |
82 |
- Conditionally use "include" in pam configuration, rather than pam_stack. |
83 |
Also mark pam config as a config file. [SME: 2551] |
84 |
|
85 |
* Mon Mar 19 2007 Shad L. Lords <slords@mail.com> 2.2.8-3 |
86 |
- Update pam module to use pam_stack with system-auth [SME: 2551] |
87 |
|
88 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
89 |
- Update to new release naming. No functional changes. |
90 |
- Make Packager generic |
91 |
|
92 |
* Mon Mar 20 2006 Charlie Brady <charlieb@e-smith.com> 2.2.8-1sme03 |
93 |
- Remove redundant SERVER_UID checking - that is taken care of by |
94 |
file system permissions. [SME: 1037] |
95 |
|
96 |
* Wed Apr 20 2005 Charlie Brady <charlieb@e-smith.com> 2.2.8-1sme02 |
97 |
- Change group of executable from admin to www, so that both apache |
98 |
instances can authenticate. Add 102 to SERVER_UIDS to cover both |
99 |
newly installed and upgraded systems. |
100 |
|
101 |
* Tue Aug 10 2004 Shad L. Lords <slords@mail.com> |
102 |
- initial package |