1 |
# $Id: mod_auth_external.spec,v 1.2 2008/04/09 13:51:51 slords Exp $ |
2 |
|
3 |
Summary: Basic authentication for the Apache web server using an external program |
4 |
Name: mod_auth_external |
5 |
Version: 2.2.8 |
6 |
Release: 5%{?dist} |
7 |
Group: System Environment/Daemons |
8 |
URL: http://unixpapa.com/mod_auth_external.html |
9 |
Source: mod_auth_external-2.2.8.tar.gz |
10 |
Source2: auth_external.conf |
11 |
Patch0: mod_auth_external-config.patch |
12 |
Patch1: mod_auth_external-no_server_uids.patch |
13 |
License: Apache Software License |
14 |
BuildRoot: %{_tmppath}/%{name}-root |
15 |
BuildPrereq: httpd-devel >= 2.0.40-12 |
16 |
Requires: httpd >= 2.0.40 |
17 |
PreReq: e-smith-lib |
18 |
BuildRequires: pam-devel |
19 |
#Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn) |
20 |
|
21 |
%description |
22 |
mod_auth_external can be used to limit access to documents served by a |
23 |
web server by checking data in an external program. |
24 |
|
25 |
%prep |
26 |
%setup -q -n %{name}-%{version} |
27 |
%patch0 -p1 |
28 |
%patch1 -p1 |
29 |
|
30 |
%build |
31 |
%{_sbindir}/apxs -DAPACHE2 -c %{name}.c |
32 |
mv .libs/%{name}.so . |
33 |
%{__strip} -g %{name}.so |
34 |
%{__cc} -o pwauth/pwauth pwauth/pwauth.c -lpam -ldl |
35 |
%{__strip} pwauth/pwauth |
36 |
|
37 |
%install |
38 |
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
39 |
mkdir -p $RPM_BUILD_ROOT%{_docdir}/mod_auth_external-%{version} |
40 |
mkdir -p $RPM_BUILD_ROOT%{_libdir}/httpd/modules |
41 |
mkdir -p $RPM_BUILD_ROOT/etc/pam.d |
42 |
install -m755 %{name}.so $RPM_BUILD_ROOT%{_libdir}/httpd/modules |
43 |
install -m755 pwauth/pwauth $RPM_BUILD_ROOT%{_libdir}/httpd/modules |
44 |
|
45 |
# Install the config file |
46 |
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d |
47 |
install -m 644 $RPM_SOURCE_DIR/auth_external.conf \ |
48 |
$RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/ |
49 |
mv pwauth/README pwauth/README.pwauth |
50 |
if test -f /lib/security/pam_pwdb.so |
51 |
then |
52 |
cat > ${RPM_BUILD_ROOT}/etc/pam.d/pwauth <<EOF |
53 |
#%PAM-1.0 |
54 |
auth required /lib/security/pam_stack.so service=system-auth |
55 |
auth required /lib/security/pam_nologin.so |
56 |
account required /lib/security/pam_stack.so service=system-auth |
57 |
EOF |
58 |
else |
59 |
cat > ${RPM_BUILD_ROOT}/etc/pam.d/pwauth <<EOF |
60 |
#%PAM-1.0 |
61 |
auth include system-auth |
62 |
auth required pam_nologin.so |
63 |
account include system-auth |
64 |
EOF |
65 |
fi |
66 |
|
67 |
%clean |
68 |
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
69 |
|
70 |
%files |
71 |
%defattr(-,root,root) |
72 |
%doc README INSTALL pwauth/README.pwauth |
73 |
%config %attr(0444,root,root) /etc/pam.d/pwauth |
74 |
%attr(04550,root,www) %{_libdir}/httpd/modules/pwauth |
75 |
%{_libdir}/httpd/modules/*.so |
76 |
%config(noreplace) %{_sysconfdir}/httpd/conf.d/*.conf |
77 |
|
78 |
%changelog |
79 |
* Sun Apr 29 2009 Shad L. Lords <slords@mail.com> 2.2.8-5 |
80 |
- Add requires on e-smith-lib so www user is created first [SME: 5318] |
81 |
|
82 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
83 |
- Clean up spec so package can be built by koji/plague |
84 |
|
85 |
* Thu Mar 22 2007 Charlie Brady <charlieb@e-smith.com> 2.2.8-4 |
86 |
- Conditionally use "include" in pam configuration, rather than pam_stack. |
87 |
Also mark pam config as a config file. [SME: 2551] |
88 |
|
89 |
* Mon Mar 19 2007 Shad L. Lords <slords@mail.com> 2.2.8-3 |
90 |
- Update pam module to use pam_stack with system-auth [SME: 2551] |
91 |
|
92 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
93 |
- Update to new release naming. No functional changes. |
94 |
- Make Packager generic |
95 |
|
96 |
* Mon Mar 20 2006 Charlie Brady <charlieb@e-smith.com> 2.2.8-1sme03 |
97 |
- Remove redundant SERVER_UID checking - that is taken care of by |
98 |
file system permissions. [SME: 1037] |
99 |
|
100 |
* Wed Apr 20 2005 Charlie Brady <charlieb@e-smith.com> 2.2.8-1sme02 |
101 |
- Change group of executable from admin to www, so that both apache |
102 |
instances can authenticate. Add 102 to SERVER_UIDS to cover both |
103 |
newly installed and upgraded systems. |
104 |
|
105 |
* Tue Aug 10 2004 Shad L. Lords <slords@mail.com> |
106 |
- initial package |