/[smeserver]/rpms/mod_auth_tkt/sme10/mod_auth_tkt.spec
ViewVC logotype

Annotation of /rpms/mod_auth_tkt/sme10/mod_auth_tkt.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Tue Mar 15 20:56:49 2016 UTC (8 years, 2 months ago) by vip-ire
Branch: MAIN
Changes since 1.2: +2 -2 lines
Bump release

1 vip-ire 1.1
2     # Use "--define='apache 1'" to build a 'mod_auth_tkt1' package for apache1
3     %define httpd httpd
4     %define name mod_auth_tkt
5     %if 0%{?rhel} < 7
6 vip-ire 1.2 %global apxs /usr/sbin/apxs
7 vip-ire 1.1 %else
8 vip-ire 1.2 %global apxs /usr/bin/apxs
9 vip-ire 1.1 %endif
10     %{?apache:%define httpd apache}
11     %{?apache:%define name mod_auth_tkt1}
12     %{?apache:%define apxs /usr/sbin/apxs1}
13    
14     %define perl_vendorlib %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
15    
16     Summary: Lightweight ticket-based authentication module for Apache.
17     Name: %{name}
18     Version: 2.3.99b1
19 vip-ire 1.3 Release: 2%{?dist}
20 vip-ire 1.1 License: Apache
21     Group: Applications/System
22     Source: http://www.openfusion.com.au/labs/dist/mod_auth_tkt-%{version}.tar.gz
23     URL: http://www.openfusion.com.au/labs/mod_auth_tkt/
24     Buildroot: %_tmppath/%{name}-%{version}
25     Requires: %{httpd}
26     BuildRequires: %{httpd}-devel
27    
28     %description
29     mod_auth_tkt provides lightweight, repository-agnostic, ticket-based
30     authentication for Apache. It implements a single-signon framework that
31     works across multiple apache instances and multiple machines. The actual
32     authentication requires a user-supplied CGI or script of some kind - see
33     the mod_auth_tkt-cgi package for perl cgi versions.
34    
35     %package cgi
36     Release: 1%{?org_tag}%{?dist}
37     Summary: CGI scripts for mod_auth_tkt apache authentication modules.
38     Group: Applications/System
39     Requires: %{name} = %{version}
40    
41     %description cgi
42     Perl CGI scripts for use with mod_auth_tkt.
43    
44    
45     %prep
46     %setup -n mod_auth_tkt-%{version}
47    
48     %build
49     test %{debug} == 1 && DEBUG='--debug'
50     MOD_PERL=`rpm -q mod_perl | grep '^mod_perl' || /bin/true`
51     if [ -n "$MOD_PERL" -a %{test} == 1 ]; then
52     ./configure --apxs=%{apxs} --test $DEBUG
53     make
54     make test
55     else
56     ./configure --apxs=%{apxs} $DEBUG
57     make
58     fi
59    
60     %install
61     test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
62     mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules
63     mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d
64     #mkdir -p $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi
65     mkdir -p $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/contrib
66     mkdir -p $RPM_BUILD_ROOT/var/www/auth
67     #mkdir -p $RPM_BUILD_ROOT/%{perl_vendorlib}/Apache
68     if [ %{httpd} == apache ]; then
69     %{apxs} -i -n "auth_tkt" -S LIBEXECDIR=$RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules src/mod_auth_tkt.so
70     else
71     %{apxs} -i -n "auth_tkt" -S LIBEXECDIR=$RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules src/mod_auth_tkt.la
72     fi
73     install -m 644 conf/02_auth_tkt.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d/
74     install -m 644 conf/auth_tkt_cgi.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d/
75     #cp cgi/Apache/* $RPM_BUILD_ROOT/%{perl_vendorlib}/Apache
76     #cp -pr cgi/* $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi
77     #rm -rf $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi/Apache
78     cp -pr cgi/* $RPM_BUILD_ROOT/var/www/auth
79     rm -rf $RPM_BUILD_ROOT/var/www/auth/Apache
80     cp -pr contrib/* $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/contrib
81     rm -rf $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/contrib/t
82     cp -pr README* INSTALL LICENSE CREDITS $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}
83     cd doc
84     make DESTDIR=$RPM_BUILD_ROOT install
85    
86     %clean
87     test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
88    
89     %files
90     %defattr(-,root,root)
91     %{_libdir}/%{httpd}
92     #%{perl_vendorlib}/Apache/AuthTkt.pm
93     %doc /usr/share/doc/%{name}-%{version}
94     %attr(0640,root,apache) %config(noreplace) %{_sysconfdir}/%{httpd}/conf.d/02_auth_tkt.conf
95     /usr/share/man/*/*
96    
97     %files cgi
98     %defattr(-,root,root)
99     %attr(0640,root,apache) %config(noreplace) %{_sysconfdir}/%{httpd}/conf.d/auth_tkt_cgi.conf
100     %config(noreplace)/var/www/auth/AuthTktConfig.pm
101     %config(noreplace)/var/www/auth/tkt.css
102     /var/www/auth/*.cgi
103    
104     %changelog
105 vip-ire 1.3 * Tue Mar 15 2016 Daniel Berteaud <daniel@firewall-services.com> 2.3.99b1-2
106 vip-ire 1.2 - Tweaks in spec file so it can build in mock/plague [SME: 9310]
107    
108 vip-ire 1.1 * Fri Jul 31 2015 Gavin Carr <gavin@openfusion.com.au> 2.3.99b1-1
109     - Update to version 2.3.99b1, 2.4 release beta1.
110    
111     * Fri Jul 10 2009 Gavin Carr <gavin@openfusion.com.au> 2.1.0
112     - Bump version number to 2.1.0 for final 2.1 release.
113    
114     * Sat Mar 28 2009 Gavin Carr <gavin@openfusion.com.au> 2.0.99b2
115     - Bump version number to 2.0.99b2, second beta release of 2.1 branch.
116     - Fix bug with partial-cookie-names incorrectly matching.
117    
118     * Thu Mar 05 2009 Gavin Carr <gavin@openfusion.com.au> 2.0.99b1
119     - Bump version number to 2.0.99b1, first beta release of 2.1 branch.
120     - Add support for SHA256 digests.
121     - Add TKTAuthSecretOld support.
122    
123     * Fri Feb 27 2009 Gavin Carr <gavin@openfusion.com.au> 2.0.0-1
124     - Bump to final version 2.0.0.
125    
126     * Fri Feb 27 2009 Gavin Carr <gavin@openfusion.com.au> 2.0.0-1
127     - Bump to final version 2.0.0.
128    
129     * Tue Mar 04 2008 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc4-1
130     - Bump to version 2.0.0rc4.
131    
132     * Tue Mar 04 2008 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc3-1
133     - Set explicit servername in t/TESTS to fix general test failures.
134     - Add explicit Apache 2.2 support.
135     - Add separate mod_auth_tkt-cgi package containing /var/www/auth CGI scripts.
136     - Factor out cgi config settings into AuthTktConfig.pm.
137     - Bump to version 2.0.0rc3.
138    
139     * Wed Nov 28 2006 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc2
140     - Bump to version 2.0.0rc2.
141    
142     * Wed Nov 01 2006 Charlie Brady <charlie_brady@mitel.com> 2.0.0rc1-2
143     - Move Apache::AuthTkt into perl's vendorarch directory.
144    
145     * Mon Apr 10 2006 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc1
146     - Add mod_auth_tkt man page.
147     - Add TKTAuthDebug support, instead of compile-time debug flag.
148     - Add TKTAuthPostTimeoutURL support (Michael Peters).
149    
150     * Mon Oct 24 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b7
151     - Deprecate TKTAuthTimeoutMin, replacing with TKTAuthTimeout, using units like
152     TKTAuthCookieExpires.
153     - Split out TKTAuthCookieSecure functionality from TKTAuthRequireSSL (Larry
154     Lansing).
155     - Add TKTAuthCookieExpires directive for guest cookies and refreshes.
156     - Add TKTAuthGuestUser %U format support for UUIDs with Apache 2.
157     - Add TKTAuthGuestUser support for setting guest user explicitly.
158     - Fix URI and HTML escaping issues with cgi scripts (Viljo Viitanen).
159     - Update CGI scripts to get local settings via Apache::AuthTkt parse_conf values.
160     - Update Apache::AuthTkt to new version (0.03) with parse_conf support.
161     - Add server config merge support to allow global secrets with vhosts.
162    
163     * Mon Aug 01 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b6
164     - Update specfile to support basic building against apache 1.
165     - Fixed bug with non-base64 quoted ticket values not being parsed correctly.
166    
167     * Tue Jun 14 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b5
168     - Change back url formation to use Host header, not server name/port.
169     - Get cookie_match to skip empty cookies it finds (e.g. logout misconfigs).
170     - Add Ian Bicking's AuthTicket python class in contrib.
171     - Add TKTAuthGuestLogin support based on patch from Ian Bicking.
172     - Add DEBUG_VERBOSE support based on patch from Ian Bicking.
173     - Fixed bug with test harness not generating local module correctly.
174    
175     * Mon May 30 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b4
176     - Change build to include 'make test' only if mod_perl is available.
177    
178     * Sat Apr 30 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b3
179    
180     * Thu Feb 21 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b2
181     - Initial release.
182    
183    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed