/[smeserver]/rpms/mod_auth_tkt/sme10/mod_auth_tkt.spec
ViewVC logotype

Annotation of /rpms/mod_auth_tkt/sme10/mod_auth_tkt.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Tue Mar 15 20:59:18 2016 UTC (8 years, 2 months ago) by vip-ire
Branch: MAIN
CVS Tags: mod_auth_tkt-2_3_99b1-2_el7_sme
Changes since 1.3: +1 -5 lines
Unconditionaly build for el7

1 vip-ire 1.1
2     # Use "--define='apache 1'" to build a 'mod_auth_tkt1' package for apache1
3     %define httpd httpd
4     %define name mod_auth_tkt
5 vip-ire 1.4 %define apxs /usr/bin/apxs
6 vip-ire 1.1 %{?apache:%define httpd apache}
7     %{?apache:%define name mod_auth_tkt1}
8     %{?apache:%define apxs /usr/sbin/apxs1}
9    
10     %define perl_vendorlib %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
11    
12     Summary: Lightweight ticket-based authentication module for Apache.
13     Name: %{name}
14     Version: 2.3.99b1
15 vip-ire 1.3 Release: 2%{?dist}
16 vip-ire 1.1 License: Apache
17     Group: Applications/System
18     Source: http://www.openfusion.com.au/labs/dist/mod_auth_tkt-%{version}.tar.gz
19     URL: http://www.openfusion.com.au/labs/mod_auth_tkt/
20     Buildroot: %_tmppath/%{name}-%{version}
21     Requires: %{httpd}
22     BuildRequires: %{httpd}-devel
23    
24     %description
25     mod_auth_tkt provides lightweight, repository-agnostic, ticket-based
26     authentication for Apache. It implements a single-signon framework that
27     works across multiple apache instances and multiple machines. The actual
28     authentication requires a user-supplied CGI or script of some kind - see
29     the mod_auth_tkt-cgi package for perl cgi versions.
30    
31     %package cgi
32     Release: 1%{?org_tag}%{?dist}
33     Summary: CGI scripts for mod_auth_tkt apache authentication modules.
34     Group: Applications/System
35     Requires: %{name} = %{version}
36    
37     %description cgi
38     Perl CGI scripts for use with mod_auth_tkt.
39    
40    
41     %prep
42     %setup -n mod_auth_tkt-%{version}
43    
44     %build
45     test %{debug} == 1 && DEBUG='--debug'
46     MOD_PERL=`rpm -q mod_perl | grep '^mod_perl' || /bin/true`
47     if [ -n "$MOD_PERL" -a %{test} == 1 ]; then
48     ./configure --apxs=%{apxs} --test $DEBUG
49     make
50     make test
51     else
52     ./configure --apxs=%{apxs} $DEBUG
53     make
54     fi
55    
56     %install
57     test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
58     mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules
59     mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d
60     #mkdir -p $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi
61     mkdir -p $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/contrib
62     mkdir -p $RPM_BUILD_ROOT/var/www/auth
63     #mkdir -p $RPM_BUILD_ROOT/%{perl_vendorlib}/Apache
64     if [ %{httpd} == apache ]; then
65     %{apxs} -i -n "auth_tkt" -S LIBEXECDIR=$RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules src/mod_auth_tkt.so
66     else
67     %{apxs} -i -n "auth_tkt" -S LIBEXECDIR=$RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules src/mod_auth_tkt.la
68     fi
69     install -m 644 conf/02_auth_tkt.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d/
70     install -m 644 conf/auth_tkt_cgi.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d/
71     #cp cgi/Apache/* $RPM_BUILD_ROOT/%{perl_vendorlib}/Apache
72     #cp -pr cgi/* $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi
73     #rm -rf $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi/Apache
74     cp -pr cgi/* $RPM_BUILD_ROOT/var/www/auth
75     rm -rf $RPM_BUILD_ROOT/var/www/auth/Apache
76     cp -pr contrib/* $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/contrib
77     rm -rf $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/contrib/t
78     cp -pr README* INSTALL LICENSE CREDITS $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}
79     cd doc
80     make DESTDIR=$RPM_BUILD_ROOT install
81    
82     %clean
83     test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
84    
85     %files
86     %defattr(-,root,root)
87     %{_libdir}/%{httpd}
88     #%{perl_vendorlib}/Apache/AuthTkt.pm
89     %doc /usr/share/doc/%{name}-%{version}
90     %attr(0640,root,apache) %config(noreplace) %{_sysconfdir}/%{httpd}/conf.d/02_auth_tkt.conf
91     /usr/share/man/*/*
92    
93     %files cgi
94     %defattr(-,root,root)
95     %attr(0640,root,apache) %config(noreplace) %{_sysconfdir}/%{httpd}/conf.d/auth_tkt_cgi.conf
96     %config(noreplace)/var/www/auth/AuthTktConfig.pm
97     %config(noreplace)/var/www/auth/tkt.css
98     /var/www/auth/*.cgi
99    
100     %changelog
101 vip-ire 1.3 * Tue Mar 15 2016 Daniel Berteaud <daniel@firewall-services.com> 2.3.99b1-2
102 vip-ire 1.2 - Tweaks in spec file so it can build in mock/plague [SME: 9310]
103    
104 vip-ire 1.1 * Fri Jul 31 2015 Gavin Carr <gavin@openfusion.com.au> 2.3.99b1-1
105     - Update to version 2.3.99b1, 2.4 release beta1.
106    
107     * Fri Jul 10 2009 Gavin Carr <gavin@openfusion.com.au> 2.1.0
108     - Bump version number to 2.1.0 for final 2.1 release.
109    
110     * Sat Mar 28 2009 Gavin Carr <gavin@openfusion.com.au> 2.0.99b2
111     - Bump version number to 2.0.99b2, second beta release of 2.1 branch.
112     - Fix bug with partial-cookie-names incorrectly matching.
113    
114     * Thu Mar 05 2009 Gavin Carr <gavin@openfusion.com.au> 2.0.99b1
115     - Bump version number to 2.0.99b1, first beta release of 2.1 branch.
116     - Add support for SHA256 digests.
117     - Add TKTAuthSecretOld support.
118    
119     * Fri Feb 27 2009 Gavin Carr <gavin@openfusion.com.au> 2.0.0-1
120     - Bump to final version 2.0.0.
121    
122     * Fri Feb 27 2009 Gavin Carr <gavin@openfusion.com.au> 2.0.0-1
123     - Bump to final version 2.0.0.
124    
125     * Tue Mar 04 2008 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc4-1
126     - Bump to version 2.0.0rc4.
127    
128     * Tue Mar 04 2008 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc3-1
129     - Set explicit servername in t/TESTS to fix general test failures.
130     - Add explicit Apache 2.2 support.
131     - Add separate mod_auth_tkt-cgi package containing /var/www/auth CGI scripts.
132     - Factor out cgi config settings into AuthTktConfig.pm.
133     - Bump to version 2.0.0rc3.
134    
135     * Wed Nov 28 2006 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc2
136     - Bump to version 2.0.0rc2.
137    
138     * Wed Nov 01 2006 Charlie Brady <charlie_brady@mitel.com> 2.0.0rc1-2
139     - Move Apache::AuthTkt into perl's vendorarch directory.
140    
141     * Mon Apr 10 2006 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc1
142     - Add mod_auth_tkt man page.
143     - Add TKTAuthDebug support, instead of compile-time debug flag.
144     - Add TKTAuthPostTimeoutURL support (Michael Peters).
145    
146     * Mon Oct 24 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b7
147     - Deprecate TKTAuthTimeoutMin, replacing with TKTAuthTimeout, using units like
148     TKTAuthCookieExpires.
149     - Split out TKTAuthCookieSecure functionality from TKTAuthRequireSSL (Larry
150     Lansing).
151     - Add TKTAuthCookieExpires directive for guest cookies and refreshes.
152     - Add TKTAuthGuestUser %U format support for UUIDs with Apache 2.
153     - Add TKTAuthGuestUser support for setting guest user explicitly.
154     - Fix URI and HTML escaping issues with cgi scripts (Viljo Viitanen).
155     - Update CGI scripts to get local settings via Apache::AuthTkt parse_conf values.
156     - Update Apache::AuthTkt to new version (0.03) with parse_conf support.
157     - Add server config merge support to allow global secrets with vhosts.
158    
159     * Mon Aug 01 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b6
160     - Update specfile to support basic building against apache 1.
161     - Fixed bug with non-base64 quoted ticket values not being parsed correctly.
162    
163     * Tue Jun 14 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b5
164     - Change back url formation to use Host header, not server name/port.
165     - Get cookie_match to skip empty cookies it finds (e.g. logout misconfigs).
166     - Add Ian Bicking's AuthTicket python class in contrib.
167     - Add TKTAuthGuestLogin support based on patch from Ian Bicking.
168     - Add DEBUG_VERBOSE support based on patch from Ian Bicking.
169     - Fixed bug with test harness not generating local module correctly.
170    
171     * Mon May 30 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b4
172     - Change build to include 'make test' only if mod_perl is available.
173    
174     * Sat Apr 30 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b3
175    
176     * Thu Feb 21 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b2
177     - Initial release.
178    
179    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed