1 |
|
2 |
# Use "--define='apache 1'" to build a 'mod_auth_tkt1' package for apache1 |
3 |
%define httpd httpd |
4 |
%define name mod_auth_tkt |
5 |
%define apxs /usr/bin/apxs |
6 |
%{?apache:%define httpd apache} |
7 |
%{?apache:%define name mod_auth_tkt1} |
8 |
%{?apache:%define apxs /usr/sbin/apxs1} |
9 |
|
10 |
%define perl_vendorlib %(eval "`perl -V:installvendorlib`"; echo $installvendorlib) |
11 |
|
12 |
Summary: Lightweight ticket-based authentication module for Apache. |
13 |
Name: %{name} |
14 |
Version: 2.3.99b1 |
15 |
Release: 3%{?dist} |
16 |
License: Apache |
17 |
Group: Applications/System |
18 |
Source: http://www.openfusion.com.au/labs/dist/mod_auth_tkt-%{version}.tar.gz |
19 |
Patch0: mod_auth_tkt-2.3.99b1-betterredirection.patch |
20 |
URL: http://www.openfusion.com.au/labs/mod_auth_tkt/ |
21 |
Buildroot: %_tmppath/%{name}-%{version} |
22 |
Requires: %{httpd} |
23 |
BuildRequires: %{httpd}-devel |
24 |
|
25 |
%description |
26 |
mod_auth_tkt provides lightweight, repository-agnostic, ticket-based |
27 |
authentication for Apache. It implements a single-signon framework that |
28 |
works across multiple apache instances and multiple machines. The actual |
29 |
authentication requires a user-supplied CGI or script of some kind - see |
30 |
the mod_auth_tkt-cgi package for perl cgi versions. |
31 |
|
32 |
%package cgi |
33 |
Release: 1%{?org_tag}%{?dist} |
34 |
Summary: CGI scripts for mod_auth_tkt apache authentication modules. |
35 |
Group: Applications/System |
36 |
Requires: %{name} = %{version} |
37 |
|
38 |
%description cgi |
39 |
Perl CGI scripts for use with mod_auth_tkt. |
40 |
|
41 |
|
42 |
%prep |
43 |
%setup -n mod_auth_tkt-%{version} |
44 |
%patch0 -p1 |
45 |
|
46 |
%build |
47 |
test %{debug} == 1 && DEBUG='--debug' |
48 |
MOD_PERL=`rpm -q mod_perl | grep '^mod_perl' || /bin/true` |
49 |
if [ -n "$MOD_PERL" -a %{test} == 1 ]; then |
50 |
./configure --apxs=%{apxs} --test $DEBUG |
51 |
make |
52 |
make test |
53 |
else |
54 |
./configure --apxs=%{apxs} $DEBUG |
55 |
make |
56 |
fi |
57 |
|
58 |
%install |
59 |
test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT |
60 |
mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules |
61 |
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d |
62 |
#mkdir -p $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi |
63 |
mkdir -p $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/contrib |
64 |
mkdir -p $RPM_BUILD_ROOT/var/www/auth |
65 |
#mkdir -p $RPM_BUILD_ROOT/%{perl_vendorlib}/Apache |
66 |
if [ %{httpd} == apache ]; then |
67 |
%{apxs} -i -n "auth_tkt" -S LIBEXECDIR=$RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules src/mod_auth_tkt.so |
68 |
else |
69 |
%{apxs} -i -n "auth_tkt" -S LIBEXECDIR=$RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules src/mod_auth_tkt.la |
70 |
fi |
71 |
install -m 644 conf/02_auth_tkt.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d/ |
72 |
install -m 644 conf/auth_tkt_cgi.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d/ |
73 |
#cp cgi/Apache/* $RPM_BUILD_ROOT/%{perl_vendorlib}/Apache |
74 |
#cp -pr cgi/* $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi |
75 |
#rm -rf $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi/Apache |
76 |
cp -pr cgi/* $RPM_BUILD_ROOT/var/www/auth |
77 |
rm -rf $RPM_BUILD_ROOT/var/www/auth/Apache |
78 |
cp -pr contrib/* $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/contrib |
79 |
rm -rf $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/contrib/t |
80 |
cp -pr README* INSTALL LICENSE CREDITS $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version} |
81 |
cd doc |
82 |
make DESTDIR=$RPM_BUILD_ROOT install |
83 |
|
84 |
%clean |
85 |
test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT |
86 |
|
87 |
%files |
88 |
%defattr(-,root,root) |
89 |
%{_libdir}/%{httpd} |
90 |
#%{perl_vendorlib}/Apache/AuthTkt.pm |
91 |
%doc /usr/share/doc/%{name}-%{version} |
92 |
%attr(0640,root,apache) %config(noreplace) %{_sysconfdir}/%{httpd}/conf.d/02_auth_tkt.conf |
93 |
/usr/share/man/*/* |
94 |
|
95 |
%files cgi |
96 |
%defattr(-,root,root) |
97 |
%attr(0640,root,apache) %config(noreplace) %{_sysconfdir}/%{httpd}/conf.d/auth_tkt_cgi.conf |
98 |
%config(noreplace)/var/www/auth/AuthTktConfig.pm |
99 |
%config(noreplace)/var/www/auth/tkt.css |
100 |
/var/www/auth/*.cgi |
101 |
|
102 |
%changelog |
103 |
* Mon Jun 13 2016 JP Pialasse <tests@pialasse.com> 2.3.99b1-3 |
104 |
- fix redirection when proxy ssl [SME: 8825] [SME: 9583] |
105 |
|
106 |
* Tue Mar 15 2016 Daniel Berteaud <daniel@firewall-services.com> 2.3.99b1-2 |
107 |
- Tweaks in spec file so it can build in mock/plague [SME: 9310] |
108 |
|
109 |
* Fri Jul 31 2015 Gavin Carr <gavin@openfusion.com.au> 2.3.99b1-1 |
110 |
- Update to version 2.3.99b1, 2.4 release beta1. |
111 |
|
112 |
* Fri Jul 10 2009 Gavin Carr <gavin@openfusion.com.au> 2.1.0 |
113 |
- Bump version number to 2.1.0 for final 2.1 release. |
114 |
|
115 |
* Sat Mar 28 2009 Gavin Carr <gavin@openfusion.com.au> 2.0.99b2 |
116 |
- Bump version number to 2.0.99b2, second beta release of 2.1 branch. |
117 |
- Fix bug with partial-cookie-names incorrectly matching. |
118 |
|
119 |
* Thu Mar 05 2009 Gavin Carr <gavin@openfusion.com.au> 2.0.99b1 |
120 |
- Bump version number to 2.0.99b1, first beta release of 2.1 branch. |
121 |
- Add support for SHA256 digests. |
122 |
- Add TKTAuthSecretOld support. |
123 |
|
124 |
* Fri Feb 27 2009 Gavin Carr <gavin@openfusion.com.au> 2.0.0-1 |
125 |
- Bump to final version 2.0.0. |
126 |
|
127 |
* Fri Feb 27 2009 Gavin Carr <gavin@openfusion.com.au> 2.0.0-1 |
128 |
- Bump to final version 2.0.0. |
129 |
|
130 |
* Tue Mar 04 2008 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc4-1 |
131 |
- Bump to version 2.0.0rc4. |
132 |
|
133 |
* Tue Mar 04 2008 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc3-1 |
134 |
- Set explicit servername in t/TESTS to fix general test failures. |
135 |
- Add explicit Apache 2.2 support. |
136 |
- Add separate mod_auth_tkt-cgi package containing /var/www/auth CGI scripts. |
137 |
- Factor out cgi config settings into AuthTktConfig.pm. |
138 |
- Bump to version 2.0.0rc3. |
139 |
|
140 |
* Wed Nov 28 2006 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc2 |
141 |
- Bump to version 2.0.0rc2. |
142 |
|
143 |
* Wed Nov 01 2006 Charlie Brady <charlie_brady@mitel.com> 2.0.0rc1-2 |
144 |
- Move Apache::AuthTkt into perl's vendorarch directory. |
145 |
|
146 |
* Mon Apr 10 2006 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc1 |
147 |
- Add mod_auth_tkt man page. |
148 |
- Add TKTAuthDebug support, instead of compile-time debug flag. |
149 |
- Add TKTAuthPostTimeoutURL support (Michael Peters). |
150 |
|
151 |
* Mon Oct 24 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b7 |
152 |
- Deprecate TKTAuthTimeoutMin, replacing with TKTAuthTimeout, using units like |
153 |
TKTAuthCookieExpires. |
154 |
- Split out TKTAuthCookieSecure functionality from TKTAuthRequireSSL (Larry |
155 |
Lansing). |
156 |
- Add TKTAuthCookieExpires directive for guest cookies and refreshes. |
157 |
- Add TKTAuthGuestUser %U format support for UUIDs with Apache 2. |
158 |
- Add TKTAuthGuestUser support for setting guest user explicitly. |
159 |
- Fix URI and HTML escaping issues with cgi scripts (Viljo Viitanen). |
160 |
- Update CGI scripts to get local settings via Apache::AuthTkt parse_conf values. |
161 |
- Update Apache::AuthTkt to new version (0.03) with parse_conf support. |
162 |
- Add server config merge support to allow global secrets with vhosts. |
163 |
|
164 |
* Mon Aug 01 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b6 |
165 |
- Update specfile to support basic building against apache 1. |
166 |
- Fixed bug with non-base64 quoted ticket values not being parsed correctly. |
167 |
|
168 |
* Tue Jun 14 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b5 |
169 |
- Change back url formation to use Host header, not server name/port. |
170 |
- Get cookie_match to skip empty cookies it finds (e.g. logout misconfigs). |
171 |
- Add Ian Bicking's AuthTicket python class in contrib. |
172 |
- Add TKTAuthGuestLogin support based on patch from Ian Bicking. |
173 |
- Add DEBUG_VERBOSE support based on patch from Ian Bicking. |
174 |
- Fixed bug with test harness not generating local module correctly. |
175 |
|
176 |
* Mon May 30 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b4 |
177 |
- Change build to include 'make test' only if mod_perl is available. |
178 |
|
179 |
* Sat Apr 30 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b3 |
180 |
|
181 |
* Thu Feb 21 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b2 |
182 |
- Initial release. |
183 |
|
184 |
|