/[smeserver]/rpms/mod_auth_tkt/sme7/mod_auth_tkt.spec
ViewVC logotype

Annotation of /rpms/mod_auth_tkt/sme7/mod_auth_tkt.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Jun 12 16:39:14 2007 UTC (17 years ago) by slords
Branch: MAIN
CVS Tags: mod_auth_tkt-2_0_0rc2-1_el4_sme
Import on branch sme7 of package mod_auth_tkt-2.0.0rc2-1.el4.sme.src.rpm

1 slords 1.1
2     # Use "--define='apache 1'" to build an 'mod_auth_tkt1' package for apache1
3     %define httpd httpd
4     %define name mod_auth_tkt
5     %{?apache:%define httpd apache}
6     %{?apache:%define name mod_auth_tkt1}
7    
8     Summary: Lightweight ticket-based authentication module for Apache.
9     Name: %{name}
10     Version: 2.0.0rc2
11     Release: 1%{?dist}
12     License: GPL
13     Group: Applications/System
14     Source: http://www.openfusion.com.au/labs/dist/mod_auth_tkt-%{version}.tar.gz
15     URL: http://www.openfusion.com.au/labs/nagios-of-plugins/
16     Buildroot: %_tmppath/%{name}-%{version}
17     Requires: %{httpd}
18     BuildRequires: %{httpd}-devel
19     BuildRequires: pcre-devel
20     AutoReq: no
21    
22     %description
23     mod_auth_tkt provides lightweight, repository-agnostic, ticket-based
24     authentication for Apache. It implements a single-signon framework that
25     works across multiple apache instances and multiple machines. The actual
26     authentication requires a user-supplied CGI or script of some kind - the
27     package includes example CGI scripts in Perl.
28    
29     %prep
30     %setup -n mod_auth_tkt-%{version}
31    
32     %build
33     test %{httpd} == apache && APXS='--apxs=/usr/sbin/apxs1'
34     test %{debug} == 1 && DEBUG='--debug'
35     MOD_PERL=`rpm -q mod_perl | grep '^mod_perl' || /bin/true`
36     if [ -n "$MOD_PERL" -a %{test} == 1 ]; then
37     ./configure --test $DEBUG
38     make
39     make test
40     else
41     ./configure $APXS $DEBUG
42     make
43     fi
44    
45     %install
46     test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
47     mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules
48     mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d
49     mkdir -p $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi
50     mkdir -p $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/contrib
51     if [ %{httpd} == apache ]; then
52     /usr/sbin/apxs1 -i -n "auth_tkt" -S LIBEXECDIR=$RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules src/mod_auth_tkt.so
53     else
54     /usr/sbin/apxs -i -n "auth_tkt" -S LIBEXECDIR=$RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules src/mod_auth_tkt.la
55     fi
56     install -m 644 conf/02_auth_tkt.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d/
57     cp -pr cgi/* $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi
58     rm -r $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi/Apache
59     mkdir -p $RPM_BUILD_ROOT/%{perl_vendorarch}/Apache
60     cp cgi/Apache/* $RPM_BUILD_ROOT/%{perl_vendorarch}/Apache
61     cp -pr contrib/* $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/contrib
62     cp -pr README* INSTALL LICENSE ChangeLog CREDITS $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}
63     cd doc
64     make DESTDIR=$RPM_BUILD_ROOT install
65    
66     %clean
67     test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
68    
69     %files
70     %defattr(-,root,root)
71     %{_libdir}/%{httpd}
72     %{perl_vendorarch}/Apache/AuthTkt.pm
73     %doc /usr/share/doc/%{name}-%{version}
74     %attr(0640,root,apache) %config(noreplace) %{_sysconfdir}/%{httpd}/conf.d/*
75     /usr/share/man/*
76    
77     %changelog
78     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
79     - Clean up spec so package can be built by koji/plague
80    
81     * Wed Nov 28 2006 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc2
82     - Bump to version 2.0.0rc2.
83    
84     * Wed Nov 01 2006 Charlie Brady <charlie_brady@mitel.com> 2.0.0rc1-2
85     - Move Apache::AuthTkt into perl's vendorarch directory.
86    
87     * Mon Apr 10 2006 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc1
88     - Add mod_auth_tkt man page.
89     - Add TKTAuthDebug support, instead of compile-time debug flag.
90     - Add TKTAuthPostTimeoutURL support (Michael Peters).
91    
92     * Mon Oct 24 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b7
93     - Deprecate TKTAuthTimeoutMin, replacing with TKTAuthTimeout, using units like
94     TKTAuthCookieExpires.
95     - Split out TKTAuthCookieSecure functionality from TKTAuthRequireSSL (Larry
96     Lansing).
97     - Add TKTAuthCookieExpires directive for guest cookies and refreshes.
98     - Add TKTAuthGuestUser %U format support for UUIDs with Apache 2.
99     - Add TKTAuthGuestUser support for setting guest user explicitly.
100     - Fix URI and HTML escaping issues with cgi scripts (Viljo Viitanen).
101     - Update CGI scripts to get local settings via Apache::AuthTkt parse_conf values.
102     - Update Apache::AuthTkt to new version (0.03) with parse_conf support.
103     - Add server config merge support to allow global secrets with vhosts.
104    
105     * Mon Aug 01 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b6
106     - Update specfile to support basic building against apache 1.
107     - Fixed bug with non-base64 quoted ticket values not being parsed correctly.
108    
109     * Tue Jun 14 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b5
110     - Change back url formation to use Host header, not server name/port.
111     - Get cookie_match to skip empty cookies it finds (e.g. logout misconfigs).
112     - Add Ian Bicking's AuthTicket python class in contrib.
113     - Add TKTAuthGuestLogin support based on patch from Ian Bicking.
114     - Add DEBUG_VERBOSE support based on patch from Ian Bicking.
115     - Fixed bug with test harness not generating local module correctly.
116    
117     * Mon May 30 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b4
118     - Change build to include 'make test' only if mod_perl is available.
119    
120     * Sat Apr 30 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b3
121    
122     * Thu Feb 21 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b2
123     - Initial release.
124    
125    
126     # arch-tag: 56c36703-99d8-409e-97dc-1b81e565b29a

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed