1 |
slords |
1.2 |
# $Id$ |
2 |
|
|
|
3 |
slords |
1.1 |
|
4 |
|
|
# Use "--define='apache 1'" to build an 'mod_auth_tkt1' package for apache1 |
5 |
|
|
%define httpd httpd |
6 |
|
|
%define name mod_auth_tkt |
7 |
|
|
%{?apache:%define httpd apache} |
8 |
|
|
%{?apache:%define name mod_auth_tkt1} |
9 |
|
|
|
10 |
|
|
Summary: Lightweight ticket-based authentication module for Apache. |
11 |
|
|
Name: %{name} |
12 |
|
|
Version: 2.0.0rc2 |
13 |
|
|
Release: 1%{?dist} |
14 |
|
|
License: GPL |
15 |
|
|
Group: Applications/System |
16 |
|
|
Source: http://www.openfusion.com.au/labs/dist/mod_auth_tkt-%{version}.tar.gz |
17 |
|
|
URL: http://www.openfusion.com.au/labs/nagios-of-plugins/ |
18 |
|
|
Buildroot: %_tmppath/%{name}-%{version} |
19 |
|
|
Requires: %{httpd} |
20 |
|
|
BuildRequires: %{httpd}-devel |
21 |
|
|
BuildRequires: pcre-devel |
22 |
|
|
AutoReq: no |
23 |
|
|
|
24 |
|
|
%description |
25 |
|
|
mod_auth_tkt provides lightweight, repository-agnostic, ticket-based |
26 |
|
|
authentication for Apache. It implements a single-signon framework that |
27 |
|
|
works across multiple apache instances and multiple machines. The actual |
28 |
|
|
authentication requires a user-supplied CGI or script of some kind - the |
29 |
|
|
package includes example CGI scripts in Perl. |
30 |
|
|
|
31 |
|
|
%prep |
32 |
|
|
%setup -n mod_auth_tkt-%{version} |
33 |
|
|
|
34 |
|
|
%build |
35 |
|
|
test %{httpd} == apache && APXS='--apxs=/usr/sbin/apxs1' |
36 |
|
|
test %{debug} == 1 && DEBUG='--debug' |
37 |
|
|
MOD_PERL=`rpm -q mod_perl | grep '^mod_perl' || /bin/true` |
38 |
|
|
if [ -n "$MOD_PERL" -a %{test} == 1 ]; then |
39 |
|
|
./configure --test $DEBUG |
40 |
|
|
make |
41 |
|
|
make test |
42 |
|
|
else |
43 |
|
|
./configure $APXS $DEBUG |
44 |
|
|
make |
45 |
|
|
fi |
46 |
|
|
|
47 |
|
|
%install |
48 |
|
|
test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT |
49 |
|
|
mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules |
50 |
|
|
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d |
51 |
|
|
mkdir -p $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi |
52 |
|
|
mkdir -p $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/contrib |
53 |
|
|
if [ %{httpd} == apache ]; then |
54 |
|
|
/usr/sbin/apxs1 -i -n "auth_tkt" -S LIBEXECDIR=$RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules src/mod_auth_tkt.so |
55 |
|
|
else |
56 |
|
|
/usr/sbin/apxs -i -n "auth_tkt" -S LIBEXECDIR=$RPM_BUILD_ROOT%{_libdir}/%{httpd}/modules src/mod_auth_tkt.la |
57 |
|
|
fi |
58 |
|
|
install -m 644 conf/02_auth_tkt.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{httpd}/conf.d/ |
59 |
|
|
cp -pr cgi/* $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi |
60 |
|
|
rm -r $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/cgi/Apache |
61 |
|
|
mkdir -p $RPM_BUILD_ROOT/%{perl_vendorarch}/Apache |
62 |
|
|
cp cgi/Apache/* $RPM_BUILD_ROOT/%{perl_vendorarch}/Apache |
63 |
|
|
cp -pr contrib/* $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/contrib |
64 |
|
|
cp -pr README* INSTALL LICENSE ChangeLog CREDITS $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version} |
65 |
|
|
cd doc |
66 |
|
|
make DESTDIR=$RPM_BUILD_ROOT install |
67 |
|
|
|
68 |
|
|
%clean |
69 |
|
|
test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT |
70 |
|
|
|
71 |
|
|
%files |
72 |
|
|
%defattr(-,root,root) |
73 |
|
|
%{_libdir}/%{httpd} |
74 |
|
|
%{perl_vendorarch}/Apache/AuthTkt.pm |
75 |
|
|
%doc /usr/share/doc/%{name}-%{version} |
76 |
|
|
%attr(0640,root,apache) %config(noreplace) %{_sysconfdir}/%{httpd}/conf.d/* |
77 |
|
|
/usr/share/man/* |
78 |
|
|
|
79 |
|
|
%changelog |
80 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
81 |
|
|
- Clean up spec so package can be built by koji/plague |
82 |
|
|
|
83 |
|
|
* Wed Nov 28 2006 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc2 |
84 |
|
|
- Bump to version 2.0.0rc2. |
85 |
|
|
|
86 |
|
|
* Wed Nov 01 2006 Charlie Brady <charlie_brady@mitel.com> 2.0.0rc1-2 |
87 |
|
|
- Move Apache::AuthTkt into perl's vendorarch directory. |
88 |
|
|
|
89 |
|
|
* Mon Apr 10 2006 Gavin Carr <gavin@openfusion.com.au> 2.0.0rc1 |
90 |
|
|
- Add mod_auth_tkt man page. |
91 |
|
|
- Add TKTAuthDebug support, instead of compile-time debug flag. |
92 |
|
|
- Add TKTAuthPostTimeoutURL support (Michael Peters). |
93 |
|
|
|
94 |
|
|
* Mon Oct 24 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b7 |
95 |
|
|
- Deprecate TKTAuthTimeoutMin, replacing with TKTAuthTimeout, using units like |
96 |
|
|
TKTAuthCookieExpires. |
97 |
|
|
- Split out TKTAuthCookieSecure functionality from TKTAuthRequireSSL (Larry |
98 |
|
|
Lansing). |
99 |
|
|
- Add TKTAuthCookieExpires directive for guest cookies and refreshes. |
100 |
|
|
- Add TKTAuthGuestUser %U format support for UUIDs with Apache 2. |
101 |
|
|
- Add TKTAuthGuestUser support for setting guest user explicitly. |
102 |
|
|
- Fix URI and HTML escaping issues with cgi scripts (Viljo Viitanen). |
103 |
|
|
- Update CGI scripts to get local settings via Apache::AuthTkt parse_conf values. |
104 |
|
|
- Update Apache::AuthTkt to new version (0.03) with parse_conf support. |
105 |
|
|
- Add server config merge support to allow global secrets with vhosts. |
106 |
|
|
|
107 |
|
|
* Mon Aug 01 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b6 |
108 |
|
|
- Update specfile to support basic building against apache 1. |
109 |
|
|
- Fixed bug with non-base64 quoted ticket values not being parsed correctly. |
110 |
|
|
|
111 |
|
|
* Tue Jun 14 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b5 |
112 |
|
|
- Change back url formation to use Host header, not server name/port. |
113 |
|
|
- Get cookie_match to skip empty cookies it finds (e.g. logout misconfigs). |
114 |
|
|
- Add Ian Bicking's AuthTicket python class in contrib. |
115 |
|
|
- Add TKTAuthGuestLogin support based on patch from Ian Bicking. |
116 |
|
|
- Add DEBUG_VERBOSE support based on patch from Ian Bicking. |
117 |
|
|
- Fixed bug with test harness not generating local module correctly. |
118 |
|
|
|
119 |
|
|
* Mon May 30 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b4 |
120 |
|
|
- Change build to include 'make test' only if mod_perl is available. |
121 |
|
|
|
122 |
|
|
* Sat Apr 30 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b3 |
123 |
|
|
|
124 |
|
|
* Thu Feb 21 2005 Gavin Carr <gavin@openfusion.com.au> 2.0.0b2 |
125 |
|
|
- Initial release. |
126 |
|
|
|
127 |
|
|
|
128 |
|
|
# arch-tag: 56c36703-99d8-409e-97dc-1b81e565b29a |