1 |
stephdl |
1.1 |
%define contentdir /var/www |
2 |
|
|
|
3 |
|
|
Name: mod_perl |
4 |
|
|
Version: 2.0.4 |
5 |
|
|
Release: 11.1%{?dist} |
6 |
|
|
Summary: An embedded Perl interpreter for the Apache HTTP Server |
7 |
|
|
|
8 |
|
|
Group: System Environment/Daemons |
9 |
|
|
License: ASL 2.0 |
10 |
|
|
URL: http://perl.apache.org/ |
11 |
|
|
Source0: http://perl.apache.org/dist/mod_perl-%{version}.tar.gz |
12 |
|
|
Source1: perl.conf |
13 |
|
|
Source2: filter-requires.sh |
14 |
|
|
Source3: filter-provides.sh |
15 |
|
|
Patch0: mod_perl-2.0.4-multilib.patch |
16 |
|
|
Patch1: mod_perl-2.0.4-inline.patch |
17 |
|
|
Patch2: mod_perl-2.0.4-CVE-2009-0796.patch |
18 |
|
|
Patch3: mod_perl-2.0.4-tipool-race.patch |
19 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
20 |
|
|
|
21 |
|
|
BuildRequires: perl-devel, perl(ExtUtils::Embed) |
22 |
|
|
BuildRequires: httpd-devel >= 2.2.0, httpd, gdbm-devel |
23 |
|
|
BuildRequires: apr-devel >= 1.2.0, apr-util-devel |
24 |
stephdl |
1.2 |
BuildRequires: perl(Tie::IxHash) |
25 |
|
|
BuildRequires: perl(Data::Dumper) |
26 |
stephdl |
1.1 |
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) |
27 |
|
|
Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn || echo missing) |
28 |
|
|
|
29 |
|
|
%define __perl_requires %{SOURCE2} |
30 |
|
|
%define __perl_provides %{SOURCE3} |
31 |
|
|
|
32 |
|
|
%description |
33 |
|
|
Mod_perl incorporates a Perl interpreter into the Apache web server, |
34 |
|
|
so that the Apache web server can directly execute Perl code. |
35 |
|
|
Mod_perl links the Perl runtime library into the Apache web server and |
36 |
|
|
provides an object-oriented Perl interface for Apache's C language |
37 |
|
|
API. The end result is a quicker CGI script turnaround process, since |
38 |
|
|
no external Perl interpreter has to be started. |
39 |
|
|
|
40 |
|
|
Install mod_perl if you're installing the Apache web server and you'd |
41 |
|
|
like for it to directly incorporate a Perl interpreter. |
42 |
|
|
|
43 |
|
|
|
44 |
|
|
%package devel |
45 |
|
|
Summary: Files needed for building XS modules that use mod_perl |
46 |
|
|
Group: Development/Libraries |
47 |
|
|
Requires: mod_perl = %{version}-%{release}, httpd-devel |
48 |
|
|
|
49 |
|
|
%description devel |
50 |
|
|
The mod_perl-devel package contains the files needed for building XS |
51 |
|
|
modules that use mod_perl. |
52 |
|
|
|
53 |
|
|
|
54 |
|
|
%prep |
55 |
|
|
%setup -q -n %{name}-%{version} |
56 |
|
|
%patch0 -p1 |
57 |
|
|
%patch1 -p1 -b .inline |
58 |
|
|
%patch2 -p1 |
59 |
|
|
%patch3 -p1 -b .tipool |
60 |
|
|
|
61 |
|
|
%build |
62 |
|
|
CFLAGS="$RPM_OPT_FLAGS -fpic" %{__perl} Makefile.PL </dev/null \ |
63 |
|
|
PREFIX=$RPM_BUILD_ROOT/usr \ |
64 |
|
|
INSTALLDIRS=vendor \ |
65 |
|
|
MP_APXS=%{_sbindir}/apxs \ |
66 |
|
|
MP_APR_CONFIG=%{_bindir}/apr-1-config |
67 |
|
|
make -C src/modules/perl %{?_smp_mflags} OPTIMIZE="$RPM_OPT_FLAGS -fpic" |
68 |
|
|
make |
69 |
|
|
|
70 |
|
|
%install |
71 |
|
|
rm -rf $RPM_BUILD_ROOT |
72 |
|
|
install -d -m 755 $RPM_BUILD_ROOT%{_libdir}/httpd/modules |
73 |
|
|
make install \ |
74 |
|
|
MODPERL_AP_LIBEXECDIR=$RPM_BUILD_ROOT%{_libdir}/httpd/modules \ |
75 |
|
|
MODPERL_AP_INCLUDEDIR=$RPM_BUILD_ROOT%{_includedir}/httpd |
76 |
|
|
|
77 |
|
|
# Remove the temporary files. |
78 |
|
|
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';' |
79 |
|
|
find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';' |
80 |
|
|
find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';' |
81 |
|
|
find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';' |
82 |
|
|
|
83 |
|
|
# Fix permissions to avoid strip failures on non-root builds. |
84 |
|
|
chmod -R u+w $RPM_BUILD_ROOT/* |
85 |
|
|
|
86 |
|
|
# Install the config file |
87 |
|
|
install -d -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d |
88 |
|
|
install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/ |
89 |
|
|
|
90 |
|
|
# Move set of modules to -devel |
91 |
|
|
devmods="ModPerl::Code ModPerl::BuildMM ModPerl::CScan \ |
92 |
|
|
ModPerl::TestRun ModPerl::Config ModPerl::WrapXS \ |
93 |
|
|
ModPerl::BuildOptions ModPerl::Manifest \ |
94 |
|
|
ModPerl::MapUtil ModPerl::StructureMap \ |
95 |
|
|
ModPerl::TypeMap ModPerl::FunctionMap \ |
96 |
|
|
ModPerl::ParseSource ModPerl::MM \ |
97 |
|
|
Apache2::Build Apache2::ParseSource Apache2::BuildConfig \ |
98 |
|
|
Apache Bundle::ApacheTest" |
99 |
|
|
for m in $devmods; do |
100 |
|
|
test -f $RPM_BUILD_ROOT%{_mandir}/man3/${m}.3pm && |
101 |
|
|
echo "%{_mandir}/man3/${m}.3pm*" |
102 |
|
|
fn=${m//::/\/} |
103 |
|
|
test -f $RPM_BUILD_ROOT%{perl_vendorarch}/${fn}.pm && |
104 |
|
|
echo %{perl_vendorarch}/${fn}.pm |
105 |
|
|
test -d $RPM_BUILD_ROOT%{perl_vendorarch}/${fn} && |
106 |
|
|
echo %{perl_vendorarch}/${fn} |
107 |
|
|
test -d $RPM_BUILD_ROOT%{perl_vendorarch}/auto/${fn} && |
108 |
|
|
echo %{perl_vendorarch}/auto/${fn} |
109 |
|
|
done | tee devel.files | sed 's/^/%%exclude /' > exclude.files |
110 |
|
|
echo "%{_mandir}/man3/Apache::*.3pm*" | tee -a devel.files \ |
111 |
|
|
| sed 's/^/%%exclude /' >> exclude.files |
112 |
|
|
|
113 |
|
|
# Completely remove Apache::Test - can be packaged separately |
114 |
|
|
#rm -rf $RPM_BUILD_ROOT%{_mandir}/man3/Apache::Test* |
115 |
|
|
#rm -rf $RPM_BUILD_ROOT%{perl_vendorarch}/Apache |
116 |
|
|
|
117 |
|
|
|
118 |
|
|
%clean |
119 |
|
|
rm -rf $RPM_BUILD_ROOT |
120 |
|
|
|
121 |
|
|
%files -f exclude.files |
122 |
|
|
%defattr(-,root,root,-) |
123 |
|
|
%doc Changes LICENSE README* STATUS SVN-MOVE docs/ |
124 |
|
|
%config(noreplace) %{_sysconfdir}/httpd/conf.d/*.conf |
125 |
|
|
%{_bindir}/* |
126 |
|
|
%{_libdir}/httpd/modules/mod_perl.so |
127 |
|
|
%{perl_vendorarch}/auto/* |
128 |
|
|
%{perl_vendorarch}/Apache2/ |
129 |
|
|
%{perl_vendorarch}/Bundle/ |
130 |
|
|
%{perl_vendorarch}/APR/ |
131 |
|
|
%{perl_vendorarch}/ModPerl/ |
132 |
|
|
%{perl_vendorarch}/*.pm |
133 |
|
|
%{_mandir}/man3/*.3* |
134 |
|
|
|
135 |
|
|
%files devel -f devel.files |
136 |
|
|
%defattr(-,root,root,-) |
137 |
|
|
%{_includedir}/httpd/* |
138 |
|
|
|
139 |
|
|
%changelog |
140 |
|
|
* Sun Feb 7 2016 stephane de labrusse <stephdl@de-labrusse.fr> 2.0.4-11.1 |
141 |
|
|
- Build new rpm for sme10 |
142 |
|
|
|
143 |
|
|
* Wed Apr 23 2014 Ian Wells <esmith@wellsi.com> 2.0.4-11.1.sme |
144 |
|
|
- Bump version number [SME: 8343] |
145 |
|
|
|
146 |
|
|
* Tue Apr 22 2014 Ian Wells <esmith@wellsi.com> 2.0.4-11.sme |
147 |
|
|
- Update to latest upstream [SME: 8343] |
148 |
|
|
|
149 |
|
|
* Wed Apr 16 2014 Jan Kaluza <jkaluza@redhat.com> - 2.0.4-11 |
150 |
|
|
- fix a race condition in tipool management (#1072766) |
151 |
|
|
|
152 |
|
|
* Tue Feb 12 2013 Shad L. Lords <slords@mail.com> - 2.0.4-10.sme |
153 |
|
|
- Move Apache::Test* man pages to devel package [SME: 7331] |
154 |
|
|
|
155 |
|
|
* Tue Dec 8 2009 Joe Orton <jorton@redhat.com> - 2.0.4-10 |
156 |
|
|
- add security fix for CVE-2009-0796 (#544455) |
157 |
|
|
|
158 |
|
|
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.4-9 |
159 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
160 |
|
|
|
161 |
|
|
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.4-8 |
162 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
163 |
|
|
|
164 |
|
|
* Fri Oct 17 2008 Joe Orton <jorton@redhat.com> 2.0.4-7 |
165 |
|
|
- fix inline abuse (#459351) |
166 |
|
|
|
167 |
|
|
* Wed Aug 6 2008 Joe Orton <jorton@redhat.com> 2.0.4-5 |
168 |
|
|
- rebuild to fix patch fuzz (#427758) |
169 |
|
|
|
170 |
|
|
* Mon Jul 14 2008 Joe Orton <jorton@redhat.com> 2.0.4-4 |
171 |
|
|
- rebuild for new BDB |
172 |
|
|
|
173 |
|
|
* Tue May 13 2008 Joe Orton <jorton@redhat.com> 2.0.4-3 |
174 |
|
|
- trim changelog; rebuild |
175 |
|
|
|
176 |
|
|
* Fri Apr 18 2008 Joe Orton <jorton@redhat.com> 2.0.4-2 |
177 |
|
|
- update to 2.0.4 |
178 |
|
|
|
179 |
|
|
* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.3-21 |
180 |
|
|
- Rebuild for perl 5.10 (again) |
181 |
|
|
|
182 |
|
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.3-20 |
183 |
|
|
- Autorebuild for GCC 4.3 |
184 |
|
|
|
185 |
|
|
* Wed Jan 30 2008 Joe Orton <jorton@redhat.com> 2.0.3-19 |
186 |
|
|
- further fixes for perl 5.10 (upstream r480903, r615751) |
187 |
|
|
|
188 |
|
|
* Wed Jan 30 2008 Joe Orton <jorton@redhat.com> 2.0.3-18 |
189 |
|
|
- fix build with perl 5.10 (upstream r480890) |
190 |
|
|
|
191 |
|
|
* Tue Jan 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-17 |
192 |
|
|
- fix perl BR |
193 |
|
|
|
194 |
|
|
* Mon Jan 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-16 |
195 |
|
|
- rebuild for new perl |
196 |
|
|
|
197 |
|
|
* Thu Dec 6 2007 Joe Orton <jorton@redhat.com> 2.0.3-15 |
198 |
|
|
- rebuild for new OpenLDAP |
199 |
|
|
|
200 |
|
|
* Wed Sep 5 2007 Joe Orton <jorton@redhat.com> 2.0.3-14 |
201 |
|
|
- filter perl(HTTP::Request::Common) Provide from -devel (#247250) |
202 |
|
|
|
203 |
|
|
* Sun Sep 2 2007 Joe Orton <jorton@redhat.com> 2.0.3-13 |
204 |
|
|
- rebuild for fixed 32-bit APR |
205 |
|
|
|
206 |
|
|
* Thu Aug 23 2007 Joe Orton <jorton@redhat.com> 2.0.3-12 |
207 |
|
|
- rebuild for expat soname bump |
208 |
|
|
|
209 |
|
|
* Tue Aug 21 2007 Joe Orton <jorton@redhat.com> 2.0.3-11 |
210 |
|
|
- rebuild for libdb soname bump |
211 |
|
|
|
212 |
|
|
* Mon Aug 20 2007 Joe Orton <jorton@redhat.com> 2.0.3-10 |
213 |
|
|
- fix License |
214 |
|
|
|
215 |
|
|
* Fri Apr 20 2007 Joe Orton <jorton@redhat.com> 2.0.3-8 |
216 |
|
|
- filter provide of perl(warnings) (#228429) |
217 |
|
|
|
218 |
|
|
* Wed Feb 28 2007 Joe Orton <jorton@redhat.com> 2.0.3-7 |
219 |
|
|
- also restore Apache::Test to devel |
220 |
|
|
- add BR for perl-devel |
221 |
|
|
|
222 |
|
|
* Tue Feb 27 2007 Joe Orton <jorton@redhat.com> 2.0.3-6 |
223 |
|
|
- filter more Apache::Test requirements |
224 |
|
|
|
225 |
|
|
* Mon Feb 26 2007 Joe Orton <jorton@redhat.com> 2.0.3-5 |
226 |
|
|
- repackage set of trimmed modules, but only in -devel |
227 |
|
|
|
228 |
|
|
* Wed Jan 31 2007 Joe Orton <jorton@redhat.com> 2.0.3-4 |
229 |
|
|
- restore ModPerl::MM |
230 |
|
|
|
231 |
|
|
* Tue Dec 5 2006 Joe Orton <jorton@redhat.com> 2.0.3-3 |
232 |
|
|
- trim modules even more aggressively (#197841) |
233 |
|
|
|
234 |
|
|
* Mon Dec 4 2006 Joe Orton <jorton@redhat.com> 2.0.3-2 |
235 |
|
|
- update to 2.0.3 |
236 |
|
|
- remove droplet in buildroot from multilib patch |
237 |
|
|
- drop build-related ModPerl:: modules and Apache::Test (#197841) |
238 |
|
|
- spec file cleanups |
239 |
|
|
|
240 |
|
|
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control |
241 |
|
|
- rebuild |
242 |
|
|
|
243 |
|
|
* Thu Jun 15 2006 Joe Orton <jorton@redhat.com> 2.0.2-6 |
244 |
|
|
- fix multilib conflicts in -devel (#192733) |
245 |
|
|
|
246 |
|
|
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.0.2-5.1 |
247 |
|
|
- bump again for double-long bug on ppc(64) |
248 |
|
|
|
249 |
|
|
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.0.2-3.2 |
250 |
|
|
- rebuilt for new gcc4.1 snapshot and glibc changes |
251 |
|
|
|
252 |
|
|
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> |
253 |
|
|
- rebuilt |
254 |
|
|
|
255 |
|
|
* Fri Dec 2 2005 Joe Orton <jorton@redhat.com> 2.0.2-3 |
256 |
|
|
- rebuild for httpd 2.2 |
257 |
|
|
|
258 |
|
|
* Wed Oct 26 2005 Joe Orton <jorton@redhat.com> 2.0.2-2 |
259 |
|
|
- update to 2.0.2 |
260 |
|
|
|
261 |
|
|
* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 2.0.1-2 |
262 |
|
|
- rebuild |
263 |
|
|
|
264 |
|
|
* Fri Jun 17 2005 Warren Togami <wtogami@redhat.com> 2.0.1-1 |
265 |
|
|
- 2.0.1 |
266 |
|
|
|
267 |
|
|
* Fri May 20 2005 Warren Togami <wtogami@redhat.com> 2.0.0-3 |
268 |
|
|
- dep changes (#114651 jpo and ville) |
269 |
|
|
|
270 |
|
|
* Fri May 20 2005 Joe Orton <jorton@redhat.com> 2.0.0-1 |
271 |
|
|
- update to 2.0.0 final |
272 |
|
|
|
273 |
|
|
* Mon Apr 18 2005 Ville Skyttรค <ville.skytta at iki.fi> - 2.0.0-0.rc5.3 |
274 |
|
|
- Fix sample configuration. |
275 |
|
|
- Explicitly disable the test suite. (#112563) |
276 |
|
|
|
277 |
|
|
* Mon Apr 18 2005 Joe Orton <jorton@redhat.com> 2.0.0-0.rc5.2 |
278 |
|
|
- fix filter-requires for new Apache2:: modules |
279 |
|
|
|
280 |
|
|
* Sat Apr 16 2005 Warren Togami <wtogami@redhat.com> - 2.0.0-0.rc5.1 |
281 |
|
|
- 2.0.0-RC5 |
282 |
|
|
|
283 |
|
|
* Sun Apr 03 2005 Jose Pedro Oliveira <jpo@di.uminho.pt> - 2.0.0-0.rc4.1 |
284 |
|
|
- Update to 2.0.0-RC4. |
285 |
|
|
- Specfile cleanup. (#153236) |