/[smeserver]/rpms/mod_perl/sme10/mod_perl.spec
ViewVC logotype

Annotation of /rpms/mod_perl/sme10/mod_perl.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Sun Feb 7 19:10:29 2016 UTC (8 years, 4 months ago) by stephdl
Branch: MAIN
CVS Tags: HEAD
Changes since 1.2: +0 -2 lines
removed  buildrequire

1 stephdl 1.1 %define contentdir /var/www
2    
3     Name: mod_perl
4     Version: 2.0.4
5     Release: 11.1%{?dist}
6     Summary: An embedded Perl interpreter for the Apache HTTP Server
7    
8     Group: System Environment/Daemons
9     License: ASL 2.0
10     URL: http://perl.apache.org/
11     Source0: http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
12     Source1: perl.conf
13     Source2: filter-requires.sh
14     Source3: filter-provides.sh
15     Patch0: mod_perl-2.0.4-multilib.patch
16     Patch1: mod_perl-2.0.4-inline.patch
17     Patch2: mod_perl-2.0.4-CVE-2009-0796.patch
18     Patch3: mod_perl-2.0.4-tipool-race.patch
19     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20    
21     BuildRequires: perl-devel, perl(ExtUtils::Embed)
22     BuildRequires: httpd-devel >= 2.2.0, httpd, gdbm-devel
23     BuildRequires: apr-devel >= 1.2.0, apr-util-devel
24     Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
25     Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn || echo missing)
26    
27     %define __perl_requires %{SOURCE2}
28     %define __perl_provides %{SOURCE3}
29    
30     %description
31     Mod_perl incorporates a Perl interpreter into the Apache web server,
32     so that the Apache web server can directly execute Perl code.
33     Mod_perl links the Perl runtime library into the Apache web server and
34     provides an object-oriented Perl interface for Apache's C language
35     API. The end result is a quicker CGI script turnaround process, since
36     no external Perl interpreter has to be started.
37    
38     Install mod_perl if you're installing the Apache web server and you'd
39     like for it to directly incorporate a Perl interpreter.
40    
41    
42     %package devel
43     Summary: Files needed for building XS modules that use mod_perl
44     Group: Development/Libraries
45     Requires: mod_perl = %{version}-%{release}, httpd-devel
46    
47     %description devel
48     The mod_perl-devel package contains the files needed for building XS
49     modules that use mod_perl.
50    
51    
52     %prep
53     %setup -q -n %{name}-%{version}
54     %patch0 -p1
55     %patch1 -p1 -b .inline
56     %patch2 -p1
57     %patch3 -p1 -b .tipool
58    
59     %build
60     CFLAGS="$RPM_OPT_FLAGS -fpic" %{__perl} Makefile.PL </dev/null \
61     PREFIX=$RPM_BUILD_ROOT/usr \
62     INSTALLDIRS=vendor \
63     MP_APXS=%{_sbindir}/apxs \
64     MP_APR_CONFIG=%{_bindir}/apr-1-config
65     make -C src/modules/perl %{?_smp_mflags} OPTIMIZE="$RPM_OPT_FLAGS -fpic"
66     make
67    
68     %install
69     rm -rf $RPM_BUILD_ROOT
70     install -d -m 755 $RPM_BUILD_ROOT%{_libdir}/httpd/modules
71     make install \
72     MODPERL_AP_LIBEXECDIR=$RPM_BUILD_ROOT%{_libdir}/httpd/modules \
73     MODPERL_AP_INCLUDEDIR=$RPM_BUILD_ROOT%{_includedir}/httpd
74    
75     # Remove the temporary files.
76     find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
77     find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
78     find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
79     find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
80    
81     # Fix permissions to avoid strip failures on non-root builds.
82     chmod -R u+w $RPM_BUILD_ROOT/*
83    
84     # Install the config file
85     install -d -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
86     install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/
87    
88     # Move set of modules to -devel
89     devmods="ModPerl::Code ModPerl::BuildMM ModPerl::CScan \
90     ModPerl::TestRun ModPerl::Config ModPerl::WrapXS \
91     ModPerl::BuildOptions ModPerl::Manifest \
92     ModPerl::MapUtil ModPerl::StructureMap \
93     ModPerl::TypeMap ModPerl::FunctionMap \
94     ModPerl::ParseSource ModPerl::MM \
95     Apache2::Build Apache2::ParseSource Apache2::BuildConfig \
96     Apache Bundle::ApacheTest"
97     for m in $devmods; do
98     test -f $RPM_BUILD_ROOT%{_mandir}/man3/${m}.3pm &&
99     echo "%{_mandir}/man3/${m}.3pm*"
100     fn=${m//::/\/}
101     test -f $RPM_BUILD_ROOT%{perl_vendorarch}/${fn}.pm &&
102     echo %{perl_vendorarch}/${fn}.pm
103     test -d $RPM_BUILD_ROOT%{perl_vendorarch}/${fn} &&
104     echo %{perl_vendorarch}/${fn}
105     test -d $RPM_BUILD_ROOT%{perl_vendorarch}/auto/${fn} &&
106     echo %{perl_vendorarch}/auto/${fn}
107     done | tee devel.files | sed 's/^/%%exclude /' > exclude.files
108     echo "%{_mandir}/man3/Apache::*.3pm*" | tee -a devel.files \
109     | sed 's/^/%%exclude /' >> exclude.files
110    
111     # Completely remove Apache::Test - can be packaged separately
112     #rm -rf $RPM_BUILD_ROOT%{_mandir}/man3/Apache::Test*
113     #rm -rf $RPM_BUILD_ROOT%{perl_vendorarch}/Apache
114    
115    
116     %clean
117     rm -rf $RPM_BUILD_ROOT
118    
119     %files -f exclude.files
120     %defattr(-,root,root,-)
121     %doc Changes LICENSE README* STATUS SVN-MOVE docs/
122     %config(noreplace) %{_sysconfdir}/httpd/conf.d/*.conf
123     %{_bindir}/*
124     %{_libdir}/httpd/modules/mod_perl.so
125     %{perl_vendorarch}/auto/*
126     %{perl_vendorarch}/Apache2/
127     %{perl_vendorarch}/Bundle/
128     %{perl_vendorarch}/APR/
129     %{perl_vendorarch}/ModPerl/
130     %{perl_vendorarch}/*.pm
131     %{_mandir}/man3/*.3*
132    
133     %files devel -f devel.files
134     %defattr(-,root,root,-)
135     %{_includedir}/httpd/*
136    
137     %changelog
138     * Sun Feb 7 2016 stephane de labrusse <stephdl@de-labrusse.fr> 2.0.4-11.1
139     - Build new rpm for sme10
140    
141     * Wed Apr 23 2014 Ian Wells <esmith@wellsi.com> 2.0.4-11.1.sme
142     - Bump version number [SME: 8343]
143    
144     * Tue Apr 22 2014 Ian Wells <esmith@wellsi.com> 2.0.4-11.sme
145     - Update to latest upstream [SME: 8343]
146    
147     * Wed Apr 16 2014 Jan Kaluza <jkaluza@redhat.com> - 2.0.4-11
148     - fix a race condition in tipool management (#1072766)
149    
150     * Tue Feb 12 2013 Shad L. Lords <slords@mail.com> - 2.0.4-10.sme
151     - Move Apache::Test* man pages to devel package [SME: 7331]
152    
153     * Tue Dec 8 2009 Joe Orton <jorton@redhat.com> - 2.0.4-10
154     - add security fix for CVE-2009-0796 (#544455)
155    
156     * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.4-9
157     - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
158    
159     * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.4-8
160     - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
161    
162     * Fri Oct 17 2008 Joe Orton <jorton@redhat.com> 2.0.4-7
163     - fix inline abuse (#459351)
164    
165     * Wed Aug 6 2008 Joe Orton <jorton@redhat.com> 2.0.4-5
166     - rebuild to fix patch fuzz (#427758)
167    
168     * Mon Jul 14 2008 Joe Orton <jorton@redhat.com> 2.0.4-4
169     - rebuild for new BDB
170    
171     * Tue May 13 2008 Joe Orton <jorton@redhat.com> 2.0.4-3
172     - trim changelog; rebuild
173    
174     * Fri Apr 18 2008 Joe Orton <jorton@redhat.com> 2.0.4-2
175     - update to 2.0.4
176    
177     * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.3-21
178     - Rebuild for perl 5.10 (again)
179    
180     * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.3-20
181     - Autorebuild for GCC 4.3
182    
183     * Wed Jan 30 2008 Joe Orton <jorton@redhat.com> 2.0.3-19
184     - further fixes for perl 5.10 (upstream r480903, r615751)
185    
186     * Wed Jan 30 2008 Joe Orton <jorton@redhat.com> 2.0.3-18
187     - fix build with perl 5.10 (upstream r480890)
188    
189     * Tue Jan 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-17
190     - fix perl BR
191    
192     * Mon Jan 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-16
193     - rebuild for new perl
194    
195     * Thu Dec 6 2007 Joe Orton <jorton@redhat.com> 2.0.3-15
196     - rebuild for new OpenLDAP
197    
198     * Wed Sep 5 2007 Joe Orton <jorton@redhat.com> 2.0.3-14
199     - filter perl(HTTP::Request::Common) Provide from -devel (#247250)
200    
201     * Sun Sep 2 2007 Joe Orton <jorton@redhat.com> 2.0.3-13
202     - rebuild for fixed 32-bit APR
203    
204     * Thu Aug 23 2007 Joe Orton <jorton@redhat.com> 2.0.3-12
205     - rebuild for expat soname bump
206    
207     * Tue Aug 21 2007 Joe Orton <jorton@redhat.com> 2.0.3-11
208     - rebuild for libdb soname bump
209    
210     * Mon Aug 20 2007 Joe Orton <jorton@redhat.com> 2.0.3-10
211     - fix License
212    
213     * Fri Apr 20 2007 Joe Orton <jorton@redhat.com> 2.0.3-8
214     - filter provide of perl(warnings) (#228429)
215    
216     * Wed Feb 28 2007 Joe Orton <jorton@redhat.com> 2.0.3-7
217     - also restore Apache::Test to devel
218     - add BR for perl-devel
219    
220     * Tue Feb 27 2007 Joe Orton <jorton@redhat.com> 2.0.3-6
221     - filter more Apache::Test requirements
222    
223     * Mon Feb 26 2007 Joe Orton <jorton@redhat.com> 2.0.3-5
224     - repackage set of trimmed modules, but only in -devel
225    
226     * Wed Jan 31 2007 Joe Orton <jorton@redhat.com> 2.0.3-4
227     - restore ModPerl::MM
228    
229     * Tue Dec 5 2006 Joe Orton <jorton@redhat.com> 2.0.3-3
230     - trim modules even more aggressively (#197841)
231    
232     * Mon Dec 4 2006 Joe Orton <jorton@redhat.com> 2.0.3-2
233     - update to 2.0.3
234     - remove droplet in buildroot from multilib patch
235     - drop build-related ModPerl:: modules and Apache::Test (#197841)
236     - spec file cleanups
237    
238     * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
239     - rebuild
240    
241     * Thu Jun 15 2006 Joe Orton <jorton@redhat.com> 2.0.2-6
242     - fix multilib conflicts in -devel (#192733)
243    
244     * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.0.2-5.1
245     - bump again for double-long bug on ppc(64)
246    
247     * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.0.2-3.2
248     - rebuilt for new gcc4.1 snapshot and glibc changes
249    
250     * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
251     - rebuilt
252    
253     * Fri Dec 2 2005 Joe Orton <jorton@redhat.com> 2.0.2-3
254     - rebuild for httpd 2.2
255    
256     * Wed Oct 26 2005 Joe Orton <jorton@redhat.com> 2.0.2-2
257     - update to 2.0.2
258    
259     * Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 2.0.1-2
260     - rebuild
261    
262     * Fri Jun 17 2005 Warren Togami <wtogami@redhat.com> 2.0.1-1
263     - 2.0.1
264    
265     * Fri May 20 2005 Warren Togami <wtogami@redhat.com> 2.0.0-3
266     - dep changes (#114651 jpo and ville)
267    
268     * Fri May 20 2005 Joe Orton <jorton@redhat.com> 2.0.0-1
269     - update to 2.0.0 final
270    
271     * Mon Apr 18 2005 Ville Skyttรค <ville.skytta at iki.fi> - 2.0.0-0.rc5.3
272     - Fix sample configuration.
273     - Explicitly disable the test suite. (#112563)
274    
275     * Mon Apr 18 2005 Joe Orton <jorton@redhat.com> 2.0.0-0.rc5.2
276     - fix filter-requires for new Apache2:: modules
277    
278     * Sat Apr 16 2005 Warren Togami <wtogami@redhat.com> - 2.0.0-0.rc5.1
279     - 2.0.0-RC5
280    
281     * Sun Apr 03 2005 Jose Pedro Oliveira <jpo@di.uminho.pt> - 2.0.0-0.rc4.1
282     - Update to 2.0.0-RC4.
283     - Specfile cleanup. (#153236)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed