1 |
slords |
1.1 |
%define contentdir /var/www |
2 |
|
|
|
3 |
|
|
Name: mod_perl |
4 |
|
|
Version: 2.0.4 |
5 |
wellsi |
1.2 |
Release: 11%{?dist} |
6 |
slords |
1.1 |
Summary: An embedded Perl interpreter for the Apache HTTP Server |
7 |
|
|
|
8 |
|
|
Group: System Environment/Daemons |
9 |
|
|
License: ASL 2.0 |
10 |
|
|
URL: http://perl.apache.org/ |
11 |
|
|
Source0: http://perl.apache.org/dist/mod_perl-%{version}.tar.gz |
12 |
|
|
Source1: perl.conf |
13 |
|
|
Source2: filter-requires.sh |
14 |
|
|
Source3: filter-provides.sh |
15 |
|
|
Patch0: mod_perl-2.0.4-multilib.patch |
16 |
|
|
Patch1: mod_perl-2.0.4-inline.patch |
17 |
|
|
Patch2: mod_perl-2.0.4-CVE-2009-0796.patch |
18 |
wellsi |
1.2 |
Patch3: mod_perl-2.0.4-tipool-race.patch |
19 |
slords |
1.1 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
20 |
|
|
|
21 |
|
|
BuildRequires: perl-devel, perl(ExtUtils::Embed) |
22 |
|
|
BuildRequires: httpd-devel >= 2.2.0, httpd, gdbm-devel |
23 |
|
|
BuildRequires: apr-devel >= 1.2.0, apr-util-devel |
24 |
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) |
25 |
|
|
Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn || echo missing) |
26 |
|
|
|
27 |
|
|
%define __perl_requires %{SOURCE2} |
28 |
|
|
%define __perl_provides %{SOURCE3} |
29 |
|
|
|
30 |
|
|
%description |
31 |
|
|
Mod_perl incorporates a Perl interpreter into the Apache web server, |
32 |
|
|
so that the Apache web server can directly execute Perl code. |
33 |
|
|
Mod_perl links the Perl runtime library into the Apache web server and |
34 |
|
|
provides an object-oriented Perl interface for Apache's C language |
35 |
|
|
API. The end result is a quicker CGI script turnaround process, since |
36 |
|
|
no external Perl interpreter has to be started. |
37 |
|
|
|
38 |
|
|
Install mod_perl if you're installing the Apache web server and you'd |
39 |
|
|
like for it to directly incorporate a Perl interpreter. |
40 |
|
|
|
41 |
|
|
|
42 |
|
|
%package devel |
43 |
|
|
Summary: Files needed for building XS modules that use mod_perl |
44 |
|
|
Group: Development/Libraries |
45 |
|
|
Requires: mod_perl = %{version}-%{release}, httpd-devel |
46 |
|
|
|
47 |
|
|
%description devel |
48 |
|
|
The mod_perl-devel package contains the files needed for building XS |
49 |
|
|
modules that use mod_perl. |
50 |
|
|
|
51 |
|
|
|
52 |
|
|
%prep |
53 |
|
|
%setup -q -n %{name}-%{version} |
54 |
|
|
%patch0 -p1 |
55 |
|
|
%patch1 -p1 -b .inline |
56 |
|
|
%patch2 -p1 |
57 |
wellsi |
1.2 |
%patch3 -p1 -b .tipool |
58 |
slords |
1.1 |
|
59 |
|
|
%build |
60 |
|
|
CFLAGS="$RPM_OPT_FLAGS -fpic" %{__perl} Makefile.PL </dev/null \ |
61 |
|
|
PREFIX=$RPM_BUILD_ROOT/usr \ |
62 |
|
|
INSTALLDIRS=vendor \ |
63 |
|
|
MP_APXS=%{_sbindir}/apxs \ |
64 |
|
|
MP_APR_CONFIG=%{_bindir}/apr-1-config |
65 |
|
|
make -C src/modules/perl %{?_smp_mflags} OPTIMIZE="$RPM_OPT_FLAGS -fpic" |
66 |
|
|
make |
67 |
|
|
|
68 |
|
|
%install |
69 |
|
|
rm -rf $RPM_BUILD_ROOT |
70 |
|
|
install -d -m 755 $RPM_BUILD_ROOT%{_libdir}/httpd/modules |
71 |
|
|
make install \ |
72 |
|
|
MODPERL_AP_LIBEXECDIR=$RPM_BUILD_ROOT%{_libdir}/httpd/modules \ |
73 |
|
|
MODPERL_AP_INCLUDEDIR=$RPM_BUILD_ROOT%{_includedir}/httpd |
74 |
|
|
|
75 |
|
|
# Remove the temporary files. |
76 |
|
|
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';' |
77 |
|
|
find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';' |
78 |
|
|
find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';' |
79 |
|
|
find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';' |
80 |
|
|
|
81 |
|
|
# Fix permissions to avoid strip failures on non-root builds. |
82 |
|
|
chmod -R u+w $RPM_BUILD_ROOT/* |
83 |
|
|
|
84 |
|
|
# Install the config file |
85 |
|
|
install -d -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d |
86 |
|
|
install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/ |
87 |
|
|
|
88 |
|
|
# Move set of modules to -devel |
89 |
|
|
devmods="ModPerl::Code ModPerl::BuildMM ModPerl::CScan \ |
90 |
|
|
ModPerl::TestRun ModPerl::Config ModPerl::WrapXS \ |
91 |
|
|
ModPerl::BuildOptions ModPerl::Manifest \ |
92 |
|
|
ModPerl::MapUtil ModPerl::StructureMap \ |
93 |
|
|
ModPerl::TypeMap ModPerl::FunctionMap \ |
94 |
|
|
ModPerl::ParseSource ModPerl::MM \ |
95 |
|
|
Apache2::Build Apache2::ParseSource Apache2::BuildConfig \ |
96 |
|
|
Apache Bundle::ApacheTest" |
97 |
|
|
for m in $devmods; do |
98 |
|
|
test -f $RPM_BUILD_ROOT%{_mandir}/man3/${m}.3pm && |
99 |
|
|
echo "%{_mandir}/man3/${m}.3pm*" |
100 |
|
|
fn=${m//::/\/} |
101 |
|
|
test -f $RPM_BUILD_ROOT%{perl_vendorarch}/${fn}.pm && |
102 |
|
|
echo %{perl_vendorarch}/${fn}.pm |
103 |
|
|
test -d $RPM_BUILD_ROOT%{perl_vendorarch}/${fn} && |
104 |
|
|
echo %{perl_vendorarch}/${fn} |
105 |
|
|
test -d $RPM_BUILD_ROOT%{perl_vendorarch}/auto/${fn} && |
106 |
|
|
echo %{perl_vendorarch}/auto/${fn} |
107 |
|
|
done | tee devel.files | sed 's/^/%%exclude /' > exclude.files |
108 |
|
|
|
109 |
|
|
# Completely remove Apache::Test - can be packaged separately |
110 |
|
|
#rm -rf $RPM_BUILD_ROOT%{_mandir}/man3/Apache::Test* |
111 |
|
|
#rm -rf $RPM_BUILD_ROOT%{perl_vendorarch}/Apache |
112 |
|
|
|
113 |
|
|
|
114 |
|
|
%clean |
115 |
|
|
rm -rf $RPM_BUILD_ROOT |
116 |
|
|
|
117 |
|
|
%files -f exclude.files |
118 |
|
|
%defattr(-,root,root,-) |
119 |
|
|
%doc Changes LICENSE README* STATUS SVN-MOVE docs/ |
120 |
|
|
%config(noreplace) %{_sysconfdir}/httpd/conf.d/*.conf |
121 |
|
|
%{_bindir}/* |
122 |
|
|
%{_libdir}/httpd/modules/mod_perl.so |
123 |
|
|
%{perl_vendorarch}/auto/* |
124 |
|
|
%{perl_vendorarch}/Apache2/ |
125 |
|
|
%{perl_vendorarch}/Bundle/ |
126 |
|
|
%{perl_vendorarch}/APR/ |
127 |
|
|
%{perl_vendorarch}/ModPerl/ |
128 |
|
|
%{perl_vendorarch}/*.pm |
129 |
|
|
%{_mandir}/man3/*.3* |
130 |
|
|
|
131 |
|
|
%files devel -f devel.files |
132 |
|
|
%defattr(-,root,root,-) |
133 |
|
|
%{_includedir}/httpd/* |
134 |
|
|
|
135 |
|
|
%changelog |
136 |
wellsi |
1.2 |
* Wed Apr 16 2014 Jan Kaluza <jkaluza@redhat.com> - 2.0.4-11 |
137 |
|
|
- fix a race condition in tipool management (#1072766) |
138 |
slords |
1.1 |
|
139 |
|
|
* Tue Dec 8 2009 Joe Orton <jorton@redhat.com> - 2.0.4-10 |
140 |
|
|
- add security fix for CVE-2009-0796 (#544455) |
141 |
|
|
|
142 |
|
|
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.4-9 |
143 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
144 |
|
|
|
145 |
|
|
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.4-8 |
146 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
147 |
|
|
|
148 |
|
|
* Fri Oct 17 2008 Joe Orton <jorton@redhat.com> 2.0.4-7 |
149 |
|
|
- fix inline abuse (#459351) |
150 |
|
|
|
151 |
|
|
* Wed Aug 6 2008 Joe Orton <jorton@redhat.com> 2.0.4-5 |
152 |
|
|
- rebuild to fix patch fuzz (#427758) |
153 |
|
|
|
154 |
|
|
* Mon Jul 14 2008 Joe Orton <jorton@redhat.com> 2.0.4-4 |
155 |
|
|
- rebuild for new BDB |
156 |
|
|
|
157 |
|
|
* Tue May 13 2008 Joe Orton <jorton@redhat.com> 2.0.4-3 |
158 |
|
|
- trim changelog; rebuild |
159 |
|
|
|
160 |
|
|
* Fri Apr 18 2008 Joe Orton <jorton@redhat.com> 2.0.4-2 |
161 |
|
|
- update to 2.0.4 |
162 |
|
|
|
163 |
|
|
* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.3-21 |
164 |
|
|
- Rebuild for perl 5.10 (again) |
165 |
|
|
|
166 |
|
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.3-20 |
167 |
|
|
- Autorebuild for GCC 4.3 |
168 |
|
|
|
169 |
|
|
* Wed Jan 30 2008 Joe Orton <jorton@redhat.com> 2.0.3-19 |
170 |
|
|
- further fixes for perl 5.10 (upstream r480903, r615751) |
171 |
|
|
|
172 |
|
|
* Wed Jan 30 2008 Joe Orton <jorton@redhat.com> 2.0.3-18 |
173 |
|
|
- fix build with perl 5.10 (upstream r480890) |
174 |
|
|
|
175 |
|
|
* Tue Jan 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-17 |
176 |
|
|
- fix perl BR |
177 |
|
|
|
178 |
|
|
* Mon Jan 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-16 |
179 |
|
|
- rebuild for new perl |
180 |
|
|
|
181 |
|
|
* Thu Dec 6 2007 Joe Orton <jorton@redhat.com> 2.0.3-15 |
182 |
|
|
- rebuild for new OpenLDAP |
183 |
|
|
|
184 |
|
|
* Wed Sep 5 2007 Joe Orton <jorton@redhat.com> 2.0.3-14 |
185 |
|
|
- filter perl(HTTP::Request::Common) Provide from -devel (#247250) |
186 |
|
|
|
187 |
|
|
* Sun Sep 2 2007 Joe Orton <jorton@redhat.com> 2.0.3-13 |
188 |
|
|
- rebuild for fixed 32-bit APR |
189 |
|
|
|
190 |
|
|
* Thu Aug 23 2007 Joe Orton <jorton@redhat.com> 2.0.3-12 |
191 |
|
|
- rebuild for expat soname bump |
192 |
|
|
|
193 |
|
|
* Tue Aug 21 2007 Joe Orton <jorton@redhat.com> 2.0.3-11 |
194 |
|
|
- rebuild for libdb soname bump |
195 |
|
|
|
196 |
|
|
* Mon Aug 20 2007 Joe Orton <jorton@redhat.com> 2.0.3-10 |
197 |
|
|
- fix License |
198 |
|
|
|
199 |
|
|
* Fri Apr 20 2007 Joe Orton <jorton@redhat.com> 2.0.3-8 |
200 |
|
|
- filter provide of perl(warnings) (#228429) |
201 |
|
|
|
202 |
|
|
* Wed Feb 28 2007 Joe Orton <jorton@redhat.com> 2.0.3-7 |
203 |
|
|
- also restore Apache::Test to devel |
204 |
|
|
- add BR for perl-devel |
205 |
|
|
|
206 |
|
|
* Tue Feb 27 2007 Joe Orton <jorton@redhat.com> 2.0.3-6 |
207 |
|
|
- filter more Apache::Test requirements |
208 |
|
|
|
209 |
|
|
* Mon Feb 26 2007 Joe Orton <jorton@redhat.com> 2.0.3-5 |
210 |
|
|
- repackage set of trimmed modules, but only in -devel |
211 |
|
|
|
212 |
|
|
* Wed Jan 31 2007 Joe Orton <jorton@redhat.com> 2.0.3-4 |
213 |
|
|
- restore ModPerl::MM |
214 |
|
|
|
215 |
|
|
* Tue Dec 5 2006 Joe Orton <jorton@redhat.com> 2.0.3-3 |
216 |
|
|
- trim modules even more aggressively (#197841) |
217 |
|
|
|
218 |
|
|
* Mon Dec 4 2006 Joe Orton <jorton@redhat.com> 2.0.3-2 |
219 |
|
|
- update to 2.0.3 |
220 |
|
|
- remove droplet in buildroot from multilib patch |
221 |
|
|
- drop build-related ModPerl:: modules and Apache::Test (#197841) |
222 |
|
|
- spec file cleanups |
223 |
|
|
|
224 |
|
|
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control |
225 |
|
|
- rebuild |
226 |
|
|
|
227 |
|
|
* Thu Jun 15 2006 Joe Orton <jorton@redhat.com> 2.0.2-6 |
228 |
|
|
- fix multilib conflicts in -devel (#192733) |
229 |
|
|
|
230 |
|
|
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.0.2-5.1 |
231 |
|
|
- bump again for double-long bug on ppc(64) |
232 |
|
|
|
233 |
|
|
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.0.2-3.2 |
234 |
|
|
- rebuilt for new gcc4.1 snapshot and glibc changes |
235 |
|
|
|
236 |
|
|
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> |
237 |
|
|
- rebuilt |
238 |
|
|
|
239 |
|
|
* Fri Dec 2 2005 Joe Orton <jorton@redhat.com> 2.0.2-3 |
240 |
|
|
- rebuild for httpd 2.2 |
241 |
|
|
|
242 |
|
|
* Wed Oct 26 2005 Joe Orton <jorton@redhat.com> 2.0.2-2 |
243 |
|
|
- update to 2.0.2 |
244 |
|
|
|
245 |
|
|
* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 2.0.1-2 |
246 |
|
|
- rebuild |
247 |
|
|
|
248 |
|
|
* Fri Jun 17 2005 Warren Togami <wtogami@redhat.com> 2.0.1-1 |
249 |
|
|
- 2.0.1 |
250 |
|
|
|
251 |
|
|
* Fri May 20 2005 Warren Togami <wtogami@redhat.com> 2.0.0-3 |
252 |
|
|
- dep changes (#114651 jpo and ville) |
253 |
|
|
|
254 |
|
|
* Fri May 20 2005 Joe Orton <jorton@redhat.com> 2.0.0-1 |
255 |
|
|
- update to 2.0.0 final |
256 |
|
|
|
257 |
|
|
* Mon Apr 18 2005 Ville Skyttรค <ville.skytta at iki.fi> - 2.0.0-0.rc5.3 |
258 |
|
|
- Fix sample configuration. |
259 |
|
|
- Explicitly disable the test suite. (#112563) |
260 |
|
|
|
261 |
|
|
* Mon Apr 18 2005 Joe Orton <jorton@redhat.com> 2.0.0-0.rc5.2 |
262 |
|
|
- fix filter-requires for new Apache2:: modules |
263 |
|
|
|
264 |
|
|
* Sat Apr 16 2005 Warren Togami <wtogami@redhat.com> - 2.0.0-0.rc5.1 |
265 |
|
|
- 2.0.0-RC5 |
266 |
|
|
|
267 |
|
|
* Sun Apr 03 2005 Jose Pedro Oliveira <jpo@di.uminho.pt> - 2.0.0-0.rc4.1 |
268 |
|
|
- Update to 2.0.0-RC4. |
269 |
|
|
- Specfile cleanup. (#153236) |