1 |
%define contentdir /var/www |
2 |
|
3 |
Name: mod_perl |
4 |
Version: 2.0.4 |
5 |
Release: 12.1%{?dist} |
6 |
Summary: An embedded Perl interpreter for the Apache HTTP Server |
7 |
|
8 |
Group: System Environment/Daemons |
9 |
License: ASL 2.0 |
10 |
URL: http://perl.apache.org/ |
11 |
Source0: http://perl.apache.org/dist/mod_perl-%{version}.tar.gz |
12 |
Source1: perl.conf |
13 |
Source2: filter-requires.sh |
14 |
Source3: filter-provides.sh |
15 |
Patch0: mod_perl-2.0.4-multilib.patch |
16 |
Patch1: mod_perl-2.0.4-inline.patch |
17 |
Patch2: mod_perl-2.0.4-CVE-2009-0796.patch |
18 |
Patch3: mod_perl-2.0.4-tipool-race.patch |
19 |
# Fix CVE-2011-2767 (arbitrary Perl code execution in the context of the user |
20 |
# account via a user-owned .htaccess), bug #1626272, CPAN RT#126984 |
21 |
Patch4: mod_perl-2.0.10-restrict_perl_section_to_server_scope.patch |
22 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
23 |
|
24 |
BuildRequires: perl-devel, perl(ExtUtils::Embed) |
25 |
BuildRequires: httpd-devel >= 2.2.0, httpd, gdbm-devel |
26 |
BuildRequires: apr-devel >= 1.2.0, apr-util-devel |
27 |
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) |
28 |
Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn || echo missing) |
29 |
|
30 |
%define __perl_requires %{SOURCE2} |
31 |
%define __perl_provides %{SOURCE3} |
32 |
|
33 |
%description |
34 |
Mod_perl incorporates a Perl interpreter into the Apache web server, |
35 |
so that the Apache web server can directly execute Perl code. |
36 |
Mod_perl links the Perl runtime library into the Apache web server and |
37 |
provides an object-oriented Perl interface for Apache's C language |
38 |
API. The end result is a quicker CGI script turnaround process, since |
39 |
no external Perl interpreter has to be started. |
40 |
|
41 |
Install mod_perl if you're installing the Apache web server and you'd |
42 |
like for it to directly incorporate a Perl interpreter. |
43 |
|
44 |
|
45 |
%package devel |
46 |
Summary: Files needed for building XS modules that use mod_perl |
47 |
Group: Development/Libraries |
48 |
Requires: mod_perl = %{version}-%{release}, httpd-devel |
49 |
|
50 |
%description devel |
51 |
The mod_perl-devel package contains the files needed for building XS |
52 |
modules that use mod_perl. |
53 |
|
54 |
|
55 |
%prep |
56 |
%setup -q -n %{name}-%{version} |
57 |
%patch0 -p1 |
58 |
%patch1 -p1 -b .inline |
59 |
%patch2 -p1 |
60 |
%patch3 -p1 -b .tipool |
61 |
%patch4 -p1 |
62 |
|
63 |
%build |
64 |
CFLAGS="$RPM_OPT_FLAGS -fpic" %{__perl} Makefile.PL </dev/null \ |
65 |
PREFIX=$RPM_BUILD_ROOT/usr \ |
66 |
INSTALLDIRS=vendor \ |
67 |
MP_APXS=%{_sbindir}/apxs \ |
68 |
MP_APR_CONFIG=%{_bindir}/apr-1-config |
69 |
make -C src/modules/perl %{?_smp_mflags} OPTIMIZE="$RPM_OPT_FLAGS -fpic" |
70 |
make |
71 |
|
72 |
%install |
73 |
rm -rf $RPM_BUILD_ROOT |
74 |
install -d -m 755 $RPM_BUILD_ROOT%{_libdir}/httpd/modules |
75 |
make install \ |
76 |
MODPERL_AP_LIBEXECDIR=$RPM_BUILD_ROOT%{_libdir}/httpd/modules \ |
77 |
MODPERL_AP_INCLUDEDIR=$RPM_BUILD_ROOT%{_includedir}/httpd |
78 |
|
79 |
# Remove the temporary files. |
80 |
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';' |
81 |
find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';' |
82 |
find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';' |
83 |
find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';' |
84 |
|
85 |
# Fix permissions to avoid strip failures on non-root builds. |
86 |
chmod -R u+w $RPM_BUILD_ROOT/* |
87 |
|
88 |
# Install the config file |
89 |
install -d -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d |
90 |
install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/ |
91 |
|
92 |
# Move set of modules to -devel |
93 |
devmods="ModPerl::Code ModPerl::BuildMM ModPerl::CScan \ |
94 |
ModPerl::TestRun ModPerl::Config ModPerl::WrapXS \ |
95 |
ModPerl::BuildOptions ModPerl::Manifest \ |
96 |
ModPerl::MapUtil ModPerl::StructureMap \ |
97 |
ModPerl::TypeMap ModPerl::FunctionMap \ |
98 |
ModPerl::ParseSource ModPerl::MM \ |
99 |
Apache2::Build Apache2::ParseSource Apache2::BuildConfig \ |
100 |
Apache Bundle::ApacheTest" |
101 |
for m in $devmods; do |
102 |
test -f $RPM_BUILD_ROOT%{_mandir}/man3/${m}.3pm && |
103 |
echo "%{_mandir}/man3/${m}.3pm*" |
104 |
fn=${m//::/\/} |
105 |
test -f $RPM_BUILD_ROOT%{perl_vendorarch}/${fn}.pm && |
106 |
echo %{perl_vendorarch}/${fn}.pm |
107 |
test -d $RPM_BUILD_ROOT%{perl_vendorarch}/${fn} && |
108 |
echo %{perl_vendorarch}/${fn} |
109 |
test -d $RPM_BUILD_ROOT%{perl_vendorarch}/auto/${fn} && |
110 |
echo %{perl_vendorarch}/auto/${fn} |
111 |
done | tee devel.files | sed 's/^/%%exclude /' > exclude.files |
112 |
echo "%{_mandir}/man3/Apache::*.3pm*" | tee -a devel.files \ |
113 |
| sed 's/^/%%exclude /' >> exclude.files |
114 |
|
115 |
# Completely remove Apache::Test - can be packaged separately |
116 |
#rm -rf $RPM_BUILD_ROOT%{_mandir}/man3/Apache::Test* |
117 |
#rm -rf $RPM_BUILD_ROOT%{perl_vendorarch}/Apache |
118 |
|
119 |
|
120 |
%clean |
121 |
rm -rf $RPM_BUILD_ROOT |
122 |
|
123 |
%files -f exclude.files |
124 |
%defattr(-,root,root,-) |
125 |
%doc Changes LICENSE README* STATUS SVN-MOVE docs/ |
126 |
%config(noreplace) %{_sysconfdir}/httpd/conf.d/*.conf |
127 |
%{_bindir}/* |
128 |
%{_libdir}/httpd/modules/mod_perl.so |
129 |
%{perl_vendorarch}/auto/* |
130 |
%{perl_vendorarch}/Apache2/ |
131 |
%{perl_vendorarch}/Bundle/ |
132 |
%{perl_vendorarch}/APR/ |
133 |
%{perl_vendorarch}/ModPerl/ |
134 |
%{perl_vendorarch}/*.pm |
135 |
%{_mandir}/man3/*.3* |
136 |
|
137 |
%files devel -f devel.files |
138 |
%defattr(-,root,root,-) |
139 |
%{_includedir}/httpd/* |
140 |
|
141 |
%changelog |
142 |
* Mon Oct 1 2018 Daniel Berteaud <daniel@firewall-services.com> - 2.0.4-12.1.sme |
143 |
- Rebase on upstream version and bump release [SME: 10625] |
144 |
|
145 |
* Wed Aug 29 2018 Petr Pisar <ppisar@redhat.com> - 2.0.4-12 |
146 |
- Fix CVE-2011-2767 (arbitrary Perl code execution in the context of the user |
147 |
account via a user-owned .htaccess) (bug #1626272) |
148 |
|
149 |
* Wed Apr 23 2014 Ian Wells <esmith@wellsi.com> 2.0.4-11.1.sme |
150 |
- Bump version number [SME: 8343] |
151 |
|
152 |
* Tue Apr 22 2014 Ian Wells <esmith@wellsi.com> 2.0.4-11.sme |
153 |
- Update to latest upstream [SME: 8343] |
154 |
|
155 |
* Wed Apr 16 2014 Jan Kaluza <jkaluza@redhat.com> - 2.0.4-11 |
156 |
- fix a race condition in tipool management (#1072766) |
157 |
|
158 |
* Tue Feb 12 2013 Shad L. Lords <slords@mail.com> - 2.0.4-10.sme |
159 |
- Move Apache::Test* man pages to devel package [SME: 7331] |
160 |
|
161 |
* Tue Dec 8 2009 Joe Orton <jorton@redhat.com> - 2.0.4-10 |
162 |
- add security fix for CVE-2009-0796 (#544455) |
163 |
|
164 |
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.4-9 |
165 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
166 |
|
167 |
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.4-8 |
168 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
169 |
|
170 |
* Fri Oct 17 2008 Joe Orton <jorton@redhat.com> 2.0.4-7 |
171 |
- fix inline abuse (#459351) |
172 |
|
173 |
* Wed Aug 6 2008 Joe Orton <jorton@redhat.com> 2.0.4-5 |
174 |
- rebuild to fix patch fuzz (#427758) |
175 |
|
176 |
* Mon Jul 14 2008 Joe Orton <jorton@redhat.com> 2.0.4-4 |
177 |
- rebuild for new BDB |
178 |
|
179 |
* Tue May 13 2008 Joe Orton <jorton@redhat.com> 2.0.4-3 |
180 |
- trim changelog; rebuild |
181 |
|
182 |
* Fri Apr 18 2008 Joe Orton <jorton@redhat.com> 2.0.4-2 |
183 |
- update to 2.0.4 |
184 |
|
185 |
* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.3-21 |
186 |
- Rebuild for perl 5.10 (again) |
187 |
|
188 |
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.3-20 |
189 |
- Autorebuild for GCC 4.3 |
190 |
|
191 |
* Wed Jan 30 2008 Joe Orton <jorton@redhat.com> 2.0.3-19 |
192 |
- further fixes for perl 5.10 (upstream r480903, r615751) |
193 |
|
194 |
* Wed Jan 30 2008 Joe Orton <jorton@redhat.com> 2.0.3-18 |
195 |
- fix build with perl 5.10 (upstream r480890) |
196 |
|
197 |
* Tue Jan 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-17 |
198 |
- fix perl BR |
199 |
|
200 |
* Mon Jan 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-16 |
201 |
- rebuild for new perl |
202 |
|
203 |
* Thu Dec 6 2007 Joe Orton <jorton@redhat.com> 2.0.3-15 |
204 |
- rebuild for new OpenLDAP |
205 |
|
206 |
* Wed Sep 5 2007 Joe Orton <jorton@redhat.com> 2.0.3-14 |
207 |
- filter perl(HTTP::Request::Common) Provide from -devel (#247250) |
208 |
|
209 |
* Sun Sep 2 2007 Joe Orton <jorton@redhat.com> 2.0.3-13 |
210 |
- rebuild for fixed 32-bit APR |
211 |
|
212 |
* Thu Aug 23 2007 Joe Orton <jorton@redhat.com> 2.0.3-12 |
213 |
- rebuild for expat soname bump |
214 |
|
215 |
* Tue Aug 21 2007 Joe Orton <jorton@redhat.com> 2.0.3-11 |
216 |
- rebuild for libdb soname bump |
217 |
|
218 |
* Mon Aug 20 2007 Joe Orton <jorton@redhat.com> 2.0.3-10 |
219 |
- fix License |
220 |
|
221 |
* Fri Apr 20 2007 Joe Orton <jorton@redhat.com> 2.0.3-8 |
222 |
- filter provide of perl(warnings) (#228429) |
223 |
|
224 |
* Wed Feb 28 2007 Joe Orton <jorton@redhat.com> 2.0.3-7 |
225 |
- also restore Apache::Test to devel |
226 |
- add BR for perl-devel |
227 |
|
228 |
* Tue Feb 27 2007 Joe Orton <jorton@redhat.com> 2.0.3-6 |
229 |
- filter more Apache::Test requirements |
230 |
|
231 |
* Mon Feb 26 2007 Joe Orton <jorton@redhat.com> 2.0.3-5 |
232 |
- repackage set of trimmed modules, but only in -devel |
233 |
|
234 |
* Wed Jan 31 2007 Joe Orton <jorton@redhat.com> 2.0.3-4 |
235 |
- restore ModPerl::MM |
236 |
|
237 |
* Tue Dec 5 2006 Joe Orton <jorton@redhat.com> 2.0.3-3 |
238 |
- trim modules even more aggressively (#197841) |
239 |
|
240 |
* Mon Dec 4 2006 Joe Orton <jorton@redhat.com> 2.0.3-2 |
241 |
- update to 2.0.3 |
242 |
- remove droplet in buildroot from multilib patch |
243 |
- drop build-related ModPerl:: modules and Apache::Test (#197841) |
244 |
- spec file cleanups |
245 |
|
246 |
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control |
247 |
- rebuild |
248 |
|
249 |
* Thu Jun 15 2006 Joe Orton <jorton@redhat.com> 2.0.2-6 |
250 |
- fix multilib conflicts in -devel (#192733) |
251 |
|
252 |
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.0.2-5.1 |
253 |
- bump again for double-long bug on ppc(64) |
254 |
|
255 |
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.0.2-3.2 |
256 |
- rebuilt for new gcc4.1 snapshot and glibc changes |
257 |
|
258 |
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> |
259 |
- rebuilt |
260 |
|
261 |
* Fri Dec 2 2005 Joe Orton <jorton@redhat.com> 2.0.2-3 |
262 |
- rebuild for httpd 2.2 |
263 |
|
264 |
* Wed Oct 26 2005 Joe Orton <jorton@redhat.com> 2.0.2-2 |
265 |
- update to 2.0.2 |
266 |
|
267 |
* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 2.0.1-2 |
268 |
- rebuild |
269 |
|
270 |
* Fri Jun 17 2005 Warren Togami <wtogami@redhat.com> 2.0.1-1 |
271 |
- 2.0.1 |
272 |
|
273 |
* Fri May 20 2005 Warren Togami <wtogami@redhat.com> 2.0.0-3 |
274 |
- dep changes (#114651 jpo and ville) |
275 |
|
276 |
* Fri May 20 2005 Joe Orton <jorton@redhat.com> 2.0.0-1 |
277 |
- update to 2.0.0 final |
278 |
|
279 |
* Mon Apr 18 2005 Ville Skyttรค <ville.skytta at iki.fi> - 2.0.0-0.rc5.3 |
280 |
- Fix sample configuration. |
281 |
- Explicitly disable the test suite. (#112563) |
282 |
|
283 |
* Mon Apr 18 2005 Joe Orton <jorton@redhat.com> 2.0.0-0.rc5.2 |
284 |
- fix filter-requires for new Apache2:: modules |
285 |
|
286 |
* Sat Apr 16 2005 Warren Togami <wtogami@redhat.com> - 2.0.0-0.rc5.1 |
287 |
- 2.0.0-RC5 |
288 |
|
289 |
* Sun Apr 03 2005 Jose Pedro Oliveira <jpo@di.uminho.pt> - 2.0.0-0.rc4.1 |
290 |
- Update to 2.0.0-RC4. |
291 |
- Specfile cleanup. (#153236) |