1 |
unnilennium |
1.1 |
# $Id: oidentd.spec 7981 2009-11-03 03:05:34Z dag $ |
2 |
|
|
# Authority: matthias |
3 |
|
|
# Upstream: Ryan McCabe <ryan$numb,org> |
4 |
|
|
|
5 |
|
|
Summary: Implementation of the RFC1413 identification server |
6 |
|
|
Name: oidentd |
7 |
unnilennium |
1.2 |
%define version 2.0.8 |
8 |
unnilennium |
1.4 |
%define release 4 |
9 |
unnilennium |
1.2 |
Version: %{version} |
10 |
|
|
Release: %{release}%{?dist} |
11 |
unnilennium |
1.1 |
License: GPL |
12 |
|
|
Group: System Environment/Daemons |
13 |
|
|
URL: http://ojnk.sourceforge.net/ |
14 |
|
|
Packager: Dag Wieers <dag@wieers.com> |
15 |
|
|
Vendor: Dag Apt Repository, http://dag.wieers.com/apt/ |
16 |
|
|
|
17 |
|
|
Source0: http://dl.sf.net/ojnk/oidentd-%{version}.tar.gz |
18 |
|
|
Source1: identd.init |
19 |
|
|
Source2: identd.spoof |
20 |
|
|
Source3: oidentd.users |
21 |
unnilennium |
1.3 |
Patch0: oidentd-2.0.8-linux-2.6.21.patch |
22 |
unnilennium |
1.1 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root |
23 |
|
|
Requires(post): /sbin/chkconfig |
24 |
|
|
Requires(preun): /sbin/service, /sbin/chkconfig |
25 |
|
|
Requires(postun): /sbin/service |
26 |
|
|
BuildRequires: byacc |
27 |
unnilennium |
1.3 |
BuildRequires: bison, flex |
28 |
unnilennium |
1.1 |
Provides: identd = %{version} |
29 |
|
|
Conflicts: pidentd |
30 |
|
|
|
31 |
|
|
%description |
32 |
|
|
The oidentd package contains identd, which implements the RFC1413 |
33 |
|
|
identification server. Identd looks up specific TCP/IP connections |
34 |
|
|
and returns either the user name or other information about the |
35 |
|
|
process that owns the connection. |
36 |
|
|
|
37 |
|
|
Install oidentd if you need to look up information about specific |
38 |
|
|
TCP/IP connections. |
39 |
|
|
|
40 |
|
|
|
41 |
|
|
%prep |
42 |
|
|
%setup |
43 |
unnilennium |
1.3 |
%patch0 -p1 |
44 |
unnilennium |
1.1 |
|
45 |
|
|
%build |
46 |
unnilennium |
1.3 |
%configure \ |
47 |
|
|
--enable-masq \ |
48 |
|
|
--enable-ipv6 \ |
49 |
|
|
--disable-debug \ |
50 |
|
|
--disable-warn \ |
51 |
|
|
CFLAGS="${RPM_OPT_FLAGS} -std=gnu89" |
52 |
unnilennium |
1.1 |
%{__make} %{?_smp_mflags} |
53 |
|
|
|
54 |
|
|
|
55 |
|
|
%install |
56 |
|
|
%{__rm} -rf %{buildroot} |
57 |
|
|
%makeinstall |
58 |
|
|
%{__install} -Dp -m 755 %{SOURCE1} %{buildroot}/etc/rc.d/init.d/identd |
59 |
|
|
%{__install} -Dp -m 640 %{SOURCE2} %{buildroot}%{_sysconfdir}/identd.spoof |
60 |
|
|
%{__install} -Dp -m 640 %{SOURCE3} %{buildroot}%{_sysconfdir}/oidentd.users |
61 |
|
|
|
62 |
|
|
|
63 |
|
|
%clean |
64 |
|
|
%{__rm} -rf %{buildroot} |
65 |
|
|
|
66 |
|
|
|
67 |
|
|
%post |
68 |
|
|
/sbin/chkconfig --add identd |
69 |
|
|
|
70 |
|
|
%preun |
71 |
|
|
if [ $1 -eq 0 ]; then |
72 |
|
|
/sbin/service identd stop >/dev/null 2>&1 |
73 |
|
|
/sbin/chkconfig --del identd |
74 |
|
|
fi |
75 |
|
|
|
76 |
|
|
%postun |
77 |
|
|
if [ $1 -ge 1 ]; then |
78 |
|
|
/sbin/service identd condrestart >/dev/null 2>&1 |
79 |
|
|
fi |
80 |
|
|
|
81 |
|
|
|
82 |
|
|
%files |
83 |
|
|
%defattr(-, root, root, 0755) |
84 |
|
|
%doc AUTHORS ChangeLog* COPYING* doc/rfc1413 NEWS README TODO |
85 |
|
|
%attr(0640, root, nobody) %config(noreplace) %{_sysconfdir}/identd.spoof |
86 |
|
|
%attr(0640, root, nobody) %config(noreplace) %{_sysconfdir}/oidentd.users |
87 |
|
|
%config /etc/rc.d/init.d/identd |
88 |
|
|
%{_sbindir}/oidentd |
89 |
|
|
%{_mandir}/man?/* |
90 |
|
|
|
91 |
|
|
|
92 |
|
|
%changelog |
93 |
unnilennium |
1.4 |
* Tue Mar 29 2016 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.8-4.sme |
94 |
unnilennium |
1.3 |
- fix missing masquerade [SME: 9404] |
95 |
|
|
- fedora patch https://bugzilla.redhat.com/show_bug.cgi?id=1305491 |
96 |
|
|
|
97 |
unnilennium |
1.2 |
* Fri Mar 18 2016 Jean-Philipe Pialasse <tests@pialasse.com> 2.08-2.sme |
98 |
|
|
- Import for SME 10 [SME: 9340] |
99 |
|
|
|
100 |
unnilennium |
1.1 |
* Mon Apr 16 2007 Dries Verachtert <dries@ulyssis.org> - 2.0.8-1 - 7981/dag |
101 |
|
|
- Updated to release 2.0.8. |
102 |
|
|
|
103 |
|
|
* Wed Nov 3 2004 Matthias Saou <http://freshrpms.net/> 2.0.7-4 |
104 |
|
|
- Rebuild for Fedora Core 3. |
105 |
|
|
- Change /etc/init.d to /etc/rc.d/init.d and minor other spec tweaks. |
106 |
|
|
|
107 |
|
|
* Wed May 19 2004 Matthias Saou <http://freshrpms.net/> 2.0.7-3 |
108 |
|
|
- Rebuild for Fedora Core 2. |
109 |
|
|
|
110 |
|
|
* Fri Nov 7 2003 Matthias Saou <http://freshrpms.net/> 2.0.7-2 |
111 |
|
|
- Rebuild for Fedora Core 1. |
112 |
|
|
|
113 |
|
|
* Tue Jul 15 2003 Matthias Saou <http://freshrpms.net/> |
114 |
|
|
- Update to 2.0.7. |
115 |
|
|
|
116 |
|
|
* Mon Mar 31 2003 Matthias Saou <http://freshrpms.net/> |
117 |
|
|
- Rebuilt for Red Hat Linux 9. |
118 |
|
|
|
119 |
|
|
* Sun Sep 29 2002 Matthias Saou <http://freshrpms.net/> |
120 |
|
|
- Rebuilt for Red Hat Linux 8.0. |
121 |
|
|
|
122 |
|
|
* Thu Aug 22 2002 Matthias Saou <http://freshrpms.net/> |
123 |
|
|
- Fixed the init script's status, thanks to Jørn for spotting this. |
124 |
|
|
|
125 |
|
|
* Wed Aug 21 2002 Matthias Saou <http://freshrpms.net/> |
126 |
|
|
- Update to 2.0.4. |
127 |
|
|
|
128 |
|
|
* Fri May 3 2002 Matthias Saou <http://freshrpms.net/> |
129 |
|
|
- Rebuilt against Red Hat Linux 7.3. |
130 |
|
|
- Added the %%{?_smp_mflags} expansion. |
131 |
|
|
|
132 |
|
|
* Tue Jan 8 2002 Matthias Saou <http://freshrpms.net/> |
133 |
|
|
- Update to 2.0.3. |
134 |
|
|
- Fix user in %files for "-". |
135 |
|
|
|
136 |
|
|
* Sun Dec 30 2001 Matthias Saou <http://freshrpms.net/> |
137 |
|
|
- Update to 2.0.2. |
138 |
|
|
|
139 |
|
|
* Thu Oct 4 2001 Matthias Saou <http://freshrpms.net/> |
140 |
|
|
- Update to 2.0.1. |
141 |
|
|
|
142 |
|
|
* Mon Oct 1 2001 Matthias Saou <http://freshrpms.net/> |
143 |
|
|
- Update to 2.0.0. |
144 |
|
|
|
145 |
|
|
* Sat Sep 15 2001 Matthias Saou <http://freshrpms.net/> |
146 |
|
|
- Update to 1.9.9.1. |
147 |
|
|
|
148 |
|
|
* Mon Aug 27 2001 Matthias Saou <http://freshrpms.net/> |
149 |
|
|
- Update to 1.9.9 (complete program rewrite). |
150 |
|
|
- Added new docs and manpages. |
151 |
|
|
|
152 |
|
|
* Tue Apr 24 2001 Matthias Saou <http://freshrpms.net/> |
153 |
|
|
- Spec file cleanup and rebuilt for Red Hat 7.1. |
154 |
|
|
|
155 |
|
|
* Tue Jan 2 2001 Matthias Saou <http://freshrpms.net/> |
156 |
|
|
- Added a Conflicts: for pidentd |
157 |
|
|
- Quick cleanup |
158 |
|
|
- Fixed o-r modes |
159 |
|
|
- Changed the uid/gid in the initscript |
160 |
|
|
|
161 |
|
|
* Wed Dec 27 2000 Matthias Saou <http://freshrpms.net/> |
162 |
|
|
- Initial RPM release |
163 |
|
|
|