1 |
Name: perl-Bytes-Random-Secure |
2 |
Version: 0.29 |
3 |
Release: 1%{?dist} |
4 |
Summary: Perl extension to generate cryptographically-secure random bytes |
5 |
License: GPL+ or Artistic |
6 |
Group: Development/Libraries |
7 |
URL: http://search.cpan.org/dist/Bytes-Random-Secure/ |
8 |
Source0: http://www.cpan.org/authors/id/D/DA/DAVIDO/Bytes-Random-Secure-%{version}.tar.gz |
9 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
10 |
BuildArch: noarch |
11 |
BuildRequires: perl >= 0:5.006000 |
12 |
BuildRequires: perl(Carp) |
13 |
BuildRequires: perl(Crypt::Random::Seed) |
14 |
BuildRequires: perl(ExtUtils::MakeMaker) |
15 |
BuildRequires: perl(Math::Random::ISAAC) |
16 |
BuildRequires: perl(Scalar::Util) >= 1.21 |
17 |
#BuildRequires: perl(Test::More) >= 0.98 |
18 |
BuildRequires: perl(Test::More) |
19 |
Requires: perl(Carp) |
20 |
Requires: perl(Crypt::Random::Seed) |
21 |
Requires: perl(Math::Random::ISAAC) |
22 |
Requires: perl(Scalar::Util) >= 1.21 |
23 |
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) |
24 |
|
25 |
%description |
26 |
Bytes::Random::Secure provides two interfaces for obtaining crypto-quality |
27 |
random bytes. The simple interface is built around plain functions. For |
28 |
greater control over the Random Number Generator's seeding, there is an |
29 |
Object Oriented interface that provides much more flexibility. |
30 |
|
31 |
%prep |
32 |
%setup -q -n Bytes-Random-Secure-%{version} |
33 |
|
34 |
%build |
35 |
%{__perl} Makefile.PL INSTALLDIRS=vendor |
36 |
make %{?_smp_mflags} |
37 |
|
38 |
%install |
39 |
rm -rf $RPM_BUILD_ROOT |
40 |
|
41 |
make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT |
42 |
|
43 |
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \; |
44 |
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \; |
45 |
|
46 |
%{_fixperms} $RPM_BUILD_ROOT/* |
47 |
|
48 |
%check |
49 |
make test |
50 |
|
51 |
%clean |
52 |
rm -rf $RPM_BUILD_ROOT |
53 |
|
54 |
%files |
55 |
%defattr(-,root,root,-) |
56 |
%doc Changes META.json README |
57 |
%{perl_vendorlib}/* |
58 |
%{_mandir}/man3/* |
59 |
|
60 |
%changelog |
61 |
* Mon Oct 08 2018 Daniel Berteaud <daniel@firewall-services.com> - 0.29-1 |
62 |
- First build, using cpanspec |