1 |
slords |
1.1 |
Summary: CGI-FormMagick module for perl |
2 |
|
|
%define name perl-CGI-FormMagick |
3 |
|
|
%define version 0.92 |
4 |
bytegw |
1.5 |
%define release 14 |
5 |
slords |
1.1 |
Name: %{name} |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: distributable |
9 |
|
|
Group: Applications/CPAN |
10 |
|
|
Source0: perl-CGI-FormMagick-%{version}.tar.gz |
11 |
|
|
Patch0: perl-CGI-FormMagick-0.92-password_validation.patch |
12 |
|
|
Patch1: perl-CGI-FormMagick-0.92-password_validation2.patch |
13 |
|
|
Patch2: perl-CGI-FormMagick-0.92-quotemeta.patch |
14 |
|
|
Patch3: perl-CGI-FormMagick-0.92-textarea.patch |
15 |
|
|
Patch4: perl-CGI-FormMagick-0.92-validateliteral.patch |
16 |
slords |
1.2 |
Patch5: perl-CGI-FormMagick-0.92-nodata.patch |
17 |
bytegw |
1.3 |
Patch6: perl-CGI-FormMagick-0.92-persistent10.patch |
18 |
slords |
1.4 |
Patch7: perl-CGI-FormMagick-0.92-persistent10.patch2 |
19 |
bytegw |
1.5 |
Patch8: perl-CGI-FormMagick-0.92-persistent10.patch3 |
20 |
slords |
1.1 |
Url: http://www.cpan.org |
21 |
|
|
BuildRoot: /var/tmp/perl-CGI-FormMagick-buildroot/ |
22 |
|
|
BuildArchitectures: noarch |
23 |
|
|
BuildRequires: perl |
24 |
|
|
Requires: perl perl(XML::Parser) expat |
25 |
bytegw |
1.3 |
Requires: perl(CGI::Persistent) >= 1.00 |
26 |
slords |
1.1 |
Requires: perl(Class::ParamParser) perl(I18N::LangTags) |
27 |
|
|
Requires: perl(Text::Iconv) |
28 |
|
|
Requires: perl(Text::Template) |
29 |
|
|
Requires: perl(Mail::RFC822::Address) |
30 |
|
|
Provides: perl(ArbitraryPackage) |
31 |
|
|
Provides: perl(CGI::FormMagick) = %{version}-%{release} |
32 |
|
|
Provides: perl(CGI::FormMagick::Sub) |
33 |
|
|
Provides: perl(CGI::FormMagick::TagMaker) = 1.01 |
34 |
|
|
Provides: perl(CGI::FormMagick::Validator) |
35 |
|
|
Autoreq: no |
36 |
|
|
|
37 |
|
|
%description |
38 |
|
|
FormMagick is a Perl module which enables XML descriptions to be used |
39 |
|
|
to generate HTML wizard-like forms. It has support for I18N/L10N. |
40 |
|
|
|
41 |
|
|
%prep |
42 |
|
|
%setup -q |
43 |
|
|
%patch0 -p1 |
44 |
|
|
%patch1 -p1 |
45 |
|
|
%patch2 -p1 |
46 |
|
|
%patch3 -p1 |
47 |
|
|
%patch4 -p1 |
48 |
slords |
1.2 |
%patch5 -p1 |
49 |
bytegw |
1.3 |
%patch6 -p1 |
50 |
slords |
1.4 |
%patch7 -p1 |
51 |
bytegw |
1.5 |
%patch8 -p1 |
52 |
slords |
1.1 |
|
53 |
|
|
%build |
54 |
|
|
grep -rsl '^#!.*perl' . | |
55 |
|
|
grep -v '.bak$' |xargs --no-run-if-empty \ |
56 |
|
|
%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' |
57 |
|
|
CFLAGS="$RPM_OPT_FLAGS" |
58 |
|
|
%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` INSTALLSITELIB=%{_prefix}/lib/perl5/site_perl |
59 |
|
|
%{__make} |
60 |
|
|
|
61 |
|
|
%clean |
62 |
|
|
rm -rf $RPM_BUILD_ROOT |
63 |
|
|
|
64 |
|
|
%install |
65 |
|
|
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
66 |
|
|
|
67 |
|
|
%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '` |
68 |
|
|
|
69 |
|
|
[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress |
70 |
|
|
|
71 |
|
|
# remove special files |
72 |
|
|
find %{buildroot} -name "perllocal.pod" \ |
73 |
|
|
-o -name ".packlist" \ |
74 |
|
|
-o -name "*.bs" \ |
75 |
|
|
|xargs -i rm -f {} |
76 |
|
|
|
77 |
|
|
# no empty directories |
78 |
|
|
find %{buildroot}%{_prefix} \ |
79 |
|
|
-type d -depth \ |
80 |
|
|
-exec rmdir {} \; 2>/dev/null |
81 |
|
|
|
82 |
|
|
find $RPM_BUILD_ROOT/usr -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" | grep -v perllocal.pod > CGI-FormMagick-%{version}-filelist |
83 |
|
|
|
84 |
|
|
%files -f CGI-FormMagick-%{version}-filelist |
85 |
|
|
%defattr(-,root,root) |
86 |
|
|
|
87 |
|
|
%changelog |
88 |
bytegw |
1.5 |
* Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-14 |
89 |
|
|
- Add path to sanitized .id parameter so tokens get created |
90 |
|
|
in right place [SME: 3584] |
91 |
|
|
|
92 |
slords |
1.4 |
* Sat Nov 24 2007 Charlie Brady <charlieb@e-smith.com> 0.92-13 |
93 |
|
|
- Sanitise .id parameter before use. [SME: 3584] |
94 |
|
|
|
95 |
bytegw |
1.3 |
* Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-12 |
96 |
|
|
- Make modules compatible with CGI::Persistent v1.00 [SME: 3581] |
97 |
|
|
|
98 |
slords |
1.2 |
* Tue Jun 12 2007 Shad L. Lords <slords@mail.com> 0.92-11 |
99 |
|
|
- Don't attempt to trim empty/undefined fields [SME: 2395] |
100 |
|
|
|
101 |
slords |
1.1 |
* Mon Jun 11 2007 Shad L. Lords <slords@mail.com> 0.92-10 |
102 |
slords |
1.2 |
- Don't validate literal fields [SME: 2395] |
103 |
slords |
1.1 |
|
104 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
105 |
|
|
- Clean up spec so package can be built by koji/plague |
106 |
|
|
|
107 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
108 |
|
|
- Update to new release naming. No functional changes. |
109 |
|
|
- Make Packager generic |
110 |
|
|
|
111 |
|
|
* Tue Aug 22 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-08 |
112 |
|
|
- Allow initializer of textarea form widgets. [SME: 1088] |
113 |
|
|
|
114 |
|
|
* Mon May 01 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-07 |
115 |
|
|
- Fix quoting of metachars in subst during inputbox output. [SME: 1352] |
116 |
|
|
|
117 |
|
|
* Wed Jan 25 2006 Mark Knox <mark_knox@mitel.com> 0.92-06 |
118 |
|
|
- Added a missing brace in previous fix [SME: 463] |
119 |
|
|
|
120 |
|
|
* Fri Jan 13 2006 Charlie Brady <charlieb@e-smith.com> 0.92-05 |
121 |
|
|
- Fix password validation check to include _ as non-alpha. [SME: 463] |
122 |
|
|
|
123 |
|
|
* Thu Dec 15 2005 Charlie Brady <charlieb@e-smith.com> 0.92-04 |
124 |
|
|
- Build into /usr/lib/perl5/site_perl so that RPM can be installed |
125 |
|
|
on either 6.x or 7.x. |
126 |
|
|
|
127 |
|
|
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 0.92-03 |
128 |
|
|
- Bump release number only |
129 |
|
|
|
130 |
|
|
* Tue Nov 29 2005 Charlie Brady <charlieb@e-smith.com> |
131 |
|
|
- [0.92-02] |
132 |
|
|
- Test rebuild after CVS synchronisation. |
133 |
|
|
|
134 |
|
|
* Mon Oct 31 2005 Mark Knox <mark_knox@mitel.com> |
135 |
|
|
- [0.92-01] |
136 |
|
|
- Imported to ClearCase, bumped version [markk MN00103900] |
137 |
|
|
- Remove generated files Makefile and t/embedded* |
138 |
|
|
- Add BuildRequires: perl => 5.8 |
139 |
|
|
|
140 |
|
|
* Thu Oct 27 2005 Charlie Brady <charlieb@e-smith.com> |
141 |
|
|
- [0.91-30] |
142 |
|
|
- Avoid warning messages if we try to trim whitespace around $field->{id} when |
143 |
|
|
it isn't defined. [SF: 1227604] |
144 |
|
|
|
145 |
|
|
* Mon Oct 3 2005 Charlie Brady <charlieb@e-smith.com> |
146 |
|
|
- [0.91-29] |
147 |
|
|
- Fix colspan attributes in display_fields(). [SF: 1309359] |
148 |
|
|
|
149 |
|
|
* Mon Sep 5 2005 Tony Clayton <apc@e-smith.com> |
150 |
|
|
- [0.91-28] |
151 |
|
|
- s/Copyright/License/ in rpm headers |
152 |
|
|
- Fix subroutine element handling in Validator.pm to fix barrage of logfile |
153 |
|
|
warnings |
154 |
|
|
- Move sessiondir,cgi object initialization from display() to new() |
155 |
|
|
- Remove deprecated sessiondir(),munge_fm_obj() methods |
156 |
|
|
|
157 |
|
|
* Tue Jul 19 2005 Charlie Brady <charlieb@e-smith.com> |
158 |
|
|
- [0.91-27] |
159 |
|
|
- Validation fixes from Shad Lords: |
160 |
|
|
- Change static strings to TAGS (for L10N) |
161 |
|
|
- Fix ip_check to actually check value |
162 |
|
|
- Update Provides header to specify version and release |
163 |
|
|
|
164 |
|
|
* Tue May 24 2005 Charlie Brady <charlieb@e-smith.com> |
165 |
|
|
- [0.91-26] |
166 |
|
|
- Don't allow rpm to auto calculate perl module dependencies - |
167 |
|
|
it gets them wrong sometimes [SF: 1205965] |
168 |
|
|
|
169 |
|
|
* Fri May 20 2005 Charlie Brady <charlieb@e-smith.com> |
170 |
|
|
- [0.91-25] |
171 |
|
|
- Apply options parsing fix (from Gordon, SF:1205448) |
172 |
|
|
|
173 |
|
|
* Tue May 17 2005 Charlie Brady <charlieb@e-smith.com> |
174 |
|
|
- [0.91-24] |
175 |
|
|
- Remove POD references to unimplemented validation-error-message. |
176 |
|
|
|
177 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
178 |
|
|
- [0.91-23] |
179 |
|
|
- Add patch contributed by Shad Lords to allow multi-select. |
180 |
|
|
|
181 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
182 |
|
|
- [0.91-22] |
183 |
|
|
- Add patch contributed by Shad Lords to be more flexible about |
184 |
|
|
whitespace in validator lists. |
185 |
|
|
|
186 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
187 |
|
|
- [0.91-21] |
188 |
|
|
- Make sure we don't leave unpackaged files in our buildroot. |
189 |
|
|
|
190 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
191 |
|
|
- [0.91-20] |
192 |
|
|
- Update build and install sections, to allow correct building under CentOS. |
193 |
|
|
|
194 |
|
|
* Wed Oct 20 2004 Sean Bradbury <bradbury@e-smith.com> |
195 |
|
|
- [0.91-19] |
196 |
|
|
- Updated requires to remove wrong requires. [bradbury MN00053465] |
197 |
|
|
|
198 |
|
|
* Tue Sep 28 2004 Michael Soulier <msoulier@e-smith.com> |
199 |
|
|
- [0.91-18] |
200 |
|
|
- Updated requires with new perl dependencies. [msoulier MN00040240] |
201 |
|
|
- Added additional headers to ensure no caching. [msoulier MN00044704] |
202 |
|
|
|
203 |
|
|
* Fri Sep 3 2004 Michael Soulier <msoulier@e-smith.com> |
204 |
|
|
- [0.91-17] |
205 |
|
|
- Updated requires with new perl dependencies. [msoulier MN00040240] |
206 |
|
|
- Fixed http header to include expiry to prevent browser caching. |
207 |
|
|
[msoulier MN00044704] |
208 |
|
|
|
209 |
|
|
* Sat Aug 21 2004 Michael Soulier <msoulier@e-smith.com> |
210 |
|
|
- [0.91-16] |
211 |
|
|
- Fixed poor subroutine detection in get_sub(). [msoulier MN00037832] |
212 |
|
|
|
213 |
|
|
* Tue Aug 3 2004 Michael Soulier <msoulier@e-smith.com> |
214 |
|
|
- [0.91-15] |
215 |
|
|
- Added an automatic trim of leading and trailing whitespace for all field |
216 |
|
|
params during validation, unless a new field attribute of "notrim" evals to |
217 |
|
|
true. [msoulier MN00042751] |
218 |
|
|
|
219 |
|
|
* Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com> |
220 |
|
|
- [0.91-14] |
221 |
|
|
- Added conditional widgets to FormMagick. fields now support a "display" |
222 |
|
|
callback, which, if false, prevents the field from being displayed or |
223 |
|
|
validated. [msoulier MN00037809] |
224 |
|
|
|
225 |
|
|
* Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com> |
226 |
|
|
- [0.91-13] |
227 |
|
|
- Updated use of CGI::FormMagick::Sub, such that a calling package is no |
228 |
|
|
longer required. The object will be searched for methods by default. |
229 |
|
|
[msoulier MN00037832] |
230 |
|
|
|
231 |
|
|
* Wed Jul 14 2004 Michael Soulier <msoulier@e-smith.com> |
232 |
|
|
- [0.91-12] |
233 |
|
|
- Catch cases where non-existant subroutines are called, and throw a fatal |
234 |
|
|
exception with a backtrace. [msoulier MN00042272] |
235 |
|
|
|
236 |
|
|
* Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com> |
237 |
|
|
- [0.91-11] |
238 |
|
|
- s/novalidate/nopost, and also prevented the post-event from running if |
239 |
|
|
nopost is set. [msoulier MN00040161] |
240 |
|
|
|
241 |
|
|
* Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com> |
242 |
|
|
- [0.91-10] |
243 |
|
|
- Added novalidate method, and a hook to it in prepare_for_next_page, so |
244 |
|
|
setting a novalidate param will prevent the current page from being |
245 |
|
|
validated. Useful for navigational links. [msoulier MN00040161] |
246 |
|
|
|
247 |
|
|
* Mon May 10 2004 Michael Soulier <msoulier@e-smith.com> |
248 |
|
|
- [0.91-09] |
249 |
|
|
- Forward-port of dcr-30134, adding the menu attribute to the page tag. |
250 |
|
|
[msoulier MN00030134] |
251 |
|
|
|
252 |
|
|
* Wed Jan 28 2004 Michael Soulier <msoulier@e-smith.com> |
253 |
|
|
- [0.91-08] |
254 |
|
|
- Fixed weak pattern matching in CGI::FormMagick::Validator::Basic::number. |
255 |
|
|
[msoulier 9039] |
256 |
|
|
|
257 |
|
|
* Mon Jan 5 2004 Michael Soulier <msoulier@e-smith.com> |
258 |
|
|
- [0.91-07] |
259 |
|
|
- Fixed bad enctype in forms definition. [msoulier 10699] |
260 |
|
|
|
261 |
|
|
* Wed Nov 19 2003 Michael Soulier <msoulier@e-smith.com> |
262 |
|
|
- [0.91-06] |
263 |
|
|
- Rolled back change in 0.91-03, as it broke the ibays panel. [msoulier 9404] |
264 |
|
|
|
265 |
|
|
* Wed Oct 22 2003 Michael Soulier <msoulier@e-smith.com> |
266 |
|
|
- [0.91-05] |
267 |
|
|
- Updated get_lexicon to merge available language lexicon in reverse order to |
268 |
|
|
the preferred languages, so the fallback languages work when the primary is |
269 |
|
|
not available. [msoulier 10397] |
270 |
|
|
|
271 |
|
|
* Fri Sep 5 2003 Tony Clayton <apc@e-smith.com> |
272 |
|
|
- [0.91-04] |
273 |
|
|
- Added munge_fm_obj() hook to FormMagick.pm [tonyc 9924] |
274 |
|
|
|
275 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
276 |
|
|
- [0.91-03] |
277 |
|
|
- Moved the parse_xml() call, and the CGI::Persistent object creation, to the |
278 |
|
|
constructor where they belong. [msoulier 9404] |
279 |
|
|
|
280 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
281 |
|
|
- [0.91-02] |
282 |
|
|
- Fixed bug in handling of literal widgets. [msoulier 8671] |
283 |
|
|
|
284 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
285 |
|
|
- [0.91-01] |
286 |
|
|
- rolling to dev stream - 0.91 |
287 |
|
|
|
288 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
289 |
|
|
- [0.90-01] |
290 |
|
|
- rolling to stable stream - 0.90 |
291 |
|
|
|
292 |
|
|
* Tue Jun 24 2003 Tony Clayton <apc@e-smith.com> |
293 |
|
|
- [0.89-06] |
294 |
|
|
- Fix TagMaker to allow input fields with value="0" [tonyc 9134] |
295 |
|
|
|
296 |
|
|
* Tue May 6 2003 Michael Soulier <msoulier@e-smith.com> |
297 |
|
|
- [0.89-05] |
298 |
|
|
- Fixed bad handling of literal widgets. [msoulier 8671] |
299 |
|
|
|
300 |
|
|
* Tue May 6 2003 Michael Soulier <msoulier@e-smith.com> |
301 |
|
|
- [0.89-04] |
302 |
|
|
- Fixed position of the skip_header check so that it's after the establishment |
303 |
|
|
of the page number. Otherwise, the page number defaults and the wrong |
304 |
|
|
post-event is executed. [msoulier 8637] |
305 |
|
|
|
306 |
|
|
* Fri May 2 2003 Michael Soulier <msoulier@e-smith.com> |
307 |
|
|
- [0.89-03] |
308 |
|
|
- Added support for a skip_header parameter, to force the display method to |
309 |
|
|
give complete control over the HTTP response to the post-event. |
310 |
|
|
[msoulier 8637] |
311 |
|
|
|
312 |
|
|
* Thu Feb 20 2003 Mark Knox <markk@e-smith.com> |
313 |
|
|
- [0.89-02] |
314 |
|
|
- Allow for dynamic field types using a subroutine call [markk 6735] |
315 |
|
|
|
316 |
|
|
* Wed Feb 05 2003 Mark Knox <m_knox@mitel.com> |
317 |
|
|
- [0.89-01] |
318 |
|
|
- Changed author details in Makefile.PL. |
319 |
|
|
- Rolled to v0.89 |
320 |
|
|
|
321 |
|
|
* Wed Feb 05 2003 Mark Knox <m_knox@mitel.com> |
322 |
|
|
- [0.88-01] |
323 |
|
|
- Rolled up changes from 0.87-01 to 0.87-14es into 0.88 and released to |
324 |
|
|
SourceForge & CPAN |
325 |
|
|
|
326 |
|
|
* Sat Jan 25 2003 Mike Dickson <miked@e-smith.com> |
327 |
|
|
- [0.87-15es] |
328 |
|
|
- removed debugging statements from HTML.pm [miked 6617] |
329 |
|
|
|
330 |
|
|
* Tue Jan 14 2003 Mark Knox <markk@e-smith.com> |
331 |
|
|
- [0.87-14es] |
332 |
|
|
- Changed DTD and input field sub to allow "rows" and "cols" args on |
333 |
|
|
textarea fields, removed size arg on same. [markk 3620] |
334 |
|
|
|
335 |
|
|
* Fri Dec 27 2002 Mike Dickson <miked@e-smith.com> |
336 |
|
|
- [0.87-13es] |
337 |
|
|
- removed debugging comments [miked 5494] |
338 |
|
|
|
339 |
|
|
* Mon Dec 16 2002 Mike Dickson <miked@e-smith.com> |
340 |
|
|
- [0.87-12es] |
341 |
|
|
- ui updates [miked 5494] |
342 |
|
|
|
343 |
|
|
* Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com> |
344 |
|
|
- [0.87-11es] |
345 |
|
|
- Forgot the dependency on the new module. [msoulier 3388] |
346 |
|
|
|
347 |
|
|
* Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com> |
348 |
|
|
- [0.87-10es] |
349 |
|
|
- Tightened the check in email_simple() by adding use of the |
350 |
|
|
Mail::RFC822::Address module. [msoulier 3388] |
351 |
|
|
|
352 |
|
|
* Mon Dec 2 2002 Mike Dickson <miked@e-smith.com> |
353 |
|
|
- [0.87-09es] |
354 |
|
|
- ui update [miked 5494] |
355 |
|
|
|
356 |
|
|
* Fri Nov 22 2002 Mike Dickson <miked@e-smith.com> |
357 |
|
|
- [0.87-08es] |
358 |
|
|
- update to use new UI elements [miked 5806] |
359 |
|
|
|
360 |
|
|
* Fri Nov 22 2002 Gordon Rowell <gordonr@e-smith.com> |
361 |
|
|
- [0.87-07es] |
362 |
|
|
- Re-import from latest SRPM so it looks like a cvs2rpm package [gordonr 5806] |
363 |
|
|
|
364 |
|
|
* Thu Oct 03 2002 Mark Knox <markk@e-smith.com> |
365 |
|
|
- [0.87-06es] |
366 |
|
|
- Removed a stray line from a previous patch that was causing breakage |
367 |
|
|
[markk 4423] |
368 |
|
|
|
369 |
|
|
* Mon Sep 30 2002 Mark Knox <markk@e-smith.com> |
370 |
|
|
- [0.87-05es] |
371 |
|
|
- Improved blank-trimming regexes [markk 4423] |
372 |
|
|
|
373 |
|
|
* Wed Aug 28 2002 Mark Knox <markk@e-smith.com> |
374 |
|
|
- [0.87-04es] |
375 |
|
|
- Move blank trimming code inside conditional to eliminate warnings [markk |
376 |
|
|
4607] |
377 |
|
|
|
378 |
|
|
* Fri Aug 16 2002 Mark Knox <markk@e-smith.com> |
379 |
|
|
- [0.87-03es] |
380 |
|
|
- Security fix: do not pass full path on session token filename [markk 4652] |
381 |
|
|
|
382 |
|
|
* Mon Jul 22 2002 Mark Knox <markk@e-smith.com> |
383 |
|
|
- [0.87-02es] |
384 |
|
|
- Patch to trim blank space from start/end of translations [markk 4423] |
385 |
|
|
|
386 |
|
|
* Mon Jul 22 2002 Mark Knox <markk@e-smith.com> |
387 |
|
|
- [0.87-01es] |
388 |
|
|
- Added "es" suffix. First local build (same as 0.87-01) [markk 4422] |
389 |
|
|
|
390 |
|
|
* Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com> |
391 |
|
|
- [0.87-01] |
392 |
|
|
- Fixed a minor HTML bug (missing > symbol) which was causing problems |
393 |
|
|
with the output of validation error messages. [skud 3807] |
394 |
|
|
|
395 |
|
|
* Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com> |
396 |
|
|
- [0.86] |
397 |
|
|
- Added get_validation_attribute() routine to make it possible to do the |
398 |
|
|
nopipes validation forcing in esmith::FormMagick [skud 3807] |
399 |
|
|
|
400 |
|
|
* Sun Jun 02 2002 Gordon Rowell <gordonr@e-smith.com> |
401 |
|
|
- Place the "nopipes" validator before all others. We never want to |
402 |
|
|
allow pipes in fields for e-smith databases. This may be able to |
403 |
|
|
be done at the esmith::FormMagick level, but this works for now. |
404 |
|
|
[gordonr 3752] |
405 |
|
|
|
406 |
|
|
* Wed May 29 2002 Kirrily Robert <skud@e-smith.com> |
407 |
|
|
- [0.85-01] |
408 |
|
|
- Fixed charset bug for text fields that come from subroutines [skud |
409 |
|
|
3677] |
410 |
|
|
|
411 |
|
|
* Thu May 16 2002 Kirrily Robert <skud@e-smith.com> |
412 |
|
|
- [0.84-02] |
413 |
|
|
- Messed it up, had to repackage. [skud #3390] |
414 |
|
|
|
415 |
|
|
* Thu May 16 2002 Kirrily Robert <skud@e-smith.com> |
416 |
|
|
- [0.84-01] |
417 |
|
|
- Fixed select box charset problem [skud #3390] |
418 |
|
|
|
419 |
|
|
* Mon May 13 2002 Kirrily Robert <skud@e-smith.com> |
420 |
|
|
- [0.83-01] |
421 |
|
|
- Various minor bugfixes etc [skud #3339, #3371, #3390, #3405] |
422 |
|
|
|
423 |
|
|
* Tue May 07 2002 Kirrily Robert <skud@e-smith.com> |
424 |
|
|
- [0.82-02] |
425 |
|
|
- Added dependency on Text::Template 1.40 or higher [skud #3371] |
426 |
|
|
|
427 |
|
|
* Tue May 07 2002 Kirrily Robert <skud@e-smith.com> |
428 |
|
|
- [0.82-01] |
429 |
|
|
- Fixed up various warnings that were thrown to the httpd error log. |
430 |
|
|
[skud #3278, #3358] |
431 |
|
|
- Templated form headers/footers are now untainted automatically. |
432 |
|
|
[skud #3371] |
433 |
|
|
|
434 |
|
|
* Fri May 03 2002 Kirrily Robert <skud@e-smith.com> |
435 |
|
|
- [0.81-02] |
436 |
|
|
- Added dependency for Text::Iconv |
437 |
|
|
|
438 |
|
|
* Wed May 01 2002 Kirrily Robert <skud@e-smith.com> |
439 |
|
|
- [0.81-01] |
440 |
|
|
- Now fails more gracefully on XML errors, dumping the XML to a file in |
441 |
|
|
/tmp as a side effect |
442 |
|
|
- You can now specify the default XML character set encoding as an |
443 |
|
|
argument to new() (defaults to undef). In future versions this should |
444 |
|
|
be changed to work on a per-lexicon basis, but for now we will use this |
445 |
|
|
stopgap measure. |
446 |
|
|
- Fixed a bug which was causing fallback_language not to work. |
447 |
|
|
|
448 |
|
|
* Fri Apr 12 2002 Kirrily Robert <skud@e-smith.com> |
449 |
|
|
- [0.80-01] |
450 |
|
|
- langtags are now all smashed to lower case |
451 |
|
|
|
452 |
|
|
* Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com> |
453 |
|
|
- [0.79-01] |
454 |
|
|
- Updating to release 0.79. |
455 |
|
|
|
456 |
|
|
* Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com> |
457 |
|
|
- [0.78-01] |
458 |
|
|
- Updating to release 0.78. |
459 |
|
|
|
460 |
|
|
* Wed Apr 03 2002 Kirrily Robert <skud@e-smith.com> |
461 |
|
|
- [0.77-01] |
462 |
|
|
- Updating to release 0.77. |
463 |
|
|
|
464 |
|
|
* Wed Mar 20 2002 Kirrily Robert <skud@e-smith.com> |
465 |
|
|
- [0.75-01] |
466 |
|
|
- Updating to release 0.75. |
467 |
|
|
|
468 |
|
|
* Wed Mar 14 2002 Gordon Rowell <gordonr@e-smith.com> |
469 |
|
|
- [0.70-02] |
470 |
|
|
- Removed use for Locale::Maketext, pending new cvs tarball from |
471 |
|
|
SourceForge (which is down ATM) |
472 |
|
|
|
473 |
|
|
* Wed Feb 20 2002 Adrian Chung <adrianc@e-smith.com> |
474 |
|
|
- [0.70-01] |
475 |
|
|
- Updating to release 0.70. |
476 |
|
|
|
477 |
|
|
* Thu Feb 07 2002 Adrian Chung <adrianc@e-smith.com> |
478 |
|
|
- [0.60-01] |
479 |
|
|
- Updated to 0.60. |
480 |
|
|
|
481 |
|
|
* Wed Jan 23 2002 Adrian Chung <adrianc@e-smith.com> |
482 |
|
|
- [0.50-01] |
483 |
|
|
- Updated to 0.50. |
484 |
|
|
|
485 |
|
|
* Wed Dec 19 2001 Gordon Rowell <gordonr@e-smith.com> |
486 |
|
|
- [0.49-03] |
487 |
|
|
- Updated with skud's tarball of the day |
488 |
|
|
|
489 |
|
|
* Mon Dec 17 2001 Gordon Rowell <gordonr@e-smith.com> |
490 |
|
|
- [0.49-02] |
491 |
|
|
- Added dependencies for the swag of modules required. These should |
492 |
|
|
probably be listed in the CPAN module instead |
493 |
|
|
|
494 |
|
|
* Mon Oct 01 2001 charlieb <charlieb@lamington> |
495 |
|
|
- Spec file automatically generated by cpan2rpm |