1 |
snetram |
1.6 |
# $Id: perl-CGI-FormMagick.spec,v 1.5 2008/04/09 13:51:52 slords Exp $ |
2 |
slords |
1.5 |
|
3 |
slords |
1.1 |
Summary: CGI-FormMagick module for perl |
4 |
|
|
%define name perl-CGI-FormMagick |
5 |
|
|
%define version 0.92 |
6 |
snetram |
1.6 |
%define release 17 |
7 |
slords |
1.1 |
Name: %{name} |
8 |
|
|
Version: %{version} |
9 |
|
|
Release: %{release}%{?dist} |
10 |
|
|
License: distributable |
11 |
|
|
Group: Applications/CPAN |
12 |
|
|
Source0: perl-CGI-FormMagick-%{version}.tar.gz |
13 |
|
|
Patch0: perl-CGI-FormMagick-0.92-password_validation.patch |
14 |
|
|
Patch1: perl-CGI-FormMagick-0.92-password_validation2.patch |
15 |
|
|
Patch2: perl-CGI-FormMagick-0.92-quotemeta.patch |
16 |
|
|
Patch3: perl-CGI-FormMagick-0.92-textarea.patch |
17 |
|
|
Patch4: perl-CGI-FormMagick-0.92-validateliteral.patch |
18 |
|
|
Patch5: perl-CGI-FormMagick-0.92-nodata.patch |
19 |
|
|
Patch6: perl-CGI-FormMagick-0.92-persistent10.patch |
20 |
|
|
Patch7: perl-CGI-FormMagick-0.92-persistent10.patch2 |
21 |
|
|
Patch8: perl-CGI-FormMagick-0.92-persistent10.patch3 |
22 |
slords |
1.2 |
Patch9: perl-CGI-FormMagick-0.92-UTF8.patch |
23 |
snetram |
1.6 |
Patch10: perl-CGI-FormMagick-0.92-ip-validation.patch |
24 |
slords |
1.1 |
Url: http://www.cpan.org |
25 |
|
|
BuildRoot: /var/tmp/perl-CGI-FormMagick-buildroot/ |
26 |
|
|
BuildArchitectures: noarch |
27 |
|
|
BuildRequires: perl |
28 |
|
|
Requires: perl perl(XML::Parser) expat |
29 |
|
|
Requires: perl(CGI::Persistent) >= 1.00 |
30 |
|
|
Requires: perl(Class::ParamParser) perl(I18N::LangTags) |
31 |
|
|
Requires: perl(Text::Iconv) |
32 |
|
|
Requires: perl(Text::Template) |
33 |
|
|
Requires: perl(Mail::RFC822::Address) |
34 |
|
|
Provides: perl(ArbitraryPackage) |
35 |
|
|
Provides: perl(CGI::FormMagick) = %{version}-%{release} |
36 |
|
|
Provides: perl(CGI::FormMagick::Sub) |
37 |
|
|
Provides: perl(CGI::FormMagick::TagMaker) = 1.01 |
38 |
|
|
Provides: perl(CGI::FormMagick::Validator) |
39 |
|
|
Autoreq: no |
40 |
|
|
|
41 |
|
|
%description |
42 |
|
|
FormMagick is a Perl module which enables XML descriptions to be used |
43 |
|
|
to generate HTML wizard-like forms. It has support for I18N/L10N. |
44 |
|
|
|
45 |
|
|
%prep |
46 |
|
|
%setup -q |
47 |
|
|
%patch0 -p1 |
48 |
|
|
%patch1 -p1 |
49 |
|
|
%patch2 -p1 |
50 |
|
|
%patch3 -p1 |
51 |
|
|
%patch4 -p1 |
52 |
|
|
%patch5 -p1 |
53 |
|
|
%patch6 -p1 |
54 |
|
|
%patch7 -p1 |
55 |
|
|
%patch8 -p1 |
56 |
slords |
1.2 |
%patch9 -p1 |
57 |
snetram |
1.6 |
%patch10 -p1 |
58 |
slords |
1.1 |
|
59 |
|
|
%build |
60 |
|
|
grep -rsl '^#!.*perl' . | |
61 |
|
|
grep -v '.bak$' |xargs --no-run-if-empty \ |
62 |
|
|
%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' |
63 |
|
|
CFLAGS="$RPM_OPT_FLAGS" |
64 |
|
|
%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` INSTALLSITELIB=%{_prefix}/lib/perl5/site_perl |
65 |
|
|
%{__make} |
66 |
|
|
|
67 |
|
|
%clean |
68 |
|
|
rm -rf $RPM_BUILD_ROOT |
69 |
|
|
|
70 |
|
|
%install |
71 |
|
|
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
72 |
|
|
|
73 |
|
|
%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '` |
74 |
|
|
|
75 |
|
|
[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress |
76 |
|
|
|
77 |
|
|
# remove special files |
78 |
|
|
find %{buildroot} -name "perllocal.pod" \ |
79 |
|
|
-o -name ".packlist" \ |
80 |
|
|
-o -name "*.bs" \ |
81 |
|
|
|xargs -i rm -f {} |
82 |
|
|
|
83 |
|
|
# no empty directories |
84 |
|
|
find %{buildroot}%{_prefix} \ |
85 |
|
|
-type d -depth \ |
86 |
|
|
-exec rmdir {} \; 2>/dev/null |
87 |
|
|
|
88 |
|
|
find $RPM_BUILD_ROOT/usr -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" | grep -v perllocal.pod > CGI-FormMagick-%{version}-filelist |
89 |
|
|
|
90 |
|
|
%files -f CGI-FormMagick-%{version}-filelist |
91 |
|
|
%defattr(-,root,root) |
92 |
|
|
|
93 |
|
|
%changelog |
94 |
snetram |
1.6 |
* Wed Mar 2 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 0.92-17 |
95 |
|
|
- Fix IP address validation [SME: 3388] |
96 |
|
|
|
97 |
slords |
1.3 |
* Mon Mar 24 2008 Shad L. Lords <slords@mail.com> 0.92-16 |
98 |
slords |
1.4 |
- Fix patch so .orig files aren't created. [SME: 4100] |
99 |
slords |
1.3 |
|
100 |
slords |
1.2 |
* Mon Mar 10 2008 Shad L. Lords <slords@mail.com> 0.92-15 |
101 |
|
|
- Output charset header defining correct charset. [SME: 3858] |
102 |
|
|
|
103 |
slords |
1.1 |
* Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-14 |
104 |
|
|
- Add path to sanitized .id parameter so tokens get created |
105 |
|
|
in right place [SME: 3584] |
106 |
|
|
|
107 |
|
|
* Sat Nov 24 2007 Charlie Brady <charlieb@e-smith.com> 0.92-13 |
108 |
|
|
- Sanitise .id parameter before use. [SME: 3584] |
109 |
|
|
|
110 |
|
|
* Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-12 |
111 |
|
|
- Make modules compatible with CGI::Persistent v1.00 [SME: 3581] |
112 |
|
|
|
113 |
|
|
* Tue Jun 12 2007 Shad L. Lords <slords@mail.com> 0.92-11 |
114 |
|
|
- Don't attempt to trim empty/undefined fields [SME: 2395] |
115 |
|
|
|
116 |
|
|
* Mon Jun 11 2007 Shad L. Lords <slords@mail.com> 0.92-10 |
117 |
|
|
- Don't validate literal fields [SME: 2395] |
118 |
|
|
|
119 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
120 |
|
|
- Clean up spec so package can be built by koji/plague |
121 |
|
|
|
122 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
123 |
|
|
- Update to new release naming. No functional changes. |
124 |
|
|
- Make Packager generic |
125 |
|
|
|
126 |
|
|
* Tue Aug 22 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-08 |
127 |
|
|
- Allow initializer of textarea form widgets. [SME: 1088] |
128 |
|
|
|
129 |
|
|
* Mon May 01 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-07 |
130 |
|
|
- Fix quoting of metachars in subst during inputbox output. [SME: 1352] |
131 |
|
|
|
132 |
|
|
* Wed Jan 25 2006 Mark Knox <mark_knox@mitel.com> 0.92-06 |
133 |
|
|
- Added a missing brace in previous fix [SME: 463] |
134 |
|
|
|
135 |
|
|
* Fri Jan 13 2006 Charlie Brady <charlieb@e-smith.com> 0.92-05 |
136 |
|
|
- Fix password validation check to include _ as non-alpha. [SME: 463] |
137 |
|
|
|
138 |
|
|
* Thu Dec 15 2005 Charlie Brady <charlieb@e-smith.com> 0.92-04 |
139 |
|
|
- Build into /usr/lib/perl5/site_perl so that RPM can be installed |
140 |
|
|
on either 6.x or 7.x. |
141 |
|
|
|
142 |
|
|
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 0.92-03 |
143 |
|
|
- Bump release number only |
144 |
|
|
|
145 |
|
|
* Tue Nov 29 2005 Charlie Brady <charlieb@e-smith.com> |
146 |
|
|
- [0.92-02] |
147 |
|
|
- Test rebuild after CVS synchronisation. |
148 |
|
|
|
149 |
|
|
* Mon Oct 31 2005 Mark Knox <mark_knox@mitel.com> |
150 |
|
|
- [0.92-01] |
151 |
|
|
- Imported to ClearCase, bumped version [markk MN00103900] |
152 |
|
|
- Remove generated files Makefile and t/embedded* |
153 |
|
|
- Add BuildRequires: perl => 5.8 |
154 |
|
|
|
155 |
|
|
* Thu Oct 27 2005 Charlie Brady <charlieb@e-smith.com> |
156 |
|
|
- [0.91-30] |
157 |
|
|
- Avoid warning messages if we try to trim whitespace around $field->{id} when |
158 |
|
|
it isn't defined. [SF: 1227604] |
159 |
|
|
|
160 |
|
|
* Mon Oct 3 2005 Charlie Brady <charlieb@e-smith.com> |
161 |
|
|
- [0.91-29] |
162 |
|
|
- Fix colspan attributes in display_fields(). [SF: 1309359] |
163 |
|
|
|
164 |
|
|
* Mon Sep 5 2005 Tony Clayton <apc@e-smith.com> |
165 |
|
|
- [0.91-28] |
166 |
|
|
- s/Copyright/License/ in rpm headers |
167 |
|
|
- Fix subroutine element handling in Validator.pm to fix barrage of logfile |
168 |
|
|
warnings |
169 |
|
|
- Move sessiondir,cgi object initialization from display() to new() |
170 |
|
|
- Remove deprecated sessiondir(),munge_fm_obj() methods |
171 |
|
|
|
172 |
|
|
* Tue Jul 19 2005 Charlie Brady <charlieb@e-smith.com> |
173 |
|
|
- [0.91-27] |
174 |
|
|
- Validation fixes from Shad Lords: |
175 |
|
|
- Change static strings to TAGS (for L10N) |
176 |
|
|
- Fix ip_check to actually check value |
177 |
|
|
- Update Provides header to specify version and release |
178 |
|
|
|
179 |
|
|
* Tue May 24 2005 Charlie Brady <charlieb@e-smith.com> |
180 |
|
|
- [0.91-26] |
181 |
|
|
- Don't allow rpm to auto calculate perl module dependencies - |
182 |
|
|
it gets them wrong sometimes [SF: 1205965] |
183 |
|
|
|
184 |
|
|
* Fri May 20 2005 Charlie Brady <charlieb@e-smith.com> |
185 |
|
|
- [0.91-25] |
186 |
|
|
- Apply options parsing fix (from Gordon, SF:1205448) |
187 |
|
|
|
188 |
|
|
* Tue May 17 2005 Charlie Brady <charlieb@e-smith.com> |
189 |
|
|
- [0.91-24] |
190 |
|
|
- Remove POD references to unimplemented validation-error-message. |
191 |
|
|
|
192 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
193 |
|
|
- [0.91-23] |
194 |
|
|
- Add patch contributed by Shad Lords to allow multi-select. |
195 |
|
|
|
196 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
197 |
|
|
- [0.91-22] |
198 |
|
|
- Add patch contributed by Shad Lords to be more flexible about |
199 |
|
|
whitespace in validator lists. |
200 |
|
|
|
201 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
202 |
|
|
- [0.91-21] |
203 |
|
|
- Make sure we don't leave unpackaged files in our buildroot. |
204 |
|
|
|
205 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
206 |
|
|
- [0.91-20] |
207 |
|
|
- Update build and install sections, to allow correct building under CentOS. |
208 |
|
|
|
209 |
|
|
* Wed Oct 20 2004 Sean Bradbury <bradbury@e-smith.com> |
210 |
|
|
- [0.91-19] |
211 |
|
|
- Updated requires to remove wrong requires. [bradbury MN00053465] |
212 |
|
|
|
213 |
|
|
* Tue Sep 28 2004 Michael Soulier <msoulier@e-smith.com> |
214 |
|
|
- [0.91-18] |
215 |
|
|
- Updated requires with new perl dependencies. [msoulier MN00040240] |
216 |
|
|
- Added additional headers to ensure no caching. [msoulier MN00044704] |
217 |
|
|
|
218 |
|
|
* Fri Sep 3 2004 Michael Soulier <msoulier@e-smith.com> |
219 |
|
|
- [0.91-17] |
220 |
|
|
- Updated requires with new perl dependencies. [msoulier MN00040240] |
221 |
|
|
- Fixed http header to include expiry to prevent browser caching. |
222 |
|
|
[msoulier MN00044704] |
223 |
|
|
|
224 |
|
|
* Sat Aug 21 2004 Michael Soulier <msoulier@e-smith.com> |
225 |
|
|
- [0.91-16] |
226 |
|
|
- Fixed poor subroutine detection in get_sub(). [msoulier MN00037832] |
227 |
|
|
|
228 |
|
|
* Tue Aug 3 2004 Michael Soulier <msoulier@e-smith.com> |
229 |
|
|
- [0.91-15] |
230 |
|
|
- Added an automatic trim of leading and trailing whitespace for all field |
231 |
|
|
params during validation, unless a new field attribute of "notrim" evals to |
232 |
|
|
true. [msoulier MN00042751] |
233 |
|
|
|
234 |
|
|
* Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com> |
235 |
|
|
- [0.91-14] |
236 |
|
|
- Added conditional widgets to FormMagick. fields now support a "display" |
237 |
|
|
callback, which, if false, prevents the field from being displayed or |
238 |
|
|
validated. [msoulier MN00037809] |
239 |
|
|
|
240 |
|
|
* Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com> |
241 |
|
|
- [0.91-13] |
242 |
|
|
- Updated use of CGI::FormMagick::Sub, such that a calling package is no |
243 |
|
|
longer required. The object will be searched for methods by default. |
244 |
|
|
[msoulier MN00037832] |
245 |
|
|
|
246 |
|
|
* Wed Jul 14 2004 Michael Soulier <msoulier@e-smith.com> |
247 |
|
|
- [0.91-12] |
248 |
|
|
- Catch cases where non-existant subroutines are called, and throw a fatal |
249 |
|
|
exception with a backtrace. [msoulier MN00042272] |
250 |
|
|
|
251 |
|
|
* Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com> |
252 |
|
|
- [0.91-11] |
253 |
|
|
- s/novalidate/nopost, and also prevented the post-event from running if |
254 |
|
|
nopost is set. [msoulier MN00040161] |
255 |
|
|
|
256 |
|
|
* Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com> |
257 |
|
|
- [0.91-10] |
258 |
|
|
- Added novalidate method, and a hook to it in prepare_for_next_page, so |
259 |
|
|
setting a novalidate param will prevent the current page from being |
260 |
|
|
validated. Useful for navigational links. [msoulier MN00040161] |
261 |
|
|
|
262 |
|
|
* Mon May 10 2004 Michael Soulier <msoulier@e-smith.com> |
263 |
|
|
- [0.91-09] |
264 |
|
|
- Forward-port of dcr-30134, adding the menu attribute to the page tag. |
265 |
|
|
[msoulier MN00030134] |
266 |
|
|
|
267 |
|
|
* Wed Jan 28 2004 Michael Soulier <msoulier@e-smith.com> |
268 |
|
|
- [0.91-08] |
269 |
|
|
- Fixed weak pattern matching in CGI::FormMagick::Validator::Basic::number. |
270 |
|
|
[msoulier 9039] |
271 |
|
|
|
272 |
|
|
* Mon Jan 5 2004 Michael Soulier <msoulier@e-smith.com> |
273 |
|
|
- [0.91-07] |
274 |
|
|
- Fixed bad enctype in forms definition. [msoulier 10699] |
275 |
|
|
|
276 |
|
|
* Wed Nov 19 2003 Michael Soulier <msoulier@e-smith.com> |
277 |
|
|
- [0.91-06] |
278 |
|
|
- Rolled back change in 0.91-03, as it broke the ibays panel. [msoulier 9404] |
279 |
|
|
|
280 |
|
|
* Wed Oct 22 2003 Michael Soulier <msoulier@e-smith.com> |
281 |
|
|
- [0.91-05] |
282 |
|
|
- Updated get_lexicon to merge available language lexicon in reverse order to |
283 |
|
|
the preferred languages, so the fallback languages work when the primary is |
284 |
|
|
not available. [msoulier 10397] |
285 |
|
|
|
286 |
|
|
* Fri Sep 5 2003 Tony Clayton <apc@e-smith.com> |
287 |
|
|
- [0.91-04] |
288 |
|
|
- Added munge_fm_obj() hook to FormMagick.pm [tonyc 9924] |
289 |
|
|
|
290 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
291 |
|
|
- [0.91-03] |
292 |
|
|
- Moved the parse_xml() call, and the CGI::Persistent object creation, to the |
293 |
|
|
constructor where they belong. [msoulier 9404] |
294 |
|
|
|
295 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
296 |
|
|
- [0.91-02] |
297 |
|
|
- Fixed bug in handling of literal widgets. [msoulier 8671] |
298 |
|
|
|
299 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
300 |
|
|
- [0.91-01] |
301 |
|
|
- rolling to dev stream - 0.91 |
302 |
|
|
|
303 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
304 |
|
|
- [0.90-01] |
305 |
|
|
- rolling to stable stream - 0.90 |
306 |
|
|
|
307 |
|
|
* Tue Jun 24 2003 Tony Clayton <apc@e-smith.com> |
308 |
|
|
- [0.89-06] |
309 |
|
|
- Fix TagMaker to allow input fields with value="0" [tonyc 9134] |
310 |
|
|
|
311 |
|
|
* Tue May 6 2003 Michael Soulier <msoulier@e-smith.com> |
312 |
|
|
- [0.89-05] |
313 |
|
|
- Fixed bad handling of literal widgets. [msoulier 8671] |
314 |
|
|
|
315 |
|
|
* Tue May 6 2003 Michael Soulier <msoulier@e-smith.com> |
316 |
|
|
- [0.89-04] |
317 |
|
|
- Fixed position of the skip_header check so that it's after the establishment |
318 |
|
|
of the page number. Otherwise, the page number defaults and the wrong |
319 |
|
|
post-event is executed. [msoulier 8637] |
320 |
|
|
|
321 |
|
|
* Fri May 2 2003 Michael Soulier <msoulier@e-smith.com> |
322 |
|
|
- [0.89-03] |
323 |
|
|
- Added support for a skip_header parameter, to force the display method to |
324 |
|
|
give complete control over the HTTP response to the post-event. |
325 |
|
|
[msoulier 8637] |
326 |
|
|
|
327 |
|
|
* Thu Feb 20 2003 Mark Knox <markk@e-smith.com> |
328 |
|
|
- [0.89-02] |
329 |
|
|
- Allow for dynamic field types using a subroutine call [markk 6735] |
330 |
|
|
|
331 |
|
|
* Wed Feb 05 2003 Mark Knox <m_knox@mitel.com> |
332 |
|
|
- [0.89-01] |
333 |
|
|
- Changed author details in Makefile.PL. |
334 |
|
|
- Rolled to v0.89 |
335 |
|
|
|
336 |
|
|
* Wed Feb 05 2003 Mark Knox <m_knox@mitel.com> |
337 |
|
|
- [0.88-01] |
338 |
|
|
- Rolled up changes from 0.87-01 to 0.87-14es into 0.88 and released to |
339 |
|
|
SourceForge & CPAN |
340 |
|
|
|
341 |
|
|
* Sat Jan 25 2003 Mike Dickson <miked@e-smith.com> |
342 |
|
|
- [0.87-15es] |
343 |
|
|
- removed debugging statements from HTML.pm [miked 6617] |
344 |
|
|
|
345 |
|
|
* Tue Jan 14 2003 Mark Knox <markk@e-smith.com> |
346 |
|
|
- [0.87-14es] |
347 |
|
|
- Changed DTD and input field sub to allow "rows" and "cols" args on |
348 |
|
|
textarea fields, removed size arg on same. [markk 3620] |
349 |
|
|
|
350 |
|
|
* Fri Dec 27 2002 Mike Dickson <miked@e-smith.com> |
351 |
|
|
- [0.87-13es] |
352 |
|
|
- removed debugging comments [miked 5494] |
353 |
|
|
|
354 |
|
|
* Mon Dec 16 2002 Mike Dickson <miked@e-smith.com> |
355 |
|
|
- [0.87-12es] |
356 |
|
|
- ui updates [miked 5494] |
357 |
|
|
|
358 |
|
|
* Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com> |
359 |
|
|
- [0.87-11es] |
360 |
|
|
- Forgot the dependency on the new module. [msoulier 3388] |
361 |
|
|
|
362 |
|
|
* Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com> |
363 |
|
|
- [0.87-10es] |
364 |
|
|
- Tightened the check in email_simple() by adding use of the |
365 |
|
|
Mail::RFC822::Address module. [msoulier 3388] |
366 |
|
|
|
367 |
|
|
* Mon Dec 2 2002 Mike Dickson <miked@e-smith.com> |
368 |
|
|
- [0.87-09es] |
369 |
|
|
- ui update [miked 5494] |
370 |
|
|
|
371 |
|
|
* Fri Nov 22 2002 Mike Dickson <miked@e-smith.com> |
372 |
|
|
- [0.87-08es] |
373 |
|
|
- update to use new UI elements [miked 5806] |
374 |
|
|
|
375 |
|
|
* Fri Nov 22 2002 Gordon Rowell <gordonr@e-smith.com> |
376 |
|
|
- [0.87-07es] |
377 |
|
|
- Re-import from latest SRPM so it looks like a cvs2rpm package [gordonr 5806] |
378 |
|
|
|
379 |
|
|
* Thu Oct 03 2002 Mark Knox <markk@e-smith.com> |
380 |
|
|
- [0.87-06es] |
381 |
|
|
- Removed a stray line from a previous patch that was causing breakage |
382 |
|
|
[markk 4423] |
383 |
|
|
|
384 |
|
|
* Mon Sep 30 2002 Mark Knox <markk@e-smith.com> |
385 |
|
|
- [0.87-05es] |
386 |
|
|
- Improved blank-trimming regexes [markk 4423] |
387 |
|
|
|
388 |
|
|
* Wed Aug 28 2002 Mark Knox <markk@e-smith.com> |
389 |
|
|
- [0.87-04es] |
390 |
|
|
- Move blank trimming code inside conditional to eliminate warnings [markk |
391 |
|
|
4607] |
392 |
|
|
|
393 |
|
|
* Fri Aug 16 2002 Mark Knox <markk@e-smith.com> |
394 |
|
|
- [0.87-03es] |
395 |
|
|
- Security fix: do not pass full path on session token filename [markk 4652] |
396 |
|
|
|
397 |
|
|
* Mon Jul 22 2002 Mark Knox <markk@e-smith.com> |
398 |
|
|
- [0.87-02es] |
399 |
|
|
- Patch to trim blank space from start/end of translations [markk 4423] |
400 |
|
|
|
401 |
|
|
* Mon Jul 22 2002 Mark Knox <markk@e-smith.com> |
402 |
|
|
- [0.87-01es] |
403 |
|
|
- Added "es" suffix. First local build (same as 0.87-01) [markk 4422] |
404 |
|
|
|
405 |
|
|
* Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com> |
406 |
|
|
- [0.87-01] |
407 |
|
|
- Fixed a minor HTML bug (missing > symbol) which was causing problems |
408 |
|
|
with the output of validation error messages. [skud 3807] |
409 |
|
|
|
410 |
|
|
* Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com> |
411 |
|
|
- [0.86] |
412 |
|
|
- Added get_validation_attribute() routine to make it possible to do the |
413 |
|
|
nopipes validation forcing in esmith::FormMagick [skud 3807] |
414 |
|
|
|
415 |
|
|
* Sun Jun 02 2002 Gordon Rowell <gordonr@e-smith.com> |
416 |
|
|
- Place the "nopipes" validator before all others. We never want to |
417 |
|
|
allow pipes in fields for e-smith databases. This may be able to |
418 |
|
|
be done at the esmith::FormMagick level, but this works for now. |
419 |
|
|
[gordonr 3752] |
420 |
|
|
|
421 |
|
|
* Wed May 29 2002 Kirrily Robert <skud@e-smith.com> |
422 |
|
|
- [0.85-01] |
423 |
|
|
- Fixed charset bug for text fields that come from subroutines [skud |
424 |
|
|
3677] |
425 |
|
|
|
426 |
|
|
* Thu May 16 2002 Kirrily Robert <skud@e-smith.com> |
427 |
|
|
- [0.84-02] |
428 |
|
|
- Messed it up, had to repackage. [skud #3390] |
429 |
|
|
|
430 |
|
|
* Thu May 16 2002 Kirrily Robert <skud@e-smith.com> |
431 |
|
|
- [0.84-01] |
432 |
|
|
- Fixed select box charset problem [skud #3390] |
433 |
|
|
|
434 |
|
|
* Mon May 13 2002 Kirrily Robert <skud@e-smith.com> |
435 |
|
|
- [0.83-01] |
436 |
|
|
- Various minor bugfixes etc [skud #3339, #3371, #3390, #3405] |
437 |
|
|
|
438 |
|
|
* Tue May 07 2002 Kirrily Robert <skud@e-smith.com> |
439 |
|
|
- [0.82-02] |
440 |
|
|
- Added dependency on Text::Template 1.40 or higher [skud #3371] |
441 |
|
|
|
442 |
|
|
* Tue May 07 2002 Kirrily Robert <skud@e-smith.com> |
443 |
|
|
- [0.82-01] |
444 |
|
|
- Fixed up various warnings that were thrown to the httpd error log. |
445 |
|
|
[skud #3278, #3358] |
446 |
|
|
- Templated form headers/footers are now untainted automatically. |
447 |
|
|
[skud #3371] |
448 |
|
|
|
449 |
|
|
* Fri May 03 2002 Kirrily Robert <skud@e-smith.com> |
450 |
|
|
- [0.81-02] |
451 |
|
|
- Added dependency for Text::Iconv |
452 |
|
|
|
453 |
|
|
* Wed May 01 2002 Kirrily Robert <skud@e-smith.com> |
454 |
|
|
- [0.81-01] |
455 |
|
|
- Now fails more gracefully on XML errors, dumping the XML to a file in |
456 |
|
|
/tmp as a side effect |
457 |
|
|
- You can now specify the default XML character set encoding as an |
458 |
|
|
argument to new() (defaults to undef). In future versions this should |
459 |
|
|
be changed to work on a per-lexicon basis, but for now we will use this |
460 |
|
|
stopgap measure. |
461 |
|
|
- Fixed a bug which was causing fallback_language not to work. |
462 |
|
|
|
463 |
|
|
* Fri Apr 12 2002 Kirrily Robert <skud@e-smith.com> |
464 |
|
|
- [0.80-01] |
465 |
|
|
- langtags are now all smashed to lower case |
466 |
|
|
|
467 |
|
|
* Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com> |
468 |
|
|
- [0.79-01] |
469 |
|
|
- Updating to release 0.79. |
470 |
|
|
|
471 |
|
|
* Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com> |
472 |
|
|
- [0.78-01] |
473 |
|
|
- Updating to release 0.78. |
474 |
|
|
|
475 |
|
|
* Wed Apr 03 2002 Kirrily Robert <skud@e-smith.com> |
476 |
|
|
- [0.77-01] |
477 |
|
|
- Updating to release 0.77. |
478 |
|
|
|
479 |
|
|
* Wed Mar 20 2002 Kirrily Robert <skud@e-smith.com> |
480 |
|
|
- [0.75-01] |
481 |
|
|
- Updating to release 0.75. |
482 |
|
|
|
483 |
|
|
* Wed Mar 14 2002 Gordon Rowell <gordonr@e-smith.com> |
484 |
|
|
- [0.70-02] |
485 |
|
|
- Removed use for Locale::Maketext, pending new cvs tarball from |
486 |
|
|
SourceForge (which is down ATM) |
487 |
|
|
|
488 |
|
|
* Wed Feb 20 2002 Adrian Chung <adrianc@e-smith.com> |
489 |
|
|
- [0.70-01] |
490 |
|
|
- Updating to release 0.70. |
491 |
|
|
|
492 |
|
|
* Thu Feb 07 2002 Adrian Chung <adrianc@e-smith.com> |
493 |
|
|
- [0.60-01] |
494 |
|
|
- Updated to 0.60. |
495 |
|
|
|
496 |
|
|
* Wed Jan 23 2002 Adrian Chung <adrianc@e-smith.com> |
497 |
|
|
- [0.50-01] |
498 |
|
|
- Updated to 0.50. |
499 |
|
|
|
500 |
|
|
* Wed Dec 19 2001 Gordon Rowell <gordonr@e-smith.com> |
501 |
|
|
- [0.49-03] |
502 |
|
|
- Updated with skud's tarball of the day |
503 |
|
|
|
504 |
|
|
* Mon Dec 17 2001 Gordon Rowell <gordonr@e-smith.com> |
505 |
|
|
- [0.49-02] |
506 |
|
|
- Added dependencies for the swag of modules required. These should |
507 |
|
|
probably be listed in the CPAN module instead |
508 |
|
|
|
509 |
|
|
* Mon Oct 01 2001 charlieb <charlieb@lamington> |
510 |
|
|
- Spec file automatically generated by cpan2rpm |