1 |
# $Id: perl-CGI-FormMagick.spec,v 1.7 2011/03/04 08:41:53 snetram Exp $ |
2 |
|
3 |
Summary: CGI-FormMagick module for perl |
4 |
%define name perl-CGI-FormMagick |
5 |
%define version 0.92 |
6 |
%define release 19 |
7 |
Name: %{name} |
8 |
Version: %{version} |
9 |
Release: %{release}%{?dist} |
10 |
License: distributable |
11 |
Group: Applications/CPAN |
12 |
Source0: perl-CGI-FormMagick-%{version}.tar.gz |
13 |
Patch0: perl-CGI-FormMagick-0.92-password_validation.patch |
14 |
Patch1: perl-CGI-FormMagick-0.92-password_validation2.patch |
15 |
Patch2: perl-CGI-FormMagick-0.92-quotemeta.patch |
16 |
Patch3: perl-CGI-FormMagick-0.92-textarea.patch |
17 |
Patch4: perl-CGI-FormMagick-0.92-validateliteral.patch |
18 |
Patch5: perl-CGI-FormMagick-0.92-nodata.patch |
19 |
Patch6: perl-CGI-FormMagick-0.92-persistent10.patch |
20 |
Patch7: perl-CGI-FormMagick-0.92-persistent10.patch2 |
21 |
Patch8: perl-CGI-FormMagick-0.92-persistent10.patch3 |
22 |
Patch9: perl-CGI-FormMagick-0.92-UTF8.patch |
23 |
Patch10: perl-CGI-FormMagick-0.92-ip-validation.patch |
24 |
Url: http://www.cpan.org |
25 |
BuildRoot: /var/tmp/perl-CGI-FormMagick-buildroot/ |
26 |
BuildArchitectures: noarch |
27 |
BuildRequires: perl |
28 |
Requires: perl perl(XML::Parser) expat |
29 |
Requires: perl(CGI::Persistent) >= 1.00 |
30 |
Requires: perl(Class::ParamParser) perl(I18N::LangTags) |
31 |
Requires: perl(Text::Iconv) |
32 |
Requires: perl(Text::Template) |
33 |
Requires: perl(Mail::RFC822::Address) |
34 |
Provides: perl(ArbitraryPackage) |
35 |
Provides: perl(CGI::FormMagick) = %{version}-%{release} |
36 |
Provides: perl(CGI::FormMagick::Sub) |
37 |
Provides: perl(CGI::FormMagick::TagMaker) = 1.01 |
38 |
Provides: perl(CGI::FormMagick::Validator) |
39 |
Autoreq: no |
40 |
|
41 |
%description |
42 |
FormMagick is a Perl module which enables XML descriptions to be used |
43 |
to generate HTML wizard-like forms. It has support for I18N/L10N. |
44 |
|
45 |
%prep |
46 |
%setup -q |
47 |
%patch0 -p1 |
48 |
%patch1 -p1 |
49 |
%patch2 -p1 |
50 |
%patch3 -p1 |
51 |
%patch4 -p1 |
52 |
%patch5 -p1 |
53 |
%patch6 -p1 |
54 |
%patch7 -p1 |
55 |
%patch8 -p1 |
56 |
%patch9 -p1 |
57 |
%patch10 -p1 |
58 |
|
59 |
%build |
60 |
grep -rsl '^#!.*perl' . | |
61 |
grep -v '.bak$' |xargs --no-run-if-empty \ |
62 |
%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' |
63 |
CFLAGS="$RPM_OPT_FLAGS" |
64 |
%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` INSTALLSITELIB=%{_prefix}/lib/perl5/site_perl |
65 |
%{__make} |
66 |
|
67 |
%clean |
68 |
rm -rf $RPM_BUILD_ROOT |
69 |
|
70 |
%install |
71 |
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
72 |
|
73 |
%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '` |
74 |
|
75 |
[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress |
76 |
|
77 |
# remove special files |
78 |
find %{buildroot} -name "perllocal.pod" \ |
79 |
-o -name ".packlist" \ |
80 |
-o -name "*.bs" \ |
81 |
|xargs -i rm -f {} |
82 |
|
83 |
# no empty directories |
84 |
find %{buildroot}%{_prefix} \ |
85 |
-type d -depth \ |
86 |
-exec rmdir {} \; 2>/dev/null |
87 |
|
88 |
find $RPM_BUILD_ROOT/usr -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" | grep -v perllocal.pod > CGI-FormMagick-%{version}-filelist |
89 |
|
90 |
%files -f CGI-FormMagick-%{version}-filelist |
91 |
%defattr(-,root,root) |
92 |
|
93 |
%changelog |
94 |
* Sat Mar 5 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 0.92-19 |
95 |
- Fix IP address validation [SME: 3388] |
96 |
|
97 |
* Fri Mar 4 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 0.92-18 |
98 |
- Fix IP address validation [SME: 3388] |
99 |
|
100 |
* Wed Mar 2 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 0.92-17 |
101 |
- Fix IP address validation [SME: 3388] |
102 |
|
103 |
* Mon Mar 24 2008 Shad L. Lords <slords@mail.com> 0.92-16 |
104 |
- Fix patch so .orig files aren't created. [SME: 4100] |
105 |
|
106 |
* Mon Mar 10 2008 Shad L. Lords <slords@mail.com> 0.92-15 |
107 |
- Output charset header defining correct charset. [SME: 3858] |
108 |
|
109 |
* Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-14 |
110 |
- Add path to sanitized .id parameter so tokens get created |
111 |
in right place [SME: 3584] |
112 |
|
113 |
* Sat Nov 24 2007 Charlie Brady <charlieb@e-smith.com> 0.92-13 |
114 |
- Sanitise .id parameter before use. [SME: 3584] |
115 |
|
116 |
* Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-12 |
117 |
- Make modules compatible with CGI::Persistent v1.00 [SME: 3581] |
118 |
|
119 |
* Tue Jun 12 2007 Shad L. Lords <slords@mail.com> 0.92-11 |
120 |
- Don't attempt to trim empty/undefined fields [SME: 2395] |
121 |
|
122 |
* Mon Jun 11 2007 Shad L. Lords <slords@mail.com> 0.92-10 |
123 |
- Don't validate literal fields [SME: 2395] |
124 |
|
125 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
126 |
- Clean up spec so package can be built by koji/plague |
127 |
|
128 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
129 |
- Update to new release naming. No functional changes. |
130 |
- Make Packager generic |
131 |
|
132 |
* Tue Aug 22 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-08 |
133 |
- Allow initializer of textarea form widgets. [SME: 1088] |
134 |
|
135 |
* Mon May 01 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-07 |
136 |
- Fix quoting of metachars in subst during inputbox output. [SME: 1352] |
137 |
|
138 |
* Wed Jan 25 2006 Mark Knox <mark_knox@mitel.com> 0.92-06 |
139 |
- Added a missing brace in previous fix [SME: 463] |
140 |
|
141 |
* Fri Jan 13 2006 Charlie Brady <charlieb@e-smith.com> 0.92-05 |
142 |
- Fix password validation check to include _ as non-alpha. [SME: 463] |
143 |
|
144 |
* Thu Dec 15 2005 Charlie Brady <charlieb@e-smith.com> 0.92-04 |
145 |
- Build into /usr/lib/perl5/site_perl so that RPM can be installed |
146 |
on either 6.x or 7.x. |
147 |
|
148 |
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 0.92-03 |
149 |
- Bump release number only |
150 |
|
151 |
* Tue Nov 29 2005 Charlie Brady <charlieb@e-smith.com> |
152 |
- [0.92-02] |
153 |
- Test rebuild after CVS synchronisation. |
154 |
|
155 |
* Mon Oct 31 2005 Mark Knox <mark_knox@mitel.com> |
156 |
- [0.92-01] |
157 |
- Imported to ClearCase, bumped version [markk MN00103900] |
158 |
- Remove generated files Makefile and t/embedded* |
159 |
- Add BuildRequires: perl => 5.8 |
160 |
|
161 |
* Thu Oct 27 2005 Charlie Brady <charlieb@e-smith.com> |
162 |
- [0.91-30] |
163 |
- Avoid warning messages if we try to trim whitespace around $field->{id} when |
164 |
it isn't defined. [SF: 1227604] |
165 |
|
166 |
* Mon Oct 3 2005 Charlie Brady <charlieb@e-smith.com> |
167 |
- [0.91-29] |
168 |
- Fix colspan attributes in display_fields(). [SF: 1309359] |
169 |
|
170 |
* Mon Sep 5 2005 Tony Clayton <apc@e-smith.com> |
171 |
- [0.91-28] |
172 |
- s/Copyright/License/ in rpm headers |
173 |
- Fix subroutine element handling in Validator.pm to fix barrage of logfile |
174 |
warnings |
175 |
- Move sessiondir,cgi object initialization from display() to new() |
176 |
- Remove deprecated sessiondir(),munge_fm_obj() methods |
177 |
|
178 |
* Tue Jul 19 2005 Charlie Brady <charlieb@e-smith.com> |
179 |
- [0.91-27] |
180 |
- Validation fixes from Shad Lords: |
181 |
- Change static strings to TAGS (for L10N) |
182 |
- Fix ip_check to actually check value |
183 |
- Update Provides header to specify version and release |
184 |
|
185 |
* Tue May 24 2005 Charlie Brady <charlieb@e-smith.com> |
186 |
- [0.91-26] |
187 |
- Don't allow rpm to auto calculate perl module dependencies - |
188 |
it gets them wrong sometimes [SF: 1205965] |
189 |
|
190 |
* Fri May 20 2005 Charlie Brady <charlieb@e-smith.com> |
191 |
- [0.91-25] |
192 |
- Apply options parsing fix (from Gordon, SF:1205448) |
193 |
|
194 |
* Tue May 17 2005 Charlie Brady <charlieb@e-smith.com> |
195 |
- [0.91-24] |
196 |
- Remove POD references to unimplemented validation-error-message. |
197 |
|
198 |
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
199 |
- [0.91-23] |
200 |
- Add patch contributed by Shad Lords to allow multi-select. |
201 |
|
202 |
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
203 |
- [0.91-22] |
204 |
- Add patch contributed by Shad Lords to be more flexible about |
205 |
whitespace in validator lists. |
206 |
|
207 |
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
208 |
- [0.91-21] |
209 |
- Make sure we don't leave unpackaged files in our buildroot. |
210 |
|
211 |
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
212 |
- [0.91-20] |
213 |
- Update build and install sections, to allow correct building under CentOS. |
214 |
|
215 |
* Wed Oct 20 2004 Sean Bradbury <bradbury@e-smith.com> |
216 |
- [0.91-19] |
217 |
- Updated requires to remove wrong requires. [bradbury MN00053465] |
218 |
|
219 |
* Tue Sep 28 2004 Michael Soulier <msoulier@e-smith.com> |
220 |
- [0.91-18] |
221 |
- Updated requires with new perl dependencies. [msoulier MN00040240] |
222 |
- Added additional headers to ensure no caching. [msoulier MN00044704] |
223 |
|
224 |
* Fri Sep 3 2004 Michael Soulier <msoulier@e-smith.com> |
225 |
- [0.91-17] |
226 |
- Updated requires with new perl dependencies. [msoulier MN00040240] |
227 |
- Fixed http header to include expiry to prevent browser caching. |
228 |
[msoulier MN00044704] |
229 |
|
230 |
* Sat Aug 21 2004 Michael Soulier <msoulier@e-smith.com> |
231 |
- [0.91-16] |
232 |
- Fixed poor subroutine detection in get_sub(). [msoulier MN00037832] |
233 |
|
234 |
* Tue Aug 3 2004 Michael Soulier <msoulier@e-smith.com> |
235 |
- [0.91-15] |
236 |
- Added an automatic trim of leading and trailing whitespace for all field |
237 |
params during validation, unless a new field attribute of "notrim" evals to |
238 |
true. [msoulier MN00042751] |
239 |
|
240 |
* Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com> |
241 |
- [0.91-14] |
242 |
- Added conditional widgets to FormMagick. fields now support a "display" |
243 |
callback, which, if false, prevents the field from being displayed or |
244 |
validated. [msoulier MN00037809] |
245 |
|
246 |
* Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com> |
247 |
- [0.91-13] |
248 |
- Updated use of CGI::FormMagick::Sub, such that a calling package is no |
249 |
longer required. The object will be searched for methods by default. |
250 |
[msoulier MN00037832] |
251 |
|
252 |
* Wed Jul 14 2004 Michael Soulier <msoulier@e-smith.com> |
253 |
- [0.91-12] |
254 |
- Catch cases where non-existant subroutines are called, and throw a fatal |
255 |
exception with a backtrace. [msoulier MN00042272] |
256 |
|
257 |
* Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com> |
258 |
- [0.91-11] |
259 |
- s/novalidate/nopost, and also prevented the post-event from running if |
260 |
nopost is set. [msoulier MN00040161] |
261 |
|
262 |
* Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com> |
263 |
- [0.91-10] |
264 |
- Added novalidate method, and a hook to it in prepare_for_next_page, so |
265 |
setting a novalidate param will prevent the current page from being |
266 |
validated. Useful for navigational links. [msoulier MN00040161] |
267 |
|
268 |
* Mon May 10 2004 Michael Soulier <msoulier@e-smith.com> |
269 |
- [0.91-09] |
270 |
- Forward-port of dcr-30134, adding the menu attribute to the page tag. |
271 |
[msoulier MN00030134] |
272 |
|
273 |
* Wed Jan 28 2004 Michael Soulier <msoulier@e-smith.com> |
274 |
- [0.91-08] |
275 |
- Fixed weak pattern matching in CGI::FormMagick::Validator::Basic::number. |
276 |
[msoulier 9039] |
277 |
|
278 |
* Mon Jan 5 2004 Michael Soulier <msoulier@e-smith.com> |
279 |
- [0.91-07] |
280 |
- Fixed bad enctype in forms definition. [msoulier 10699] |
281 |
|
282 |
* Wed Nov 19 2003 Michael Soulier <msoulier@e-smith.com> |
283 |
- [0.91-06] |
284 |
- Rolled back change in 0.91-03, as it broke the ibays panel. [msoulier 9404] |
285 |
|
286 |
* Wed Oct 22 2003 Michael Soulier <msoulier@e-smith.com> |
287 |
- [0.91-05] |
288 |
- Updated get_lexicon to merge available language lexicon in reverse order to |
289 |
the preferred languages, so the fallback languages work when the primary is |
290 |
not available. [msoulier 10397] |
291 |
|
292 |
* Fri Sep 5 2003 Tony Clayton <apc@e-smith.com> |
293 |
- [0.91-04] |
294 |
- Added munge_fm_obj() hook to FormMagick.pm [tonyc 9924] |
295 |
|
296 |
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
297 |
- [0.91-03] |
298 |
- Moved the parse_xml() call, and the CGI::Persistent object creation, to the |
299 |
constructor where they belong. [msoulier 9404] |
300 |
|
301 |
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
302 |
- [0.91-02] |
303 |
- Fixed bug in handling of literal widgets. [msoulier 8671] |
304 |
|
305 |
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
306 |
- [0.91-01] |
307 |
- rolling to dev stream - 0.91 |
308 |
|
309 |
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
310 |
- [0.90-01] |
311 |
- rolling to stable stream - 0.90 |
312 |
|
313 |
* Tue Jun 24 2003 Tony Clayton <apc@e-smith.com> |
314 |
- [0.89-06] |
315 |
- Fix TagMaker to allow input fields with value="0" [tonyc 9134] |
316 |
|
317 |
* Tue May 6 2003 Michael Soulier <msoulier@e-smith.com> |
318 |
- [0.89-05] |
319 |
- Fixed bad handling of literal widgets. [msoulier 8671] |
320 |
|
321 |
* Tue May 6 2003 Michael Soulier <msoulier@e-smith.com> |
322 |
- [0.89-04] |
323 |
- Fixed position of the skip_header check so that it's after the establishment |
324 |
of the page number. Otherwise, the page number defaults and the wrong |
325 |
post-event is executed. [msoulier 8637] |
326 |
|
327 |
* Fri May 2 2003 Michael Soulier <msoulier@e-smith.com> |
328 |
- [0.89-03] |
329 |
- Added support for a skip_header parameter, to force the display method to |
330 |
give complete control over the HTTP response to the post-event. |
331 |
[msoulier 8637] |
332 |
|
333 |
* Thu Feb 20 2003 Mark Knox <markk@e-smith.com> |
334 |
- [0.89-02] |
335 |
- Allow for dynamic field types using a subroutine call [markk 6735] |
336 |
|
337 |
* Wed Feb 05 2003 Mark Knox <m_knox@mitel.com> |
338 |
- [0.89-01] |
339 |
- Changed author details in Makefile.PL. |
340 |
- Rolled to v0.89 |
341 |
|
342 |
* Wed Feb 05 2003 Mark Knox <m_knox@mitel.com> |
343 |
- [0.88-01] |
344 |
- Rolled up changes from 0.87-01 to 0.87-14es into 0.88 and released to |
345 |
SourceForge & CPAN |
346 |
|
347 |
* Sat Jan 25 2003 Mike Dickson <miked@e-smith.com> |
348 |
- [0.87-15es] |
349 |
- removed debugging statements from HTML.pm [miked 6617] |
350 |
|
351 |
* Tue Jan 14 2003 Mark Knox <markk@e-smith.com> |
352 |
- [0.87-14es] |
353 |
- Changed DTD and input field sub to allow "rows" and "cols" args on |
354 |
textarea fields, removed size arg on same. [markk 3620] |
355 |
|
356 |
* Fri Dec 27 2002 Mike Dickson <miked@e-smith.com> |
357 |
- [0.87-13es] |
358 |
- removed debugging comments [miked 5494] |
359 |
|
360 |
* Mon Dec 16 2002 Mike Dickson <miked@e-smith.com> |
361 |
- [0.87-12es] |
362 |
- ui updates [miked 5494] |
363 |
|
364 |
* Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com> |
365 |
- [0.87-11es] |
366 |
- Forgot the dependency on the new module. [msoulier 3388] |
367 |
|
368 |
* Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com> |
369 |
- [0.87-10es] |
370 |
- Tightened the check in email_simple() by adding use of the |
371 |
Mail::RFC822::Address module. [msoulier 3388] |
372 |
|
373 |
* Mon Dec 2 2002 Mike Dickson <miked@e-smith.com> |
374 |
- [0.87-09es] |
375 |
- ui update [miked 5494] |
376 |
|
377 |
* Fri Nov 22 2002 Mike Dickson <miked@e-smith.com> |
378 |
- [0.87-08es] |
379 |
- update to use new UI elements [miked 5806] |
380 |
|
381 |
* Fri Nov 22 2002 Gordon Rowell <gordonr@e-smith.com> |
382 |
- [0.87-07es] |
383 |
- Re-import from latest SRPM so it looks like a cvs2rpm package [gordonr 5806] |
384 |
|
385 |
* Thu Oct 03 2002 Mark Knox <markk@e-smith.com> |
386 |
- [0.87-06es] |
387 |
- Removed a stray line from a previous patch that was causing breakage |
388 |
[markk 4423] |
389 |
|
390 |
* Mon Sep 30 2002 Mark Knox <markk@e-smith.com> |
391 |
- [0.87-05es] |
392 |
- Improved blank-trimming regexes [markk 4423] |
393 |
|
394 |
* Wed Aug 28 2002 Mark Knox <markk@e-smith.com> |
395 |
- [0.87-04es] |
396 |
- Move blank trimming code inside conditional to eliminate warnings [markk |
397 |
4607] |
398 |
|
399 |
* Fri Aug 16 2002 Mark Knox <markk@e-smith.com> |
400 |
- [0.87-03es] |
401 |
- Security fix: do not pass full path on session token filename [markk 4652] |
402 |
|
403 |
* Mon Jul 22 2002 Mark Knox <markk@e-smith.com> |
404 |
- [0.87-02es] |
405 |
- Patch to trim blank space from start/end of translations [markk 4423] |
406 |
|
407 |
* Mon Jul 22 2002 Mark Knox <markk@e-smith.com> |
408 |
- [0.87-01es] |
409 |
- Added "es" suffix. First local build (same as 0.87-01) [markk 4422] |
410 |
|
411 |
* Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com> |
412 |
- [0.87-01] |
413 |
- Fixed a minor HTML bug (missing > symbol) which was causing problems |
414 |
with the output of validation error messages. [skud 3807] |
415 |
|
416 |
* Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com> |
417 |
- [0.86] |
418 |
- Added get_validation_attribute() routine to make it possible to do the |
419 |
nopipes validation forcing in esmith::FormMagick [skud 3807] |
420 |
|
421 |
* Sun Jun 02 2002 Gordon Rowell <gordonr@e-smith.com> |
422 |
- Place the "nopipes" validator before all others. We never want to |
423 |
allow pipes in fields for e-smith databases. This may be able to |
424 |
be done at the esmith::FormMagick level, but this works for now. |
425 |
[gordonr 3752] |
426 |
|
427 |
* Wed May 29 2002 Kirrily Robert <skud@e-smith.com> |
428 |
- [0.85-01] |
429 |
- Fixed charset bug for text fields that come from subroutines [skud |
430 |
3677] |
431 |
|
432 |
* Thu May 16 2002 Kirrily Robert <skud@e-smith.com> |
433 |
- [0.84-02] |
434 |
- Messed it up, had to repackage. [skud #3390] |
435 |
|
436 |
* Thu May 16 2002 Kirrily Robert <skud@e-smith.com> |
437 |
- [0.84-01] |
438 |
- Fixed select box charset problem [skud #3390] |
439 |
|
440 |
* Mon May 13 2002 Kirrily Robert <skud@e-smith.com> |
441 |
- [0.83-01] |
442 |
- Various minor bugfixes etc [skud #3339, #3371, #3390, #3405] |
443 |
|
444 |
* Tue May 07 2002 Kirrily Robert <skud@e-smith.com> |
445 |
- [0.82-02] |
446 |
- Added dependency on Text::Template 1.40 or higher [skud #3371] |
447 |
|
448 |
* Tue May 07 2002 Kirrily Robert <skud@e-smith.com> |
449 |
- [0.82-01] |
450 |
- Fixed up various warnings that were thrown to the httpd error log. |
451 |
[skud #3278, #3358] |
452 |
- Templated form headers/footers are now untainted automatically. |
453 |
[skud #3371] |
454 |
|
455 |
* Fri May 03 2002 Kirrily Robert <skud@e-smith.com> |
456 |
- [0.81-02] |
457 |
- Added dependency for Text::Iconv |
458 |
|
459 |
* Wed May 01 2002 Kirrily Robert <skud@e-smith.com> |
460 |
- [0.81-01] |
461 |
- Now fails more gracefully on XML errors, dumping the XML to a file in |
462 |
/tmp as a side effect |
463 |
- You can now specify the default XML character set encoding as an |
464 |
argument to new() (defaults to undef). In future versions this should |
465 |
be changed to work on a per-lexicon basis, but for now we will use this |
466 |
stopgap measure. |
467 |
- Fixed a bug which was causing fallback_language not to work. |
468 |
|
469 |
* Fri Apr 12 2002 Kirrily Robert <skud@e-smith.com> |
470 |
- [0.80-01] |
471 |
- langtags are now all smashed to lower case |
472 |
|
473 |
* Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com> |
474 |
- [0.79-01] |
475 |
- Updating to release 0.79. |
476 |
|
477 |
* Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com> |
478 |
- [0.78-01] |
479 |
- Updating to release 0.78. |
480 |
|
481 |
* Wed Apr 03 2002 Kirrily Robert <skud@e-smith.com> |
482 |
- [0.77-01] |
483 |
- Updating to release 0.77. |
484 |
|
485 |
* Wed Mar 20 2002 Kirrily Robert <skud@e-smith.com> |
486 |
- [0.75-01] |
487 |
- Updating to release 0.75. |
488 |
|
489 |
* Wed Mar 14 2002 Gordon Rowell <gordonr@e-smith.com> |
490 |
- [0.70-02] |
491 |
- Removed use for Locale::Maketext, pending new cvs tarball from |
492 |
SourceForge (which is down ATM) |
493 |
|
494 |
* Wed Feb 20 2002 Adrian Chung <adrianc@e-smith.com> |
495 |
- [0.70-01] |
496 |
- Updating to release 0.70. |
497 |
|
498 |
* Thu Feb 07 2002 Adrian Chung <adrianc@e-smith.com> |
499 |
- [0.60-01] |
500 |
- Updated to 0.60. |
501 |
|
502 |
* Wed Jan 23 2002 Adrian Chung <adrianc@e-smith.com> |
503 |
- [0.50-01] |
504 |
- Updated to 0.50. |
505 |
|
506 |
* Wed Dec 19 2001 Gordon Rowell <gordonr@e-smith.com> |
507 |
- [0.49-03] |
508 |
- Updated with skud's tarball of the day |
509 |
|
510 |
* Mon Dec 17 2001 Gordon Rowell <gordonr@e-smith.com> |
511 |
- [0.49-02] |
512 |
- Added dependencies for the swag of modules required. These should |
513 |
probably be listed in the CPAN module instead |
514 |
|
515 |
* Mon Oct 01 2001 charlieb <charlieb@lamington> |
516 |
- Spec file automatically generated by cpan2rpm |