1 |
slords |
1.1 |
Summary: CGI-FormMagick module for perl |
2 |
|
|
%define name perl-CGI-FormMagick |
3 |
|
|
%define version 0.92 |
4 |
bytegw |
1.3 |
%define release 12 |
5 |
slords |
1.1 |
Name: %{name} |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: distributable |
9 |
|
|
Group: Applications/CPAN |
10 |
|
|
Source0: perl-CGI-FormMagick-%{version}.tar.gz |
11 |
|
|
Patch0: perl-CGI-FormMagick-0.92-password_validation.patch |
12 |
|
|
Patch1: perl-CGI-FormMagick-0.92-password_validation2.patch |
13 |
|
|
Patch2: perl-CGI-FormMagick-0.92-quotemeta.patch |
14 |
|
|
Patch3: perl-CGI-FormMagick-0.92-textarea.patch |
15 |
|
|
Patch4: perl-CGI-FormMagick-0.92-validateliteral.patch |
16 |
slords |
1.2 |
Patch5: perl-CGI-FormMagick-0.92-nodata.patch |
17 |
bytegw |
1.3 |
Patch6: perl-CGI-FormMagick-0.92-persistent10.patch |
18 |
slords |
1.1 |
Url: http://www.cpan.org |
19 |
|
|
BuildRoot: /var/tmp/perl-CGI-FormMagick-buildroot/ |
20 |
|
|
BuildArchitectures: noarch |
21 |
|
|
BuildRequires: perl |
22 |
|
|
Requires: perl perl(XML::Parser) expat |
23 |
bytegw |
1.3 |
Requires: perl(CGI::Persistent) >= 1.00 |
24 |
slords |
1.1 |
Requires: perl(Class::ParamParser) perl(I18N::LangTags) |
25 |
|
|
Requires: perl(Text::Iconv) |
26 |
|
|
Requires: perl(Text::Template) |
27 |
|
|
Requires: perl(Mail::RFC822::Address) |
28 |
|
|
Provides: perl(ArbitraryPackage) |
29 |
|
|
Provides: perl(CGI::FormMagick) = %{version}-%{release} |
30 |
|
|
Provides: perl(CGI::FormMagick::Sub) |
31 |
|
|
Provides: perl(CGI::FormMagick::TagMaker) = 1.01 |
32 |
|
|
Provides: perl(CGI::FormMagick::Validator) |
33 |
|
|
Autoreq: no |
34 |
|
|
|
35 |
|
|
%description |
36 |
|
|
FormMagick is a Perl module which enables XML descriptions to be used |
37 |
|
|
to generate HTML wizard-like forms. It has support for I18N/L10N. |
38 |
|
|
|
39 |
|
|
%prep |
40 |
|
|
%setup -q |
41 |
|
|
%patch0 -p1 |
42 |
|
|
%patch1 -p1 |
43 |
|
|
%patch2 -p1 |
44 |
|
|
%patch3 -p1 |
45 |
|
|
%patch4 -p1 |
46 |
slords |
1.2 |
%patch5 -p1 |
47 |
bytegw |
1.3 |
%patch6 -p1 |
48 |
slords |
1.1 |
|
49 |
|
|
%build |
50 |
|
|
grep -rsl '^#!.*perl' . | |
51 |
|
|
grep -v '.bak$' |xargs --no-run-if-empty \ |
52 |
|
|
%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' |
53 |
|
|
CFLAGS="$RPM_OPT_FLAGS" |
54 |
|
|
%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` INSTALLSITELIB=%{_prefix}/lib/perl5/site_perl |
55 |
|
|
%{__make} |
56 |
|
|
|
57 |
|
|
%clean |
58 |
|
|
rm -rf $RPM_BUILD_ROOT |
59 |
|
|
|
60 |
|
|
%install |
61 |
|
|
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
62 |
|
|
|
63 |
|
|
%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '` |
64 |
|
|
|
65 |
|
|
[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress |
66 |
|
|
|
67 |
|
|
# remove special files |
68 |
|
|
find %{buildroot} -name "perllocal.pod" \ |
69 |
|
|
-o -name ".packlist" \ |
70 |
|
|
-o -name "*.bs" \ |
71 |
|
|
|xargs -i rm -f {} |
72 |
|
|
|
73 |
|
|
# no empty directories |
74 |
|
|
find %{buildroot}%{_prefix} \ |
75 |
|
|
-type d -depth \ |
76 |
|
|
-exec rmdir {} \; 2>/dev/null |
77 |
|
|
|
78 |
|
|
find $RPM_BUILD_ROOT/usr -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" | grep -v perllocal.pod > CGI-FormMagick-%{version}-filelist |
79 |
|
|
|
80 |
|
|
%files -f CGI-FormMagick-%{version}-filelist |
81 |
|
|
%defattr(-,root,root) |
82 |
|
|
|
83 |
|
|
%changelog |
84 |
bytegw |
1.3 |
* Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-12 |
85 |
|
|
- Make modules compatible with CGI::Persistent v1.00 [SME: 3581] |
86 |
|
|
|
87 |
slords |
1.2 |
* Tue Jun 12 2007 Shad L. Lords <slords@mail.com> 0.92-11 |
88 |
|
|
- Don't attempt to trim empty/undefined fields [SME: 2395] |
89 |
|
|
|
90 |
slords |
1.1 |
* Mon Jun 11 2007 Shad L. Lords <slords@mail.com> 0.92-10 |
91 |
slords |
1.2 |
- Don't validate literal fields [SME: 2395] |
92 |
slords |
1.1 |
|
93 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
94 |
|
|
- Clean up spec so package can be built by koji/plague |
95 |
|
|
|
96 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
97 |
|
|
- Update to new release naming. No functional changes. |
98 |
|
|
- Make Packager generic |
99 |
|
|
|
100 |
|
|
* Tue Aug 22 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-08 |
101 |
|
|
- Allow initializer of textarea form widgets. [SME: 1088] |
102 |
|
|
|
103 |
|
|
* Mon May 01 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-07 |
104 |
|
|
- Fix quoting of metachars in subst during inputbox output. [SME: 1352] |
105 |
|
|
|
106 |
|
|
* Wed Jan 25 2006 Mark Knox <mark_knox@mitel.com> 0.92-06 |
107 |
|
|
- Added a missing brace in previous fix [SME: 463] |
108 |
|
|
|
109 |
|
|
* Fri Jan 13 2006 Charlie Brady <charlieb@e-smith.com> 0.92-05 |
110 |
|
|
- Fix password validation check to include _ as non-alpha. [SME: 463] |
111 |
|
|
|
112 |
|
|
* Thu Dec 15 2005 Charlie Brady <charlieb@e-smith.com> 0.92-04 |
113 |
|
|
- Build into /usr/lib/perl5/site_perl so that RPM can be installed |
114 |
|
|
on either 6.x or 7.x. |
115 |
|
|
|
116 |
|
|
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 0.92-03 |
117 |
|
|
- Bump release number only |
118 |
|
|
|
119 |
|
|
* Tue Nov 29 2005 Charlie Brady <charlieb@e-smith.com> |
120 |
|
|
- [0.92-02] |
121 |
|
|
- Test rebuild after CVS synchronisation. |
122 |
|
|
|
123 |
|
|
* Mon Oct 31 2005 Mark Knox <mark_knox@mitel.com> |
124 |
|
|
- [0.92-01] |
125 |
|
|
- Imported to ClearCase, bumped version [markk MN00103900] |
126 |
|
|
- Remove generated files Makefile and t/embedded* |
127 |
|
|
- Add BuildRequires: perl => 5.8 |
128 |
|
|
|
129 |
|
|
* Thu Oct 27 2005 Charlie Brady <charlieb@e-smith.com> |
130 |
|
|
- [0.91-30] |
131 |
|
|
- Avoid warning messages if we try to trim whitespace around $field->{id} when |
132 |
|
|
it isn't defined. [SF: 1227604] |
133 |
|
|
|
134 |
|
|
* Mon Oct 3 2005 Charlie Brady <charlieb@e-smith.com> |
135 |
|
|
- [0.91-29] |
136 |
|
|
- Fix colspan attributes in display_fields(). [SF: 1309359] |
137 |
|
|
|
138 |
|
|
* Mon Sep 5 2005 Tony Clayton <apc@e-smith.com> |
139 |
|
|
- [0.91-28] |
140 |
|
|
- s/Copyright/License/ in rpm headers |
141 |
|
|
- Fix subroutine element handling in Validator.pm to fix barrage of logfile |
142 |
|
|
warnings |
143 |
|
|
- Move sessiondir,cgi object initialization from display() to new() |
144 |
|
|
- Remove deprecated sessiondir(),munge_fm_obj() methods |
145 |
|
|
|
146 |
|
|
* Tue Jul 19 2005 Charlie Brady <charlieb@e-smith.com> |
147 |
|
|
- [0.91-27] |
148 |
|
|
- Validation fixes from Shad Lords: |
149 |
|
|
- Change static strings to TAGS (for L10N) |
150 |
|
|
- Fix ip_check to actually check value |
151 |
|
|
- Update Provides header to specify version and release |
152 |
|
|
|
153 |
|
|
* Tue May 24 2005 Charlie Brady <charlieb@e-smith.com> |
154 |
|
|
- [0.91-26] |
155 |
|
|
- Don't allow rpm to auto calculate perl module dependencies - |
156 |
|
|
it gets them wrong sometimes [SF: 1205965] |
157 |
|
|
|
158 |
|
|
* Fri May 20 2005 Charlie Brady <charlieb@e-smith.com> |
159 |
|
|
- [0.91-25] |
160 |
|
|
- Apply options parsing fix (from Gordon, SF:1205448) |
161 |
|
|
|
162 |
|
|
* Tue May 17 2005 Charlie Brady <charlieb@e-smith.com> |
163 |
|
|
- [0.91-24] |
164 |
|
|
- Remove POD references to unimplemented validation-error-message. |
165 |
|
|
|
166 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
167 |
|
|
- [0.91-23] |
168 |
|
|
- Add patch contributed by Shad Lords to allow multi-select. |
169 |
|
|
|
170 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
171 |
|
|
- [0.91-22] |
172 |
|
|
- Add patch contributed by Shad Lords to be more flexible about |
173 |
|
|
whitespace in validator lists. |
174 |
|
|
|
175 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
176 |
|
|
- [0.91-21] |
177 |
|
|
- Make sure we don't leave unpackaged files in our buildroot. |
178 |
|
|
|
179 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
180 |
|
|
- [0.91-20] |
181 |
|
|
- Update build and install sections, to allow correct building under CentOS. |
182 |
|
|
|
183 |
|
|
* Wed Oct 20 2004 Sean Bradbury <bradbury@e-smith.com> |
184 |
|
|
- [0.91-19] |
185 |
|
|
- Updated requires to remove wrong requires. [bradbury MN00053465] |
186 |
|
|
|
187 |
|
|
* Tue Sep 28 2004 Michael Soulier <msoulier@e-smith.com> |
188 |
|
|
- [0.91-18] |
189 |
|
|
- Updated requires with new perl dependencies. [msoulier MN00040240] |
190 |
|
|
- Added additional headers to ensure no caching. [msoulier MN00044704] |
191 |
|
|
|
192 |
|
|
* Fri Sep 3 2004 Michael Soulier <msoulier@e-smith.com> |
193 |
|
|
- [0.91-17] |
194 |
|
|
- Updated requires with new perl dependencies. [msoulier MN00040240] |
195 |
|
|
- Fixed http header to include expiry to prevent browser caching. |
196 |
|
|
[msoulier MN00044704] |
197 |
|
|
|
198 |
|
|
* Sat Aug 21 2004 Michael Soulier <msoulier@e-smith.com> |
199 |
|
|
- [0.91-16] |
200 |
|
|
- Fixed poor subroutine detection in get_sub(). [msoulier MN00037832] |
201 |
|
|
|
202 |
|
|
* Tue Aug 3 2004 Michael Soulier <msoulier@e-smith.com> |
203 |
|
|
- [0.91-15] |
204 |
|
|
- Added an automatic trim of leading and trailing whitespace for all field |
205 |
|
|
params during validation, unless a new field attribute of "notrim" evals to |
206 |
|
|
true. [msoulier MN00042751] |
207 |
|
|
|
208 |
|
|
* Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com> |
209 |
|
|
- [0.91-14] |
210 |
|
|
- Added conditional widgets to FormMagick. fields now support a "display" |
211 |
|
|
callback, which, if false, prevents the field from being displayed or |
212 |
|
|
validated. [msoulier MN00037809] |
213 |
|
|
|
214 |
|
|
* Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com> |
215 |
|
|
- [0.91-13] |
216 |
|
|
- Updated use of CGI::FormMagick::Sub, such that a calling package is no |
217 |
|
|
longer required. The object will be searched for methods by default. |
218 |
|
|
[msoulier MN00037832] |
219 |
|
|
|
220 |
|
|
* Wed Jul 14 2004 Michael Soulier <msoulier@e-smith.com> |
221 |
|
|
- [0.91-12] |
222 |
|
|
- Catch cases where non-existant subroutines are called, and throw a fatal |
223 |
|
|
exception with a backtrace. [msoulier MN00042272] |
224 |
|
|
|
225 |
|
|
* Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com> |
226 |
|
|
- [0.91-11] |
227 |
|
|
- s/novalidate/nopost, and also prevented the post-event from running if |
228 |
|
|
nopost is set. [msoulier MN00040161] |
229 |
|
|
|
230 |
|
|
* Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com> |
231 |
|
|
- [0.91-10] |
232 |
|
|
- Added novalidate method, and a hook to it in prepare_for_next_page, so |
233 |
|
|
setting a novalidate param will prevent the current page from being |
234 |
|
|
validated. Useful for navigational links. [msoulier MN00040161] |
235 |
|
|
|
236 |
|
|
* Mon May 10 2004 Michael Soulier <msoulier@e-smith.com> |
237 |
|
|
- [0.91-09] |
238 |
|
|
- Forward-port of dcr-30134, adding the menu attribute to the page tag. |
239 |
|
|
[msoulier MN00030134] |
240 |
|
|
|
241 |
|
|
* Wed Jan 28 2004 Michael Soulier <msoulier@e-smith.com> |
242 |
|
|
- [0.91-08] |
243 |
|
|
- Fixed weak pattern matching in CGI::FormMagick::Validator::Basic::number. |
244 |
|
|
[msoulier 9039] |
245 |
|
|
|
246 |
|
|
* Mon Jan 5 2004 Michael Soulier <msoulier@e-smith.com> |
247 |
|
|
- [0.91-07] |
248 |
|
|
- Fixed bad enctype in forms definition. [msoulier 10699] |
249 |
|
|
|
250 |
|
|
* Wed Nov 19 2003 Michael Soulier <msoulier@e-smith.com> |
251 |
|
|
- [0.91-06] |
252 |
|
|
- Rolled back change in 0.91-03, as it broke the ibays panel. [msoulier 9404] |
253 |
|
|
|
254 |
|
|
* Wed Oct 22 2003 Michael Soulier <msoulier@e-smith.com> |
255 |
|
|
- [0.91-05] |
256 |
|
|
- Updated get_lexicon to merge available language lexicon in reverse order to |
257 |
|
|
the preferred languages, so the fallback languages work when the primary is |
258 |
|
|
not available. [msoulier 10397] |
259 |
|
|
|
260 |
|
|
* Fri Sep 5 2003 Tony Clayton <apc@e-smith.com> |
261 |
|
|
- [0.91-04] |
262 |
|
|
- Added munge_fm_obj() hook to FormMagick.pm [tonyc 9924] |
263 |
|
|
|
264 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
265 |
|
|
- [0.91-03] |
266 |
|
|
- Moved the parse_xml() call, and the CGI::Persistent object creation, to the |
267 |
|
|
constructor where they belong. [msoulier 9404] |
268 |
|
|
|
269 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
270 |
|
|
- [0.91-02] |
271 |
|
|
- Fixed bug in handling of literal widgets. [msoulier 8671] |
272 |
|
|
|
273 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
274 |
|
|
- [0.91-01] |
275 |
|
|
- rolling to dev stream - 0.91 |
276 |
|
|
|
277 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
278 |
|
|
- [0.90-01] |
279 |
|
|
- rolling to stable stream - 0.90 |
280 |
|
|
|
281 |
|
|
* Tue Jun 24 2003 Tony Clayton <apc@e-smith.com> |
282 |
|
|
- [0.89-06] |
283 |
|
|
- Fix TagMaker to allow input fields with value="0" [tonyc 9134] |
284 |
|
|
|
285 |
|
|
* Tue May 6 2003 Michael Soulier <msoulier@e-smith.com> |
286 |
|
|
- [0.89-05] |
287 |
|
|
- Fixed bad handling of literal widgets. [msoulier 8671] |
288 |
|
|
|
289 |
|
|
* Tue May 6 2003 Michael Soulier <msoulier@e-smith.com> |
290 |
|
|
- [0.89-04] |
291 |
|
|
- Fixed position of the skip_header check so that it's after the establishment |
292 |
|
|
of the page number. Otherwise, the page number defaults and the wrong |
293 |
|
|
post-event is executed. [msoulier 8637] |
294 |
|
|
|
295 |
|
|
* Fri May 2 2003 Michael Soulier <msoulier@e-smith.com> |
296 |
|
|
- [0.89-03] |
297 |
|
|
- Added support for a skip_header parameter, to force the display method to |
298 |
|
|
give complete control over the HTTP response to the post-event. |
299 |
|
|
[msoulier 8637] |
300 |
|
|
|
301 |
|
|
* Thu Feb 20 2003 Mark Knox <markk@e-smith.com> |
302 |
|
|
- [0.89-02] |
303 |
|
|
- Allow for dynamic field types using a subroutine call [markk 6735] |
304 |
|
|
|
305 |
|
|
* Wed Feb 05 2003 Mark Knox <m_knox@mitel.com> |
306 |
|
|
- [0.89-01] |
307 |
|
|
- Changed author details in Makefile.PL. |
308 |
|
|
- Rolled to v0.89 |
309 |
|
|
|
310 |
|
|
* Wed Feb 05 2003 Mark Knox <m_knox@mitel.com> |
311 |
|
|
- [0.88-01] |
312 |
|
|
- Rolled up changes from 0.87-01 to 0.87-14es into 0.88 and released to |
313 |
|
|
SourceForge & CPAN |
314 |
|
|
|
315 |
|
|
* Sat Jan 25 2003 Mike Dickson <miked@e-smith.com> |
316 |
|
|
- [0.87-15es] |
317 |
|
|
- removed debugging statements from HTML.pm [miked 6617] |
318 |
|
|
|
319 |
|
|
* Tue Jan 14 2003 Mark Knox <markk@e-smith.com> |
320 |
|
|
- [0.87-14es] |
321 |
|
|
- Changed DTD and input field sub to allow "rows" and "cols" args on |
322 |
|
|
textarea fields, removed size arg on same. [markk 3620] |
323 |
|
|
|
324 |
|
|
* Fri Dec 27 2002 Mike Dickson <miked@e-smith.com> |
325 |
|
|
- [0.87-13es] |
326 |
|
|
- removed debugging comments [miked 5494] |
327 |
|
|
|
328 |
|
|
* Mon Dec 16 2002 Mike Dickson <miked@e-smith.com> |
329 |
|
|
- [0.87-12es] |
330 |
|
|
- ui updates [miked 5494] |
331 |
|
|
|
332 |
|
|
* Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com> |
333 |
|
|
- [0.87-11es] |
334 |
|
|
- Forgot the dependency on the new module. [msoulier 3388] |
335 |
|
|
|
336 |
|
|
* Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com> |
337 |
|
|
- [0.87-10es] |
338 |
|
|
- Tightened the check in email_simple() by adding use of the |
339 |
|
|
Mail::RFC822::Address module. [msoulier 3388] |
340 |
|
|
|
341 |
|
|
* Mon Dec 2 2002 Mike Dickson <miked@e-smith.com> |
342 |
|
|
- [0.87-09es] |
343 |
|
|
- ui update [miked 5494] |
344 |
|
|
|
345 |
|
|
* Fri Nov 22 2002 Mike Dickson <miked@e-smith.com> |
346 |
|
|
- [0.87-08es] |
347 |
|
|
- update to use new UI elements [miked 5806] |
348 |
|
|
|
349 |
|
|
* Fri Nov 22 2002 Gordon Rowell <gordonr@e-smith.com> |
350 |
|
|
- [0.87-07es] |
351 |
|
|
- Re-import from latest SRPM so it looks like a cvs2rpm package [gordonr 5806] |
352 |
|
|
|
353 |
|
|
* Thu Oct 03 2002 Mark Knox <markk@e-smith.com> |
354 |
|
|
- [0.87-06es] |
355 |
|
|
- Removed a stray line from a previous patch that was causing breakage |
356 |
|
|
[markk 4423] |
357 |
|
|
|
358 |
|
|
* Mon Sep 30 2002 Mark Knox <markk@e-smith.com> |
359 |
|
|
- [0.87-05es] |
360 |
|
|
- Improved blank-trimming regexes [markk 4423] |
361 |
|
|
|
362 |
|
|
* Wed Aug 28 2002 Mark Knox <markk@e-smith.com> |
363 |
|
|
- [0.87-04es] |
364 |
|
|
- Move blank trimming code inside conditional to eliminate warnings [markk |
365 |
|
|
4607] |
366 |
|
|
|
367 |
|
|
* Fri Aug 16 2002 Mark Knox <markk@e-smith.com> |
368 |
|
|
- [0.87-03es] |
369 |
|
|
- Security fix: do not pass full path on session token filename [markk 4652] |
370 |
|
|
|
371 |
|
|
* Mon Jul 22 2002 Mark Knox <markk@e-smith.com> |
372 |
|
|
- [0.87-02es] |
373 |
|
|
- Patch to trim blank space from start/end of translations [markk 4423] |
374 |
|
|
|
375 |
|
|
* Mon Jul 22 2002 Mark Knox <markk@e-smith.com> |
376 |
|
|
- [0.87-01es] |
377 |
|
|
- Added "es" suffix. First local build (same as 0.87-01) [markk 4422] |
378 |
|
|
|
379 |
|
|
* Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com> |
380 |
|
|
- [0.87-01] |
381 |
|
|
- Fixed a minor HTML bug (missing > symbol) which was causing problems |
382 |
|
|
with the output of validation error messages. [skud 3807] |
383 |
|
|
|
384 |
|
|
* Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com> |
385 |
|
|
- [0.86] |
386 |
|
|
- Added get_validation_attribute() routine to make it possible to do the |
387 |
|
|
nopipes validation forcing in esmith::FormMagick [skud 3807] |
388 |
|
|
|
389 |
|
|
* Sun Jun 02 2002 Gordon Rowell <gordonr@e-smith.com> |
390 |
|
|
- Place the "nopipes" validator before all others. We never want to |
391 |
|
|
allow pipes in fields for e-smith databases. This may be able to |
392 |
|
|
be done at the esmith::FormMagick level, but this works for now. |
393 |
|
|
[gordonr 3752] |
394 |
|
|
|
395 |
|
|
* Wed May 29 2002 Kirrily Robert <skud@e-smith.com> |
396 |
|
|
- [0.85-01] |
397 |
|
|
- Fixed charset bug for text fields that come from subroutines [skud |
398 |
|
|
3677] |
399 |
|
|
|
400 |
|
|
* Thu May 16 2002 Kirrily Robert <skud@e-smith.com> |
401 |
|
|
- [0.84-02] |
402 |
|
|
- Messed it up, had to repackage. [skud #3390] |
403 |
|
|
|
404 |
|
|
* Thu May 16 2002 Kirrily Robert <skud@e-smith.com> |
405 |
|
|
- [0.84-01] |
406 |
|
|
- Fixed select box charset problem [skud #3390] |
407 |
|
|
|
408 |
|
|
* Mon May 13 2002 Kirrily Robert <skud@e-smith.com> |
409 |
|
|
- [0.83-01] |
410 |
|
|
- Various minor bugfixes etc [skud #3339, #3371, #3390, #3405] |
411 |
|
|
|
412 |
|
|
* Tue May 07 2002 Kirrily Robert <skud@e-smith.com> |
413 |
|
|
- [0.82-02] |
414 |
|
|
- Added dependency on Text::Template 1.40 or higher [skud #3371] |
415 |
|
|
|
416 |
|
|
* Tue May 07 2002 Kirrily Robert <skud@e-smith.com> |
417 |
|
|
- [0.82-01] |
418 |
|
|
- Fixed up various warnings that were thrown to the httpd error log. |
419 |
|
|
[skud #3278, #3358] |
420 |
|
|
- Templated form headers/footers are now untainted automatically. |
421 |
|
|
[skud #3371] |
422 |
|
|
|
423 |
|
|
* Fri May 03 2002 Kirrily Robert <skud@e-smith.com> |
424 |
|
|
- [0.81-02] |
425 |
|
|
- Added dependency for Text::Iconv |
426 |
|
|
|
427 |
|
|
* Wed May 01 2002 Kirrily Robert <skud@e-smith.com> |
428 |
|
|
- [0.81-01] |
429 |
|
|
- Now fails more gracefully on XML errors, dumping the XML to a file in |
430 |
|
|
/tmp as a side effect |
431 |
|
|
- You can now specify the default XML character set encoding as an |
432 |
|
|
argument to new() (defaults to undef). In future versions this should |
433 |
|
|
be changed to work on a per-lexicon basis, but for now we will use this |
434 |
|
|
stopgap measure. |
435 |
|
|
- Fixed a bug which was causing fallback_language not to work. |
436 |
|
|
|
437 |
|
|
* Fri Apr 12 2002 Kirrily Robert <skud@e-smith.com> |
438 |
|
|
- [0.80-01] |
439 |
|
|
- langtags are now all smashed to lower case |
440 |
|
|
|
441 |
|
|
* Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com> |
442 |
|
|
- [0.79-01] |
443 |
|
|
- Updating to release 0.79. |
444 |
|
|
|
445 |
|
|
* Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com> |
446 |
|
|
- [0.78-01] |
447 |
|
|
- Updating to release 0.78. |
448 |
|
|
|
449 |
|
|
* Wed Apr 03 2002 Kirrily Robert <skud@e-smith.com> |
450 |
|
|
- [0.77-01] |
451 |
|
|
- Updating to release 0.77. |
452 |
|
|
|
453 |
|
|
* Wed Mar 20 2002 Kirrily Robert <skud@e-smith.com> |
454 |
|
|
- [0.75-01] |
455 |
|
|
- Updating to release 0.75. |
456 |
|
|
|
457 |
|
|
* Wed Mar 14 2002 Gordon Rowell <gordonr@e-smith.com> |
458 |
|
|
- [0.70-02] |
459 |
|
|
- Removed use for Locale::Maketext, pending new cvs tarball from |
460 |
|
|
SourceForge (which is down ATM) |
461 |
|
|
|
462 |
|
|
* Wed Feb 20 2002 Adrian Chung <adrianc@e-smith.com> |
463 |
|
|
- [0.70-01] |
464 |
|
|
- Updating to release 0.70. |
465 |
|
|
|
466 |
|
|
* Thu Feb 07 2002 Adrian Chung <adrianc@e-smith.com> |
467 |
|
|
- [0.60-01] |
468 |
|
|
- Updated to 0.60. |
469 |
|
|
|
470 |
|
|
* Wed Jan 23 2002 Adrian Chung <adrianc@e-smith.com> |
471 |
|
|
- [0.50-01] |
472 |
|
|
- Updated to 0.50. |
473 |
|
|
|
474 |
|
|
* Wed Dec 19 2001 Gordon Rowell <gordonr@e-smith.com> |
475 |
|
|
- [0.49-03] |
476 |
|
|
- Updated with skud's tarball of the day |
477 |
|
|
|
478 |
|
|
* Mon Dec 17 2001 Gordon Rowell <gordonr@e-smith.com> |
479 |
|
|
- [0.49-02] |
480 |
|
|
- Added dependencies for the swag of modules required. These should |
481 |
|
|
probably be listed in the CPAN module instead |
482 |
|
|
|
483 |
|
|
* Mon Oct 01 2001 charlieb <charlieb@lamington> |
484 |
|
|
- Spec file automatically generated by cpan2rpm |