1 |
slords |
1.1 |
Summary: CGI-FormMagick module for perl |
2 |
|
|
%define name perl-CGI-FormMagick |
3 |
|
|
%define version 0.92 |
4 |
slords |
1.2 |
%define release 15 |
5 |
slords |
1.1 |
Name: %{name} |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: distributable |
9 |
|
|
Group: Applications/CPAN |
10 |
|
|
Source0: perl-CGI-FormMagick-%{version}.tar.gz |
11 |
|
|
Patch0: perl-CGI-FormMagick-0.92-password_validation.patch |
12 |
|
|
Patch1: perl-CGI-FormMagick-0.92-password_validation2.patch |
13 |
|
|
Patch2: perl-CGI-FormMagick-0.92-quotemeta.patch |
14 |
|
|
Patch3: perl-CGI-FormMagick-0.92-textarea.patch |
15 |
|
|
Patch4: perl-CGI-FormMagick-0.92-validateliteral.patch |
16 |
|
|
Patch5: perl-CGI-FormMagick-0.92-nodata.patch |
17 |
|
|
Patch6: perl-CGI-FormMagick-0.92-persistent10.patch |
18 |
|
|
Patch7: perl-CGI-FormMagick-0.92-persistent10.patch2 |
19 |
|
|
Patch8: perl-CGI-FormMagick-0.92-persistent10.patch3 |
20 |
slords |
1.2 |
Patch9: perl-CGI-FormMagick-0.92-UTF8.patch |
21 |
slords |
1.1 |
Url: http://www.cpan.org |
22 |
|
|
BuildRoot: /var/tmp/perl-CGI-FormMagick-buildroot/ |
23 |
|
|
BuildArchitectures: noarch |
24 |
|
|
BuildRequires: perl |
25 |
|
|
Requires: perl perl(XML::Parser) expat |
26 |
|
|
Requires: perl(CGI::Persistent) >= 1.00 |
27 |
|
|
Requires: perl(Class::ParamParser) perl(I18N::LangTags) |
28 |
|
|
Requires: perl(Text::Iconv) |
29 |
|
|
Requires: perl(Text::Template) |
30 |
|
|
Requires: perl(Mail::RFC822::Address) |
31 |
|
|
Provides: perl(ArbitraryPackage) |
32 |
|
|
Provides: perl(CGI::FormMagick) = %{version}-%{release} |
33 |
|
|
Provides: perl(CGI::FormMagick::Sub) |
34 |
|
|
Provides: perl(CGI::FormMagick::TagMaker) = 1.01 |
35 |
|
|
Provides: perl(CGI::FormMagick::Validator) |
36 |
|
|
Autoreq: no |
37 |
|
|
|
38 |
|
|
%description |
39 |
|
|
FormMagick is a Perl module which enables XML descriptions to be used |
40 |
|
|
to generate HTML wizard-like forms. It has support for I18N/L10N. |
41 |
|
|
|
42 |
|
|
%prep |
43 |
|
|
%setup -q |
44 |
|
|
%patch0 -p1 |
45 |
|
|
%patch1 -p1 |
46 |
|
|
%patch2 -p1 |
47 |
|
|
%patch3 -p1 |
48 |
|
|
%patch4 -p1 |
49 |
|
|
%patch5 -p1 |
50 |
|
|
%patch6 -p1 |
51 |
|
|
%patch7 -p1 |
52 |
|
|
%patch8 -p1 |
53 |
slords |
1.2 |
%patch9 -p1 |
54 |
slords |
1.1 |
|
55 |
|
|
%build |
56 |
|
|
grep -rsl '^#!.*perl' . | |
57 |
|
|
grep -v '.bak$' |xargs --no-run-if-empty \ |
58 |
|
|
%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' |
59 |
|
|
CFLAGS="$RPM_OPT_FLAGS" |
60 |
|
|
%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` INSTALLSITELIB=%{_prefix}/lib/perl5/site_perl |
61 |
|
|
%{__make} |
62 |
|
|
|
63 |
|
|
%clean |
64 |
|
|
rm -rf $RPM_BUILD_ROOT |
65 |
|
|
|
66 |
|
|
%install |
67 |
|
|
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
68 |
|
|
|
69 |
|
|
%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '` |
70 |
|
|
|
71 |
|
|
[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress |
72 |
|
|
|
73 |
|
|
# remove special files |
74 |
|
|
find %{buildroot} -name "perllocal.pod" \ |
75 |
|
|
-o -name ".packlist" \ |
76 |
|
|
-o -name "*.bs" \ |
77 |
|
|
|xargs -i rm -f {} |
78 |
|
|
|
79 |
|
|
# no empty directories |
80 |
|
|
find %{buildroot}%{_prefix} \ |
81 |
|
|
-type d -depth \ |
82 |
|
|
-exec rmdir {} \; 2>/dev/null |
83 |
|
|
|
84 |
|
|
find $RPM_BUILD_ROOT/usr -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" | grep -v perllocal.pod > CGI-FormMagick-%{version}-filelist |
85 |
|
|
|
86 |
|
|
%files -f CGI-FormMagick-%{version}-filelist |
87 |
|
|
%defattr(-,root,root) |
88 |
|
|
|
89 |
|
|
%changelog |
90 |
slords |
1.2 |
* Mon Mar 10 2008 Shad L. Lords <slords@mail.com> 0.92-15 |
91 |
|
|
- Output charset header defining correct charset. [SME: 3858] |
92 |
|
|
|
93 |
slords |
1.1 |
* Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-14 |
94 |
|
|
- Add path to sanitized .id parameter so tokens get created |
95 |
|
|
in right place [SME: 3584] |
96 |
|
|
|
97 |
|
|
* Sat Nov 24 2007 Charlie Brady <charlieb@e-smith.com> 0.92-13 |
98 |
|
|
- Sanitise .id parameter before use. [SME: 3584] |
99 |
|
|
|
100 |
|
|
* Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-12 |
101 |
|
|
- Make modules compatible with CGI::Persistent v1.00 [SME: 3581] |
102 |
|
|
|
103 |
|
|
* Tue Jun 12 2007 Shad L. Lords <slords@mail.com> 0.92-11 |
104 |
|
|
- Don't attempt to trim empty/undefined fields [SME: 2395] |
105 |
|
|
|
106 |
|
|
* Mon Jun 11 2007 Shad L. Lords <slords@mail.com> 0.92-10 |
107 |
|
|
- Don't validate literal fields [SME: 2395] |
108 |
|
|
|
109 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
110 |
|
|
- Clean up spec so package can be built by koji/plague |
111 |
|
|
|
112 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
113 |
|
|
- Update to new release naming. No functional changes. |
114 |
|
|
- Make Packager generic |
115 |
|
|
|
116 |
|
|
* Tue Aug 22 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-08 |
117 |
|
|
- Allow initializer of textarea form widgets. [SME: 1088] |
118 |
|
|
|
119 |
|
|
* Mon May 01 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-07 |
120 |
|
|
- Fix quoting of metachars in subst during inputbox output. [SME: 1352] |
121 |
|
|
|
122 |
|
|
* Wed Jan 25 2006 Mark Knox <mark_knox@mitel.com> 0.92-06 |
123 |
|
|
- Added a missing brace in previous fix [SME: 463] |
124 |
|
|
|
125 |
|
|
* Fri Jan 13 2006 Charlie Brady <charlieb@e-smith.com> 0.92-05 |
126 |
|
|
- Fix password validation check to include _ as non-alpha. [SME: 463] |
127 |
|
|
|
128 |
|
|
* Thu Dec 15 2005 Charlie Brady <charlieb@e-smith.com> 0.92-04 |
129 |
|
|
- Build into /usr/lib/perl5/site_perl so that RPM can be installed |
130 |
|
|
on either 6.x or 7.x. |
131 |
|
|
|
132 |
|
|
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 0.92-03 |
133 |
|
|
- Bump release number only |
134 |
|
|
|
135 |
|
|
* Tue Nov 29 2005 Charlie Brady <charlieb@e-smith.com> |
136 |
|
|
- [0.92-02] |
137 |
|
|
- Test rebuild after CVS synchronisation. |
138 |
|
|
|
139 |
|
|
* Mon Oct 31 2005 Mark Knox <mark_knox@mitel.com> |
140 |
|
|
- [0.92-01] |
141 |
|
|
- Imported to ClearCase, bumped version [markk MN00103900] |
142 |
|
|
- Remove generated files Makefile and t/embedded* |
143 |
|
|
- Add BuildRequires: perl => 5.8 |
144 |
|
|
|
145 |
|
|
* Thu Oct 27 2005 Charlie Brady <charlieb@e-smith.com> |
146 |
|
|
- [0.91-30] |
147 |
|
|
- Avoid warning messages if we try to trim whitespace around $field->{id} when |
148 |
|
|
it isn't defined. [SF: 1227604] |
149 |
|
|
|
150 |
|
|
* Mon Oct 3 2005 Charlie Brady <charlieb@e-smith.com> |
151 |
|
|
- [0.91-29] |
152 |
|
|
- Fix colspan attributes in display_fields(). [SF: 1309359] |
153 |
|
|
|
154 |
|
|
* Mon Sep 5 2005 Tony Clayton <apc@e-smith.com> |
155 |
|
|
- [0.91-28] |
156 |
|
|
- s/Copyright/License/ in rpm headers |
157 |
|
|
- Fix subroutine element handling in Validator.pm to fix barrage of logfile |
158 |
|
|
warnings |
159 |
|
|
- Move sessiondir,cgi object initialization from display() to new() |
160 |
|
|
- Remove deprecated sessiondir(),munge_fm_obj() methods |
161 |
|
|
|
162 |
|
|
* Tue Jul 19 2005 Charlie Brady <charlieb@e-smith.com> |
163 |
|
|
- [0.91-27] |
164 |
|
|
- Validation fixes from Shad Lords: |
165 |
|
|
- Change static strings to TAGS (for L10N) |
166 |
|
|
- Fix ip_check to actually check value |
167 |
|
|
- Update Provides header to specify version and release |
168 |
|
|
|
169 |
|
|
* Tue May 24 2005 Charlie Brady <charlieb@e-smith.com> |
170 |
|
|
- [0.91-26] |
171 |
|
|
- Don't allow rpm to auto calculate perl module dependencies - |
172 |
|
|
it gets them wrong sometimes [SF: 1205965] |
173 |
|
|
|
174 |
|
|
* Fri May 20 2005 Charlie Brady <charlieb@e-smith.com> |
175 |
|
|
- [0.91-25] |
176 |
|
|
- Apply options parsing fix (from Gordon, SF:1205448) |
177 |
|
|
|
178 |
|
|
* Tue May 17 2005 Charlie Brady <charlieb@e-smith.com> |
179 |
|
|
- [0.91-24] |
180 |
|
|
- Remove POD references to unimplemented validation-error-message. |
181 |
|
|
|
182 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
183 |
|
|
- [0.91-23] |
184 |
|
|
- Add patch contributed by Shad Lords to allow multi-select. |
185 |
|
|
|
186 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
187 |
|
|
- [0.91-22] |
188 |
|
|
- Add patch contributed by Shad Lords to be more flexible about |
189 |
|
|
whitespace in validator lists. |
190 |
|
|
|
191 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
192 |
|
|
- [0.91-21] |
193 |
|
|
- Make sure we don't leave unpackaged files in our buildroot. |
194 |
|
|
|
195 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
196 |
|
|
- [0.91-20] |
197 |
|
|
- Update build and install sections, to allow correct building under CentOS. |
198 |
|
|
|
199 |
|
|
* Wed Oct 20 2004 Sean Bradbury <bradbury@e-smith.com> |
200 |
|
|
- [0.91-19] |
201 |
|
|
- Updated requires to remove wrong requires. [bradbury MN00053465] |
202 |
|
|
|
203 |
|
|
* Tue Sep 28 2004 Michael Soulier <msoulier@e-smith.com> |
204 |
|
|
- [0.91-18] |
205 |
|
|
- Updated requires with new perl dependencies. [msoulier MN00040240] |
206 |
|
|
- Added additional headers to ensure no caching. [msoulier MN00044704] |
207 |
|
|
|
208 |
|
|
* Fri Sep 3 2004 Michael Soulier <msoulier@e-smith.com> |
209 |
|
|
- [0.91-17] |
210 |
|
|
- Updated requires with new perl dependencies. [msoulier MN00040240] |
211 |
|
|
- Fixed http header to include expiry to prevent browser caching. |
212 |
|
|
[msoulier MN00044704] |
213 |
|
|
|
214 |
|
|
* Sat Aug 21 2004 Michael Soulier <msoulier@e-smith.com> |
215 |
|
|
- [0.91-16] |
216 |
|
|
- Fixed poor subroutine detection in get_sub(). [msoulier MN00037832] |
217 |
|
|
|
218 |
|
|
* Tue Aug 3 2004 Michael Soulier <msoulier@e-smith.com> |
219 |
|
|
- [0.91-15] |
220 |
|
|
- Added an automatic trim of leading and trailing whitespace for all field |
221 |
|
|
params during validation, unless a new field attribute of "notrim" evals to |
222 |
|
|
true. [msoulier MN00042751] |
223 |
|
|
|
224 |
|
|
* Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com> |
225 |
|
|
- [0.91-14] |
226 |
|
|
- Added conditional widgets to FormMagick. fields now support a "display" |
227 |
|
|
callback, which, if false, prevents the field from being displayed or |
228 |
|
|
validated. [msoulier MN00037809] |
229 |
|
|
|
230 |
|
|
* Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com> |
231 |
|
|
- [0.91-13] |
232 |
|
|
- Updated use of CGI::FormMagick::Sub, such that a calling package is no |
233 |
|
|
longer required. The object will be searched for methods by default. |
234 |
|
|
[msoulier MN00037832] |
235 |
|
|
|
236 |
|
|
* Wed Jul 14 2004 Michael Soulier <msoulier@e-smith.com> |
237 |
|
|
- [0.91-12] |
238 |
|
|
- Catch cases where non-existant subroutines are called, and throw a fatal |
239 |
|
|
exception with a backtrace. [msoulier MN00042272] |
240 |
|
|
|
241 |
|
|
* Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com> |
242 |
|
|
- [0.91-11] |
243 |
|
|
- s/novalidate/nopost, and also prevented the post-event from running if |
244 |
|
|
nopost is set. [msoulier MN00040161] |
245 |
|
|
|
246 |
|
|
* Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com> |
247 |
|
|
- [0.91-10] |
248 |
|
|
- Added novalidate method, and a hook to it in prepare_for_next_page, so |
249 |
|
|
setting a novalidate param will prevent the current page from being |
250 |
|
|
validated. Useful for navigational links. [msoulier MN00040161] |
251 |
|
|
|
252 |
|
|
* Mon May 10 2004 Michael Soulier <msoulier@e-smith.com> |
253 |
|
|
- [0.91-09] |
254 |
|
|
- Forward-port of dcr-30134, adding the menu attribute to the page tag. |
255 |
|
|
[msoulier MN00030134] |
256 |
|
|
|
257 |
|
|
* Wed Jan 28 2004 Michael Soulier <msoulier@e-smith.com> |
258 |
|
|
- [0.91-08] |
259 |
|
|
- Fixed weak pattern matching in CGI::FormMagick::Validator::Basic::number. |
260 |
|
|
[msoulier 9039] |
261 |
|
|
|
262 |
|
|
* Mon Jan 5 2004 Michael Soulier <msoulier@e-smith.com> |
263 |
|
|
- [0.91-07] |
264 |
|
|
- Fixed bad enctype in forms definition. [msoulier 10699] |
265 |
|
|
|
266 |
|
|
* Wed Nov 19 2003 Michael Soulier <msoulier@e-smith.com> |
267 |
|
|
- [0.91-06] |
268 |
|
|
- Rolled back change in 0.91-03, as it broke the ibays panel. [msoulier 9404] |
269 |
|
|
|
270 |
|
|
* Wed Oct 22 2003 Michael Soulier <msoulier@e-smith.com> |
271 |
|
|
- [0.91-05] |
272 |
|
|
- Updated get_lexicon to merge available language lexicon in reverse order to |
273 |
|
|
the preferred languages, so the fallback languages work when the primary is |
274 |
|
|
not available. [msoulier 10397] |
275 |
|
|
|
276 |
|
|
* Fri Sep 5 2003 Tony Clayton <apc@e-smith.com> |
277 |
|
|
- [0.91-04] |
278 |
|
|
- Added munge_fm_obj() hook to FormMagick.pm [tonyc 9924] |
279 |
|
|
|
280 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
281 |
|
|
- [0.91-03] |
282 |
|
|
- Moved the parse_xml() call, and the CGI::Persistent object creation, to the |
283 |
|
|
constructor where they belong. [msoulier 9404] |
284 |
|
|
|
285 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
286 |
|
|
- [0.91-02] |
287 |
|
|
- Fixed bug in handling of literal widgets. [msoulier 8671] |
288 |
|
|
|
289 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
290 |
|
|
- [0.91-01] |
291 |
|
|
- rolling to dev stream - 0.91 |
292 |
|
|
|
293 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
294 |
|
|
- [0.90-01] |
295 |
|
|
- rolling to stable stream - 0.90 |
296 |
|
|
|
297 |
|
|
* Tue Jun 24 2003 Tony Clayton <apc@e-smith.com> |
298 |
|
|
- [0.89-06] |
299 |
|
|
- Fix TagMaker to allow input fields with value="0" [tonyc 9134] |
300 |
|
|
|
301 |
|
|
* Tue May 6 2003 Michael Soulier <msoulier@e-smith.com> |
302 |
|
|
- [0.89-05] |
303 |
|
|
- Fixed bad handling of literal widgets. [msoulier 8671] |
304 |
|
|
|
305 |
|
|
* Tue May 6 2003 Michael Soulier <msoulier@e-smith.com> |
306 |
|
|
- [0.89-04] |
307 |
|
|
- Fixed position of the skip_header check so that it's after the establishment |
308 |
|
|
of the page number. Otherwise, the page number defaults and the wrong |
309 |
|
|
post-event is executed. [msoulier 8637] |
310 |
|
|
|
311 |
|
|
* Fri May 2 2003 Michael Soulier <msoulier@e-smith.com> |
312 |
|
|
- [0.89-03] |
313 |
|
|
- Added support for a skip_header parameter, to force the display method to |
314 |
|
|
give complete control over the HTTP response to the post-event. |
315 |
|
|
[msoulier 8637] |
316 |
|
|
|
317 |
|
|
* Thu Feb 20 2003 Mark Knox <markk@e-smith.com> |
318 |
|
|
- [0.89-02] |
319 |
|
|
- Allow for dynamic field types using a subroutine call [markk 6735] |
320 |
|
|
|
321 |
|
|
* Wed Feb 05 2003 Mark Knox <m_knox@mitel.com> |
322 |
|
|
- [0.89-01] |
323 |
|
|
- Changed author details in Makefile.PL. |
324 |
|
|
- Rolled to v0.89 |
325 |
|
|
|
326 |
|
|
* Wed Feb 05 2003 Mark Knox <m_knox@mitel.com> |
327 |
|
|
- [0.88-01] |
328 |
|
|
- Rolled up changes from 0.87-01 to 0.87-14es into 0.88 and released to |
329 |
|
|
SourceForge & CPAN |
330 |
|
|
|
331 |
|
|
* Sat Jan 25 2003 Mike Dickson <miked@e-smith.com> |
332 |
|
|
- [0.87-15es] |
333 |
|
|
- removed debugging statements from HTML.pm [miked 6617] |
334 |
|
|
|
335 |
|
|
* Tue Jan 14 2003 Mark Knox <markk@e-smith.com> |
336 |
|
|
- [0.87-14es] |
337 |
|
|
- Changed DTD and input field sub to allow "rows" and "cols" args on |
338 |
|
|
textarea fields, removed size arg on same. [markk 3620] |
339 |
|
|
|
340 |
|
|
* Fri Dec 27 2002 Mike Dickson <miked@e-smith.com> |
341 |
|
|
- [0.87-13es] |
342 |
|
|
- removed debugging comments [miked 5494] |
343 |
|
|
|
344 |
|
|
* Mon Dec 16 2002 Mike Dickson <miked@e-smith.com> |
345 |
|
|
- [0.87-12es] |
346 |
|
|
- ui updates [miked 5494] |
347 |
|
|
|
348 |
|
|
* Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com> |
349 |
|
|
- [0.87-11es] |
350 |
|
|
- Forgot the dependency on the new module. [msoulier 3388] |
351 |
|
|
|
352 |
|
|
* Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com> |
353 |
|
|
- [0.87-10es] |
354 |
|
|
- Tightened the check in email_simple() by adding use of the |
355 |
|
|
Mail::RFC822::Address module. [msoulier 3388] |
356 |
|
|
|
357 |
|
|
* Mon Dec 2 2002 Mike Dickson <miked@e-smith.com> |
358 |
|
|
- [0.87-09es] |
359 |
|
|
- ui update [miked 5494] |
360 |
|
|
|
361 |
|
|
* Fri Nov 22 2002 Mike Dickson <miked@e-smith.com> |
362 |
|
|
- [0.87-08es] |
363 |
|
|
- update to use new UI elements [miked 5806] |
364 |
|
|
|
365 |
|
|
* Fri Nov 22 2002 Gordon Rowell <gordonr@e-smith.com> |
366 |
|
|
- [0.87-07es] |
367 |
|
|
- Re-import from latest SRPM so it looks like a cvs2rpm package [gordonr 5806] |
368 |
|
|
|
369 |
|
|
* Thu Oct 03 2002 Mark Knox <markk@e-smith.com> |
370 |
|
|
- [0.87-06es] |
371 |
|
|
- Removed a stray line from a previous patch that was causing breakage |
372 |
|
|
[markk 4423] |
373 |
|
|
|
374 |
|
|
* Mon Sep 30 2002 Mark Knox <markk@e-smith.com> |
375 |
|
|
- [0.87-05es] |
376 |
|
|
- Improved blank-trimming regexes [markk 4423] |
377 |
|
|
|
378 |
|
|
* Wed Aug 28 2002 Mark Knox <markk@e-smith.com> |
379 |
|
|
- [0.87-04es] |
380 |
|
|
- Move blank trimming code inside conditional to eliminate warnings [markk |
381 |
|
|
4607] |
382 |
|
|
|
383 |
|
|
* Fri Aug 16 2002 Mark Knox <markk@e-smith.com> |
384 |
|
|
- [0.87-03es] |
385 |
|
|
- Security fix: do not pass full path on session token filename [markk 4652] |
386 |
|
|
|
387 |
|
|
* Mon Jul 22 2002 Mark Knox <markk@e-smith.com> |
388 |
|
|
- [0.87-02es] |
389 |
|
|
- Patch to trim blank space from start/end of translations [markk 4423] |
390 |
|
|
|
391 |
|
|
* Mon Jul 22 2002 Mark Knox <markk@e-smith.com> |
392 |
|
|
- [0.87-01es] |
393 |
|
|
- Added "es" suffix. First local build (same as 0.87-01) [markk 4422] |
394 |
|
|
|
395 |
|
|
* Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com> |
396 |
|
|
- [0.87-01] |
397 |
|
|
- Fixed a minor HTML bug (missing > symbol) which was causing problems |
398 |
|
|
with the output of validation error messages. [skud 3807] |
399 |
|
|
|
400 |
|
|
* Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com> |
401 |
|
|
- [0.86] |
402 |
|
|
- Added get_validation_attribute() routine to make it possible to do the |
403 |
|
|
nopipes validation forcing in esmith::FormMagick [skud 3807] |
404 |
|
|
|
405 |
|
|
* Sun Jun 02 2002 Gordon Rowell <gordonr@e-smith.com> |
406 |
|
|
- Place the "nopipes" validator before all others. We never want to |
407 |
|
|
allow pipes in fields for e-smith databases. This may be able to |
408 |
|
|
be done at the esmith::FormMagick level, but this works for now. |
409 |
|
|
[gordonr 3752] |
410 |
|
|
|
411 |
|
|
* Wed May 29 2002 Kirrily Robert <skud@e-smith.com> |
412 |
|
|
- [0.85-01] |
413 |
|
|
- Fixed charset bug for text fields that come from subroutines [skud |
414 |
|
|
3677] |
415 |
|
|
|
416 |
|
|
* Thu May 16 2002 Kirrily Robert <skud@e-smith.com> |
417 |
|
|
- [0.84-02] |
418 |
|
|
- Messed it up, had to repackage. [skud #3390] |
419 |
|
|
|
420 |
|
|
* Thu May 16 2002 Kirrily Robert <skud@e-smith.com> |
421 |
|
|
- [0.84-01] |
422 |
|
|
- Fixed select box charset problem [skud #3390] |
423 |
|
|
|
424 |
|
|
* Mon May 13 2002 Kirrily Robert <skud@e-smith.com> |
425 |
|
|
- [0.83-01] |
426 |
|
|
- Various minor bugfixes etc [skud #3339, #3371, #3390, #3405] |
427 |
|
|
|
428 |
|
|
* Tue May 07 2002 Kirrily Robert <skud@e-smith.com> |
429 |
|
|
- [0.82-02] |
430 |
|
|
- Added dependency on Text::Template 1.40 or higher [skud #3371] |
431 |
|
|
|
432 |
|
|
* Tue May 07 2002 Kirrily Robert <skud@e-smith.com> |
433 |
|
|
- [0.82-01] |
434 |
|
|
- Fixed up various warnings that were thrown to the httpd error log. |
435 |
|
|
[skud #3278, #3358] |
436 |
|
|
- Templated form headers/footers are now untainted automatically. |
437 |
|
|
[skud #3371] |
438 |
|
|
|
439 |
|
|
* Fri May 03 2002 Kirrily Robert <skud@e-smith.com> |
440 |
|
|
- [0.81-02] |
441 |
|
|
- Added dependency for Text::Iconv |
442 |
|
|
|
443 |
|
|
* Wed May 01 2002 Kirrily Robert <skud@e-smith.com> |
444 |
|
|
- [0.81-01] |
445 |
|
|
- Now fails more gracefully on XML errors, dumping the XML to a file in |
446 |
|
|
/tmp as a side effect |
447 |
|
|
- You can now specify the default XML character set encoding as an |
448 |
|
|
argument to new() (defaults to undef). In future versions this should |
449 |
|
|
be changed to work on a per-lexicon basis, but for now we will use this |
450 |
|
|
stopgap measure. |
451 |
|
|
- Fixed a bug which was causing fallback_language not to work. |
452 |
|
|
|
453 |
|
|
* Fri Apr 12 2002 Kirrily Robert <skud@e-smith.com> |
454 |
|
|
- [0.80-01] |
455 |
|
|
- langtags are now all smashed to lower case |
456 |
|
|
|
457 |
|
|
* Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com> |
458 |
|
|
- [0.79-01] |
459 |
|
|
- Updating to release 0.79. |
460 |
|
|
|
461 |
|
|
* Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com> |
462 |
|
|
- [0.78-01] |
463 |
|
|
- Updating to release 0.78. |
464 |
|
|
|
465 |
|
|
* Wed Apr 03 2002 Kirrily Robert <skud@e-smith.com> |
466 |
|
|
- [0.77-01] |
467 |
|
|
- Updating to release 0.77. |
468 |
|
|
|
469 |
|
|
* Wed Mar 20 2002 Kirrily Robert <skud@e-smith.com> |
470 |
|
|
- [0.75-01] |
471 |
|
|
- Updating to release 0.75. |
472 |
|
|
|
473 |
|
|
* Wed Mar 14 2002 Gordon Rowell <gordonr@e-smith.com> |
474 |
|
|
- [0.70-02] |
475 |
|
|
- Removed use for Locale::Maketext, pending new cvs tarball from |
476 |
|
|
SourceForge (which is down ATM) |
477 |
|
|
|
478 |
|
|
* Wed Feb 20 2002 Adrian Chung <adrianc@e-smith.com> |
479 |
|
|
- [0.70-01] |
480 |
|
|
- Updating to release 0.70. |
481 |
|
|
|
482 |
|
|
* Thu Feb 07 2002 Adrian Chung <adrianc@e-smith.com> |
483 |
|
|
- [0.60-01] |
484 |
|
|
- Updated to 0.60. |
485 |
|
|
|
486 |
|
|
* Wed Jan 23 2002 Adrian Chung <adrianc@e-smith.com> |
487 |
|
|
- [0.50-01] |
488 |
|
|
- Updated to 0.50. |
489 |
|
|
|
490 |
|
|
* Wed Dec 19 2001 Gordon Rowell <gordonr@e-smith.com> |
491 |
|
|
- [0.49-03] |
492 |
|
|
- Updated with skud's tarball of the day |
493 |
|
|
|
494 |
|
|
* Mon Dec 17 2001 Gordon Rowell <gordonr@e-smith.com> |
495 |
|
|
- [0.49-02] |
496 |
|
|
- Added dependencies for the swag of modules required. These should |
497 |
|
|
probably be listed in the CPAN module instead |
498 |
|
|
|
499 |
|
|
* Mon Oct 01 2001 charlieb <charlieb@lamington> |
500 |
|
|
- Spec file automatically generated by cpan2rpm |