1 |
slords |
1.1 |
Summary: CGI-FormMagick module for perl |
2 |
|
|
%define name perl-CGI-FormMagick |
3 |
|
|
%define version 0.92 |
4 |
slords |
1.3 |
%define release 16 |
5 |
slords |
1.1 |
Name: %{name} |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: distributable |
9 |
|
|
Group: Applications/CPAN |
10 |
|
|
Source0: perl-CGI-FormMagick-%{version}.tar.gz |
11 |
|
|
Patch0: perl-CGI-FormMagick-0.92-password_validation.patch |
12 |
|
|
Patch1: perl-CGI-FormMagick-0.92-password_validation2.patch |
13 |
|
|
Patch2: perl-CGI-FormMagick-0.92-quotemeta.patch |
14 |
|
|
Patch3: perl-CGI-FormMagick-0.92-textarea.patch |
15 |
|
|
Patch4: perl-CGI-FormMagick-0.92-validateliteral.patch |
16 |
|
|
Patch5: perl-CGI-FormMagick-0.92-nodata.patch |
17 |
|
|
Patch6: perl-CGI-FormMagick-0.92-persistent10.patch |
18 |
|
|
Patch7: perl-CGI-FormMagick-0.92-persistent10.patch2 |
19 |
|
|
Patch8: perl-CGI-FormMagick-0.92-persistent10.patch3 |
20 |
slords |
1.2 |
Patch9: perl-CGI-FormMagick-0.92-UTF8.patch |
21 |
slords |
1.1 |
Url: http://www.cpan.org |
22 |
|
|
BuildRoot: /var/tmp/perl-CGI-FormMagick-buildroot/ |
23 |
|
|
BuildArchitectures: noarch |
24 |
|
|
BuildRequires: perl |
25 |
|
|
Requires: perl perl(XML::Parser) expat |
26 |
|
|
Requires: perl(CGI::Persistent) >= 1.00 |
27 |
|
|
Requires: perl(Class::ParamParser) perl(I18N::LangTags) |
28 |
|
|
Requires: perl(Text::Iconv) |
29 |
|
|
Requires: perl(Text::Template) |
30 |
|
|
Requires: perl(Mail::RFC822::Address) |
31 |
|
|
Provides: perl(ArbitraryPackage) |
32 |
|
|
Provides: perl(CGI::FormMagick) = %{version}-%{release} |
33 |
|
|
Provides: perl(CGI::FormMagick::Sub) |
34 |
|
|
Provides: perl(CGI::FormMagick::TagMaker) = 1.01 |
35 |
|
|
Provides: perl(CGI::FormMagick::Validator) |
36 |
|
|
Autoreq: no |
37 |
|
|
|
38 |
|
|
%description |
39 |
|
|
FormMagick is a Perl module which enables XML descriptions to be used |
40 |
|
|
to generate HTML wizard-like forms. It has support for I18N/L10N. |
41 |
|
|
|
42 |
|
|
%prep |
43 |
|
|
%setup -q |
44 |
|
|
%patch0 -p1 |
45 |
|
|
%patch1 -p1 |
46 |
|
|
%patch2 -p1 |
47 |
|
|
%patch3 -p1 |
48 |
|
|
%patch4 -p1 |
49 |
|
|
%patch5 -p1 |
50 |
|
|
%patch6 -p1 |
51 |
|
|
%patch7 -p1 |
52 |
|
|
%patch8 -p1 |
53 |
slords |
1.2 |
%patch9 -p1 |
54 |
slords |
1.1 |
|
55 |
|
|
%build |
56 |
|
|
grep -rsl '^#!.*perl' . | |
57 |
|
|
grep -v '.bak$' |xargs --no-run-if-empty \ |
58 |
|
|
%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' |
59 |
|
|
CFLAGS="$RPM_OPT_FLAGS" |
60 |
|
|
%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` INSTALLSITELIB=%{_prefix}/lib/perl5/site_perl |
61 |
|
|
%{__make} |
62 |
|
|
|
63 |
|
|
%clean |
64 |
|
|
rm -rf $RPM_BUILD_ROOT |
65 |
|
|
|
66 |
|
|
%install |
67 |
|
|
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
68 |
|
|
|
69 |
|
|
%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '` |
70 |
|
|
|
71 |
|
|
[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress |
72 |
|
|
|
73 |
|
|
# remove special files |
74 |
|
|
find %{buildroot} -name "perllocal.pod" \ |
75 |
|
|
-o -name ".packlist" \ |
76 |
|
|
-o -name "*.bs" \ |
77 |
|
|
|xargs -i rm -f {} |
78 |
|
|
|
79 |
|
|
# no empty directories |
80 |
|
|
find %{buildroot}%{_prefix} \ |
81 |
|
|
-type d -depth \ |
82 |
|
|
-exec rmdir {} \; 2>/dev/null |
83 |
|
|
|
84 |
|
|
find $RPM_BUILD_ROOT/usr -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" | grep -v perllocal.pod > CGI-FormMagick-%{version}-filelist |
85 |
|
|
|
86 |
|
|
%files -f CGI-FormMagick-%{version}-filelist |
87 |
|
|
%defattr(-,root,root) |
88 |
|
|
|
89 |
|
|
%changelog |
90 |
slords |
1.3 |
* Mon Mar 24 2008 Shad L. Lords <slords@mail.com> 0.92-16 |
91 |
|
|
- Fix patch so .orig files aren't created. |
92 |
|
|
|
93 |
slords |
1.2 |
* Mon Mar 10 2008 Shad L. Lords <slords@mail.com> 0.92-15 |
94 |
|
|
- Output charset header defining correct charset. [SME: 3858] |
95 |
|
|
|
96 |
slords |
1.1 |
* Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-14 |
97 |
|
|
- Add path to sanitized .id parameter so tokens get created |
98 |
|
|
in right place [SME: 3584] |
99 |
|
|
|
100 |
|
|
* Sat Nov 24 2007 Charlie Brady <charlieb@e-smith.com> 0.92-13 |
101 |
|
|
- Sanitise .id parameter before use. [SME: 3584] |
102 |
|
|
|
103 |
|
|
* Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-12 |
104 |
|
|
- Make modules compatible with CGI::Persistent v1.00 [SME: 3581] |
105 |
|
|
|
106 |
|
|
* Tue Jun 12 2007 Shad L. Lords <slords@mail.com> 0.92-11 |
107 |
|
|
- Don't attempt to trim empty/undefined fields [SME: 2395] |
108 |
|
|
|
109 |
|
|
* Mon Jun 11 2007 Shad L. Lords <slords@mail.com> 0.92-10 |
110 |
|
|
- Don't validate literal fields [SME: 2395] |
111 |
|
|
|
112 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
113 |
|
|
- Clean up spec so package can be built by koji/plague |
114 |
|
|
|
115 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
116 |
|
|
- Update to new release naming. No functional changes. |
117 |
|
|
- Make Packager generic |
118 |
|
|
|
119 |
|
|
* Tue Aug 22 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-08 |
120 |
|
|
- Allow initializer of textarea form widgets. [SME: 1088] |
121 |
|
|
|
122 |
|
|
* Mon May 01 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-07 |
123 |
|
|
- Fix quoting of metachars in subst during inputbox output. [SME: 1352] |
124 |
|
|
|
125 |
|
|
* Wed Jan 25 2006 Mark Knox <mark_knox@mitel.com> 0.92-06 |
126 |
|
|
- Added a missing brace in previous fix [SME: 463] |
127 |
|
|
|
128 |
|
|
* Fri Jan 13 2006 Charlie Brady <charlieb@e-smith.com> 0.92-05 |
129 |
|
|
- Fix password validation check to include _ as non-alpha. [SME: 463] |
130 |
|
|
|
131 |
|
|
* Thu Dec 15 2005 Charlie Brady <charlieb@e-smith.com> 0.92-04 |
132 |
|
|
- Build into /usr/lib/perl5/site_perl so that RPM can be installed |
133 |
|
|
on either 6.x or 7.x. |
134 |
|
|
|
135 |
|
|
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 0.92-03 |
136 |
|
|
- Bump release number only |
137 |
|
|
|
138 |
|
|
* Tue Nov 29 2005 Charlie Brady <charlieb@e-smith.com> |
139 |
|
|
- [0.92-02] |
140 |
|
|
- Test rebuild after CVS synchronisation. |
141 |
|
|
|
142 |
|
|
* Mon Oct 31 2005 Mark Knox <mark_knox@mitel.com> |
143 |
|
|
- [0.92-01] |
144 |
|
|
- Imported to ClearCase, bumped version [markk MN00103900] |
145 |
|
|
- Remove generated files Makefile and t/embedded* |
146 |
|
|
- Add BuildRequires: perl => 5.8 |
147 |
|
|
|
148 |
|
|
* Thu Oct 27 2005 Charlie Brady <charlieb@e-smith.com> |
149 |
|
|
- [0.91-30] |
150 |
|
|
- Avoid warning messages if we try to trim whitespace around $field->{id} when |
151 |
|
|
it isn't defined. [SF: 1227604] |
152 |
|
|
|
153 |
|
|
* Mon Oct 3 2005 Charlie Brady <charlieb@e-smith.com> |
154 |
|
|
- [0.91-29] |
155 |
|
|
- Fix colspan attributes in display_fields(). [SF: 1309359] |
156 |
|
|
|
157 |
|
|
* Mon Sep 5 2005 Tony Clayton <apc@e-smith.com> |
158 |
|
|
- [0.91-28] |
159 |
|
|
- s/Copyright/License/ in rpm headers |
160 |
|
|
- Fix subroutine element handling in Validator.pm to fix barrage of logfile |
161 |
|
|
warnings |
162 |
|
|
- Move sessiondir,cgi object initialization from display() to new() |
163 |
|
|
- Remove deprecated sessiondir(),munge_fm_obj() methods |
164 |
|
|
|
165 |
|
|
* Tue Jul 19 2005 Charlie Brady <charlieb@e-smith.com> |
166 |
|
|
- [0.91-27] |
167 |
|
|
- Validation fixes from Shad Lords: |
168 |
|
|
- Change static strings to TAGS (for L10N) |
169 |
|
|
- Fix ip_check to actually check value |
170 |
|
|
- Update Provides header to specify version and release |
171 |
|
|
|
172 |
|
|
* Tue May 24 2005 Charlie Brady <charlieb@e-smith.com> |
173 |
|
|
- [0.91-26] |
174 |
|
|
- Don't allow rpm to auto calculate perl module dependencies - |
175 |
|
|
it gets them wrong sometimes [SF: 1205965] |
176 |
|
|
|
177 |
|
|
* Fri May 20 2005 Charlie Brady <charlieb@e-smith.com> |
178 |
|
|
- [0.91-25] |
179 |
|
|
- Apply options parsing fix (from Gordon, SF:1205448) |
180 |
|
|
|
181 |
|
|
* Tue May 17 2005 Charlie Brady <charlieb@e-smith.com> |
182 |
|
|
- [0.91-24] |
183 |
|
|
- Remove POD references to unimplemented validation-error-message. |
184 |
|
|
|
185 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
186 |
|
|
- [0.91-23] |
187 |
|
|
- Add patch contributed by Shad Lords to allow multi-select. |
188 |
|
|
|
189 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
190 |
|
|
- [0.91-22] |
191 |
|
|
- Add patch contributed by Shad Lords to be more flexible about |
192 |
|
|
whitespace in validator lists. |
193 |
|
|
|
194 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
195 |
|
|
- [0.91-21] |
196 |
|
|
- Make sure we don't leave unpackaged files in our buildroot. |
197 |
|
|
|
198 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
199 |
|
|
- [0.91-20] |
200 |
|
|
- Update build and install sections, to allow correct building under CentOS. |
201 |
|
|
|
202 |
|
|
* Wed Oct 20 2004 Sean Bradbury <bradbury@e-smith.com> |
203 |
|
|
- [0.91-19] |
204 |
|
|
- Updated requires to remove wrong requires. [bradbury MN00053465] |
205 |
|
|
|
206 |
|
|
* Tue Sep 28 2004 Michael Soulier <msoulier@e-smith.com> |
207 |
|
|
- [0.91-18] |
208 |
|
|
- Updated requires with new perl dependencies. [msoulier MN00040240] |
209 |
|
|
- Added additional headers to ensure no caching. [msoulier MN00044704] |
210 |
|
|
|
211 |
|
|
* Fri Sep 3 2004 Michael Soulier <msoulier@e-smith.com> |
212 |
|
|
- [0.91-17] |
213 |
|
|
- Updated requires with new perl dependencies. [msoulier MN00040240] |
214 |
|
|
- Fixed http header to include expiry to prevent browser caching. |
215 |
|
|
[msoulier MN00044704] |
216 |
|
|
|
217 |
|
|
* Sat Aug 21 2004 Michael Soulier <msoulier@e-smith.com> |
218 |
|
|
- [0.91-16] |
219 |
|
|
- Fixed poor subroutine detection in get_sub(). [msoulier MN00037832] |
220 |
|
|
|
221 |
|
|
* Tue Aug 3 2004 Michael Soulier <msoulier@e-smith.com> |
222 |
|
|
- [0.91-15] |
223 |
|
|
- Added an automatic trim of leading and trailing whitespace for all field |
224 |
|
|
params during validation, unless a new field attribute of "notrim" evals to |
225 |
|
|
true. [msoulier MN00042751] |
226 |
|
|
|
227 |
|
|
* Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com> |
228 |
|
|
- [0.91-14] |
229 |
|
|
- Added conditional widgets to FormMagick. fields now support a "display" |
230 |
|
|
callback, which, if false, prevents the field from being displayed or |
231 |
|
|
validated. [msoulier MN00037809] |
232 |
|
|
|
233 |
|
|
* Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com> |
234 |
|
|
- [0.91-13] |
235 |
|
|
- Updated use of CGI::FormMagick::Sub, such that a calling package is no |
236 |
|
|
longer required. The object will be searched for methods by default. |
237 |
|
|
[msoulier MN00037832] |
238 |
|
|
|
239 |
|
|
* Wed Jul 14 2004 Michael Soulier <msoulier@e-smith.com> |
240 |
|
|
- [0.91-12] |
241 |
|
|
- Catch cases where non-existant subroutines are called, and throw a fatal |
242 |
|
|
exception with a backtrace. [msoulier MN00042272] |
243 |
|
|
|
244 |
|
|
* Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com> |
245 |
|
|
- [0.91-11] |
246 |
|
|
- s/novalidate/nopost, and also prevented the post-event from running if |
247 |
|
|
nopost is set. [msoulier MN00040161] |
248 |
|
|
|
249 |
|
|
* Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com> |
250 |
|
|
- [0.91-10] |
251 |
|
|
- Added novalidate method, and a hook to it in prepare_for_next_page, so |
252 |
|
|
setting a novalidate param will prevent the current page from being |
253 |
|
|
validated. Useful for navigational links. [msoulier MN00040161] |
254 |
|
|
|
255 |
|
|
* Mon May 10 2004 Michael Soulier <msoulier@e-smith.com> |
256 |
|
|
- [0.91-09] |
257 |
|
|
- Forward-port of dcr-30134, adding the menu attribute to the page tag. |
258 |
|
|
[msoulier MN00030134] |
259 |
|
|
|
260 |
|
|
* Wed Jan 28 2004 Michael Soulier <msoulier@e-smith.com> |
261 |
|
|
- [0.91-08] |
262 |
|
|
- Fixed weak pattern matching in CGI::FormMagick::Validator::Basic::number. |
263 |
|
|
[msoulier 9039] |
264 |
|
|
|
265 |
|
|
* Mon Jan 5 2004 Michael Soulier <msoulier@e-smith.com> |
266 |
|
|
- [0.91-07] |
267 |
|
|
- Fixed bad enctype in forms definition. [msoulier 10699] |
268 |
|
|
|
269 |
|
|
* Wed Nov 19 2003 Michael Soulier <msoulier@e-smith.com> |
270 |
|
|
- [0.91-06] |
271 |
|
|
- Rolled back change in 0.91-03, as it broke the ibays panel. [msoulier 9404] |
272 |
|
|
|
273 |
|
|
* Wed Oct 22 2003 Michael Soulier <msoulier@e-smith.com> |
274 |
|
|
- [0.91-05] |
275 |
|
|
- Updated get_lexicon to merge available language lexicon in reverse order to |
276 |
|
|
the preferred languages, so the fallback languages work when the primary is |
277 |
|
|
not available. [msoulier 10397] |
278 |
|
|
|
279 |
|
|
* Fri Sep 5 2003 Tony Clayton <apc@e-smith.com> |
280 |
|
|
- [0.91-04] |
281 |
|
|
- Added munge_fm_obj() hook to FormMagick.pm [tonyc 9924] |
282 |
|
|
|
283 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
284 |
|
|
- [0.91-03] |
285 |
|
|
- Moved the parse_xml() call, and the CGI::Persistent object creation, to the |
286 |
|
|
constructor where they belong. [msoulier 9404] |
287 |
|
|
|
288 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
289 |
|
|
- [0.91-02] |
290 |
|
|
- Fixed bug in handling of literal widgets. [msoulier 8671] |
291 |
|
|
|
292 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
293 |
|
|
- [0.91-01] |
294 |
|
|
- rolling to dev stream - 0.91 |
295 |
|
|
|
296 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
297 |
|
|
- [0.90-01] |
298 |
|
|
- rolling to stable stream - 0.90 |
299 |
|
|
|
300 |
|
|
* Tue Jun 24 2003 Tony Clayton <apc@e-smith.com> |
301 |
|
|
- [0.89-06] |
302 |
|
|
- Fix TagMaker to allow input fields with value="0" [tonyc 9134] |
303 |
|
|
|
304 |
|
|
* Tue May 6 2003 Michael Soulier <msoulier@e-smith.com> |
305 |
|
|
- [0.89-05] |
306 |
|
|
- Fixed bad handling of literal widgets. [msoulier 8671] |
307 |
|
|
|
308 |
|
|
* Tue May 6 2003 Michael Soulier <msoulier@e-smith.com> |
309 |
|
|
- [0.89-04] |
310 |
|
|
- Fixed position of the skip_header check so that it's after the establishment |
311 |
|
|
of the page number. Otherwise, the page number defaults and the wrong |
312 |
|
|
post-event is executed. [msoulier 8637] |
313 |
|
|
|
314 |
|
|
* Fri May 2 2003 Michael Soulier <msoulier@e-smith.com> |
315 |
|
|
- [0.89-03] |
316 |
|
|
- Added support for a skip_header parameter, to force the display method to |
317 |
|
|
give complete control over the HTTP response to the post-event. |
318 |
|
|
[msoulier 8637] |
319 |
|
|
|
320 |
|
|
* Thu Feb 20 2003 Mark Knox <markk@e-smith.com> |
321 |
|
|
- [0.89-02] |
322 |
|
|
- Allow for dynamic field types using a subroutine call [markk 6735] |
323 |
|
|
|
324 |
|
|
* Wed Feb 05 2003 Mark Knox <m_knox@mitel.com> |
325 |
|
|
- [0.89-01] |
326 |
|
|
- Changed author details in Makefile.PL. |
327 |
|
|
- Rolled to v0.89 |
328 |
|
|
|
329 |
|
|
* Wed Feb 05 2003 Mark Knox <m_knox@mitel.com> |
330 |
|
|
- [0.88-01] |
331 |
|
|
- Rolled up changes from 0.87-01 to 0.87-14es into 0.88 and released to |
332 |
|
|
SourceForge & CPAN |
333 |
|
|
|
334 |
|
|
* Sat Jan 25 2003 Mike Dickson <miked@e-smith.com> |
335 |
|
|
- [0.87-15es] |
336 |
|
|
- removed debugging statements from HTML.pm [miked 6617] |
337 |
|
|
|
338 |
|
|
* Tue Jan 14 2003 Mark Knox <markk@e-smith.com> |
339 |
|
|
- [0.87-14es] |
340 |
|
|
- Changed DTD and input field sub to allow "rows" and "cols" args on |
341 |
|
|
textarea fields, removed size arg on same. [markk 3620] |
342 |
|
|
|
343 |
|
|
* Fri Dec 27 2002 Mike Dickson <miked@e-smith.com> |
344 |
|
|
- [0.87-13es] |
345 |
|
|
- removed debugging comments [miked 5494] |
346 |
|
|
|
347 |
|
|
* Mon Dec 16 2002 Mike Dickson <miked@e-smith.com> |
348 |
|
|
- [0.87-12es] |
349 |
|
|
- ui updates [miked 5494] |
350 |
|
|
|
351 |
|
|
* Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com> |
352 |
|
|
- [0.87-11es] |
353 |
|
|
- Forgot the dependency on the new module. [msoulier 3388] |
354 |
|
|
|
355 |
|
|
* Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com> |
356 |
|
|
- [0.87-10es] |
357 |
|
|
- Tightened the check in email_simple() by adding use of the |
358 |
|
|
Mail::RFC822::Address module. [msoulier 3388] |
359 |
|
|
|
360 |
|
|
* Mon Dec 2 2002 Mike Dickson <miked@e-smith.com> |
361 |
|
|
- [0.87-09es] |
362 |
|
|
- ui update [miked 5494] |
363 |
|
|
|
364 |
|
|
* Fri Nov 22 2002 Mike Dickson <miked@e-smith.com> |
365 |
|
|
- [0.87-08es] |
366 |
|
|
- update to use new UI elements [miked 5806] |
367 |
|
|
|
368 |
|
|
* Fri Nov 22 2002 Gordon Rowell <gordonr@e-smith.com> |
369 |
|
|
- [0.87-07es] |
370 |
|
|
- Re-import from latest SRPM so it looks like a cvs2rpm package [gordonr 5806] |
371 |
|
|
|
372 |
|
|
* Thu Oct 03 2002 Mark Knox <markk@e-smith.com> |
373 |
|
|
- [0.87-06es] |
374 |
|
|
- Removed a stray line from a previous patch that was causing breakage |
375 |
|
|
[markk 4423] |
376 |
|
|
|
377 |
|
|
* Mon Sep 30 2002 Mark Knox <markk@e-smith.com> |
378 |
|
|
- [0.87-05es] |
379 |
|
|
- Improved blank-trimming regexes [markk 4423] |
380 |
|
|
|
381 |
|
|
* Wed Aug 28 2002 Mark Knox <markk@e-smith.com> |
382 |
|
|
- [0.87-04es] |
383 |
|
|
- Move blank trimming code inside conditional to eliminate warnings [markk |
384 |
|
|
4607] |
385 |
|
|
|
386 |
|
|
* Fri Aug 16 2002 Mark Knox <markk@e-smith.com> |
387 |
|
|
- [0.87-03es] |
388 |
|
|
- Security fix: do not pass full path on session token filename [markk 4652] |
389 |
|
|
|
390 |
|
|
* Mon Jul 22 2002 Mark Knox <markk@e-smith.com> |
391 |
|
|
- [0.87-02es] |
392 |
|
|
- Patch to trim blank space from start/end of translations [markk 4423] |
393 |
|
|
|
394 |
|
|
* Mon Jul 22 2002 Mark Knox <markk@e-smith.com> |
395 |
|
|
- [0.87-01es] |
396 |
|
|
- Added "es" suffix. First local build (same as 0.87-01) [markk 4422] |
397 |
|
|
|
398 |
|
|
* Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com> |
399 |
|
|
- [0.87-01] |
400 |
|
|
- Fixed a minor HTML bug (missing > symbol) which was causing problems |
401 |
|
|
with the output of validation error messages. [skud 3807] |
402 |
|
|
|
403 |
|
|
* Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com> |
404 |
|
|
- [0.86] |
405 |
|
|
- Added get_validation_attribute() routine to make it possible to do the |
406 |
|
|
nopipes validation forcing in esmith::FormMagick [skud 3807] |
407 |
|
|
|
408 |
|
|
* Sun Jun 02 2002 Gordon Rowell <gordonr@e-smith.com> |
409 |
|
|
- Place the "nopipes" validator before all others. We never want to |
410 |
|
|
allow pipes in fields for e-smith databases. This may be able to |
411 |
|
|
be done at the esmith::FormMagick level, but this works for now. |
412 |
|
|
[gordonr 3752] |
413 |
|
|
|
414 |
|
|
* Wed May 29 2002 Kirrily Robert <skud@e-smith.com> |
415 |
|
|
- [0.85-01] |
416 |
|
|
- Fixed charset bug for text fields that come from subroutines [skud |
417 |
|
|
3677] |
418 |
|
|
|
419 |
|
|
* Thu May 16 2002 Kirrily Robert <skud@e-smith.com> |
420 |
|
|
- [0.84-02] |
421 |
|
|
- Messed it up, had to repackage. [skud #3390] |
422 |
|
|
|
423 |
|
|
* Thu May 16 2002 Kirrily Robert <skud@e-smith.com> |
424 |
|
|
- [0.84-01] |
425 |
|
|
- Fixed select box charset problem [skud #3390] |
426 |
|
|
|
427 |
|
|
* Mon May 13 2002 Kirrily Robert <skud@e-smith.com> |
428 |
|
|
- [0.83-01] |
429 |
|
|
- Various minor bugfixes etc [skud #3339, #3371, #3390, #3405] |
430 |
|
|
|
431 |
|
|
* Tue May 07 2002 Kirrily Robert <skud@e-smith.com> |
432 |
|
|
- [0.82-02] |
433 |
|
|
- Added dependency on Text::Template 1.40 or higher [skud #3371] |
434 |
|
|
|
435 |
|
|
* Tue May 07 2002 Kirrily Robert <skud@e-smith.com> |
436 |
|
|
- [0.82-01] |
437 |
|
|
- Fixed up various warnings that were thrown to the httpd error log. |
438 |
|
|
[skud #3278, #3358] |
439 |
|
|
- Templated form headers/footers are now untainted automatically. |
440 |
|
|
[skud #3371] |
441 |
|
|
|
442 |
|
|
* Fri May 03 2002 Kirrily Robert <skud@e-smith.com> |
443 |
|
|
- [0.81-02] |
444 |
|
|
- Added dependency for Text::Iconv |
445 |
|
|
|
446 |
|
|
* Wed May 01 2002 Kirrily Robert <skud@e-smith.com> |
447 |
|
|
- [0.81-01] |
448 |
|
|
- Now fails more gracefully on XML errors, dumping the XML to a file in |
449 |
|
|
/tmp as a side effect |
450 |
|
|
- You can now specify the default XML character set encoding as an |
451 |
|
|
argument to new() (defaults to undef). In future versions this should |
452 |
|
|
be changed to work on a per-lexicon basis, but for now we will use this |
453 |
|
|
stopgap measure. |
454 |
|
|
- Fixed a bug which was causing fallback_language not to work. |
455 |
|
|
|
456 |
|
|
* Fri Apr 12 2002 Kirrily Robert <skud@e-smith.com> |
457 |
|
|
- [0.80-01] |
458 |
|
|
- langtags are now all smashed to lower case |
459 |
|
|
|
460 |
|
|
* Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com> |
461 |
|
|
- [0.79-01] |
462 |
|
|
- Updating to release 0.79. |
463 |
|
|
|
464 |
|
|
* Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com> |
465 |
|
|
- [0.78-01] |
466 |
|
|
- Updating to release 0.78. |
467 |
|
|
|
468 |
|
|
* Wed Apr 03 2002 Kirrily Robert <skud@e-smith.com> |
469 |
|
|
- [0.77-01] |
470 |
|
|
- Updating to release 0.77. |
471 |
|
|
|
472 |
|
|
* Wed Mar 20 2002 Kirrily Robert <skud@e-smith.com> |
473 |
|
|
- [0.75-01] |
474 |
|
|
- Updating to release 0.75. |
475 |
|
|
|
476 |
|
|
* Wed Mar 14 2002 Gordon Rowell <gordonr@e-smith.com> |
477 |
|
|
- [0.70-02] |
478 |
|
|
- Removed use for Locale::Maketext, pending new cvs tarball from |
479 |
|
|
SourceForge (which is down ATM) |
480 |
|
|
|
481 |
|
|
* Wed Feb 20 2002 Adrian Chung <adrianc@e-smith.com> |
482 |
|
|
- [0.70-01] |
483 |
|
|
- Updating to release 0.70. |
484 |
|
|
|
485 |
|
|
* Thu Feb 07 2002 Adrian Chung <adrianc@e-smith.com> |
486 |
|
|
- [0.60-01] |
487 |
|
|
- Updated to 0.60. |
488 |
|
|
|
489 |
|
|
* Wed Jan 23 2002 Adrian Chung <adrianc@e-smith.com> |
490 |
|
|
- [0.50-01] |
491 |
|
|
- Updated to 0.50. |
492 |
|
|
|
493 |
|
|
* Wed Dec 19 2001 Gordon Rowell <gordonr@e-smith.com> |
494 |
|
|
- [0.49-03] |
495 |
|
|
- Updated with skud's tarball of the day |
496 |
|
|
|
497 |
|
|
* Mon Dec 17 2001 Gordon Rowell <gordonr@e-smith.com> |
498 |
|
|
- [0.49-02] |
499 |
|
|
- Added dependencies for the swag of modules required. These should |
500 |
|
|
probably be listed in the CPAN module instead |
501 |
|
|
|
502 |
|
|
* Mon Oct 01 2001 charlieb <charlieb@lamington> |
503 |
|
|
- Spec file automatically generated by cpan2rpm |