1 |
snetram |
1.8 |
# $Id: perl-CGI-FormMagick.spec,v 1.7 2009/11/24 21:06:08 snetram Exp $ |
2 |
slords |
1.5 |
|
3 |
slords |
1.1 |
Summary: CGI-FormMagick module for perl |
4 |
|
|
%define name perl-CGI-FormMagick |
5 |
|
|
%define version 0.92 |
6 |
snetram |
1.8 |
%define release 19 |
7 |
slords |
1.1 |
Name: %{name} |
8 |
|
|
Version: %{version} |
9 |
|
|
Release: %{release}%{?dist} |
10 |
|
|
License: distributable |
11 |
|
|
Group: Applications/CPAN |
12 |
|
|
Source0: perl-CGI-FormMagick-%{version}.tar.gz |
13 |
|
|
Patch0: perl-CGI-FormMagick-0.92-password_validation.patch |
14 |
|
|
Patch1: perl-CGI-FormMagick-0.92-password_validation2.patch |
15 |
|
|
Patch2: perl-CGI-FormMagick-0.92-quotemeta.patch |
16 |
|
|
Patch3: perl-CGI-FormMagick-0.92-textarea.patch |
17 |
|
|
Patch4: perl-CGI-FormMagick-0.92-validateliteral.patch |
18 |
|
|
Patch5: perl-CGI-FormMagick-0.92-nodata.patch |
19 |
|
|
Patch6: perl-CGI-FormMagick-0.92-persistent10.patch |
20 |
|
|
Patch7: perl-CGI-FormMagick-0.92-persistent10.patch2 |
21 |
|
|
Patch8: perl-CGI-FormMagick-0.92-persistent10.patch3 |
22 |
slords |
1.2 |
Patch9: perl-CGI-FormMagick-0.92-UTF8.patch |
23 |
snetram |
1.6 |
Patch10: perl-CGI-FormMagick-0.92-uninitialized-value.patch |
24 |
snetram |
1.8 |
Patch11: perl-CGI-FormMagick-0.92-ip-validation.patch |
25 |
slords |
1.1 |
Url: http://www.cpan.org |
26 |
|
|
BuildRoot: /var/tmp/perl-CGI-FormMagick-buildroot/ |
27 |
|
|
BuildArchitectures: noarch |
28 |
|
|
BuildRequires: perl |
29 |
|
|
Requires: perl perl(XML::Parser) expat |
30 |
|
|
Requires: perl(CGI::Persistent) >= 1.00 |
31 |
|
|
Requires: perl(Class::ParamParser) perl(I18N::LangTags) |
32 |
|
|
Requires: perl(Text::Iconv) |
33 |
|
|
Requires: perl(Text::Template) |
34 |
|
|
Requires: perl(Mail::RFC822::Address) |
35 |
|
|
Provides: perl(ArbitraryPackage) |
36 |
|
|
Provides: perl(CGI::FormMagick) = %{version}-%{release} |
37 |
|
|
Provides: perl(CGI::FormMagick::Sub) |
38 |
|
|
Provides: perl(CGI::FormMagick::TagMaker) = 1.01 |
39 |
|
|
Provides: perl(CGI::FormMagick::Validator) |
40 |
|
|
Autoreq: no |
41 |
|
|
|
42 |
|
|
%description |
43 |
|
|
FormMagick is a Perl module which enables XML descriptions to be used |
44 |
|
|
to generate HTML wizard-like forms. It has support for I18N/L10N. |
45 |
|
|
|
46 |
|
|
%prep |
47 |
|
|
%setup -q |
48 |
|
|
%patch0 -p1 |
49 |
|
|
%patch1 -p1 |
50 |
|
|
%patch2 -p1 |
51 |
|
|
%patch3 -p1 |
52 |
|
|
%patch4 -p1 |
53 |
|
|
%patch5 -p1 |
54 |
|
|
%patch6 -p1 |
55 |
|
|
%patch7 -p1 |
56 |
|
|
%patch8 -p1 |
57 |
slords |
1.2 |
%patch9 -p1 |
58 |
snetram |
1.6 |
%patch10 -p1 |
59 |
snetram |
1.8 |
%patch11 -p1 |
60 |
slords |
1.1 |
|
61 |
|
|
%build |
62 |
|
|
grep -rsl '^#!.*perl' . | |
63 |
|
|
grep -v '.bak$' |xargs --no-run-if-empty \ |
64 |
|
|
%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' |
65 |
|
|
CFLAGS="$RPM_OPT_FLAGS" |
66 |
|
|
%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` INSTALLSITELIB=%{_prefix}/lib/perl5/site_perl |
67 |
|
|
%{__make} |
68 |
|
|
|
69 |
|
|
%clean |
70 |
|
|
rm -rf $RPM_BUILD_ROOT |
71 |
|
|
|
72 |
|
|
%install |
73 |
|
|
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
74 |
|
|
|
75 |
|
|
%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '` |
76 |
|
|
|
77 |
|
|
[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress |
78 |
|
|
|
79 |
|
|
# remove special files |
80 |
|
|
find %{buildroot} -name "perllocal.pod" \ |
81 |
|
|
-o -name ".packlist" \ |
82 |
|
|
-o -name "*.bs" \ |
83 |
|
|
|xargs -i rm -f {} |
84 |
|
|
|
85 |
|
|
# no empty directories |
86 |
|
|
find %{buildroot}%{_prefix} \ |
87 |
|
|
-type d -depth \ |
88 |
|
|
-exec rmdir {} \; 2>/dev/null |
89 |
|
|
|
90 |
|
|
find $RPM_BUILD_ROOT/usr -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" | grep -v perllocal.pod > CGI-FormMagick-%{version}-filelist |
91 |
|
|
|
92 |
|
|
%files -f CGI-FormMagick-%{version}-filelist |
93 |
|
|
%defattr(-,root,root) |
94 |
|
|
|
95 |
|
|
%changelog |
96 |
snetram |
1.8 |
* Wed Mar 2 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 0.92-19 |
97 |
|
|
- Fix IP address validation [SME: 6446] |
98 |
|
|
|
99 |
snetram |
1.7 |
* Tue Nov 24 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 0.92-18 |
100 |
|
|
- Fix year in previous changelog entry [SME: 3144] |
101 |
|
|
|
102 |
|
|
* Tue Nov 24 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 0.92-17 |
103 |
snetram |
1.6 |
- Fix unitialized value errors in HTML.pm [SME: 3144] |
104 |
|
|
|
105 |
slords |
1.3 |
* Mon Mar 24 2008 Shad L. Lords <slords@mail.com> 0.92-16 |
106 |
slords |
1.4 |
- Fix patch so .orig files aren't created. [SME: 4100] |
107 |
slords |
1.3 |
|
108 |
slords |
1.2 |
* Mon Mar 10 2008 Shad L. Lords <slords@mail.com> 0.92-15 |
109 |
|
|
- Output charset header defining correct charset. [SME: 3858] |
110 |
|
|
|
111 |
slords |
1.1 |
* Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-14 |
112 |
|
|
- Add path to sanitized .id parameter so tokens get created |
113 |
|
|
in right place [SME: 3584] |
114 |
|
|
|
115 |
|
|
* Sat Nov 24 2007 Charlie Brady <charlieb@e-smith.com> 0.92-13 |
116 |
|
|
- Sanitise .id parameter before use. [SME: 3584] |
117 |
|
|
|
118 |
|
|
* Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-12 |
119 |
|
|
- Make modules compatible with CGI::Persistent v1.00 [SME: 3581] |
120 |
|
|
|
121 |
|
|
* Tue Jun 12 2007 Shad L. Lords <slords@mail.com> 0.92-11 |
122 |
|
|
- Don't attempt to trim empty/undefined fields [SME: 2395] |
123 |
|
|
|
124 |
|
|
* Mon Jun 11 2007 Shad L. Lords <slords@mail.com> 0.92-10 |
125 |
|
|
- Don't validate literal fields [SME: 2395] |
126 |
|
|
|
127 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
128 |
|
|
- Clean up spec so package can be built by koji/plague |
129 |
|
|
|
130 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
131 |
|
|
- Update to new release naming. No functional changes. |
132 |
|
|
- Make Packager generic |
133 |
|
|
|
134 |
|
|
* Tue Aug 22 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-08 |
135 |
|
|
- Allow initializer of textarea form widgets. [SME: 1088] |
136 |
|
|
|
137 |
|
|
* Mon May 01 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-07 |
138 |
|
|
- Fix quoting of metachars in subst during inputbox output. [SME: 1352] |
139 |
|
|
|
140 |
|
|
* Wed Jan 25 2006 Mark Knox <mark_knox@mitel.com> 0.92-06 |
141 |
|
|
- Added a missing brace in previous fix [SME: 463] |
142 |
|
|
|
143 |
|
|
* Fri Jan 13 2006 Charlie Brady <charlieb@e-smith.com> 0.92-05 |
144 |
|
|
- Fix password validation check to include _ as non-alpha. [SME: 463] |
145 |
|
|
|
146 |
|
|
* Thu Dec 15 2005 Charlie Brady <charlieb@e-smith.com> 0.92-04 |
147 |
|
|
- Build into /usr/lib/perl5/site_perl so that RPM can be installed |
148 |
|
|
on either 6.x or 7.x. |
149 |
|
|
|
150 |
|
|
* Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 0.92-03 |
151 |
|
|
- Bump release number only |
152 |
|
|
|
153 |
|
|
* Tue Nov 29 2005 Charlie Brady <charlieb@e-smith.com> |
154 |
|
|
- [0.92-02] |
155 |
|
|
- Test rebuild after CVS synchronisation. |
156 |
|
|
|
157 |
|
|
* Mon Oct 31 2005 Mark Knox <mark_knox@mitel.com> |
158 |
|
|
- [0.92-01] |
159 |
|
|
- Imported to ClearCase, bumped version [markk MN00103900] |
160 |
|
|
- Remove generated files Makefile and t/embedded* |
161 |
|
|
- Add BuildRequires: perl => 5.8 |
162 |
|
|
|
163 |
|
|
* Thu Oct 27 2005 Charlie Brady <charlieb@e-smith.com> |
164 |
|
|
- [0.91-30] |
165 |
|
|
- Avoid warning messages if we try to trim whitespace around $field->{id} when |
166 |
|
|
it isn't defined. [SF: 1227604] |
167 |
|
|
|
168 |
|
|
* Mon Oct 3 2005 Charlie Brady <charlieb@e-smith.com> |
169 |
|
|
- [0.91-29] |
170 |
|
|
- Fix colspan attributes in display_fields(). [SF: 1309359] |
171 |
|
|
|
172 |
|
|
* Mon Sep 5 2005 Tony Clayton <apc@e-smith.com> |
173 |
|
|
- [0.91-28] |
174 |
|
|
- s/Copyright/License/ in rpm headers |
175 |
|
|
- Fix subroutine element handling in Validator.pm to fix barrage of logfile |
176 |
|
|
warnings |
177 |
|
|
- Move sessiondir,cgi object initialization from display() to new() |
178 |
|
|
- Remove deprecated sessiondir(),munge_fm_obj() methods |
179 |
|
|
|
180 |
|
|
* Tue Jul 19 2005 Charlie Brady <charlieb@e-smith.com> |
181 |
|
|
- [0.91-27] |
182 |
|
|
- Validation fixes from Shad Lords: |
183 |
|
|
- Change static strings to TAGS (for L10N) |
184 |
|
|
- Fix ip_check to actually check value |
185 |
|
|
- Update Provides header to specify version and release |
186 |
|
|
|
187 |
|
|
* Tue May 24 2005 Charlie Brady <charlieb@e-smith.com> |
188 |
|
|
- [0.91-26] |
189 |
|
|
- Don't allow rpm to auto calculate perl module dependencies - |
190 |
|
|
it gets them wrong sometimes [SF: 1205965] |
191 |
|
|
|
192 |
|
|
* Fri May 20 2005 Charlie Brady <charlieb@e-smith.com> |
193 |
|
|
- [0.91-25] |
194 |
|
|
- Apply options parsing fix (from Gordon, SF:1205448) |
195 |
|
|
|
196 |
|
|
* Tue May 17 2005 Charlie Brady <charlieb@e-smith.com> |
197 |
|
|
- [0.91-24] |
198 |
|
|
- Remove POD references to unimplemented validation-error-message. |
199 |
|
|
|
200 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
201 |
|
|
- [0.91-23] |
202 |
|
|
- Add patch contributed by Shad Lords to allow multi-select. |
203 |
|
|
|
204 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
205 |
|
|
- [0.91-22] |
206 |
|
|
- Add patch contributed by Shad Lords to be more flexible about |
207 |
|
|
whitespace in validator lists. |
208 |
|
|
|
209 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
210 |
|
|
- [0.91-21] |
211 |
|
|
- Make sure we don't leave unpackaged files in our buildroot. |
212 |
|
|
|
213 |
|
|
* Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com> |
214 |
|
|
- [0.91-20] |
215 |
|
|
- Update build and install sections, to allow correct building under CentOS. |
216 |
|
|
|
217 |
|
|
* Wed Oct 20 2004 Sean Bradbury <bradbury@e-smith.com> |
218 |
|
|
- [0.91-19] |
219 |
|
|
- Updated requires to remove wrong requires. [bradbury MN00053465] |
220 |
|
|
|
221 |
|
|
* Tue Sep 28 2004 Michael Soulier <msoulier@e-smith.com> |
222 |
|
|
- [0.91-18] |
223 |
|
|
- Updated requires with new perl dependencies. [msoulier MN00040240] |
224 |
|
|
- Added additional headers to ensure no caching. [msoulier MN00044704] |
225 |
|
|
|
226 |
|
|
* Fri Sep 3 2004 Michael Soulier <msoulier@e-smith.com> |
227 |
|
|
- [0.91-17] |
228 |
|
|
- Updated requires with new perl dependencies. [msoulier MN00040240] |
229 |
|
|
- Fixed http header to include expiry to prevent browser caching. |
230 |
|
|
[msoulier MN00044704] |
231 |
|
|
|
232 |
|
|
* Sat Aug 21 2004 Michael Soulier <msoulier@e-smith.com> |
233 |
|
|
- [0.91-16] |
234 |
|
|
- Fixed poor subroutine detection in get_sub(). [msoulier MN00037832] |
235 |
|
|
|
236 |
|
|
* Tue Aug 3 2004 Michael Soulier <msoulier@e-smith.com> |
237 |
|
|
- [0.91-15] |
238 |
|
|
- Added an automatic trim of leading and trailing whitespace for all field |
239 |
|
|
params during validation, unless a new field attribute of "notrim" evals to |
240 |
|
|
true. [msoulier MN00042751] |
241 |
|
|
|
242 |
|
|
* Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com> |
243 |
|
|
- [0.91-14] |
244 |
|
|
- Added conditional widgets to FormMagick. fields now support a "display" |
245 |
|
|
callback, which, if false, prevents the field from being displayed or |
246 |
|
|
validated. [msoulier MN00037809] |
247 |
|
|
|
248 |
|
|
* Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com> |
249 |
|
|
- [0.91-13] |
250 |
|
|
- Updated use of CGI::FormMagick::Sub, such that a calling package is no |
251 |
|
|
longer required. The object will be searched for methods by default. |
252 |
|
|
[msoulier MN00037832] |
253 |
|
|
|
254 |
|
|
* Wed Jul 14 2004 Michael Soulier <msoulier@e-smith.com> |
255 |
|
|
- [0.91-12] |
256 |
|
|
- Catch cases where non-existant subroutines are called, and throw a fatal |
257 |
|
|
exception with a backtrace. [msoulier MN00042272] |
258 |
|
|
|
259 |
|
|
* Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com> |
260 |
|
|
- [0.91-11] |
261 |
|
|
- s/novalidate/nopost, and also prevented the post-event from running if |
262 |
|
|
nopost is set. [msoulier MN00040161] |
263 |
|
|
|
264 |
|
|
* Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com> |
265 |
|
|
- [0.91-10] |
266 |
|
|
- Added novalidate method, and a hook to it in prepare_for_next_page, so |
267 |
|
|
setting a novalidate param will prevent the current page from being |
268 |
|
|
validated. Useful for navigational links. [msoulier MN00040161] |
269 |
|
|
|
270 |
|
|
* Mon May 10 2004 Michael Soulier <msoulier@e-smith.com> |
271 |
|
|
- [0.91-09] |
272 |
|
|
- Forward-port of dcr-30134, adding the menu attribute to the page tag. |
273 |
|
|
[msoulier MN00030134] |
274 |
|
|
|
275 |
|
|
* Wed Jan 28 2004 Michael Soulier <msoulier@e-smith.com> |
276 |
|
|
- [0.91-08] |
277 |
|
|
- Fixed weak pattern matching in CGI::FormMagick::Validator::Basic::number. |
278 |
|
|
[msoulier 9039] |
279 |
|
|
|
280 |
|
|
* Mon Jan 5 2004 Michael Soulier <msoulier@e-smith.com> |
281 |
|
|
- [0.91-07] |
282 |
|
|
- Fixed bad enctype in forms definition. [msoulier 10699] |
283 |
|
|
|
284 |
|
|
* Wed Nov 19 2003 Michael Soulier <msoulier@e-smith.com> |
285 |
|
|
- [0.91-06] |
286 |
|
|
- Rolled back change in 0.91-03, as it broke the ibays panel. [msoulier 9404] |
287 |
|
|
|
288 |
|
|
* Wed Oct 22 2003 Michael Soulier <msoulier@e-smith.com> |
289 |
|
|
- [0.91-05] |
290 |
|
|
- Updated get_lexicon to merge available language lexicon in reverse order to |
291 |
|
|
the preferred languages, so the fallback languages work when the primary is |
292 |
|
|
not available. [msoulier 10397] |
293 |
|
|
|
294 |
|
|
* Fri Sep 5 2003 Tony Clayton <apc@e-smith.com> |
295 |
|
|
- [0.91-04] |
296 |
|
|
- Added munge_fm_obj() hook to FormMagick.pm [tonyc 9924] |
297 |
|
|
|
298 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
299 |
|
|
- [0.91-03] |
300 |
|
|
- Moved the parse_xml() call, and the CGI::Persistent object creation, to the |
301 |
|
|
constructor where they belong. [msoulier 9404] |
302 |
|
|
|
303 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
304 |
|
|
- [0.91-02] |
305 |
|
|
- Fixed bug in handling of literal widgets. [msoulier 8671] |
306 |
|
|
|
307 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
308 |
|
|
- [0.91-01] |
309 |
|
|
- rolling to dev stream - 0.91 |
310 |
|
|
|
311 |
|
|
* Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com> |
312 |
|
|
- [0.90-01] |
313 |
|
|
- rolling to stable stream - 0.90 |
314 |
|
|
|
315 |
|
|
* Tue Jun 24 2003 Tony Clayton <apc@e-smith.com> |
316 |
|
|
- [0.89-06] |
317 |
|
|
- Fix TagMaker to allow input fields with value="0" [tonyc 9134] |
318 |
|
|
|
319 |
|
|
* Tue May 6 2003 Michael Soulier <msoulier@e-smith.com> |
320 |
|
|
- [0.89-05] |
321 |
|
|
- Fixed bad handling of literal widgets. [msoulier 8671] |
322 |
|
|
|
323 |
|
|
* Tue May 6 2003 Michael Soulier <msoulier@e-smith.com> |
324 |
|
|
- [0.89-04] |
325 |
|
|
- Fixed position of the skip_header check so that it's after the establishment |
326 |
|
|
of the page number. Otherwise, the page number defaults and the wrong |
327 |
|
|
post-event is executed. [msoulier 8637] |
328 |
|
|
|
329 |
|
|
* Fri May 2 2003 Michael Soulier <msoulier@e-smith.com> |
330 |
|
|
- [0.89-03] |
331 |
|
|
- Added support for a skip_header parameter, to force the display method to |
332 |
|
|
give complete control over the HTTP response to the post-event. |
333 |
|
|
[msoulier 8637] |
334 |
|
|
|
335 |
|
|
* Thu Feb 20 2003 Mark Knox <markk@e-smith.com> |
336 |
|
|
- [0.89-02] |
337 |
|
|
- Allow for dynamic field types using a subroutine call [markk 6735] |
338 |
|
|
|
339 |
|
|
* Wed Feb 05 2003 Mark Knox <m_knox@mitel.com> |
340 |
|
|
- [0.89-01] |
341 |
|
|
- Changed author details in Makefile.PL. |
342 |
|
|
- Rolled to v0.89 |
343 |
|
|
|
344 |
|
|
* Wed Feb 05 2003 Mark Knox <m_knox@mitel.com> |
345 |
|
|
- [0.88-01] |
346 |
|
|
- Rolled up changes from 0.87-01 to 0.87-14es into 0.88 and released to |
347 |
|
|
SourceForge & CPAN |
348 |
|
|
|
349 |
|
|
* Sat Jan 25 2003 Mike Dickson <miked@e-smith.com> |
350 |
|
|
- [0.87-15es] |
351 |
|
|
- removed debugging statements from HTML.pm [miked 6617] |
352 |
|
|
|
353 |
|
|
* Tue Jan 14 2003 Mark Knox <markk@e-smith.com> |
354 |
|
|
- [0.87-14es] |
355 |
|
|
- Changed DTD and input field sub to allow "rows" and "cols" args on |
356 |
|
|
textarea fields, removed size arg on same. [markk 3620] |
357 |
|
|
|
358 |
|
|
* Fri Dec 27 2002 Mike Dickson <miked@e-smith.com> |
359 |
|
|
- [0.87-13es] |
360 |
|
|
- removed debugging comments [miked 5494] |
361 |
|
|
|
362 |
|
|
* Mon Dec 16 2002 Mike Dickson <miked@e-smith.com> |
363 |
|
|
- [0.87-12es] |
364 |
|
|
- ui updates [miked 5494] |
365 |
|
|
|
366 |
|
|
* Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com> |
367 |
|
|
- [0.87-11es] |
368 |
|
|
- Forgot the dependency on the new module. [msoulier 3388] |
369 |
|
|
|
370 |
|
|
* Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com> |
371 |
|
|
- [0.87-10es] |
372 |
|
|
- Tightened the check in email_simple() by adding use of the |
373 |
|
|
Mail::RFC822::Address module. [msoulier 3388] |
374 |
|
|
|
375 |
|
|
* Mon Dec 2 2002 Mike Dickson <miked@e-smith.com> |
376 |
|
|
- [0.87-09es] |
377 |
|
|
- ui update [miked 5494] |
378 |
|
|
|
379 |
|
|
* Fri Nov 22 2002 Mike Dickson <miked@e-smith.com> |
380 |
|
|
- [0.87-08es] |
381 |
|
|
- update to use new UI elements [miked 5806] |
382 |
|
|
|
383 |
|
|
* Fri Nov 22 2002 Gordon Rowell <gordonr@e-smith.com> |
384 |
|
|
- [0.87-07es] |
385 |
|
|
- Re-import from latest SRPM so it looks like a cvs2rpm package [gordonr 5806] |
386 |
|
|
|
387 |
|
|
* Thu Oct 03 2002 Mark Knox <markk@e-smith.com> |
388 |
|
|
- [0.87-06es] |
389 |
|
|
- Removed a stray line from a previous patch that was causing breakage |
390 |
|
|
[markk 4423] |
391 |
|
|
|
392 |
|
|
* Mon Sep 30 2002 Mark Knox <markk@e-smith.com> |
393 |
|
|
- [0.87-05es] |
394 |
|
|
- Improved blank-trimming regexes [markk 4423] |
395 |
|
|
|
396 |
|
|
* Wed Aug 28 2002 Mark Knox <markk@e-smith.com> |
397 |
|
|
- [0.87-04es] |
398 |
|
|
- Move blank trimming code inside conditional to eliminate warnings [markk |
399 |
|
|
4607] |
400 |
|
|
|
401 |
|
|
* Fri Aug 16 2002 Mark Knox <markk@e-smith.com> |
402 |
|
|
- [0.87-03es] |
403 |
|
|
- Security fix: do not pass full path on session token filename [markk 4652] |
404 |
|
|
|
405 |
|
|
* Mon Jul 22 2002 Mark Knox <markk@e-smith.com> |
406 |
|
|
- [0.87-02es] |
407 |
|
|
- Patch to trim blank space from start/end of translations [markk 4423] |
408 |
|
|
|
409 |
|
|
* Mon Jul 22 2002 Mark Knox <markk@e-smith.com> |
410 |
|
|
- [0.87-01es] |
411 |
|
|
- Added "es" suffix. First local build (same as 0.87-01) [markk 4422] |
412 |
|
|
|
413 |
|
|
* Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com> |
414 |
|
|
- [0.87-01] |
415 |
|
|
- Fixed a minor HTML bug (missing > symbol) which was causing problems |
416 |
|
|
with the output of validation error messages. [skud 3807] |
417 |
|
|
|
418 |
|
|
* Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com> |
419 |
|
|
- [0.86] |
420 |
|
|
- Added get_validation_attribute() routine to make it possible to do the |
421 |
|
|
nopipes validation forcing in esmith::FormMagick [skud 3807] |
422 |
|
|
|
423 |
|
|
* Sun Jun 02 2002 Gordon Rowell <gordonr@e-smith.com> |
424 |
|
|
- Place the "nopipes" validator before all others. We never want to |
425 |
|
|
allow pipes in fields for e-smith databases. This may be able to |
426 |
|
|
be done at the esmith::FormMagick level, but this works for now. |
427 |
|
|
[gordonr 3752] |
428 |
|
|
|
429 |
|
|
* Wed May 29 2002 Kirrily Robert <skud@e-smith.com> |
430 |
|
|
- [0.85-01] |
431 |
|
|
- Fixed charset bug for text fields that come from subroutines [skud |
432 |
|
|
3677] |
433 |
|
|
|
434 |
|
|
* Thu May 16 2002 Kirrily Robert <skud@e-smith.com> |
435 |
|
|
- [0.84-02] |
436 |
|
|
- Messed it up, had to repackage. [skud #3390] |
437 |
|
|
|
438 |
|
|
* Thu May 16 2002 Kirrily Robert <skud@e-smith.com> |
439 |
|
|
- [0.84-01] |
440 |
|
|
- Fixed select box charset problem [skud #3390] |
441 |
|
|
|
442 |
|
|
* Mon May 13 2002 Kirrily Robert <skud@e-smith.com> |
443 |
|
|
- [0.83-01] |
444 |
|
|
- Various minor bugfixes etc [skud #3339, #3371, #3390, #3405] |
445 |
|
|
|
446 |
|
|
* Tue May 07 2002 Kirrily Robert <skud@e-smith.com> |
447 |
|
|
- [0.82-02] |
448 |
|
|
- Added dependency on Text::Template 1.40 or higher [skud #3371] |
449 |
|
|
|
450 |
|
|
* Tue May 07 2002 Kirrily Robert <skud@e-smith.com> |
451 |
|
|
- [0.82-01] |
452 |
|
|
- Fixed up various warnings that were thrown to the httpd error log. |
453 |
|
|
[skud #3278, #3358] |
454 |
|
|
- Templated form headers/footers are now untainted automatically. |
455 |
|
|
[skud #3371] |
456 |
|
|
|
457 |
|
|
* Fri May 03 2002 Kirrily Robert <skud@e-smith.com> |
458 |
|
|
- [0.81-02] |
459 |
|
|
- Added dependency for Text::Iconv |
460 |
|
|
|
461 |
|
|
* Wed May 01 2002 Kirrily Robert <skud@e-smith.com> |
462 |
|
|
- [0.81-01] |
463 |
|
|
- Now fails more gracefully on XML errors, dumping the XML to a file in |
464 |
|
|
/tmp as a side effect |
465 |
|
|
- You can now specify the default XML character set encoding as an |
466 |
|
|
argument to new() (defaults to undef). In future versions this should |
467 |
|
|
be changed to work on a per-lexicon basis, but for now we will use this |
468 |
|
|
stopgap measure. |
469 |
|
|
- Fixed a bug which was causing fallback_language not to work. |
470 |
|
|
|
471 |
|
|
* Fri Apr 12 2002 Kirrily Robert <skud@e-smith.com> |
472 |
|
|
- [0.80-01] |
473 |
|
|
- langtags are now all smashed to lower case |
474 |
|
|
|
475 |
|
|
* Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com> |
476 |
|
|
- [0.79-01] |
477 |
|
|
- Updating to release 0.79. |
478 |
|
|
|
479 |
|
|
* Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com> |
480 |
|
|
- [0.78-01] |
481 |
|
|
- Updating to release 0.78. |
482 |
|
|
|
483 |
|
|
* Wed Apr 03 2002 Kirrily Robert <skud@e-smith.com> |
484 |
|
|
- [0.77-01] |
485 |
|
|
- Updating to release 0.77. |
486 |
|
|
|
487 |
|
|
* Wed Mar 20 2002 Kirrily Robert <skud@e-smith.com> |
488 |
|
|
- [0.75-01] |
489 |
|
|
- Updating to release 0.75. |
490 |
|
|
|
491 |
|
|
* Wed Mar 14 2002 Gordon Rowell <gordonr@e-smith.com> |
492 |
|
|
- [0.70-02] |
493 |
|
|
- Removed use for Locale::Maketext, pending new cvs tarball from |
494 |
|
|
SourceForge (which is down ATM) |
495 |
|
|
|
496 |
|
|
* Wed Feb 20 2002 Adrian Chung <adrianc@e-smith.com> |
497 |
|
|
- [0.70-01] |
498 |
|
|
- Updating to release 0.70. |
499 |
|
|
|
500 |
|
|
* Thu Feb 07 2002 Adrian Chung <adrianc@e-smith.com> |
501 |
|
|
- [0.60-01] |
502 |
|
|
- Updated to 0.60. |
503 |
|
|
|
504 |
|
|
* Wed Jan 23 2002 Adrian Chung <adrianc@e-smith.com> |
505 |
|
|
- [0.50-01] |
506 |
|
|
- Updated to 0.50. |
507 |
|
|
|
508 |
|
|
* Wed Dec 19 2001 Gordon Rowell <gordonr@e-smith.com> |
509 |
|
|
- [0.49-03] |
510 |
|
|
- Updated with skud's tarball of the day |
511 |
|
|
|
512 |
|
|
* Mon Dec 17 2001 Gordon Rowell <gordonr@e-smith.com> |
513 |
|
|
- [0.49-02] |
514 |
|
|
- Added dependencies for the swag of modules required. These should |
515 |
|
|
probably be listed in the CPAN module instead |
516 |
|
|
|
517 |
|
|
* Mon Oct 01 2001 charlieb <charlieb@lamington> |
518 |
|
|
- Spec file automatically generated by cpan2rpm |