/[smeserver]/rpms/perl-CGI-FormMagick/sme9/perl-CGI-FormMagick.spec
ViewVC logotype

Annotation of /rpms/perl-CGI-FormMagick/sme9/perl-CGI-FormMagick.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Fri Jan 25 17:43:22 2013 UTC (11 years, 5 months ago) by slords
Branch: MAIN
CVS Tags: perl-CGI-FormMagick-0_93-1_el6_sme
Changes since 1.1: +2 -1 lines
Fix buildrequires

1 slords 1.2 # $Id: perl-CGI-FormMagick.spec,v 1.1 2013/01/25 17:39:33 slords Exp $
2 slords 1.1
3     Summary: CGI-FormMagick module for perl
4     %define name perl-CGI-FormMagick
5     %define version 0.93
6     %define release 1
7     Name: %{name}
8     Version: %{version}
9     Release: %{release}%{?dist}
10     License: distributable
11     Group: Applications/CPAN
12     Source0: %{name}-%{version}.tar.xz
13     Url: http://www.cpan.org
14     BuildRoot: /var/tmp/perl-CGI-FormMagick-buildroot/
15     BuildArchitectures: noarch
16     BuildRequires: perl
17 slords 1.2 BuildRequires: perl(ExtUtils::MakeMaker)
18 slords 1.1 Requires: perl perl(XML::Parser) expat
19     Requires: perl(CGI::Persistent) >= 1.00
20     Requires: perl(Class::ParamParser) perl(I18N::LangTags)
21     Requires: perl(Text::Iconv)
22     Requires: perl(Text::Template)
23     Requires: perl(Mail::RFC822::Address)
24     Provides: perl(ArbitraryPackage)
25     Provides: perl(CGI::FormMagick) = %{version}-%{release}
26     Provides: perl(CGI::FormMagick::Sub)
27     Provides: perl(CGI::FormMagick::TagMaker) = 1.01
28     Provides: perl(CGI::FormMagick::Validator)
29     Autoreq: no
30    
31     %description
32     FormMagick is a Perl module which enables XML descriptions to be used
33     to generate HTML wizard-like forms. It has support for I18N/L10N.
34    
35     %prep
36     %setup -q
37    
38     %build
39     grep -rsl '^#!.*perl' . |
40     grep -v '.bak$' |xargs --no-run-if-empty \
41     %__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
42     CFLAGS="$RPM_OPT_FLAGS"
43     %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '`
44     %{__make}
45    
46     %clean
47     rm -rf $RPM_BUILD_ROOT
48    
49     %install
50     [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
51    
52     %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '` INSTALLDIRS=vendor
53    
54     [ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
55    
56     # remove special files
57     find %{buildroot} -name "perllocal.pod" \
58     -o -name ".packlist" \
59     -o -name "*.bs" \
60     |xargs -i rm -f {}
61    
62     # no empty directories
63     find %{buildroot}%{_prefix} \
64     -type d -depth \
65     -exec rmdir {} \; 2>/dev/null
66    
67     find $RPM_BUILD_ROOT/usr -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" | grep -v perllocal.pod > CGI-FormMagick-%{version}-filelist
68    
69     %files -f CGI-FormMagick-%{version}-filelist
70     %defattr(-,root,root)
71    
72     %changelog
73     * Fri Jan 25 2013 Shad L. Lords <slords@mail.com> 0.93-1
74     - Roll new stream for sme9
75    
76     * Sat Mar 5 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 0.92-21
77     - Fix IP address validation [SME: 6446]
78    
79     * Fri Mar 4 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 0.92-20
80     - Fix IP address validation [SME: 6446]
81    
82     * Wed Mar 2 2011 Jonathan Martens <smeserver-contribs@snetram.nl> 0.92-19
83     - Fix IP address validation [SME: 6446]
84    
85     * Tue Nov 24 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 0.92-18
86     - Fix year in previous changelog entry [SME: 3144]
87    
88     * Tue Nov 24 2009 Jonathan Martens <smeserver-contribs@snetram.nl> 0.92-17
89     - Fix unitialized value errors in HTML.pm [SME: 3144]
90    
91     * Mon Mar 24 2008 Shad L. Lords <slords@mail.com> 0.92-16
92     - Fix patch so .orig files aren't created. [SME: 4100]
93    
94     * Mon Mar 10 2008 Shad L. Lords <slords@mail.com> 0.92-15
95     - Output charset header defining correct charset. [SME: 3858]
96    
97     * Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-14
98     - Add path to sanitized .id parameter so tokens get created
99     in right place [SME: 3584]
100    
101     * Sat Nov 24 2007 Charlie Brady <charlieb@e-smith.com> 0.92-13
102     - Sanitise .id parameter before use. [SME: 3584]
103    
104     * Sat Nov 24 2007 Shad L. Lords <slords@mail.com> 0.92-12
105     - Make modules compatible with CGI::Persistent v1.00 [SME: 3581]
106    
107     * Tue Jun 12 2007 Shad L. Lords <slords@mail.com> 0.92-11
108     - Don't attempt to trim empty/undefined fields [SME: 2395]
109    
110     * Mon Jun 11 2007 Shad L. Lords <slords@mail.com> 0.92-10
111     - Don't validate literal fields [SME: 2395]
112    
113     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
114     - Clean up spec so package can be built by koji/plague
115    
116     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
117     - Update to new release naming. No functional changes.
118     - Make Packager generic
119    
120     * Tue Aug 22 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-08
121     - Allow initializer of textarea form widgets. [SME: 1088]
122    
123     * Mon May 01 2006 Charlie Brady <charlie_brady@mitel.com> 0.92-07
124     - Fix quoting of metachars in subst during inputbox output. [SME: 1352]
125    
126     * Wed Jan 25 2006 Mark Knox <mark_knox@mitel.com> 0.92-06
127     - Added a missing brace in previous fix [SME: 463]
128    
129     * Fri Jan 13 2006 Charlie Brady <charlieb@e-smith.com> 0.92-05
130     - Fix password validation check to include _ as non-alpha. [SME: 463]
131    
132     * Thu Dec 15 2005 Charlie Brady <charlieb@e-smith.com> 0.92-04
133     - Build into /usr/lib/perl5/site_perl so that RPM can be installed
134     on either 6.x or 7.x.
135    
136     * Wed Nov 30 2005 Gordon Rowell <gordonr@gormand.com.au> 0.92-03
137     - Bump release number only
138    
139     * Tue Nov 29 2005 Charlie Brady <charlieb@e-smith.com>
140     - [0.92-02]
141     - Test rebuild after CVS synchronisation.
142    
143     * Mon Oct 31 2005 Mark Knox <mark_knox@mitel.com>
144     - [0.92-01]
145     - Imported to ClearCase, bumped version [markk MN00103900]
146     - Remove generated files Makefile and t/embedded*
147     - Add BuildRequires: perl => 5.8
148    
149     * Thu Oct 27 2005 Charlie Brady <charlieb@e-smith.com>
150     - [0.91-30]
151     - Avoid warning messages if we try to trim whitespace around $field->{id} when
152     it isn't defined. [SF: 1227604]
153    
154     * Mon Oct 3 2005 Charlie Brady <charlieb@e-smith.com>
155     - [0.91-29]
156     - Fix colspan attributes in display_fields(). [SF: 1309359]
157    
158     * Mon Sep 5 2005 Tony Clayton <apc@e-smith.com>
159     - [0.91-28]
160     - s/Copyright/License/ in rpm headers
161     - Fix subroutine element handling in Validator.pm to fix barrage of logfile
162     warnings
163     - Move sessiondir,cgi object initialization from display() to new()
164     - Remove deprecated sessiondir(),munge_fm_obj() methods
165    
166     * Tue Jul 19 2005 Charlie Brady <charlieb@e-smith.com>
167     - [0.91-27]
168     - Validation fixes from Shad Lords:
169     - Change static strings to TAGS (for L10N)
170     - Fix ip_check to actually check value
171     - Update Provides header to specify version and release
172    
173     * Tue May 24 2005 Charlie Brady <charlieb@e-smith.com>
174     - [0.91-26]
175     - Don't allow rpm to auto calculate perl module dependencies -
176     it gets them wrong sometimes [SF: 1205965]
177    
178     * Fri May 20 2005 Charlie Brady <charlieb@e-smith.com>
179     - [0.91-25]
180     - Apply options parsing fix (from Gordon, SF:1205448)
181    
182     * Tue May 17 2005 Charlie Brady <charlieb@e-smith.com>
183     - [0.91-24]
184     - Remove POD references to unimplemented validation-error-message.
185    
186     * Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com>
187     - [0.91-23]
188     - Add patch contributed by Shad Lords to allow multi-select.
189    
190     * Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com>
191     - [0.91-22]
192     - Add patch contributed by Shad Lords to be more flexible about
193     whitespace in validator lists.
194    
195     * Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com>
196     - [0.91-21]
197     - Make sure we don't leave unpackaged files in our buildroot.
198    
199     * Tue Mar 29 2005 Charlie Brady <charlieb@e-smith.com>
200     - [0.91-20]
201     - Update build and install sections, to allow correct building under CentOS.
202    
203     * Wed Oct 20 2004 Sean Bradbury <bradbury@e-smith.com>
204     - [0.91-19]
205     - Updated requires to remove wrong requires. [bradbury MN00053465]
206    
207     * Tue Sep 28 2004 Michael Soulier <msoulier@e-smith.com>
208     - [0.91-18]
209     - Updated requires with new perl dependencies. [msoulier MN00040240]
210     - Added additional headers to ensure no caching. [msoulier MN00044704]
211    
212     * Fri Sep 3 2004 Michael Soulier <msoulier@e-smith.com>
213     - [0.91-17]
214     - Updated requires with new perl dependencies. [msoulier MN00040240]
215     - Fixed http header to include expiry to prevent browser caching.
216     [msoulier MN00044704]
217    
218     * Sat Aug 21 2004 Michael Soulier <msoulier@e-smith.com>
219     - [0.91-16]
220     - Fixed poor subroutine detection in get_sub(). [msoulier MN00037832]
221    
222     * Tue Aug 3 2004 Michael Soulier <msoulier@e-smith.com>
223     - [0.91-15]
224     - Added an automatic trim of leading and trailing whitespace for all field
225     params during validation, unless a new field attribute of "notrim" evals to
226     true. [msoulier MN00042751]
227    
228     * Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com>
229     - [0.91-14]
230     - Added conditional widgets to FormMagick. fields now support a "display"
231     callback, which, if false, prevents the field from being displayed or
232     validated. [msoulier MN00037809]
233    
234     * Thu Jul 15 2004 Michael Soulier <msoulier@e-smith.com>
235     - [0.91-13]
236     - Updated use of CGI::FormMagick::Sub, such that a calling package is no
237     longer required. The object will be searched for methods by default.
238     [msoulier MN00037832]
239    
240     * Wed Jul 14 2004 Michael Soulier <msoulier@e-smith.com>
241     - [0.91-12]
242     - Catch cases where non-existant subroutines are called, and throw a fatal
243     exception with a backtrace. [msoulier MN00042272]
244    
245     * Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com>
246     - [0.91-11]
247     - s/novalidate/nopost, and also prevented the post-event from running if
248     nopost is set. [msoulier MN00040161]
249    
250     * Tue Jul 13 2004 Michael Soulier <msoulier@e-smith.com>
251     - [0.91-10]
252     - Added novalidate method, and a hook to it in prepare_for_next_page, so
253     setting a novalidate param will prevent the current page from being
254     validated. Useful for navigational links. [msoulier MN00040161]
255    
256     * Mon May 10 2004 Michael Soulier <msoulier@e-smith.com>
257     - [0.91-09]
258     - Forward-port of dcr-30134, adding the menu attribute to the page tag.
259     [msoulier MN00030134]
260    
261     * Wed Jan 28 2004 Michael Soulier <msoulier@e-smith.com>
262     - [0.91-08]
263     - Fixed weak pattern matching in CGI::FormMagick::Validator::Basic::number.
264     [msoulier 9039]
265    
266     * Mon Jan 5 2004 Michael Soulier <msoulier@e-smith.com>
267     - [0.91-07]
268     - Fixed bad enctype in forms definition. [msoulier 10699]
269    
270     * Wed Nov 19 2003 Michael Soulier <msoulier@e-smith.com>
271     - [0.91-06]
272     - Rolled back change in 0.91-03, as it broke the ibays panel. [msoulier 9404]
273    
274     * Wed Oct 22 2003 Michael Soulier <msoulier@e-smith.com>
275     - [0.91-05]
276     - Updated get_lexicon to merge available language lexicon in reverse order to
277     the preferred languages, so the fallback languages work when the primary is
278     not available. [msoulier 10397]
279    
280     * Fri Sep 5 2003 Tony Clayton <apc@e-smith.com>
281     - [0.91-04]
282     - Added munge_fm_obj() hook to FormMagick.pm [tonyc 9924]
283    
284     * Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com>
285     - [0.91-03]
286     - Moved the parse_xml() call, and the CGI::Persistent object creation, to the
287     constructor where they belong. [msoulier 9404]
288    
289     * Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com>
290     - [0.91-02]
291     - Fixed bug in handling of literal widgets. [msoulier 8671]
292    
293     * Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com>
294     - [0.91-01]
295     - rolling to dev stream - 0.91
296    
297     * Wed Sep 3 2003 Michael Soulier <msoulier@e-smith.com>
298     - [0.90-01]
299     - rolling to stable stream - 0.90
300    
301     * Tue Jun 24 2003 Tony Clayton <apc@e-smith.com>
302     - [0.89-06]
303     - Fix TagMaker to allow input fields with value="0" [tonyc 9134]
304    
305     * Tue May 6 2003 Michael Soulier <msoulier@e-smith.com>
306     - [0.89-05]
307     - Fixed bad handling of literal widgets. [msoulier 8671]
308    
309     * Tue May 6 2003 Michael Soulier <msoulier@e-smith.com>
310     - [0.89-04]
311     - Fixed position of the skip_header check so that it's after the establishment
312     of the page number. Otherwise, the page number defaults and the wrong
313     post-event is executed. [msoulier 8637]
314    
315     * Fri May 2 2003 Michael Soulier <msoulier@e-smith.com>
316     - [0.89-03]
317     - Added support for a skip_header parameter, to force the display method to
318     give complete control over the HTTP response to the post-event.
319     [msoulier 8637]
320    
321     * Thu Feb 20 2003 Mark Knox <markk@e-smith.com>
322     - [0.89-02]
323     - Allow for dynamic field types using a subroutine call [markk 6735]
324    
325     * Wed Feb 05 2003 Mark Knox <m_knox@mitel.com>
326     - [0.89-01]
327     - Changed author details in Makefile.PL.
328     - Rolled to v0.89
329    
330     * Wed Feb 05 2003 Mark Knox <m_knox@mitel.com>
331     - [0.88-01]
332     - Rolled up changes from 0.87-01 to 0.87-14es into 0.88 and released to
333     SourceForge & CPAN
334    
335     * Sat Jan 25 2003 Mike Dickson <miked@e-smith.com>
336     - [0.87-15es]
337     - removed debugging statements from HTML.pm [miked 6617]
338    
339     * Tue Jan 14 2003 Mark Knox <markk@e-smith.com>
340     - [0.87-14es]
341     - Changed DTD and input field sub to allow "rows" and "cols" args on
342     textarea fields, removed size arg on same. [markk 3620]
343    
344     * Fri Dec 27 2002 Mike Dickson <miked@e-smith.com>
345     - [0.87-13es]
346     - removed debugging comments [miked 5494]
347    
348     * Mon Dec 16 2002 Mike Dickson <miked@e-smith.com>
349     - [0.87-12es]
350     - ui updates [miked 5494]
351    
352     * Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com>
353     - [0.87-11es]
354     - Forgot the dependency on the new module. [msoulier 3388]
355    
356     * Tue Dec 10 2002 Michael Soulier <msoulier@e-smith.com>
357     - [0.87-10es]
358     - Tightened the check in email_simple() by adding use of the
359     Mail::RFC822::Address module. [msoulier 3388]
360    
361     * Mon Dec 2 2002 Mike Dickson <miked@e-smith.com>
362     - [0.87-09es]
363     - ui update [miked 5494]
364    
365     * Fri Nov 22 2002 Mike Dickson <miked@e-smith.com>
366     - [0.87-08es]
367     - update to use new UI elements [miked 5806]
368    
369     * Fri Nov 22 2002 Gordon Rowell <gordonr@e-smith.com>
370     - [0.87-07es]
371     - Re-import from latest SRPM so it looks like a cvs2rpm package [gordonr 5806]
372    
373     * Thu Oct 03 2002 Mark Knox <markk@e-smith.com>
374     - [0.87-06es]
375     - Removed a stray line from a previous patch that was causing breakage
376     [markk 4423]
377    
378     * Mon Sep 30 2002 Mark Knox <markk@e-smith.com>
379     - [0.87-05es]
380     - Improved blank-trimming regexes [markk 4423]
381    
382     * Wed Aug 28 2002 Mark Knox <markk@e-smith.com>
383     - [0.87-04es]
384     - Move blank trimming code inside conditional to eliminate warnings [markk
385     4607]
386    
387     * Fri Aug 16 2002 Mark Knox <markk@e-smith.com>
388     - [0.87-03es]
389     - Security fix: do not pass full path on session token filename [markk 4652]
390    
391     * Mon Jul 22 2002 Mark Knox <markk@e-smith.com>
392     - [0.87-02es]
393     - Patch to trim blank space from start/end of translations [markk 4423]
394    
395     * Mon Jul 22 2002 Mark Knox <markk@e-smith.com>
396     - [0.87-01es]
397     - Added "es" suffix. First local build (same as 0.87-01) [markk 4422]
398    
399     * Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com>
400     - [0.87-01]
401     - Fixed a minor HTML bug (missing > symbol) which was causing problems
402     with the output of validation error messages. [skud 3807]
403    
404     * Mon Jun 24 2002 Kirrily Robert <skud@e-smith.com>
405     - [0.86]
406     - Added get_validation_attribute() routine to make it possible to do the
407     nopipes validation forcing in esmith::FormMagick [skud 3807]
408    
409     * Sun Jun 02 2002 Gordon Rowell <gordonr@e-smith.com>
410     - Place the "nopipes" validator before all others. We never want to
411     allow pipes in fields for e-smith databases. This may be able to
412     be done at the esmith::FormMagick level, but this works for now.
413     [gordonr 3752]
414    
415     * Wed May 29 2002 Kirrily Robert <skud@e-smith.com>
416     - [0.85-01]
417     - Fixed charset bug for text fields that come from subroutines [skud
418     3677]
419    
420     * Thu May 16 2002 Kirrily Robert <skud@e-smith.com>
421     - [0.84-02]
422     - Messed it up, had to repackage. [skud #3390]
423    
424     * Thu May 16 2002 Kirrily Robert <skud@e-smith.com>
425     - [0.84-01]
426     - Fixed select box charset problem [skud #3390]
427    
428     * Mon May 13 2002 Kirrily Robert <skud@e-smith.com>
429     - [0.83-01]
430     - Various minor bugfixes etc [skud #3339, #3371, #3390, #3405]
431    
432     * Tue May 07 2002 Kirrily Robert <skud@e-smith.com>
433     - [0.82-02]
434     - Added dependency on Text::Template 1.40 or higher [skud #3371]
435    
436     * Tue May 07 2002 Kirrily Robert <skud@e-smith.com>
437     - [0.82-01]
438     - Fixed up various warnings that were thrown to the httpd error log.
439     [skud #3278, #3358]
440     - Templated form headers/footers are now untainted automatically.
441     [skud #3371]
442    
443     * Fri May 03 2002 Kirrily Robert <skud@e-smith.com>
444     - [0.81-02]
445     - Added dependency for Text::Iconv
446    
447     * Wed May 01 2002 Kirrily Robert <skud@e-smith.com>
448     - [0.81-01]
449     - Now fails more gracefully on XML errors, dumping the XML to a file in
450     /tmp as a side effect
451     - You can now specify the default XML character set encoding as an
452     argument to new() (defaults to undef). In future versions this should
453     be changed to work on a per-lexicon basis, but for now we will use this
454     stopgap measure.
455     - Fixed a bug which was causing fallback_language not to work.
456    
457     * Fri Apr 12 2002 Kirrily Robert <skud@e-smith.com>
458     - [0.80-01]
459     - langtags are now all smashed to lower case
460    
461     * Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com>
462     - [0.79-01]
463     - Updating to release 0.79.
464    
465     * Thu Apr 04 2002 Kirrily Robert <skud@e-smith.com>
466     - [0.78-01]
467     - Updating to release 0.78.
468    
469     * Wed Apr 03 2002 Kirrily Robert <skud@e-smith.com>
470     - [0.77-01]
471     - Updating to release 0.77.
472    
473     * Wed Mar 20 2002 Kirrily Robert <skud@e-smith.com>
474     - [0.75-01]
475     - Updating to release 0.75.
476    
477     * Wed Mar 14 2002 Gordon Rowell <gordonr@e-smith.com>
478     - [0.70-02]
479     - Removed use for Locale::Maketext, pending new cvs tarball from
480     SourceForge (which is down ATM)
481    
482     * Wed Feb 20 2002 Adrian Chung <adrianc@e-smith.com>
483     - [0.70-01]
484     - Updating to release 0.70.
485    
486     * Thu Feb 07 2002 Adrian Chung <adrianc@e-smith.com>
487     - [0.60-01]
488     - Updated to 0.60.
489    
490     * Wed Jan 23 2002 Adrian Chung <adrianc@e-smith.com>
491     - [0.50-01]
492     - Updated to 0.50.
493    
494     * Wed Dec 19 2001 Gordon Rowell <gordonr@e-smith.com>
495     - [0.49-03]
496     - Updated with skud's tarball of the day
497    
498     * Mon Dec 17 2001 Gordon Rowell <gordonr@e-smith.com>
499     - [0.49-02]
500     - Added dependencies for the swag of modules required. These should
501     probably be listed in the CPAN module instead
502    
503     * Mon Oct 01 2001 charlieb <charlieb@lamington>
504     - Spec file automatically generated by cpan2rpm

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed