1 |
slords |
1.1 |
# |
2 |
|
|
# - CGI::Persistent - |
3 |
|
|
# This spec file was automatically generated by cpan2rpm [ver: 2.026] |
4 |
|
|
# The following arguments were used: |
5 |
|
|
# --release=1centos CGI::Persistent |
6 |
|
|
# For more information on cpan2rpm please visit: http://perl.arix.com/ |
7 |
|
|
# |
8 |
|
|
%define pkgname CGI-Persistent |
9 |
|
|
%define filelist %{pkgname}-%{version}-filelist |
10 |
|
|
%define NVR %{pkgname}-%{version}-%{release} |
11 |
|
|
%define maketest 1 |
12 |
|
|
|
13 |
|
|
name: perl-CGI-Persistent |
14 |
|
|
summary: CGI-Persistent - - Transparent state persistence for CGI applications. |
15 |
|
|
version: 0.22 |
16 |
|
|
release: 8%{?dist} |
17 |
|
|
license: Artistic |
18 |
|
|
group: Applications/CPAN |
19 |
|
|
url: http://www.cpan.org |
20 |
|
|
buildroot: %{_tmppath}/%{name}-%{version}-%(id -u -n) |
21 |
|
|
buildarch: noarch |
22 |
|
|
prefix: %(echo %{_prefix}) |
23 |
|
|
source: http://search.cpan.org/dist/V/VI/VIPUL/CGI-Persistent-0.22.tar.gz |
24 |
|
|
Patch0: perl-CGI-Persistent-0.22-patch.2002051500 |
25 |
|
|
Patch1: perl-CGI-Persistent-0.22.patch.2002081600 |
26 |
|
|
Patch2: perl-CGI-Persistent-0.22.patch.2002090400 |
27 |
|
|
Patch3: perl-CGI-Persistent-0.22.patch.2004111101 |
28 |
|
|
Patch4: perl-CGI-Persistent-0.22-patch.stringify |
29 |
|
|
Patch5: perl-CGI-Persistent-0.22-fileparse.patch |
30 |
|
|
Requires: perl |
31 |
|
|
BuildRequires: perl(Persistence::Object::Simple) |
32 |
|
|
|
33 |
|
|
%description |
34 |
|
|
This is a perl module, autogenerated by cpan2rpm. The original package's |
35 |
|
|
description was: |
36 |
|
|
|
37 |
|
|
Transparent State Persistence in CGI scripts |
38 |
|
|
|
39 |
|
|
use CGI::Persistent; |
40 |
|
|
|
41 |
|
|
my $cgi = new CGI::Persistent "/directory"; |
42 |
|
|
print $cgi->header (); |
43 |
|
|
my $url = $cgi->state_url (); |
44 |
|
|
print "<a href=$url>I am a persistent CGI session.</a>"; |
45 |
|
|
|
46 |
|
|
%prep |
47 |
|
|
%setup -q -n CGI-Persistent-%{version} |
48 |
|
|
%patch0 -p1 |
49 |
|
|
%patch1 -p1 |
50 |
|
|
%patch2 -p1 |
51 |
|
|
%patch3 -p0 |
52 |
|
|
%patch4 -p1 |
53 |
|
|
%patch5 -p1 |
54 |
|
|
|
55 |
|
|
%build |
56 |
|
|
grep -rsl '^#!.*perl' . | |
57 |
|
|
grep -v '.bak$' |xargs --no-run-if-empty \ |
58 |
|
|
%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' |
59 |
|
|
CFLAGS="$RPM_OPT_FLAGS" |
60 |
|
|
%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` |
61 |
|
|
%{__make} |
62 |
|
|
%if %maketest |
63 |
|
|
%{__make} test |
64 |
|
|
%endif |
65 |
|
|
|
66 |
|
|
%install |
67 |
|
|
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
68 |
|
|
|
69 |
|
|
%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '` |
70 |
|
|
|
71 |
|
|
[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress |
72 |
|
|
|
73 |
|
|
# SuSE Linux |
74 |
|
|
if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ] |
75 |
|
|
then |
76 |
|
|
%{__mkdir_p} %{buildroot}/var/adm/perl-modules |
77 |
|
|
%{__cat} `find %{buildroot} -name "perllocal.pod"` \ |
78 |
|
|
| %{__sed} -e s+%{buildroot}++g \ |
79 |
|
|
> %{buildroot}/var/adm/perl-modules/%{name} |
80 |
|
|
fi |
81 |
|
|
|
82 |
|
|
# remove special files |
83 |
|
|
find %{buildroot} -name "perllocal.pod" \ |
84 |
|
|
-o -name ".packlist" \ |
85 |
|
|
-o -name "*.bs" \ |
86 |
|
|
|xargs -i rm -f {} |
87 |
|
|
|
88 |
|
|
# no empty directories |
89 |
|
|
find %{buildroot}%{_prefix} \ |
90 |
|
|
-type d -depth \ |
91 |
|
|
-exec rmdir {} \; 2>/dev/null |
92 |
|
|
|
93 |
|
|
%{__perl} -MFile::Find -le ' |
94 |
|
|
find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}"); |
95 |
|
|
print "%doc html"; |
96 |
|
|
for my $x (sort @dirs, @files) { |
97 |
|
|
push @ret, $x unless indirs($x); |
98 |
|
|
} |
99 |
|
|
print join "\n", sort @ret; |
100 |
|
|
|
101 |
|
|
sub wanted { |
102 |
|
|
return if /auto$/; |
103 |
|
|
|
104 |
|
|
local $_ = $File::Find::name; |
105 |
|
|
my $f = $_; s|^\Q%{buildroot}\E||; |
106 |
|
|
return unless length; |
107 |
|
|
return $files[@files] = $_ if -f $f; |
108 |
|
|
|
109 |
|
|
$d = $_; |
110 |
|
|
/\Q$d\E/ && return for reverse sort @INC; |
111 |
|
|
$d =~ /\Q$_\E/ && return |
112 |
|
|
for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|; |
113 |
|
|
|
114 |
|
|
$dirs[@dirs] = $_; |
115 |
|
|
} |
116 |
|
|
|
117 |
|
|
sub indirs { |
118 |
|
|
my $x = shift; |
119 |
|
|
$x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs; |
120 |
|
|
} |
121 |
|
|
' > %filelist |
122 |
|
|
|
123 |
|
|
[ -z %filelist ] && { |
124 |
|
|
echo "ERROR: empty %files listing" |
125 |
|
|
exit -1 |
126 |
|
|
} |
127 |
|
|
|
128 |
|
|
%clean |
129 |
|
|
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
130 |
|
|
|
131 |
|
|
%files -f %filelist |
132 |
|
|
%defattr(-,root,root) |
133 |
|
|
|
134 |
|
|
%changelog |
135 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
136 |
|
|
- Clean up spec so package can be built by koji/plague |
137 |
|
|
|
138 |
|
|
* Tue Feb 13 2007 Charlie Brady <charlie_brady@mitel.com> |
139 |
|
|
- Avoid portability problem with File::Basename::basename. [SME: 2472] |
140 |
|
|
|
141 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
142 |
|
|
- Update to new release naming. No functional changes. |
143 |
|
|
- Make Packager generic |
144 |
|
|
|
145 |
|
|
* Wed Sep 13 2006 Michael Soulier <msoulier@digitaltorque.ca> 0.22-6es01 |
146 |
|
|
- Added stringify of cgi params as black magic workaround to undetermined |
147 |
|
|
crash in Data::Dumper::Dumpxs. [sme 1837] |
148 |
|
|
|
149 |
|
|
* Thu Nov 11 2004 Charlie Brady <charlieb@e-smith.com> 0.22-6 |
150 |
|
|
- Gracefully handle missing $id arg in constructor. |
151 |
|
|
|
152 |
|
|
* Mon Sep 27 2004 Charlie Brady <charlieb@e-smith.com> |
153 |
|
|
- [0.22-5] |
154 |
|
|
- Replace deprecated Copyright header with License header. |
155 |
|
|
- Use new cpan2rpm template for build and install sections, for compatibility |
156 |
|
|
with later perl/rpm. |
157 |
|
|
- Roll release number for new CentOS build. |
158 |
|
|
|
159 |
|
|
* Wed Sep 04 2002 Mark Knox <markk@e-smith.com> |
160 |
|
|
- [0.22-4] |
161 |
|
|
- Better handling of session directory to eliminate some warnings [markk 4768] |
162 |
|
|
|
163 |
|
|
* Fri Aug 16 2002 Mark Knox <markk@e-smith.com> |
164 |
|
|
- [0.22-3] |
165 |
|
|
- Changed to not use full paths in .id field, and to store session directory |
166 |
|
|
from new() [markk 4652] |
167 |
|
|
|
168 |
|
|
* Wed May 15 2002 Kirrily Robert <skud@e-smith.com> |
169 |
|
|
- [0.22-2] |
170 |
|
|
- Added no-xhtml pragma to 'use CGI' to avoid l10n weirdness [skud 3390] |
171 |
|
|
|
172 |
|
|
* Mon Feb 18 2002 charlieb <charlieb@lamington> |
173 |
|
|
- Spec file automatically generated by cpan2rpm |