1 |
slords |
1.2 |
# $Id: perl-CGI-Persistent.spec,v 1.1 2007/11/25 23:18:30 slords Exp $ |
2 |
slords |
1.1 |
# Authority: dag |
3 |
|
|
# Upstream: Vipul Ved Prakash <mail$vipul,net> |
4 |
|
|
|
5 |
|
|
%define perl_vendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib) |
6 |
|
|
%define perl_vendorarch %(eval "`%{__perl} -V:installvendorarch`"; echo $installvendorarch) |
7 |
|
|
|
8 |
|
|
%define real_name CGI-Persistent |
9 |
|
|
|
10 |
|
|
Summary: Transparent state persistence for CGI applications |
11 |
|
|
Name: perl-CGI-Persistent |
12 |
|
|
Version: 1.00 |
13 |
|
|
Release: 2.0.1%{dist} |
14 |
|
|
License: Artistic/GPL |
15 |
|
|
Group: Applications/CPAN |
16 |
|
|
URL: http://search.cpan.org/dist/CGI-Persistent/ |
17 |
|
|
|
18 |
|
|
Packager: Dag Wieers <dag@wieers.com> |
19 |
|
|
Vendor: Dag Apt Repository, http://dag.wieers.com/apt/ |
20 |
|
|
|
21 |
|
|
Source: http://www.cpan.org/modules/by-module/CGI/CGI-Persistent-%{version}.tar.gz |
22 |
|
|
Patch0: perl-CGI-Persistent-1.00-relpath.patch |
23 |
|
|
Patch1: perl-CGI-Persistent-1.00-relpath.patch2 |
24 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root |
25 |
|
|
|
26 |
|
|
BuildArch: noarch |
27 |
|
|
BuildRequires: perl |
28 |
|
|
|
29 |
|
|
%description |
30 |
|
|
Transparent state persistence for CGI applications. |
31 |
|
|
|
32 |
|
|
%prep |
33 |
|
|
%setup -n %{real_name}-%{version} |
34 |
|
|
%patch0 -p1 |
35 |
|
|
%patch1 -p1 |
36 |
|
|
|
37 |
|
|
%build |
38 |
|
|
%{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}" |
39 |
|
|
%{__make} %{?_smp_mflags} |
40 |
|
|
|
41 |
|
|
%install |
42 |
|
|
%{__rm} -rf %{buildroot} |
43 |
|
|
%{__make} pure_install |
44 |
|
|
|
45 |
|
|
### Clean up buildroot |
46 |
|
|
find %{buildroot} -name .packlist -exec %{__rm} {} \; |
47 |
|
|
|
48 |
|
|
%clean |
49 |
|
|
%{__rm} -rf %{buildroot} |
50 |
|
|
|
51 |
|
|
%files |
52 |
|
|
%defattr(-, root, root, 0755) |
53 |
|
|
%doc MANIFEST META.yml |
54 |
|
|
%doc %{_mandir}/man3/CGI::Persistent.3pm* |
55 |
|
|
%dir %{perl_vendorlib}/CGI/ |
56 |
|
|
#%{perl_vendorlib}/CGI/Persistent/ |
57 |
|
|
%{perl_vendorlib}/CGI/Persistent.pm |
58 |
|
|
|
59 |
|
|
%changelog |
60 |
|
|
* Sun Nov 25 2007 Shad L. Lords <slords@mail.com> - 1.00-2.0.1 |
61 |
|
|
- Added no-xhtml pragma to 'use CGI' to avoid l10n weirdness [skud 3390] |
62 |
|
|
- Changed to not use full paths in .id field, and to store session directory |
63 |
|
|
from new() [markk 4652] |
64 |
|
|
- Better handling of session directory to eliminate some warnings [markk 4768] |
65 |
|
|
- Gracefully handle missing $id arg in constructor. |
66 |
|
|
- Added stringify of cgi params as black magic workaround to undetermined |
67 |
|
|
crash in Data::Dumper::Dumpxs. [sme 1837] |
68 |
|
|
- Avoid portability problem with File::Basename::basename. [SME: 2472] |
69 |
|
|
- Update base package to 1.00, with all SME fixes applied. [SME: 3584] |
70 |
|
|
- Sync with rpmforge package to make pushing update upstream easier. [SME: 3584] |
71 |
|
|
|
72 |
|
|
* Sun Nov 25 2007 Dag Wieers <dag@wieers.com> - 1.00-2 - 6014+/dag |
73 |
|
|
- Added patch to restrict access. (Shad L. Lords) |
74 |
|
|
|
75 |
|
|
* Fri Nov 23 2007 Dag Wieers <dag@wieers.com> - 1.00-1 |
76 |
|
|
- Initial package. (using DAR) |