1 |
vip-ire |
1.1 |
Name: perl-ExtUtils-CBuilder |
2 |
|
|
Version: 0.280224 |
3 |
|
|
Release: 1%{?dist} |
4 |
|
|
Summary: Compile and link C code for Perl modules |
5 |
|
|
License: GPL+ or Artistic |
6 |
|
|
Group: Development/Libraries |
7 |
|
|
URL: http://search.cpan.org/dist/ExtUtils-CBuilder/ |
8 |
|
|
Source0: http://www.cpan.org/authors/id/A/AM/AMBS/ExtUtils-CBuilder-%{version}.tar.gz |
9 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
10 |
|
|
BuildArch: noarch |
11 |
|
|
BuildRequires: perl(Cwd) |
12 |
|
|
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.30 |
13 |
|
|
BuildRequires: perl(File::Spec) >= 3.13 |
14 |
|
|
BuildRequires: perl(File::Temp) |
15 |
|
|
BuildRequires: perl(IPC::Cmd) |
16 |
|
|
BuildRequires: perl(Perl::OSType) >= 1 |
17 |
|
|
BuildRequires: perl(Test::More) >= 0.47 |
18 |
|
|
BuildRequires: perl(Text::ParseWords) |
19 |
|
|
Requires: perl(Cwd) |
20 |
|
|
Requires: perl(ExtUtils::MakeMaker) >= 6.30 |
21 |
|
|
Requires: perl(File::Spec) >= 3.13 |
22 |
|
|
Requires: perl(File::Temp) |
23 |
|
|
Requires: perl(IPC::Cmd) |
24 |
|
|
Requires: perl(Perl::OSType) >= 1 |
25 |
|
|
Requires: perl(Text::ParseWords) |
26 |
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) |
27 |
|
|
|
28 |
|
|
%description |
29 |
|
|
This module can build the C portions of Perl modules by invoking the |
30 |
|
|
appropriate compilers and linkers in a cross-platform manner. It was |
31 |
|
|
motivated by the Module::Build project, but may be useful for other |
32 |
|
|
purposes as well. However, it is not intended as a general cross-platform |
33 |
|
|
interface to all your C building needs. That would have been a much more |
34 |
|
|
ambitious goal! |
35 |
|
|
|
36 |
|
|
%prep |
37 |
|
|
%setup -q -n ExtUtils-CBuilder-%{version} |
38 |
|
|
|
39 |
|
|
%build |
40 |
|
|
%{__perl} Makefile.PL INSTALLDIRS=vendor |
41 |
|
|
make %{?_smp_mflags} |
42 |
|
|
|
43 |
|
|
%install |
44 |
|
|
rm -rf $RPM_BUILD_ROOT |
45 |
|
|
|
46 |
|
|
make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT |
47 |
|
|
|
48 |
|
|
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \; |
49 |
|
|
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \; |
50 |
|
|
|
51 |
|
|
%{_fixperms} $RPM_BUILD_ROOT/* |
52 |
|
|
|
53 |
|
|
%check |
54 |
|
|
make test |
55 |
|
|
|
56 |
|
|
%clean |
57 |
|
|
rm -rf $RPM_BUILD_ROOT |
58 |
|
|
|
59 |
|
|
%files |
60 |
|
|
%defattr(-,root,root,-) |
61 |
|
|
%doc Changes CONTRIBUTING dist.ini LICENSE META.json README README.mkdn README.patching README.release |
62 |
|
|
%{perl_vendorlib}/* |
63 |
|
|
%{_mandir}/man3/* |
64 |
|
|
|
65 |
|
|
%changelog |
66 |
|
|
* Tue Feb 09 2016 Daniel Berteaud <daniel@firewall-services.com> 0.280224-1 |
67 |
|
|
- First build using cpanspec |