1 |
Name: perl-ExtUtils-Constant |
2 |
Version: 0.23 |
3 |
Release: 1%{?dist} |
4 |
Summary: Generate XS code to import C header constants |
5 |
License: CHECK(GPL+ or Artistic) |
6 |
Group: Development/Libraries |
7 |
URL: http://search.cpan.org/dist/ExtUtils-Constant/ |
8 |
Source0: http://www.cpan.org/authors/id/N/NW/NWCLARK/ExtUtils-Constant-%{version}.tar.gz |
9 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
10 |
BuildArch: noarch |
11 |
BuildRequires: perl(ExtUtils::MakeMaker) |
12 |
BuildRequires: /usr/bin/rename |
13 |
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) |
14 |
|
15 |
%description |
16 |
ExtUtils::Constant facilitates generating C and XS wrapper code to allow |
17 |
perl modules to AUTOLOAD constants defined in C library header files. It is |
18 |
principally used by the h2xs utility, on which this code is based. It |
19 |
doesn't contain the routines to scan header files to extract these |
20 |
constants. |
21 |
|
22 |
%prep |
23 |
%setup -q -n ExtUtils-Constant-%{version} |
24 |
|
25 |
%build |
26 |
%{__perl} Makefile.PL INSTALLDIRS=vendor |
27 |
make %{?_smp_mflags} |
28 |
|
29 |
%install |
30 |
rm -rf $RPM_BUILD_ROOT |
31 |
|
32 |
make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT |
33 |
|
34 |
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \; |
35 |
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \; |
36 |
|
37 |
# The man pages conflict with those in the main perl package :-/ |
38 |
/usr/bin/rename .3pm -%{version}.3pm %{buildroot}%{_mandir}/man3/*.3pm |
39 |
|
40 |
%{_fixperms} $RPM_BUILD_ROOT/* |
41 |
|
42 |
%check |
43 |
make test |
44 |
|
45 |
%clean |
46 |
rm -rf $RPM_BUILD_ROOT |
47 |
|
48 |
%files |
49 |
%defattr(-,root,root,-) |
50 |
%doc Changes README |
51 |
%{perl_vendorlib}/* |
52 |
%{_mandir}/man3/* |
53 |
|
54 |
%changelog |
55 |
* Tue Feb 09 2016 Daniel Berteaud <daniel@firewall-services.com> 0.23-1 |
56 |
- First build using cpanspec |