1 |
michel |
1.1 |
Name: perl-Mojo-JWT |
2 |
|
|
Version: 0.08 |
3 |
michel |
1.2 |
Release: 2%{?dist} |
4 |
michel |
1.1 |
Summary: JSON Web Token the Mojo way |
5 |
|
|
License: GPL+ or Artistic |
6 |
|
|
Group: Development/Libraries |
7 |
|
|
URL: http://search.cpan.org/dist/Mojo-JWT/ |
8 |
|
|
Source0: http://www.cpan.org/authors/id/J/JB/JBERGER/Mojo-JWT-%{version}.tar.gz |
9 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
10 |
|
|
BuildArch: noarch |
11 |
|
|
BuildRequires: perl >= 0:5.010 |
12 |
|
|
BuildRequires: perl(Crypt::OpenSSL::RSA) |
13 |
|
|
BuildRequires: perl(Digest::SHA) |
14 |
|
|
BuildRequires: perl(Module::Build) |
15 |
|
|
BuildRequires: perl(Module::Build::Tiny) |
16 |
|
|
BuildRequires: perl(Test::More) |
17 |
|
|
BuildRequires: perl(Mojolicious) >= 5.00 |
18 |
|
|
Requires: perl(Crypt::OpenSSL::RSA) |
19 |
|
|
Requires: perl(Digest::SHA) |
20 |
|
|
Requires: perl(Mojolicious) >= 5.00 |
21 |
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) |
22 |
|
|
|
23 |
|
|
%description |
24 |
|
|
JSON Web Token is described in https://tools.ietf.org/html/rfc7519. |
25 |
|
|
Mojo::JWT implements that standard with an API that should feel familiar to |
26 |
|
|
Mojolicious users (though of course it is useful elsewhere). Indeed, JWT is |
27 |
|
|
much like Mojolicious::Sessions except that the result is a url-safe text |
28 |
|
|
string rather than a cookie. |
29 |
|
|
|
30 |
|
|
%prep |
31 |
|
|
%setup -q -n Mojo-JWT-%{version} |
32 |
|
|
|
33 |
|
|
%build |
34 |
|
|
%{__perl} Build.PL prefix /usr installdirs=vendor |
35 |
|
|
./Build |
36 |
|
|
|
37 |
|
|
%install |
38 |
|
|
rm -rf $RPM_BUILD_ROOT |
39 |
|
|
|
40 |
|
|
##./Build install destdir=$RPM_BUILD_ROOT create_packlist=0 |
41 |
|
|
|
42 |
|
|
./Build install \ |
43 |
|
|
--destdir $RPM_BUILD_ROOT \ |
44 |
|
|
--install_path libdoc=%{_mandir}/man3 |
45 |
|
|
|
46 |
|
|
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \; |
47 |
|
|
#find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \; |
48 |
|
|
|
49 |
|
|
%{_fixperms} $RPM_BUILD_ROOT/* |
50 |
|
|
|
51 |
|
|
%check |
52 |
|
|
./Build test |
53 |
|
|
|
54 |
|
|
%clean |
55 |
|
|
rm -rf $RPM_BUILD_ROOT |
56 |
|
|
|
57 |
|
|
%files |
58 |
|
|
%defattr(-,root,root,-) |
59 |
|
|
%doc Changes cpanfile LICENSE META.json metamerge.json README |
60 |
|
|
/usr/local/share/perl5/* |
61 |
|
|
%{_mandir}/man3/* |
62 |
|
|
|
63 |
|
|
%changelog |
64 |
michel |
1.2 |
* Sat Jun 25 2022 Michel Begue <mab974@misouk.com> 0.08-2 |
65 |
|
|
- fix email |
66 |
|
|
|
67 |
michel |
1.1 |
* Wed Aug 26 2020 Michel Begue <mab974@gmail.com> 0.08-1 |
68 |
|
|
- First build using cpanspec |