1 |
michel |
1.1 |
Name: perl-Mojo-JWT |
2 |
|
|
Version: 0.08 |
3 |
michel |
1.3 |
Release: 3%{?dist} |
4 |
michel |
1.1 |
Summary: JSON Web Token the Mojo way |
5 |
|
|
License: GPL+ or Artistic |
6 |
|
|
Group: Development/Libraries |
7 |
|
|
URL: http://search.cpan.org/dist/Mojo-JWT/ |
8 |
|
|
Source0: http://www.cpan.org/authors/id/J/JB/JBERGER/Mojo-JWT-%{version}.tar.gz |
9 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
10 |
|
|
BuildArch: noarch |
11 |
|
|
BuildRequires: perl >= 0:5.010 |
12 |
|
|
BuildRequires: perl(Crypt::OpenSSL::RSA) |
13 |
|
|
BuildRequires: perl(Digest::SHA) |
14 |
|
|
BuildRequires: perl(Module::Build) |
15 |
|
|
BuildRequires: perl(Module::Build::Tiny) |
16 |
|
|
BuildRequires: perl(Test::More) |
17 |
|
|
BuildRequires: perl(Mojolicious) >= 5.00 |
18 |
|
|
Requires: perl(Crypt::OpenSSL::RSA) |
19 |
|
|
Requires: perl(Digest::SHA) |
20 |
|
|
Requires: perl(Mojolicious) >= 5.00 |
21 |
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) |
22 |
michel |
1.3 |
Provides: perl(Mojo::JWT) |
23 |
michel |
1.1 |
|
24 |
|
|
%description |
25 |
|
|
JSON Web Token is described in https://tools.ietf.org/html/rfc7519. |
26 |
|
|
Mojo::JWT implements that standard with an API that should feel familiar to |
27 |
|
|
Mojolicious users (though of course it is useful elsewhere). Indeed, JWT is |
28 |
|
|
much like Mojolicious::Sessions except that the result is a url-safe text |
29 |
|
|
string rather than a cookie. |
30 |
|
|
|
31 |
|
|
%prep |
32 |
|
|
%setup -q -n Mojo-JWT-%{version} |
33 |
|
|
|
34 |
|
|
%build |
35 |
|
|
%{__perl} Build.PL prefix /usr installdirs=vendor |
36 |
|
|
./Build |
37 |
|
|
|
38 |
|
|
%install |
39 |
|
|
rm -rf $RPM_BUILD_ROOT |
40 |
|
|
|
41 |
|
|
##./Build install destdir=$RPM_BUILD_ROOT create_packlist=0 |
42 |
|
|
|
43 |
|
|
./Build install \ |
44 |
|
|
--destdir $RPM_BUILD_ROOT \ |
45 |
|
|
--install_path libdoc=%{_mandir}/man3 |
46 |
|
|
|
47 |
|
|
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \; |
48 |
|
|
#find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \; |
49 |
|
|
|
50 |
|
|
%{_fixperms} $RPM_BUILD_ROOT/* |
51 |
|
|
|
52 |
|
|
%check |
53 |
|
|
./Build test |
54 |
|
|
|
55 |
|
|
%clean |
56 |
|
|
rm -rf $RPM_BUILD_ROOT |
57 |
|
|
|
58 |
|
|
%files |
59 |
|
|
%defattr(-,root,root,-) |
60 |
|
|
%doc Changes cpanfile LICENSE META.json metamerge.json README |
61 |
|
|
/usr/local/share/perl5/* |
62 |
|
|
%{_mandir}/man3/* |
63 |
|
|
|
64 |
|
|
%changelog |
65 |
michel |
1.3 |
* Sun Jul 31 2022 Michel Begue <mab974@misouk.com> 0.08-3 |
66 |
|
|
- add Provides: perl(Mojo::JWT) |
67 |
|
|
|
68 |
michel |
1.2 |
* Sat Jun 25 2022 Michel Begue <mab974@misouk.com> 0.08-2 |
69 |
|
|
- fix email |
70 |
|
|
|
71 |
michel |
1.1 |
* Wed Aug 26 2020 Michel Begue <mab974@gmail.com> 0.08-1 |
72 |
|
|
- First build using cpanspec |