/[smeserver]/rpms/perl-Mojolicious/sme10/perl-Mojolicious.spec
ViewVC logotype

Annotation of /rpms/perl-Mojolicious/sme10/perl-Mojolicious.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Tue Feb 9 14:28:13 2016 UTC (8 years, 3 months ago) by vip-ire
Branch: MAIN
CVS Tags: perl-Mojolicious-6_44-2_el7_sme, HEAD
Changes since 1.1: +6 -1 lines
* Tue Feb 09 2016 Daniel Berteaud <daniel@firewall-services.com> 6.44-2
- Add perl(JSON::PP) to the BuildReq so it can build on plague
  [SME: 7819]

1 vip-ire 1.1 Name: perl-Mojolicious
2     version: 6.44
3 vip-ire 1.2 Release: 2%{?dist}
4 vip-ire 1.1 Summary: A next generation web framework for Perl
5     License: Artistic 2.0
6     Group: Development/Libraries
7     URL: http://mojolicious.org/
8     Source0: http://www.cpan.org/authors/id/K/KR/KRAIH/Mojolicious-%{version}.tar.gz
9     Patch0: Mojolicious-6.08.untaint.patch
10     Patch1: Mojolicious-6.12.cleanup.patch
11     Patch2: Mojolicious-6.12.cleanup.patch2
12     Patch3: Mojolicious-6.15.cleanup.patch
13     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14     BuildArch: noarch
15     BuildRequires: perl >= 0:5.010001
16     BuildRequires: perl(ExtUtils::MakeMaker)
17     BuildRequires: perl(Test::Builder)
18     BuildRequires: perl(Test::Harness)
19     BuildRequires: perl(Test::More)
20     BuildRequires: perl(Taint::Util)
21     BuildRequires: perl(Pod::Simple) >= 3.09
22     BuildRequires: perl(Time::Local) >= 1.2000
23     BuildRequires: perl(IO::Socket::IP) >= 0.26
24     Requires: perl(IO::Socket::IP) >= 0.26
25     BuildRequires: perl(IO::Compress::Gzip)
26     BuildRequires: perl(Digest::MD5)
27     BuildRequires: perl(Digest::SHA)
28     BuildRequires: perl(Time::HiRes)
29     BuildRequires: perl(Compress::Raw::Zlib)
30     Requires: perl(Taint::Util)
31     BuildRequires: perl(Socket) >= 1.97
32 vip-ire 1.2 BuildRequires: perl(JSON::PP)
33 vip-ire 1.1 Requires: perl(Socket) >= 1.97
34     Requires: perl(IO::Socket::SSL) >= 1.94
35     Requires: perl(Net::DNS::Native) >= 0.15
36     Requires: perl(Pod::Simple) >= 3.09
37     Requires: perl(Time::Local) >= 1.2000
38     Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
39     %define filelist %{pkgname}-%{version}-filelist
40     %define NVR %{pkgname}-%{version}-%{release}
41     %define maketest 1
42     %define custom_find_req %{_tmppath}/%{NVR}-find-requires
43     %define _use_internal_dependency_generator 0
44     %define __find_requires %{custom_find_req}
45     %define __perl_requires %{custom_find_req}
46     %define perl_vendorlib /usr/share/perl5/vendor_perl
47    
48     %description
49     Back in the early days of the web there was this wonderful Perl library
50     called CGI, many people only learned Perl because of it. It was simple
51     enough to get started without knowing much about the language and powerful
52     enough to keep you going, learning by doing was much fun. While most of the
53     techniques used are outdated now, the idea behind it is not. Mojolicious is
54     a new attempt at implementing this idea using state of the art technology.
55    
56     %prep
57     %setup -q -n Mojolicious-%{version} -b 0
58     %patch0 -p1
59     #%patch1 -p2
60     %patch2 -p2
61     %patch3 -p2
62    
63     %build
64     %{__perl} Makefile.PL INSTALLDIRS=vendor INSTALLVENDORLIB=/usr/share/perl5/vendor_perl
65     make %{?_smp_mflags}
66    
67     %install
68     rm -rf $RPM_BUILD_ROOT
69     cat <<EOF > %{custom_find_req}
70     #!/bin/sh
71     /usr/lib/rpm/find-requires |grep -v -e 'feature' -e 'IO::Epoll' -e 'IO::KQueue' -e 'EV'
72     EOF
73     chmod 755 %{custom_find_req}
74    
75     make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
76    
77     find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
78     find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
79    
80     %{_fixperms} $RPM_BUILD_ROOT/*
81    
82     %check
83     make test
84    
85     %clean
86     rm -rf $RPM_BUILD_ROOT
87     rm -f %{custom_find_req}
88    
89     %files
90     %defattr(-,root,root,-)
91     %doc Changes LICENSE examples
92     %{_bindir}/mojo
93     %{_bindir}/morbo
94     %{_bindir}/hypnotoad
95     %{perl_vendorlib}/*
96     %{_mandir}/man1/*
97     %{_mandir}/man3/*
98    
99     %changelog
100 vip-ire 1.2 * Tue Feb 09 2016 Daniel Berteaud <daniel@firewall-services.com> 6.44-2
101     - Add perl(JSON::PP) to the BuildReq so it can build on plague
102     [SME: 7819]
103    
104 vip-ire 1.1 * Mon Feb 08 2016 Charlie Brady <charlie_brady@mitel.com>
105     - Upgrade Mojolicious to 6.44.
106    
107     * Thu Oct 08 2015 Charlie Brady <charlie_brady@mitel.com>
108     - Upgrade Mojolicious to 6.23.
109    
110     * Mon Sep 21 2015 Charlie Brady <charlie_brady@mitel.com>
111     - Upgrade Mojolicious to 6.20.
112    
113     * Mon Aug 24 2015 Charlie Brady <charlie_brady@mitel.com>
114     - Upgrade Mojolicious to 6.17.
115    
116     * Wed Aug 19 2015 Charlie Brady <charlie_brady@mitel.com>
117     - Fix more cleanup warnings.
118     - Fix warning in Mojo::Asset::Memory::move_to.
119    
120     * Tue Aug 18 2015 Charlie Brady <charlie_brady@mitel.com> 6.15-1
121     - Upgrade Mojolicious to 6.15.
122    
123     * Wed Jul 08 2015 Charlie Brady <charlie_brady@mitel.com> 6.12-3
124     - Fix more cleanup warnings.
125    
126     * Tue Jul 07 2015 Charlie Brady <charlie_brady@mitel.com> 6.12-2
127     - Fix bug in Mojo::UserAgent cleanup when Net::DNS::Native is
128     installed.
129    
130     * Tue Jul 07 2015 Charlie Brady <charlie_brady@mitel.com> 6.12-1
131     - Upgrade Mojolicious to 6.12.
132     - Add Requires for recent IO::Socket::SSL and Net::DNS::Native
133    
134     * Tue Jun 23 2015 Charlie Brady <charlie_brady@mitel.com> 6.11-2
135     - Add missing BuildRequires: perl(Socket) >= 1.97.
136    
137     * Wed Jun 10 2015 Charlie Brady <charlie_brady@mitel.com> 6.11-1
138     - Upgrade Mojolicious to 6.11.
139    
140     * Wed Apr 15 2015 Charlie Brady <charlie_brady@mitel.com> 6.08-1
141     - Upgrade Mojolicious to 6.08.
142    
143     * Sat Feb 28 2015 Charlie Brady <charlie_brady@mitel.com> 6.0-1
144     - Upgrade Mojolicious to 6.0.
145     - Remove Mojolicious-Plugin-CSRFProtect.
146    
147     * Thu Oct 16 2014 Charlie Brady <charlie_brady@mitel.com> - 5.50-1
148     - Upgrade Mojolicious to 5.50 (security update). [MN00548037]
149    
150     * Wed Aug 27 2014 Charlie Brady <charlie_brady@mitel.com> - 5.33-1
151     - Upgrade Mojolicious to 5.33. [MN00540216]
152    
153     * Thu Jun 12 2014 Charlie Brady <charlie_brady@mitel.com> - 5.05-2
154     - Remove the patch which downgraded the version requirement of
155     IO::Socket::SSL. [MN00522946].
156    
157     * Mon Jun 09 2014 Charlie Brady <charlie_brady@mitel.com> - 5.05-1
158     - Upgrade Mojolicious to 5.05. [MN00522946]
159    
160     * Fri Apr 25 2014 Charlie Brady <charlie_brady@mitel.com> - 4.94-1
161     - Upgrade Mojolicious to 4.94. [MN00522946]
162    
163     * Mon Mar 31 2014 Charlie Brady <charlie_brady@mitel.com> - 4.91-1
164     - Upgrade Mojolicious to 4.91. [MN00522946]
165    
166     * Fri Oct 25 2013 Charlie Brady <charlie_brady@mitel.com> - 4.50-2
167     - Drop IO::Socket::SSL dependency from 1.75 to 1.44. [MN00504964]
168    
169     * Fri Oct 25 2013 Charlie Brady <charlie_brady@mitel.com> - 4.50-1
170     - Upgrade Mojolicious to 4.50. [MN00500199]
171    
172     * Tue Jul 09 2013 Charlie Brady <charlie_brady@mitel.com> - 4.18-2
173     - Add untaint for eval in Mojo::Template. [MN00480041]
174    
175     * Tue Jul 09 2013 Charlie Brady <charlie_brady@mitel.com> - 4.18-1
176     - Upgrade Mojolicious to 4.18. Not yet taint or SSL friendly. [MN00480041]
177    
178     * Wed May 01 2013 Charlie Brady <charlie_brady@mitel.com> - 3.97-3
179     - Add untaint for eval in Mojo::Template. [MN00480041]
180    
181     * Wed May 01 2013 Charlie Brady <charlie_brady@mitel.com> - 3.97-2
182     - Upgrade Mojolicious-Plugin-CSRFProtect to version 0.13. [MN00480041]
183    
184     * Wed May 01 2013 Charlie Brady <charlie_brady@mitel.com> - 3.97-1
185     - Upgrade Mojolicious to 3.97. Not yet taint or SSL friendly. [MN00480041]
186    
187     * Wed Sep 26 2012 Martin Gillen <martin_gillen@mitel.com> - 3.05-6
188     - Upgrade Mojolicious-Plugin-CSRFProtect to version 0.12. [MN00390742]
189    
190     * Thu Aug 23 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-5
191     - Fix typo in IO::Socket::SSL dependency patch. [MN00443005]
192    
193     * Mon Aug 20 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-4
194     - Update CSRF plugin. [MN00441747]
195    
196     * Tue Aug 14 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-3
197     - Drop IO::Socket::SSL dependency from 1.75 to 1.44. [MN00443005]
198    
199     * Tue Aug 14 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-2
200     - Apply untaint patch.
201    
202     * Wed Jul 11 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-1
203     - Upgrade to latest upstream.
204    
205     * Mon Apr 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.91-1
206     - Upgrade to latest upstream.
207    
208     * Mon Apr 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.49-2
209     - Add CSRFProtect plugin. [MN00396402]
210     - Build into /usr/share/perl5/vendor_perl.
211    
212     * Tue Feb 14 2012 Charlie Brady <charlie_brady@mitel.com> - 2.49-1
213     - Upgrade to latest upstream.
214    
215     * Wed Feb 08 2012 Charlie Brady <charlie_brady@mitel.com> - 2.47-1
216     - Upgrade to latest upstream.
217    
218     * Wed Feb 01 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46-5
219     - Update untaint patch to include untaint of template code when
220     running under -T.
221    
222     * Wed Feb 01 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46-4
223     - Restore use of pre-exising perl-Mojolicious spec file. Re-remove
224     dependency on EV module.
225    
226     * Mon Jan 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46-3
227     - Build into /usr/lib/perl5/vendor_perl.
228    
229     * Mon Jan 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46-2
230     - Apply untaint patch.
231    
232     * Mon Jan 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46
233     - Upgrade to latest upstream.
234    
235     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.69-3
236     - Remove dependency on EV module.
237    
238     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.69-2
239     - Apply patch to permit setuid scripts to run - untaint data.
240    
241     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.69-1
242     - Update to upstream 1.64 - no patches, but do not require
243     IO::Epoll and IO::KQueue modules.
244    
245     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.64-2
246     - Apply patch to permit setuid scripts to run - untaint data.
247    
248     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.64-1
249     - Update to upstream 1.64 - no patches, but do not require
250     IO::Epoll and IO::KQueue modules.
251    
252     * Fri Jul 15 2011 Charlie Brady <charlie_brady@mitel.com> 1.48-2
253     - Ensure that 'perl(feature)' does not appear in dependency list.
254    
255     * Mon Jun 27 2011 Charlie Brady <charlie_brady@mitel.com> 1.48-1
256     - Update to upstream 1.48 - no patches
257    
258     * Thu Apr 21 2011 Charlie Brady <charlie_brady@mitel.com> 1.21-2
259     - Apply patches (taint checking and test fixes.
260    
261     * Thu Apr 21 2011 Charlie Brady <charlie_brady@mitel.com> 1.21-1
262     - Update to upstream 1.21 - no patches
263    
264     * Mon Jan 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.0-2
265     - Backport to perl 5.8.5 (mostly test fixes).
266    
267     * Mon Jan 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.0-1
268     - Latest upstream release.
269    
270     * Sun Dec 12 2010 Charlie Brady <charlie_brady@mitel.com> 0.999950-2
271     - Latest upstream snapshot, includes exception template
272     - https://github.com/kraih/mojo/tree/fba7a4b549d8e247e03f1e3fc6284cd92fafb4a4
273    
274     * Sun Dec 05 2010 Charlie Brady <charlie_brady@mitel.com> 0.999950-1
275     - Latest upstream release.
276     http://search.cpan.org/src/KRAIH/Mojolicious-0.999950/Changes
277    
278     * Sun Nov 21 2010 Charlie Brady <charlieb@budge.apana.org.au> 0.999941-2
279     - Patch around exceptions in taint mode.
280    
281     * Sun Nov 21 2010 Charlie Brady <charlieb@budge.apana.org.au> 0.999941-1
282     - Latest upstream release.
283     http://search.cpan.org/src/KRAIH/Mojolicious-0.999941/Changes
284    
285     * Mon Aug 16 2010 Yanko Kaneti <yaneti@declera.com> 0.999927-1
286     - Latest upstream release.
287     http://search.cpan.org/src/KRAIH/Mojolicious-0.999927/Changes
288    
289     * Tue Jun 22 2010 Petr Pisar <ppisar@redhat.com> 0.999926-2
290     - Rebuild against perl-5.12
291    
292     * Fri Jun 16 2010 Yanko Kaneti <yaneti@declera.com> 0.999926-1
293     - Latest upstream release.
294     http://search.cpan.org/src/KRAIH/Mojolicious-0.999926/Changes
295    
296     * Fri Jun 11 2010 Yanko Kaneti <yaneti@declera.com> 0.999925-3
297     - Actually include the examples.
298    
299     * Fri Jun 11 2010 Yanko Kaneti <yaneti@declera.com> 0.999925-2
300     - Initial import. Include examples as doc.
301    
302     * Tue Jun 08 2010 Yanko Kaneti <yaneti@declera.com> 0.999925-1
303     - Specfile mostly autogenerated by cpanspec 1.78.

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed