/[smeserver]/rpms/perl-Mojolicious/sme9/perl-Mojolicious.spec
ViewVC logotype

Annotation of /rpms/perl-Mojolicious/sme9/perl-Mojolicious.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Tue Apr 15 18:59:10 2014 UTC (10 years, 2 months ago) by slords
Branch: MAIN
CVS Tags: perl-Mojolicious-4_91-1_el6_sme
Changes since 1.1: +4 -1 lines
Fix buildreqs

1 wellsi 1.1 Name: perl-Mojolicious
2     version: 4.91
3     Release: 1%{?dist}
4     Summary: A next generation web framework for Perl
5     License: Artistic 2.0
6     Group: Development/Libraries
7     URL: http://mojolicious.org/
8     Source0: http://www.cpan.org/authors/id/K/KR/KRAIH/Mojolicious-%{version}.tar.gz
9     Patch0: Mojolicious-4.91.untaint.patch
10     Patch1: Mojolicious-4.91.SSL_version.patch
11     %define CSRFProtect_version 0.13
12     Source1: Mojolicious-Plugin-CSRFProtect-%{CSRFProtect_version}.tar.gz
13     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14     BuildArch: noarch
15     BuildRequires: perl >= 0:5.008007
16     BuildRequires: perl(ExtUtils::MakeMaker)
17     BuildRequires: perl(Test::Builder)
18     BuildRequires: perl(Test::Harness)
19     BuildRequires: perl(Test::More)
20     BuildRequires: perl(Taint::Util)
21 slords 1.2 BuildRequires: perl(Compress::Raw::Zlib)
22     BuildRequires: perl(Digest::SHA)
23     BuildRequires: perl(IO::Compress::Gzip)
24     BuildRequires: perl(Time::HiRes)
25 wellsi 1.1 Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
26     %define filelist %{pkgname}-%{version}-filelist
27     %define NVR %{pkgname}-%{version}-%{release}
28     %define maketest 1
29     %define custom_find_req %{_tmppath}/%{NVR}-find-requires
30     %define _use_internal_dependency_generator 0
31     %define __find_requires %{custom_find_req}
32     %define __perl_requires %{custom_find_req}
33     %define perl_vendorlib /usr/share/perl5/vendor_perl
34    
35     %description
36     Back in the early days of the web there was this wonderful Perl library
37     called CGI, many people only learned Perl because of it. It was simple
38     enough to get started without knowing much about the language and powerful
39     enough to keep you going, learning by doing was much fun. While most of the
40     techniques used are outdated now, the idea behind it is not. Mojolicious is
41     a new attempt at implementing this idea using state of the art technology.
42    
43     %prep
44     %setup -q -n Mojolicious-%{version} -b 0 -a 1
45     %patch0 -p1
46     %patch1 -p1
47     mv Mojolicious-Plugin-CSRFProtect-%{CSRFProtect_version}/lib/Mojolicious/Plugin/* lib/Mojolicious/Plugin/
48     rm -rf Mojolicious-Plugin-CSRFProtect-%{CSRFProtect_version}
49    
50     %build
51     %{__perl} Makefile.PL INSTALLDIRS=vendor INSTALLVENDORLIB=/usr/share/perl5/vendor_perl
52     make %{?_smp_mflags}
53    
54     %install
55     rm -rf $RPM_BUILD_ROOT
56     cat <<EOF > %{custom_find_req}
57     #!/bin/sh
58     /usr/lib/rpm/find-requires |grep -v -e 'feature' -e 'IO::Epoll' -e 'IO::KQueue' -e 'EV'
59     EOF
60     chmod 755 %{custom_find_req}
61    
62     make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
63    
64     find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
65     find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
66    
67     %{_fixperms} $RPM_BUILD_ROOT/*
68    
69     %check
70     make test
71    
72     %clean
73     rm -rf $RPM_BUILD_ROOT
74     rm -f %{custom_find_req}
75    
76     %files
77     %defattr(-,root,root,-)
78     %doc Changes LICENSE examples
79     %{_bindir}/mojo
80     %{_bindir}/morbo
81     %{_bindir}/hypnotoad
82     %{perl_vendorlib}/*
83     %{_mandir}/man1/*
84     %{_mandir}/man3/*
85    
86     %changelog
87     * Mon Mar 31 2014 Charlie Brady <charlie_brady@mitel.com> - 4.91-1
88     - Upgrade Mojolicious to 4.91. []
89    
90     * Fri Oct 25 2013 Charlie Brady <charlie_brady@mitel.com> - 4.50-2
91     - Drop IO::Socket::SSL dependency from 1.75 to 1.44. [MN00504964]
92    
93     * Fri Oct 25 2013 Charlie Brady <charlie_brady@mitel.com> - 4.50-1
94     - Upgrade Mojolicious to 4.50. [MN00500199]
95    
96     * Tue Jul 09 2013 Charlie Brady <charlie_brady@mitel.com> - 4.18-2
97     - Add untaint for eval in Mojo::Template. [MN00480041]
98    
99     * Tue Jul 09 2013 Charlie Brady <charlie_brady@mitel.com> - 4.18-1
100     - Upgrade Mojolicious to 4.18. Not yet taint or SSL friendly. [MN00480041]
101    
102     * Wed May 01 2013 Charlie Brady <charlie_brady@mitel.com> - 3.97-3
103     - Add untaint for eval in Mojo::Template. [MN00480041]
104    
105     * Wed May 01 2013 Charlie Brady <charlie_brady@mitel.com> - 3.97-2
106     - Upgrade Mojolicious-Plugin-CSRFProtect to version 0.13. [MN00480041]
107    
108     * Wed May 01 2013 Charlie Brady <charlie_brady@mitel.com> - 3.97-1
109     - Upgrade Mojolicious to 3.97. Not yet taint or SSL friendly. [MN00480041]
110    
111     * Wed Sep 26 2012 Martin Gillen <martin_gillen@mitel.com> - 3.05-6
112     - Upgrade Mojolicious-Plugin-CSRFProtect to version 0.12. [MN00390742]
113    
114     * Thu Aug 23 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-5
115     - Fix typo in IO::Socket::SSL dependency patch. [MN00443005]
116    
117     * Mon Aug 20 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-4
118     - Update CSRF plugin. [MN00441747]
119    
120     * Tue Aug 14 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-3
121     - Drop IO::Socket::SSL dependency from 1.75 to 1.44. [MN00443005]
122    
123     * Tue Aug 14 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-2
124     - Apply untaint patch.
125    
126     * Wed Jul 11 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-1
127     - Upgrade to latest upstream.
128    
129     * Mon Apr 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.91-1
130     - Upgrade to latest upstream.
131    
132     * Mon Apr 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.49-2
133     - Add CSRFProtect plugin. [MN00396402]
134     - Build into /usr/share/perl5/vendor_perl.
135    
136     * Tue Feb 14 2012 Charlie Brady <charlie_brady@mitel.com> - 2.49-1
137     - Upgrade to latest upstream.
138    
139     * Wed Feb 08 2012 Charlie Brady <charlie_brady@mitel.com> - 2.47-1
140     - Upgrade to latest upstream.
141    
142     * Wed Feb 01 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46-5
143     - Update untaint patch to include untaint of template code when
144     running under -T.
145    
146     * Wed Feb 01 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46-4
147     - Restore use of pre-exising perl-Mojolicious spec file. Re-remove
148     dependency on EV module.
149    
150     * Mon Jan 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46-3
151     - Build into /usr/lib/perl5/vendor_perl.
152    
153     * Mon Jan 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46-2
154     - Apply untaint patch.
155    
156     * Mon Jan 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46
157     - Upgrade to latest upstream.
158    
159     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.69-3
160     - Remove dependency on EV module.
161    
162     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.69-2
163     - Apply patch to permit setuid scripts to run - untaint data.
164    
165     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.69-1
166     - Update to upstream 1.64 - no patches, but do not require
167     IO::Epoll and IO::KQueue modules.
168    
169     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.64-2
170     - Apply patch to permit setuid scripts to run - untaint data.
171    
172     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.64-1
173     - Update to upstream 1.64 - no patches, but do not require
174     IO::Epoll and IO::KQueue modules.
175    
176     * Fri Jul 15 2011 Charlie Brady <charlie_brady@mitel.com> 1.48-2
177     - Ensure that 'perl(feature)' does not appear in dependency list.
178    
179     * Mon Jun 27 2011 Charlie Brady <charlie_brady@mitel.com> 1.48-1
180     - Update to upstream 1.48 - no patches
181    
182     * Thu Apr 21 2011 Charlie Brady <charlie_brady@mitel.com> 1.21-2
183     - Apply patches (taint checking and test fixes.
184    
185     * Thu Apr 21 2011 Charlie Brady <charlie_brady@mitel.com> 1.21-1
186     - Update to upstream 1.21 - no patches
187    
188     * Mon Jan 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.0-2
189     - Backport to perl 5.8.5 (mostly test fixes).
190    
191     * Mon Jan 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.0-1
192     - Latest upstream release.
193    
194     * Sun Dec 12 2010 Charlie Brady <charlie_brady@mitel.com> 0.999950-2
195     - Latest upstream snapshot, includes exception template
196     - https://github.com/kraih/mojo/tree/fba7a4b549d8e247e03f1e3fc6284cd92fafb4a4
197    
198     * Sun Dec 05 2010 Charlie Brady <charlie_brady@mitel.com> 0.999950-1
199     - Latest upstream release.
200     http://search.cpan.org/src/KRAIH/Mojolicious-0.999950/Changes
201    
202     * Sun Nov 21 2010 Charlie Brady <charlieb@budge.apana.org.au> 0.999941-2
203     - Patch around exceptions in taint mode.
204    
205     * Sun Nov 21 2010 Charlie Brady <charlieb@budge.apana.org.au> 0.999941-1
206     - Latest upstream release.
207     http://search.cpan.org/src/KRAIH/Mojolicious-0.999941/Changes
208    
209     * Mon Aug 16 2010 Yanko Kaneti <yaneti@declera.com> 0.999927-1
210     - Latest upstream release.
211     http://search.cpan.org/src/KRAIH/Mojolicious-0.999927/Changes
212    
213     * Tue Jun 22 2010 Petr Pisar <ppisar@redhat.com> 0.999926-2
214     - Rebuild against perl-5.12
215    
216     * Fri Jun 16 2010 Yanko Kaneti <yaneti@declera.com> 0.999926-1
217     - Latest upstream release.
218     http://search.cpan.org/src/KRAIH/Mojolicious-0.999926/Changes
219    
220     * Fri Jun 11 2010 Yanko Kaneti <yaneti@declera.com> 0.999925-3
221     - Actually include the examples.
222    
223     * Fri Jun 11 2010 Yanko Kaneti <yaneti@declera.com> 0.999925-2
224     - Initial import. Include examples as doc.
225    
226     * Tue Jun 08 2010 Yanko Kaneti <yaneti@declera.com> 0.999925-1
227     - Specfile mostly autogenerated by cpanspec 1.78.

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed