/[smeserver]/rpms/perl-Mojolicious/sme9/perl-Mojolicious.spec
ViewVC logotype

Annotation of /rpms/perl-Mojolicious/sme9/perl-Mojolicious.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.8 - (hide annotations) (download)
Wed Feb 10 07:52:18 2016 UTC (8 years, 3 months ago) by vip-ire
Branch: MAIN
Changes since 1.7: +6 -1 lines
* Wed Feb 10 2016 Daniel Berteaud <daniel@firewall-services.com> 6.44-3.sme
- Add a patch to remove warnings during tests [SME: 7819]

1 wellsi 1.1 Name: perl-Mojolicious
2 vip-ire 1.6 version: 6.44
3 vip-ire 1.8 Release: 3%{?dist}
4 wellsi 1.1 Summary: A next generation web framework for Perl
5     License: Artistic 2.0
6     Group: Development/Libraries
7     URL: http://mojolicious.org/
8     Source0: http://www.cpan.org/authors/id/K/KR/KRAIH/Mojolicious-%{version}.tar.gz
9 vip-ire 1.6 Patch0: Mojolicious-6.08.untaint.patch
10     Patch1: Mojolicious-6.12.cleanup.patch
11     Patch2: Mojolicious-6.12.cleanup.patch2
12     Patch3: Mojolicious-6.15.cleanup.patch
13 vip-ire 1.8 Patch4: Mojolicious-6.44-warnings_during_global_destructors.patch
14 wellsi 1.1 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15     BuildArch: noarch
16 vip-ire 1.6 BuildRequires: perl >= 0:5.010001
17 wellsi 1.1 BuildRequires: perl(ExtUtils::MakeMaker)
18     BuildRequires: perl(Test::Builder)
19     BuildRequires: perl(Test::Harness)
20     BuildRequires: perl(Test::More)
21     BuildRequires: perl(Taint::Util)
22 vip-ire 1.6 BuildRequires: perl(Pod::Simple) >= 3.09
23     BuildRequires: perl(Time::Local) >= 1.2000
24     BuildRequires: perl(IO::Socket::IP) >= 0.26
25     Requires: perl(IO::Socket::IP) >= 0.26
26     BuildRequires: perl(IO::Compress::Gzip)
27 vip-ire 1.4 BuildRequires: perl(Digest::MD5)
28     BuildRequires: perl(Digest::SHA)
29     BuildRequires: perl(Time::HiRes)
30     BuildRequires: perl(Compress::Raw::Zlib)
31 vip-ire 1.3 Requires: perl(Taint::Util)
32 vip-ire 1.6 BuildRequires: perl(Socket) >= 1.97
33 vip-ire 1.7 BuildRequires: perl(JSON::PP)
34 vip-ire 1.6 Requires: perl(Socket) >= 1.97
35     Requires: perl(IO::Socket::SSL) >= 1.94
36     Requires: perl(Net::DNS::Native) >= 0.15
37     Requires: perl(Pod::Simple) >= 3.09
38     Requires: perl(Time::Local) >= 1.2000
39 wellsi 1.1 Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
40     %define filelist %{pkgname}-%{version}-filelist
41     %define NVR %{pkgname}-%{version}-%{release}
42     %define maketest 1
43     %define custom_find_req %{_tmppath}/%{NVR}-find-requires
44     %define _use_internal_dependency_generator 0
45     %define __find_requires %{custom_find_req}
46     %define __perl_requires %{custom_find_req}
47     %define perl_vendorlib /usr/share/perl5/vendor_perl
48    
49     %description
50     Back in the early days of the web there was this wonderful Perl library
51     called CGI, many people only learned Perl because of it. It was simple
52     enough to get started without knowing much about the language and powerful
53     enough to keep you going, learning by doing was much fun. While most of the
54     techniques used are outdated now, the idea behind it is not. Mojolicious is
55     a new attempt at implementing this idea using state of the art technology.
56    
57     %prep
58 vip-ire 1.6 %setup -q -n Mojolicious-%{version} -b 0
59 wellsi 1.1 %patch0 -p1
60 vip-ire 1.6 #%patch1 -p2
61     %patch2 -p2
62     %patch3 -p2
63 vip-ire 1.8 %patch4 -p0
64 wellsi 1.1
65     %build
66     %{__perl} Makefile.PL INSTALLDIRS=vendor INSTALLVENDORLIB=/usr/share/perl5/vendor_perl
67     make %{?_smp_mflags}
68    
69     %install
70     rm -rf $RPM_BUILD_ROOT
71     cat <<EOF > %{custom_find_req}
72     #!/bin/sh
73     /usr/lib/rpm/find-requires |grep -v -e 'feature' -e 'IO::Epoll' -e 'IO::KQueue' -e 'EV'
74     EOF
75     chmod 755 %{custom_find_req}
76    
77     make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
78    
79     find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
80     find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
81    
82     %{_fixperms} $RPM_BUILD_ROOT/*
83    
84     %check
85     make test
86    
87     %clean
88     rm -rf $RPM_BUILD_ROOT
89     rm -f %{custom_find_req}
90    
91     %files
92     %defattr(-,root,root,-)
93     %doc Changes LICENSE examples
94     %{_bindir}/mojo
95     %{_bindir}/morbo
96     %{_bindir}/hypnotoad
97     %{perl_vendorlib}/*
98     %{_mandir}/man1/*
99     %{_mandir}/man3/*
100    
101     %changelog
102 vip-ire 1.8 * Wed Feb 10 2016 Daniel Berteaud <daniel@firewall-services.com> 6.44-3.sme
103     - Add a patch to remove warnings during tests [SME: 7819]
104    
105 vip-ire 1.7 * Tue Feb 09 2016 Daniel Berteaud <daniel@firewall-services.com> 6.44-2
106     - Add perl(JSON::PP) to the BuildReq so it can build on plague
107     [SME: 7819]
108    
109 vip-ire 1.6 * Mon Feb 08 2016 Charlie Brady <charlie_brady@mitel.com>
110     - Upgrade Mojolicious to 6.44.
111    
112     * Thu Oct 08 2015 Charlie Brady <charlie_brady@mitel.com>
113     - Upgrade Mojolicious to 6.23.
114    
115     * Mon Sep 21 2015 Charlie Brady <charlie_brady@mitel.com>
116     - Upgrade Mojolicious to 6.20.
117    
118     * Mon Aug 24 2015 Charlie Brady <charlie_brady@mitel.com>
119     - Upgrade Mojolicious to 6.17.
120    
121     * Wed Aug 19 2015 Charlie Brady <charlie_brady@mitel.com>
122     - Fix more cleanup warnings.
123     - Fix warning in Mojo::Asset::Memory::move_to.
124    
125     * Tue Aug 18 2015 Charlie Brady <charlie_brady@mitel.com> 6.15-1
126     - Upgrade Mojolicious to 6.15.
127    
128     * Wed Jul 08 2015 Charlie Brady <charlie_brady@mitel.com> 6.12-3
129     - Fix more cleanup warnings.
130    
131     * Tue Jul 07 2015 Charlie Brady <charlie_brady@mitel.com> 6.12-2
132     - Fix bug in Mojo::UserAgent cleanup when Net::DNS::Native is
133     installed.
134    
135     * Tue Jul 07 2015 Charlie Brady <charlie_brady@mitel.com> 6.12-1
136     - Upgrade Mojolicious to 6.12.
137     - Add Requires for recent IO::Socket::SSL and Net::DNS::Native
138    
139     * Tue Jun 23 2015 Charlie Brady <charlie_brady@mitel.com> 6.11-2
140     - Add missing BuildRequires: perl(Socket) >= 1.97.
141    
142     * Wed Jun 10 2015 Charlie Brady <charlie_brady@mitel.com> 6.11-1
143     - Upgrade Mojolicious to 6.11.
144    
145     * Wed Apr 15 2015 Charlie Brady <charlie_brady@mitel.com> 6.08-1
146     - Upgrade Mojolicious to 6.08.
147    
148     * Sat Feb 28 2015 Charlie Brady <charlie_brady@mitel.com> 6.0-1
149     - Upgrade Mojolicious to 6.0.
150     - Remove Mojolicious-Plugin-CSRFProtect.
151    
152     * Thu Oct 16 2014 Charlie Brady <charlie_brady@mitel.com> - 5.50-1
153     - Upgrade Mojolicious to 5.50 (security update). [MN00548037]
154    
155     * Wed Aug 27 2014 Charlie Brady <charlie_brady@mitel.com> - 5.33-1
156     - Upgrade Mojolicious to 5.33. [MN00540216]
157    
158     * Thu Jun 12 2014 Charlie Brady <charlie_brady@mitel.com> - 5.05-2
159     - Remove the patch which downgraded the version requirement of
160     IO::Socket::SSL. [MN00522946].
161 vip-ire 1.4
162 vip-ire 1.3 * Mon Jun 09 2014 Charlie Brady <charlie_brady@mitel.com> - 5.05-1
163     - Upgrade Mojolicious to 5.05. [MN00522946]
164    
165     * Fri Apr 25 2014 Charlie Brady <charlie_brady@mitel.com> - 4.94-1
166     - Upgrade Mojolicious to 4.94. [MN00522946]
167    
168 wellsi 1.1 * Mon Mar 31 2014 Charlie Brady <charlie_brady@mitel.com> - 4.91-1
169 vip-ire 1.3 - Upgrade Mojolicious to 4.91. [MN00522946]
170 wellsi 1.1
171     * Fri Oct 25 2013 Charlie Brady <charlie_brady@mitel.com> - 4.50-2
172     - Drop IO::Socket::SSL dependency from 1.75 to 1.44. [MN00504964]
173    
174     * Fri Oct 25 2013 Charlie Brady <charlie_brady@mitel.com> - 4.50-1
175     - Upgrade Mojolicious to 4.50. [MN00500199]
176    
177     * Tue Jul 09 2013 Charlie Brady <charlie_brady@mitel.com> - 4.18-2
178     - Add untaint for eval in Mojo::Template. [MN00480041]
179    
180     * Tue Jul 09 2013 Charlie Brady <charlie_brady@mitel.com> - 4.18-1
181     - Upgrade Mojolicious to 4.18. Not yet taint or SSL friendly. [MN00480041]
182    
183     * Wed May 01 2013 Charlie Brady <charlie_brady@mitel.com> - 3.97-3
184     - Add untaint for eval in Mojo::Template. [MN00480041]
185    
186     * Wed May 01 2013 Charlie Brady <charlie_brady@mitel.com> - 3.97-2
187     - Upgrade Mojolicious-Plugin-CSRFProtect to version 0.13. [MN00480041]
188    
189     * Wed May 01 2013 Charlie Brady <charlie_brady@mitel.com> - 3.97-1
190     - Upgrade Mojolicious to 3.97. Not yet taint or SSL friendly. [MN00480041]
191    
192     * Wed Sep 26 2012 Martin Gillen <martin_gillen@mitel.com> - 3.05-6
193     - Upgrade Mojolicious-Plugin-CSRFProtect to version 0.12. [MN00390742]
194    
195     * Thu Aug 23 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-5
196     - Fix typo in IO::Socket::SSL dependency patch. [MN00443005]
197    
198     * Mon Aug 20 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-4
199     - Update CSRF plugin. [MN00441747]
200    
201     * Tue Aug 14 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-3
202     - Drop IO::Socket::SSL dependency from 1.75 to 1.44. [MN00443005]
203    
204     * Tue Aug 14 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-2
205     - Apply untaint patch.
206    
207     * Wed Jul 11 2012 Charlie Brady <charlie_brady@mitel.com> - 3.05-1
208     - Upgrade to latest upstream.
209    
210     * Mon Apr 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.91-1
211     - Upgrade to latest upstream.
212    
213     * Mon Apr 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.49-2
214     - Add CSRFProtect plugin. [MN00396402]
215     - Build into /usr/share/perl5/vendor_perl.
216    
217     * Tue Feb 14 2012 Charlie Brady <charlie_brady@mitel.com> - 2.49-1
218     - Upgrade to latest upstream.
219    
220     * Wed Feb 08 2012 Charlie Brady <charlie_brady@mitel.com> - 2.47-1
221     - Upgrade to latest upstream.
222    
223     * Wed Feb 01 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46-5
224     - Update untaint patch to include untaint of template code when
225     running under -T.
226    
227     * Wed Feb 01 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46-4
228     - Restore use of pre-exising perl-Mojolicious spec file. Re-remove
229     dependency on EV module.
230    
231     * Mon Jan 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46-3
232     - Build into /usr/lib/perl5/vendor_perl.
233    
234     * Mon Jan 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46-2
235     - Apply untaint patch.
236    
237     * Mon Jan 30 2012 Charlie Brady <charlie_brady@mitel.com> - 2.46
238     - Upgrade to latest upstream.
239    
240     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.69-3
241     - Remove dependency on EV module.
242    
243     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.69-2
244     - Apply patch to permit setuid scripts to run - untaint data.
245    
246     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.69-1
247     - Update to upstream 1.64 - no patches, but do not require
248     IO::Epoll and IO::KQueue modules.
249    
250     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.64-2
251     - Apply patch to permit setuid scripts to run - untaint data.
252    
253     * Wed Aug 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.64-1
254     - Update to upstream 1.64 - no patches, but do not require
255     IO::Epoll and IO::KQueue modules.
256    
257     * Fri Jul 15 2011 Charlie Brady <charlie_brady@mitel.com> 1.48-2
258     - Ensure that 'perl(feature)' does not appear in dependency list.
259    
260     * Mon Jun 27 2011 Charlie Brady <charlie_brady@mitel.com> 1.48-1
261     - Update to upstream 1.48 - no patches
262    
263     * Thu Apr 21 2011 Charlie Brady <charlie_brady@mitel.com> 1.21-2
264     - Apply patches (taint checking and test fixes.
265    
266     * Thu Apr 21 2011 Charlie Brady <charlie_brady@mitel.com> 1.21-1
267     - Update to upstream 1.21 - no patches
268    
269     * Mon Jan 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.0-2
270     - Backport to perl 5.8.5 (mostly test fixes).
271    
272     * Mon Jan 03 2011 Charlie Brady <charlie_brady@mitel.com> 1.0-1
273     - Latest upstream release.
274    
275     * Sun Dec 12 2010 Charlie Brady <charlie_brady@mitel.com> 0.999950-2
276     - Latest upstream snapshot, includes exception template
277     - https://github.com/kraih/mojo/tree/fba7a4b549d8e247e03f1e3fc6284cd92fafb4a4
278    
279     * Sun Dec 05 2010 Charlie Brady <charlie_brady@mitel.com> 0.999950-1
280     - Latest upstream release.
281     http://search.cpan.org/src/KRAIH/Mojolicious-0.999950/Changes
282    
283     * Sun Nov 21 2010 Charlie Brady <charlieb@budge.apana.org.au> 0.999941-2
284     - Patch around exceptions in taint mode.
285    
286     * Sun Nov 21 2010 Charlie Brady <charlieb@budge.apana.org.au> 0.999941-1
287     - Latest upstream release.
288     http://search.cpan.org/src/KRAIH/Mojolicious-0.999941/Changes
289    
290     * Mon Aug 16 2010 Yanko Kaneti <yaneti@declera.com> 0.999927-1
291     - Latest upstream release.
292     http://search.cpan.org/src/KRAIH/Mojolicious-0.999927/Changes
293    
294     * Tue Jun 22 2010 Petr Pisar <ppisar@redhat.com> 0.999926-2
295     - Rebuild against perl-5.12
296    
297     * Fri Jun 16 2010 Yanko Kaneti <yaneti@declera.com> 0.999926-1
298     - Latest upstream release.
299     http://search.cpan.org/src/KRAIH/Mojolicious-0.999926/Changes
300    
301     * Fri Jun 11 2010 Yanko Kaneti <yaneti@declera.com> 0.999925-3
302     - Actually include the examples.
303    
304     * Fri Jun 11 2010 Yanko Kaneti <yaneti@declera.com> 0.999925-2
305     - Initial import. Include examples as doc.
306    
307     * Tue Jun 08 2010 Yanko Kaneti <yaneti@declera.com> 0.999925-1
308     - Specfile mostly autogenerated by cpanspec 1.78.

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed