1 |
Name: perl-Net-DNS-Native |
2 |
Version: 0.15 |
3 |
Release: 1%{?dist} |
4 |
Summary: Non-blocking system DNS resolver |
5 |
License: GPL+ or Artistic |
6 |
Group: Development/Libraries |
7 |
URL: http://search.cpan.org/dist/Net-DNS-Native/ |
8 |
Source0: http://www.cpan.org/authors/id/O/OL/OLEG/Net-DNS-Native-%{version}.tar.gz |
9 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
10 |
BuildRequires: perl(ExtUtils::MakeMaker) |
11 |
BuildRequires: perl(Socket) >= 1.94 |
12 |
BuildRequires: perl(Test::More) >= 0.88 |
13 |
Requires: perl(Socket) >= 1.94 |
14 |
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) |
15 |
|
16 |
%description |
17 |
This class provides several methods for host name resolution. It is |
18 |
designed to be used with event loops. All resolving are done by |
19 |
getaddrinfo(3) implemented in your system library. Since getaddrinfo() is |
20 |
blocking function and we don't want to block, calls to this function will |
21 |
be done in separate thread. This class uses system native threads and not |
22 |
perl threads. So overhead shouldn't be too big. |
23 |
|
24 |
%prep |
25 |
%setup -q -n Net-DNS-Native-%{version} |
26 |
|
27 |
%build |
28 |
%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS" |
29 |
make %{?_smp_mflags} |
30 |
|
31 |
%install |
32 |
rm -rf $RPM_BUILD_ROOT |
33 |
|
34 |
make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT |
35 |
|
36 |
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \; |
37 |
find $RPM_BUILD_ROOT -type f -name '*.bs' -size 0 -exec rm -f {} \; |
38 |
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \; |
39 |
|
40 |
%{_fixperms} $RPM_BUILD_ROOT/* |
41 |
|
42 |
%check |
43 |
make test |
44 |
|
45 |
%clean |
46 |
rm -rf $RPM_BUILD_ROOT |
47 |
|
48 |
%files |
49 |
%defattr(-,root,root,-) |
50 |
%doc Changes META.json README |
51 |
%{perl_vendorarch}/auto/* |
52 |
%{perl_vendorarch}/Net* |
53 |
%{_mandir}/man3/* |
54 |
|
55 |
%changelog |
56 |
* Tue Feb 09 2016 Daniel Berteaud <daniel@firewall-services.com> 0.15-1 |
57 |
- First build using cpanspec |