1 |
Name: perl-Net-Ident |
2 |
Version: 1.24 |
3 |
Release: 1%{?dist} |
4 |
Summary: Lookup the username on the remote end of a TCP/IP connection |
5 |
License: Artistic |
6 |
Group: Development/Libraries |
7 |
URL: http://search.cpan.org/dist/Net-Ident/ |
8 |
Source0: http://www.cpan.org/authors/id/T/TO/TODDR/Net-Ident-%{version}.tar.gz |
9 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
10 |
BuildArch: noarch |
11 |
BuildRequires: perl(Carp) |
12 |
BuildRequires: perl(Config) |
13 |
BuildRequires: perl(Exporter) |
14 |
BuildRequires: perl(ExtUtils::MakeMaker) |
15 |
BuildRequires: perl(Socket) |
16 |
BuildRequires: perl(Test::More) |
17 |
Requires: perl(Carp) |
18 |
Requires: perl(Config) |
19 |
Requires: perl(Exporter) |
20 |
Requires: perl(Socket) |
21 |
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) |
22 |
|
23 |
%description |
24 |
You can either use the simple interface, which does one ident lookup at a |
25 |
time, or use the asynchronous interface to perform (possibly) many |
26 |
simultaneous lookups, or simply continue serving other things while the |
27 |
lookup is proceeding. |
28 |
|
29 |
%prep |
30 |
%setup -q -n Net-Ident-%{version} |
31 |
|
32 |
%build |
33 |
%{__perl} Makefile.PL INSTALLDIRS=vendor |
34 |
make %{?_smp_mflags} |
35 |
|
36 |
%install |
37 |
rm -rf $RPM_BUILD_ROOT |
38 |
|
39 |
make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT |
40 |
|
41 |
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \; |
42 |
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \; |
43 |
|
44 |
%{_fixperms} $RPM_BUILD_ROOT/* |
45 |
|
46 |
%check |
47 |
make test |
48 |
|
49 |
%clean |
50 |
rm -rf $RPM_BUILD_ROOT |
51 |
|
52 |
%files |
53 |
%defattr(-,root,root,-) |
54 |
%doc Changes META.json README |
55 |
%{perl_vendorlib}/* |
56 |
%{_mandir}/man3/* |
57 |
|
58 |
%changelog |
59 |
* Thu Mar 17 2016 Daniel Berteaud <daniel@firewall-services.com> 1.24-1 |
60 |
- First build using cpanspec [SME: 9323] |