1 |
slords |
1.1 |
# |
2 |
|
|
# - Net::SMTP::SSL - |
3 |
|
|
# This spec file was automatically generated by cpan2rpm [ver: 2.026] |
4 |
|
|
# The following arguments were used: |
5 |
|
|
# Net::SMTP::SSL |
6 |
|
|
# For more information on cpan2rpm please visit: http://perl.arix.com/ |
7 |
|
|
# |
8 |
|
|
|
9 |
|
|
%define pkgname Net-SMTP-SSL |
10 |
|
|
%define filelist %{pkgname}-%{version}-filelist |
11 |
|
|
%define NVR %{pkgname}-%{version}-%{release} |
12 |
|
|
%define maketest 1 |
13 |
|
|
|
14 |
|
|
name: perl-Net-SMTP-SSL |
15 |
|
|
summary: Net-SMTP-SSL - SSL support for Net::SMTP |
16 |
|
|
version: 1.01 |
17 |
|
|
release: 1%{?dist} |
18 |
|
|
license: Artistic |
19 |
|
|
group: Applications/CPAN |
20 |
|
|
url: http://www.cpan.org |
21 |
|
|
buildroot: %{_tmppath}/%{name}-%{version}-%(id -u -n) |
22 |
|
|
buildarch: noarch |
23 |
|
|
prefix: %(echo %{_prefix}) |
24 |
|
|
source: http://search.cpan.org/dist/C/CW/CWEST/Net-SMTP-SSL-1.01.tar.gz |
25 |
|
|
buildrequires: perl(IO::Socket::SSL) |
26 |
|
|
|
27 |
|
|
%description |
28 |
|
|
Implements the same API as L<Net::SMTP|Net::SMTP>, but uses |
29 |
|
|
L<IO::Socket::SSL|IO::Socket::SSL> for its network operations. Due to |
30 |
|
|
the nature of C<Net::SMTP>'s C<new> method, it is not overridden to make |
31 |
|
|
use of a default port for the SMTPS service. Perhaps future versions |
32 |
|
|
will be smart like that. Port C<465> is usually what you want, and it's |
33 |
|
|
not a pain to specify that. |
34 |
|
|
|
35 |
|
|
For interface documentation, please see L<Net::SMTP|Net::SMTP>. |
36 |
|
|
|
37 |
|
|
# |
38 |
|
|
# This package was generated automatically with the cpan2rpm |
39 |
|
|
# utility. To get this software or for more information |
40 |
|
|
# please visit: http://perl.arix.com/ |
41 |
|
|
# |
42 |
|
|
|
43 |
|
|
%prep |
44 |
|
|
%setup -q -n %{pkgname}-%{version} |
45 |
|
|
chmod -R u+w %{_builddir}/%{pkgname}-%{version} |
46 |
|
|
|
47 |
|
|
%build |
48 |
|
|
grep -rsl '^#!.*perl' . | |
49 |
|
|
grep -v '.bak$' |xargs --no-run-if-empty \ |
50 |
|
|
%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' |
51 |
|
|
CFLAGS="$RPM_OPT_FLAGS" |
52 |
|
|
%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` |
53 |
|
|
%{__make} |
54 |
|
|
%if %maketest |
55 |
|
|
%{__make} test |
56 |
|
|
%endif |
57 |
|
|
|
58 |
|
|
%install |
59 |
|
|
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
60 |
|
|
|
61 |
|
|
%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '` |
62 |
|
|
|
63 |
|
|
[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress |
64 |
|
|
|
65 |
|
|
# SuSE Linux |
66 |
|
|
if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ] |
67 |
|
|
then |
68 |
|
|
%{__mkdir_p} %{buildroot}/var/adm/perl-modules |
69 |
|
|
%{__cat} `find %{buildroot} -name "perllocal.pod"` \ |
70 |
|
|
| %{__sed} -e s+%{buildroot}++g \ |
71 |
|
|
> %{buildroot}/var/adm/perl-modules/%{name} |
72 |
|
|
fi |
73 |
|
|
|
74 |
|
|
# remove special files |
75 |
|
|
find %{buildroot} -name "perllocal.pod" \ |
76 |
|
|
-o -name ".packlist" \ |
77 |
|
|
-o -name "*.bs" \ |
78 |
|
|
|xargs -i rm -f {} |
79 |
|
|
|
80 |
|
|
# no empty directories |
81 |
|
|
find %{buildroot}%{_prefix} \ |
82 |
|
|
-type d -depth \ |
83 |
|
|
-exec rmdir {} \; 2>/dev/null |
84 |
|
|
|
85 |
|
|
%{__perl} -MFile::Find -le ' |
86 |
|
|
find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}"); |
87 |
|
|
print "%doc Changes README"; |
88 |
|
|
for my $x (sort @dirs, @files) { |
89 |
|
|
push @ret, $x unless indirs($x); |
90 |
|
|
} |
91 |
|
|
print join "\n", sort @ret; |
92 |
|
|
|
93 |
|
|
sub wanted { |
94 |
|
|
return if /auto$/; |
95 |
|
|
|
96 |
|
|
local $_ = $File::Find::name; |
97 |
|
|
my $f = $_; s|^\Q%{buildroot}\E||; |
98 |
|
|
return unless length; |
99 |
|
|
return $files[@files] = $_ if -f $f; |
100 |
|
|
|
101 |
|
|
$d = $_; |
102 |
|
|
/\Q$d\E/ && return for reverse sort @INC; |
103 |
|
|
$d =~ /\Q$_\E/ && return |
104 |
|
|
for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|; |
105 |
|
|
|
106 |
|
|
$dirs[@dirs] = $_; |
107 |
|
|
} |
108 |
|
|
|
109 |
|
|
sub indirs { |
110 |
|
|
my $x = shift; |
111 |
|
|
$x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs; |
112 |
|
|
} |
113 |
|
|
' > %filelist |
114 |
|
|
|
115 |
|
|
[ -z %filelist ] && { |
116 |
|
|
echo "ERROR: empty %files listing" |
117 |
|
|
exit -1 |
118 |
|
|
} |
119 |
|
|
|
120 |
|
|
%clean |
121 |
|
|
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
122 |
|
|
|
123 |
|
|
%files -f %filelist |
124 |
|
|
%defattr(-,root,root) |
125 |
|
|
|
126 |
|
|
%changelog |
127 |
|
|
* Fri Oct 19 2007 root@eccserver01 |
128 |
|
|
- Initial build. |