1 |
# $Id$ |
2 |
|
3 |
# |
4 |
# - Net::SMTP::SSL - |
5 |
# This spec file was automatically generated by cpan2rpm [ver: 2.026] |
6 |
# The following arguments were used: |
7 |
# Net::SMTP::SSL |
8 |
# For more information on cpan2rpm please visit: http://perl.arix.com/ |
9 |
# |
10 |
|
11 |
%define pkgname Net-SMTP-SSL |
12 |
%define filelist %{pkgname}-%{version}-filelist |
13 |
%define NVR %{pkgname}-%{version}-%{release} |
14 |
%define maketest 1 |
15 |
|
16 |
name: perl-Net-SMTP-SSL |
17 |
summary: Net-SMTP-SSL - SSL support for Net::SMTP |
18 |
version: 1.01 |
19 |
release: 1%{?dist} |
20 |
license: Artistic |
21 |
group: Applications/CPAN |
22 |
url: http://www.cpan.org |
23 |
buildroot: %{_tmppath}/%{name}-%{version}-%(id -u -n) |
24 |
buildarch: noarch |
25 |
prefix: %(echo %{_prefix}) |
26 |
source: http://search.cpan.org/dist/C/CW/CWEST/Net-SMTP-SSL-1.01.tar.gz |
27 |
buildrequires: perl(IO::Socket::SSL) |
28 |
|
29 |
%description |
30 |
Implements the same API as L<Net::SMTP|Net::SMTP>, but uses |
31 |
L<IO::Socket::SSL|IO::Socket::SSL> for its network operations. Due to |
32 |
the nature of C<Net::SMTP>'s C<new> method, it is not overridden to make |
33 |
use of a default port for the SMTPS service. Perhaps future versions |
34 |
will be smart like that. Port C<465> is usually what you want, and it's |
35 |
not a pain to specify that. |
36 |
|
37 |
For interface documentation, please see L<Net::SMTP|Net::SMTP>. |
38 |
|
39 |
# |
40 |
# This package was generated automatically with the cpan2rpm |
41 |
# utility. To get this software or for more information |
42 |
# please visit: http://perl.arix.com/ |
43 |
# |
44 |
|
45 |
%prep |
46 |
%setup -q -n %{pkgname}-%{version} |
47 |
chmod -R u+w %{_builddir}/%{pkgname}-%{version} |
48 |
|
49 |
%build |
50 |
grep -rsl '^#!.*perl' . | |
51 |
grep -v '.bak$' |xargs --no-run-if-empty \ |
52 |
%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' |
53 |
CFLAGS="$RPM_OPT_FLAGS" |
54 |
%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` |
55 |
%{__make} |
56 |
%if %maketest |
57 |
%{__make} test |
58 |
%endif |
59 |
|
60 |
%install |
61 |
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
62 |
|
63 |
%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '` |
64 |
|
65 |
[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress |
66 |
|
67 |
# SuSE Linux |
68 |
if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ] |
69 |
then |
70 |
%{__mkdir_p} %{buildroot}/var/adm/perl-modules |
71 |
%{__cat} `find %{buildroot} -name "perllocal.pod"` \ |
72 |
| %{__sed} -e s+%{buildroot}++g \ |
73 |
> %{buildroot}/var/adm/perl-modules/%{name} |
74 |
fi |
75 |
|
76 |
# remove special files |
77 |
find %{buildroot} -name "perllocal.pod" \ |
78 |
-o -name ".packlist" \ |
79 |
-o -name "*.bs" \ |
80 |
|xargs -i rm -f {} |
81 |
|
82 |
# no empty directories |
83 |
find %{buildroot}%{_prefix} \ |
84 |
-type d -depth \ |
85 |
-exec rmdir {} \; 2>/dev/null |
86 |
|
87 |
%{__perl} -MFile::Find -le ' |
88 |
find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}"); |
89 |
print "%doc Changes README"; |
90 |
for my $x (sort @dirs, @files) { |
91 |
push @ret, $x unless indirs($x); |
92 |
} |
93 |
print join "\n", sort @ret; |
94 |
|
95 |
sub wanted { |
96 |
return if /auto$/; |
97 |
|
98 |
local $_ = $File::Find::name; |
99 |
my $f = $_; s|^\Q%{buildroot}\E||; |
100 |
return unless length; |
101 |
return $files[@files] = $_ if -f $f; |
102 |
|
103 |
$d = $_; |
104 |
/\Q$d\E/ && return for reverse sort @INC; |
105 |
$d =~ /\Q$_\E/ && return |
106 |
for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|; |
107 |
|
108 |
$dirs[@dirs] = $_; |
109 |
} |
110 |
|
111 |
sub indirs { |
112 |
my $x = shift; |
113 |
$x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs; |
114 |
} |
115 |
' > %filelist |
116 |
|
117 |
[ -z %filelist ] && { |
118 |
echo "ERROR: empty %files listing" |
119 |
exit -1 |
120 |
} |
121 |
|
122 |
%clean |
123 |
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
124 |
|
125 |
%files -f %filelist |
126 |
%defattr(-,root,root) |
127 |
|
128 |
%changelog |
129 |
* Fri Oct 19 2007 root@eccserver01 |
130 |
- Initial build. |