1 |
# |
2 |
# - Net::SMTP::TLS - |
3 |
# This spec file was automatically generated by cpan2rpm [ver: 2.026] |
4 |
# The following arguments were used: |
5 |
# Net::SMTP::TLS |
6 |
# For more information on cpan2rpm please visit: http://perl.arix.com/ |
7 |
# |
8 |
|
9 |
%define pkgname Net-SMTP-TLS |
10 |
%define filelist %{pkgname}-%{version}-filelist |
11 |
%define NVR %{pkgname}-%{version}-%{release} |
12 |
%define maketest 1 |
13 |
|
14 |
name: perl-Net-SMTP-TLS |
15 |
summary: Net-SMTP-TLS - An SMTP client supporting TLS and AUTH |
16 |
version: 0.12 |
17 |
release: 1%{?dist} |
18 |
vendor: Alexander Christian Westholm <awestholm@verizon.net> |
19 |
license: Artistic |
20 |
group: Applications/CPAN |
21 |
url: http://www.cpan.org |
22 |
buildroot: %{_tmppath}/%{name}-%{version}-%(id -u -n) |
23 |
buildarch: noarch |
24 |
prefix: %(echo %{_prefix}) |
25 |
source: http://search.cpan.org/dist/A/AW/AWESTHOLM/Net-SMTP-TLS-0.12.tar.gz |
26 |
|
27 |
%description |
28 |
B<Net::SMTP::TLS> is a TLS and AUTH capable SMTP client which offers an interface that users will find familiar from L<Net::SMTP>. B<Net::SMTP::TLS> implements a subset of the methods provided by that module, but certainly not (yet) a complete mirror image of that API. |
29 |
|
30 |
The methods supported by B<Net::SMTP::TLS> are used in the above example. Though self explanatory for the most part, please see the perldoc for L<Net::SMTP> if you are unclear. |
31 |
|
32 |
The differences in the methods provided are as follows: |
33 |
|
34 |
=over |
35 |
|
36 |
The I<mail> method does not take the options list taken by L<Net::SMTP> |
37 |
|
38 |
The I<to> method also does not take options, and is the only method available to set the recipient (unlike the many synonyms provided by L<Net::SMTP>). |
39 |
|
40 |
The constructor takes a limited number of L<Net::SMTP>'s parameters. The constructor for B<Net::SMTP::TLS> takes the following (in addition to the hostname of the mail server, which must be the first parameter and is not explicitly named): |
41 |
|
42 |
=over |
43 |
|
44 |
NoTLS - In the unlikely event that you need to use this class to perform non-TLS SMTP (you ought to be using Net::SMTP itself for that...), this will turn off TLS when supplied with a true value. This will most often cause an error related to authentication when used on a server that requires TLS |
45 |
|
46 |
Hello - hostname used in the EHLO command |
47 |
|
48 |
Port - port to connect to the SMTP service (defaults to 25) |
49 |
|
50 |
Timeout - Timeout for inital socket connection (defaults to 5, passed directly to L<IO::Socket::INET>) |
51 |
|
52 |
User - username for SMTP AUTH |
53 |
|
54 |
Password - password for SMTP AUTH |
55 |
|
56 |
=back |
57 |
|
58 |
=back |
59 |
|
60 |
# |
61 |
# This package was generated automatically with the cpan2rpm |
62 |
# utility. To get this software or for more information |
63 |
# please visit: http://perl.arix.com/ |
64 |
# |
65 |
|
66 |
%prep |
67 |
%setup -q -n %{pkgname}-%{version} |
68 |
chmod -R u+w %{_builddir}/%{pkgname}-%{version} |
69 |
|
70 |
%build |
71 |
grep -rsl '^#!.*perl' . | |
72 |
grep -v '.bak$' |xargs --no-run-if-empty \ |
73 |
%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' |
74 |
CFLAGS="$RPM_OPT_FLAGS" |
75 |
%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` |
76 |
%{__make} |
77 |
%if %maketest |
78 |
%{__make} test |
79 |
%endif |
80 |
|
81 |
%install |
82 |
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
83 |
|
84 |
%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '` |
85 |
|
86 |
[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress |
87 |
|
88 |
# SuSE Linux |
89 |
if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ] |
90 |
then |
91 |
%{__mkdir_p} %{buildroot}/var/adm/perl-modules |
92 |
%{__cat} `find %{buildroot} -name "perllocal.pod"` \ |
93 |
| %{__sed} -e s+%{buildroot}++g \ |
94 |
> %{buildroot}/var/adm/perl-modules/%{name} |
95 |
fi |
96 |
|
97 |
# remove special files |
98 |
find %{buildroot} -name "perllocal.pod" \ |
99 |
-o -name ".packlist" \ |
100 |
-o -name "*.bs" \ |
101 |
|xargs -i rm -f {} |
102 |
|
103 |
# no empty directories |
104 |
find %{buildroot}%{_prefix} \ |
105 |
-type d -depth \ |
106 |
-exec rmdir {} \; 2>/dev/null |
107 |
|
108 |
%{__perl} -MFile::Find -le ' |
109 |
find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}"); |
110 |
print "%doc Changes README"; |
111 |
for my $x (sort @dirs, @files) { |
112 |
push @ret, $x unless indirs($x); |
113 |
} |
114 |
print join "\n", sort @ret; |
115 |
|
116 |
sub wanted { |
117 |
return if /auto$/; |
118 |
|
119 |
local $_ = $File::Find::name; |
120 |
my $f = $_; s|^\Q%{buildroot}\E||; |
121 |
return unless length; |
122 |
return $files[@files] = $_ if -f $f; |
123 |
|
124 |
$d = $_; |
125 |
/\Q$d\E/ && return for reverse sort @INC; |
126 |
$d =~ /\Q$_\E/ && return |
127 |
for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|; |
128 |
|
129 |
$dirs[@dirs] = $_; |
130 |
} |
131 |
|
132 |
sub indirs { |
133 |
my $x = shift; |
134 |
$x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs; |
135 |
} |
136 |
' > %filelist |
137 |
|
138 |
[ -z %filelist ] && { |
139 |
echo "ERROR: empty %files listing" |
140 |
exit -1 |
141 |
} |
142 |
|
143 |
%clean |
144 |
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
145 |
|
146 |
%files -f %filelist |
147 |
%defattr(-,root,root) |
148 |
|
149 |
%changelog |
150 |
* Tue Mar 11 2008 slords@b32-4.lordsfam.net |
151 |
- Initial build. |