/[smeserver]/rpms/perl-Object-Persistence/sme10/perl-Object-Persistence.spec
ViewVC logotype

Annotation of /rpms/perl-Object-Persistence/sme10/perl-Object-Persistence.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.5 - (hide annotations) (download)
Sun Feb 7 20:10:33 2016 UTC (8 years, 3 months ago) by stephdl
Branch: MAIN
Changes since 1.4: +2 -2 lines
* Sun Feb 7 2016 stephane de labrusse <stephdl@de-labrusse.fr> 0.92-5.sme
- Build new rpm for sme10

1 stephdl 1.5 # $Id: perl-Object-Persistence.spec,v 1.4 2016/02/07 19:57:48 stephdl Exp $
2 vip-ire 1.1
3     #
4     # - Object-Persistence -
5     # This spec file was automatically generated by cpan2rpm [ver: 2.026]
6     # The following arguments were used:
7     # --no-requires=Crypt::Random --release=3 Persistence::Object::Simple
8     # For more information on cpan2rpm please visit: http://perl.arix.com/
9     #
10     %define pkgname Object-Persistence
11     %define filelist %{pkgname}-%{version}-filelist
12     %define NVR %{pkgname}-%{version}-%{release}
13     %define maketest 1
14     %define custom_find_req %{_tmppath}/%{NVR}-find-requires
15     %define _use_internal_dependency_generator 0
16     %define __find_requires %{custom_find_req}
17     %define __perl_requires %{custom_find_req}
18    
19     name: perl-Object-Persistence
20     summary: Object-Persistence - Object Persistence with Data::Dumper.
21     version: 0.92
22     release: 5%{?dist}
23     license: Artistic
24     group: Applications/CPAN
25     url: http://www.cpan.org
26     buildroot: %{_tmppath}/%{name}-%{version}-%(id -u -n)
27     buildarch: noarch
28     prefix: %(echo %{_prefix})
29     source: http://search.cpan.org/dist/V/VI/VIPUL/Object-Persistence-0.92.tar.gz
30     Patch0: %{pkgname}-%{version}.patch.2002052300
31     Patch1: %{pkgname}-%{version}.patch.2004092700
32     Patch2: %{pkgname}-%{version}.patch.forceDumpperl
33    
34 stephdl 1.5 BuildRequires: perl(ExtUtils::MakeMaker) perl(Digest::MD5)
35 vip-ire 1.1
36     %description
37     P::O::S provides persistence functionality to its objects. Object definitions
38     are stored as stringified perl data structures, generated with Data::Dumper,
39     that are amenable to manual editing and external processing from outside the
40     class interface.
41    
42     Persistence is achieved with a blessed hash container that holds the object
43     data. The container can store objects that employ non-hash structures as
44     well. See L<"Inheriting Persistence::Object::Simple">, L<"Class Methods"> and
45     the persistent list class example (examples/Plist.pm).
46    
47     #
48     # This package was generated automatically with the cpan2rpm
49     # utility. To get this software or for more information
50     # please visit: http://perl.arix.com/
51     #
52    
53     %prep
54     %setup -q -n %{pkgname}-%{version}
55     chmod -R u+w %{_builddir}/%{pkgname}-%{version}
56     %patch0 -p1
57     %patch1 -p1
58     %patch2 -p1
59    
60     %build
61     grep -rsl '^#!.*perl' . |
62     grep -v '.bak$' |xargs --no-run-if-empty \
63     %__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
64     CFLAGS="$RPM_OPT_FLAGS"
65     %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '`
66     %{__make}
67     %if %maketest
68     %{__make} test
69     %endif
70    
71     %install
72     [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
73     cat <<EOF > %{custom_find_req}
74     #!/bin/sh
75     /usr/lib/rpm/find-requires |grep -v -e 'Crypt::Random'
76     EOF
77     chmod 755 %{custom_find_req}
78    
79     %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
80    
81     [ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
82    
83     # SuSE Linux
84     if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
85     then
86     %{__mkdir_p} %{buildroot}/var/adm/perl-modules
87     %{__cat} `find %{buildroot} -name "perllocal.pod"` \
88     | %{__sed} -e s+%{buildroot}++g \
89     > %{buildroot}/var/adm/perl-modules/%{name}
90     fi
91    
92     # remove special files
93     find %{buildroot} -name "perllocal.pod" \
94     -o -name ".packlist" \
95     -o -name "*.bs" \
96     |xargs -i rm -f {}
97    
98     # no empty directories
99     find %{buildroot}%{_prefix} \
100     -type d -depth \
101     -exec rmdir {} \; 2>/dev/null
102    
103     %{__perl} -MFile::Find -le '
104     find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
105     print "%doc Changes examples";
106     for my $x (sort @dirs, @files) {
107     push @ret, $x unless indirs($x);
108     }
109     print join "\n", sort @ret;
110    
111     sub wanted {
112     return if /auto$/;
113    
114     local $_ = $File::Find::name;
115     my $f = $_; s|^\Q%{buildroot}\E||;
116     return unless length;
117     return $files[@files] = $_ if -f $f;
118    
119     $d = $_;
120     /\Q$d\E/ && return for reverse sort @INC;
121     $d =~ /\Q$_\E/ && return
122     for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
123    
124     $dirs[@dirs] = $_;
125     }
126    
127     sub indirs {
128     my $x = shift;
129     $x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
130     }
131     ' > %filelist
132    
133     [ -z %filelist ] && {
134     echo "ERROR: empty %files listing"
135     exit -1
136     }
137    
138     %clean
139     [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
140     rm -f %{custom_find_req}
141    
142     %files -f %filelist
143     %defattr(-,root,root)
144    
145     %changelog
146 stephdl 1.3 * Sun Feb 7 2016 stephane de labrusse <stephdl@de-labrusse.fr> 0.92-5.sme
147     - Build new rpm for sme10
148    
149 vip-ire 1.1 * Wed Sep 9 2015 Daniel Berteaud <daniel@firewall-services.com> - 0.92-5.sme
150     - Add correct BuildReq so it can build on el6 [SME: 8887]
151    
152     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
153     - Clean up spec so package can be built by koji/plague
154    
155     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
156     - Update to new release naming. No functional changes.
157     - Make Packager generic
158    
159     * Wed Sep 13 2006 Michael Soulier <michael_soulier@mitel.com>
160     - Forced Data::Dumper to use Dumpperl to work around interpreter crash.
161     [sme 1837]
162    
163     * Mon Sep 27 2004 Charlie Brady <charlieb@e-smith.com>
164     - [0.92-3es01]
165     - Remove "AutoReqProv: no" so that rpmbuild calculates proper
166     provides. Remove Provides header thus made redudent.
167     [charlieb MN00040240]
168     - Fix croak in Simple.pm so that problems with cache file opens
169     are reported [charlieb ]
170     - Use new cpan2rpm template for build (for compat with CentOS).
171    
172     * Wed Sep 22 2004 Michael Soulier <michael_soulier@mitel.com>
173     - [0.92-2es01]
174     - Rebuilding to get proper provides. [msoulier MN00040240]
175    
176     * Thu May 23 2002 Mark Knox <markk@e-smith.com>
177     - [0.92-2]
178     - Changed untaint to slurp in all contents of temp file in order to prevent
179     semicolons in values from corrupting the session. [markk 3630]
180    
181     * Mon Feb 18 2002 Charlie Brady <charlieb@e-smith.com>
182     - Upgrade to version 0.92 (received by email).
183    
184     * Mon Feb 26 2001 Tony Clayton <tonyc@e-smith.com>
185     - initial release

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed