/[smeserver]/rpms/perl-Object-Persistence/sme10/perl-Object-Persistence.spec
ViewVC logotype

Annotation of /rpms/perl-Object-Persistence/sme10/perl-Object-Persistence.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.6 - (hide annotations) (download)
Tue Feb 9 21:58:33 2016 UTC (8 years, 4 months ago) by vip-ire
Branch: MAIN
Changes since 1.5: +7 -2 lines
* Tue Feb 9 2016 Daniel Berteaud <daniel@firewall-services.com> - 0.92-6.sme
- Add correct BuildReq so it can build on el7 [SME: 9210]

1 vip-ire 1.6 # $Id: perl-Object-Persistence.spec,v 1.5 2016/02/07 20:10:33 stephdl Exp $
2 vip-ire 1.1
3     #
4     # - Object-Persistence -
5     # This spec file was automatically generated by cpan2rpm [ver: 2.026]
6     # The following arguments were used:
7     # --no-requires=Crypt::Random --release=3 Persistence::Object::Simple
8     # For more information on cpan2rpm please visit: http://perl.arix.com/
9     #
10     %define pkgname Object-Persistence
11     %define filelist %{pkgname}-%{version}-filelist
12     %define NVR %{pkgname}-%{version}-%{release}
13     %define maketest 1
14     %define custom_find_req %{_tmppath}/%{NVR}-find-requires
15     %define _use_internal_dependency_generator 0
16     %define __find_requires %{custom_find_req}
17     %define __perl_requires %{custom_find_req}
18    
19     name: perl-Object-Persistence
20     summary: Object-Persistence - Object Persistence with Data::Dumper.
21     version: 0.92
22     release: 5%{?dist}
23     license: Artistic
24     group: Applications/CPAN
25     url: http://www.cpan.org
26     buildroot: %{_tmppath}/%{name}-%{version}-%(id -u -n)
27     buildarch: noarch
28     prefix: %(echo %{_prefix})
29     source: http://search.cpan.org/dist/V/VI/VIPUL/Object-Persistence-0.92.tar.gz
30     Patch0: %{pkgname}-%{version}.patch.2002052300
31     Patch1: %{pkgname}-%{version}.patch.2004092700
32     Patch2: %{pkgname}-%{version}.patch.forceDumpperl
33    
34 vip-ire 1.6 BuildRequires: perl(ExtUtils::MakeMaker)
35     BuildRequires: perl(Digest::MD5)
36     BuildRequires: perl(Data::Dumper)
37 vip-ire 1.1
38     %description
39     P::O::S provides persistence functionality to its objects. Object definitions
40     are stored as stringified perl data structures, generated with Data::Dumper,
41     that are amenable to manual editing and external processing from outside the
42     class interface.
43    
44     Persistence is achieved with a blessed hash container that holds the object
45     data. The container can store objects that employ non-hash structures as
46     well. See L<"Inheriting Persistence::Object::Simple">, L<"Class Methods"> and
47     the persistent list class example (examples/Plist.pm).
48    
49     #
50     # This package was generated automatically with the cpan2rpm
51     # utility. To get this software or for more information
52     # please visit: http://perl.arix.com/
53     #
54    
55     %prep
56     %setup -q -n %{pkgname}-%{version}
57     chmod -R u+w %{_builddir}/%{pkgname}-%{version}
58     %patch0 -p1
59     %patch1 -p1
60     %patch2 -p1
61    
62     %build
63     grep -rsl '^#!.*perl' . |
64     grep -v '.bak$' |xargs --no-run-if-empty \
65     %__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
66     CFLAGS="$RPM_OPT_FLAGS"
67     %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '`
68     %{__make}
69     %if %maketest
70     %{__make} test
71     %endif
72    
73     %install
74     [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
75     cat <<EOF > %{custom_find_req}
76     #!/bin/sh
77     /usr/lib/rpm/find-requires |grep -v -e 'Crypt::Random'
78     EOF
79     chmod 755 %{custom_find_req}
80    
81     %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
82    
83     [ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
84    
85     # SuSE Linux
86     if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
87     then
88     %{__mkdir_p} %{buildroot}/var/adm/perl-modules
89     %{__cat} `find %{buildroot} -name "perllocal.pod"` \
90     | %{__sed} -e s+%{buildroot}++g \
91     > %{buildroot}/var/adm/perl-modules/%{name}
92     fi
93    
94     # remove special files
95     find %{buildroot} -name "perllocal.pod" \
96     -o -name ".packlist" \
97     -o -name "*.bs" \
98     |xargs -i rm -f {}
99    
100     # no empty directories
101     find %{buildroot}%{_prefix} \
102     -type d -depth \
103     -exec rmdir {} \; 2>/dev/null
104    
105     %{__perl} -MFile::Find -le '
106     find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
107     print "%doc Changes examples";
108     for my $x (sort @dirs, @files) {
109     push @ret, $x unless indirs($x);
110     }
111     print join "\n", sort @ret;
112    
113     sub wanted {
114     return if /auto$/;
115    
116     local $_ = $File::Find::name;
117     my $f = $_; s|^\Q%{buildroot}\E||;
118     return unless length;
119     return $files[@files] = $_ if -f $f;
120    
121     $d = $_;
122     /\Q$d\E/ && return for reverse sort @INC;
123     $d =~ /\Q$_\E/ && return
124     for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
125    
126     $dirs[@dirs] = $_;
127     }
128    
129     sub indirs {
130     my $x = shift;
131     $x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
132     }
133     ' > %filelist
134    
135     [ -z %filelist ] && {
136     echo "ERROR: empty %files listing"
137     exit -1
138     }
139    
140     %clean
141     [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
142     rm -f %{custom_find_req}
143    
144     %files -f %filelist
145     %defattr(-,root,root)
146    
147     %changelog
148 vip-ire 1.6 * Tue Feb 9 2016 Daniel Berteaud <daniel@firewall-services.com> - 0.92-6.sme
149     - Add correct BuildReq so it can build on el7 [SME: 9210]
150    
151 stephdl 1.3 * Sun Feb 7 2016 stephane de labrusse <stephdl@de-labrusse.fr> 0.92-5.sme
152     - Build new rpm for sme10
153    
154 vip-ire 1.1 * Wed Sep 9 2015 Daniel Berteaud <daniel@firewall-services.com> - 0.92-5.sme
155     - Add correct BuildReq so it can build on el6 [SME: 8887]
156    
157     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
158     - Clean up spec so package can be built by koji/plague
159    
160     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
161     - Update to new release naming. No functional changes.
162     - Make Packager generic
163    
164     * Wed Sep 13 2006 Michael Soulier <michael_soulier@mitel.com>
165     - Forced Data::Dumper to use Dumpperl to work around interpreter crash.
166     [sme 1837]
167    
168     * Mon Sep 27 2004 Charlie Brady <charlieb@e-smith.com>
169     - [0.92-3es01]
170     - Remove "AutoReqProv: no" so that rpmbuild calculates proper
171     provides. Remove Provides header thus made redudent.
172     [charlieb MN00040240]
173     - Fix croak in Simple.pm so that problems with cache file opens
174     are reported [charlieb ]
175     - Use new cpan2rpm template for build (for compat with CentOS).
176    
177     * Wed Sep 22 2004 Michael Soulier <michael_soulier@mitel.com>
178     - [0.92-2es01]
179     - Rebuilding to get proper provides. [msoulier MN00040240]
180    
181     * Thu May 23 2002 Mark Knox <markk@e-smith.com>
182     - [0.92-2]
183     - Changed untaint to slurp in all contents of temp file in order to prevent
184     semicolons in values from corrupting the session. [markk 3630]
185    
186     * Mon Feb 18 2002 Charlie Brady <charlieb@e-smith.com>
187     - Upgrade to version 0.92 (received by email).
188    
189     * Mon Feb 26 2001 Tony Clayton <tonyc@e-smith.com>
190     - initial release

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed