/[smeserver]/rpms/perl-Object-Persistence/sme10/perl-Object-Persistence.spec
ViewVC logotype

Annotation of /rpms/perl-Object-Persistence/sme10/perl-Object-Persistence.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.8 - (hide annotations) (download)
Sun Jun 4 13:22:15 2023 UTC (12 months, 1 week ago) by brianr
Branch: MAIN
CVS Tags: perl-Object-Persistence-0_92-7_el7_sme, HEAD
Changes since 1.7: +6 -2 lines
* Sun Jun 04 2023 brian Read <brianr@koozali.org> -0.92-7.sme
- add manifest.pm to Requirerments [SME: 12364]

1 brianr 1.8 # $Id: perl-Object-Persistence.spec,v 1.7 2016/02/09 22:00:11 vip-ire Exp $
2 vip-ire 1.1
3     #
4     # - Object-Persistence -
5     # This spec file was automatically generated by cpan2rpm [ver: 2.026]
6     # The following arguments were used:
7     # --no-requires=Crypt::Random --release=3 Persistence::Object::Simple
8     # For more information on cpan2rpm please visit: http://perl.arix.com/
9     #
10     %define pkgname Object-Persistence
11     %define filelist %{pkgname}-%{version}-filelist
12     %define NVR %{pkgname}-%{version}-%{release}
13     %define maketest 1
14     %define custom_find_req %{_tmppath}/%{NVR}-find-requires
15     %define _use_internal_dependency_generator 0
16     %define __find_requires %{custom_find_req}
17     %define __perl_requires %{custom_find_req}
18    
19     name: perl-Object-Persistence
20     summary: Object-Persistence - Object Persistence with Data::Dumper.
21     version: 0.92
22 brianr 1.8 release: 7%{?dist}
23 vip-ire 1.1 license: Artistic
24     group: Applications/CPAN
25     url: http://www.cpan.org
26     buildroot: %{_tmppath}/%{name}-%{version}-%(id -u -n)
27     buildarch: noarch
28     prefix: %(echo %{_prefix})
29     source: http://search.cpan.org/dist/V/VI/VIPUL/Object-Persistence-0.92.tar.gz
30     Patch0: %{pkgname}-%{version}.patch.2002052300
31     Patch1: %{pkgname}-%{version}.patch.2004092700
32     Patch2: %{pkgname}-%{version}.patch.forceDumpperl
33    
34 vip-ire 1.6 BuildRequires: perl(ExtUtils::MakeMaker)
35 brianr 1.8 BuildRequires: perl(ExtUtils::Manifest)
36 vip-ire 1.6 BuildRequires: perl(Digest::MD5)
37     BuildRequires: perl(Data::Dumper)
38 vip-ire 1.1
39     %description
40     P::O::S provides persistence functionality to its objects. Object definitions
41     are stored as stringified perl data structures, generated with Data::Dumper,
42     that are amenable to manual editing and external processing from outside the
43     class interface.
44    
45     Persistence is achieved with a blessed hash container that holds the object
46     data. The container can store objects that employ non-hash structures as
47     well. See L<"Inheriting Persistence::Object::Simple">, L<"Class Methods"> and
48     the persistent list class example (examples/Plist.pm).
49    
50     #
51     # This package was generated automatically with the cpan2rpm
52     # utility. To get this software or for more information
53     # please visit: http://perl.arix.com/
54     #
55    
56     %prep
57     %setup -q -n %{pkgname}-%{version}
58     chmod -R u+w %{_builddir}/%{pkgname}-%{version}
59     %patch0 -p1
60     %patch1 -p1
61     %patch2 -p1
62    
63     %build
64     grep -rsl '^#!.*perl' . |
65     grep -v '.bak$' |xargs --no-run-if-empty \
66     %__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
67     CFLAGS="$RPM_OPT_FLAGS"
68     %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '`
69     %{__make}
70     %if %maketest
71     %{__make} test
72     %endif
73    
74     %install
75     [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
76     cat <<EOF > %{custom_find_req}
77     #!/bin/sh
78     /usr/lib/rpm/find-requires |grep -v -e 'Crypt::Random'
79     EOF
80     chmod 755 %{custom_find_req}
81    
82     %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
83    
84     [ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
85    
86     # SuSE Linux
87     if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
88     then
89     %{__mkdir_p} %{buildroot}/var/adm/perl-modules
90     %{__cat} `find %{buildroot} -name "perllocal.pod"` \
91     | %{__sed} -e s+%{buildroot}++g \
92     > %{buildroot}/var/adm/perl-modules/%{name}
93     fi
94    
95     # remove special files
96     find %{buildroot} -name "perllocal.pod" \
97     -o -name ".packlist" \
98     -o -name "*.bs" \
99     |xargs -i rm -f {}
100    
101     # no empty directories
102     find %{buildroot}%{_prefix} \
103     -type d -depth \
104     -exec rmdir {} \; 2>/dev/null
105    
106     %{__perl} -MFile::Find -le '
107     find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
108     print "%doc Changes examples";
109     for my $x (sort @dirs, @files) {
110     push @ret, $x unless indirs($x);
111     }
112     print join "\n", sort @ret;
113    
114     sub wanted {
115     return if /auto$/;
116    
117     local $_ = $File::Find::name;
118     my $f = $_; s|^\Q%{buildroot}\E||;
119     return unless length;
120     return $files[@files] = $_ if -f $f;
121    
122     $d = $_;
123     /\Q$d\E/ && return for reverse sort @INC;
124     $d =~ /\Q$_\E/ && return
125     for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
126    
127     $dirs[@dirs] = $_;
128     }
129    
130     sub indirs {
131     my $x = shift;
132     $x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
133     }
134     ' > %filelist
135    
136     [ -z %filelist ] && {
137     echo "ERROR: empty %files listing"
138     exit -1
139     }
140    
141     %clean
142     [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
143     rm -f %{custom_find_req}
144    
145     %files -f %filelist
146     %defattr(-,root,root)
147    
148     %changelog
149 brianr 1.8 * Sun Jun 04 2023 brian Read <brianr@koozali.org> -0.92-7.sme
150     - add manifest.pm to Requirerments [SME: 12364]
151    
152 vip-ire 1.6 * Tue Feb 9 2016 Daniel Berteaud <daniel@firewall-services.com> - 0.92-6.sme
153     - Add correct BuildReq so it can build on el7 [SME: 9210]
154    
155 stephdl 1.3 * Sun Feb 7 2016 stephane de labrusse <stephdl@de-labrusse.fr> 0.92-5.sme
156     - Build new rpm for sme10
157    
158 vip-ire 1.1 * Wed Sep 9 2015 Daniel Berteaud <daniel@firewall-services.com> - 0.92-5.sme
159     - Add correct BuildReq so it can build on el6 [SME: 8887]
160    
161     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
162     - Clean up spec so package can be built by koji/plague
163    
164     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
165     - Update to new release naming. No functional changes.
166     - Make Packager generic
167    
168     * Wed Sep 13 2006 Michael Soulier <michael_soulier@mitel.com>
169     - Forced Data::Dumper to use Dumpperl to work around interpreter crash.
170     [sme 1837]
171    
172     * Mon Sep 27 2004 Charlie Brady <charlieb@e-smith.com>
173     - [0.92-3es01]
174     - Remove "AutoReqProv: no" so that rpmbuild calculates proper
175     provides. Remove Provides header thus made redudent.
176     [charlieb MN00040240]
177     - Fix croak in Simple.pm so that problems with cache file opens
178     are reported [charlieb ]
179     - Use new cpan2rpm template for build (for compat with CentOS).
180    
181     * Wed Sep 22 2004 Michael Soulier <michael_soulier@mitel.com>
182     - [0.92-2es01]
183     - Rebuilding to get proper provides. [msoulier MN00040240]
184    
185     * Thu May 23 2002 Mark Knox <markk@e-smith.com>
186     - [0.92-2]
187     - Changed untaint to slurp in all contents of temp file in order to prevent
188     semicolons in values from corrupting the session. [markk 3630]
189    
190     * Mon Feb 18 2002 Charlie Brady <charlieb@e-smith.com>
191     - Upgrade to version 0.92 (received by email).
192    
193     * Mon Feb 26 2001 Tony Clayton <tonyc@e-smith.com>
194     - initial release

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed