1 |
# $Id$ |
2 |
# Authority: shuff |
3 |
# Upstream: Tom Zoerner <tomzo$users,sourceforge,net> |
4 |
|
5 |
%define perl_vendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib) |
6 |
%define perl_vendorarch %(eval "`%{__perl} -V:installvendorarch`"; echo $installvendorarch) |
7 |
|
8 |
%define real_name Quota |
9 |
|
10 |
Summary: Perl interface to file system quotas |
11 |
Name: perl-Quota |
12 |
Version: 1.6.7 |
13 |
Release: 2%{?dist} |
14 |
License: Artistic/GPL |
15 |
Group: Applications/CPAN |
16 |
URL: http://search.cpan.org/dist/Quota/ |
17 |
|
18 |
Packager: Steve Huff <shuff@vecna.org> |
19 |
Vendor: Dag Apt Repository, http://dag.wieers.com/apt/ |
20 |
|
21 |
Source: http://www.cpan.org/modules/by-module/Quota/Quota-%{version}.tar.gz |
22 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root |
23 |
|
24 |
BuildRequires: perl |
25 |
BuildRequires: perl(ExtUtils::MakeMaker) |
26 |
BuildRequires: quota quota-devel |
27 |
|
28 |
%description |
29 |
The Quota module provides access to file system quotas. The |
30 |
quotactl system call or ioctl is used to query or set quotas |
31 |
on the local host, or queries are submitted via RPC to a |
32 |
remote host. Mount tables can be parsed with getmntent and |
33 |
paths can be translated to device files (or whatever the |
34 |
actual quotactl implementations needs as argument) of the |
35 |
according file system. |
36 |
|
37 |
%prep |
38 |
%setup -n %{real_name}-%{version} |
39 |
|
40 |
%build |
41 |
CFLAGS="%{optflags} -fPIC" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}" |
42 |
%{__make} %{?_smp_mflags} OPTIMIZE="%{optflags} -fPIC" |
43 |
|
44 |
%install |
45 |
%{__rm} -rf %{buildroot} |
46 |
%{__make} pure_install |
47 |
|
48 |
### Clean up buildroot |
49 |
find %{buildroot} -name .packlist -exec %{__rm} {} \; |
50 |
|
51 |
### Clean up docs |
52 |
find contrib/ -type f -exec %{__chmod} a-x {} \; |
53 |
|
54 |
%clean |
55 |
%{__rm} -rf %{buildroot} |
56 |
|
57 |
%files |
58 |
%defattr(-, root, root, 0755) |
59 |
%doc CHANGES INSTALL MANIFEST META.yml README contrib/ |
60 |
%doc %{_mandir}/man3/Quota.3pm* |
61 |
%{perl_vendorarch}/auto/Quota/ |
62 |
%{perl_vendorarch}/Quota.pm |
63 |
|
64 |
%changelog |
65 |
* Fri Feb 1 2013 Shad L. Lords <slords@mail.com> - 1.6.7-2.sme |
66 |
- Add buildrequires so building on rhel6 works [SME: 7253] |
67 |
|
68 |
* Fri Apr 13 2012 Steve Huf <shuff@vecna.org> - 1.6.7-1 |
69 |
- Updated to version 1.6.7. |
70 |
|
71 |
* Wed Jul 22 2009 Christoph Maser <cmr@financial.com> - 1.6.3-1 |
72 |
- Updated to version 1.6.3. |
73 |
|
74 |
* Wed Jan 23 2008 Dag Wieers <dag@wieers.com> - 1.6.2-1 |
75 |
- Updated to release 1.6.2. |
76 |
|
77 |
* Tue Dec 04 2007 Dag Wieers <dag@wieers.com> - 1.6.1-1 |
78 |
- Updated to release 1.6.1. |
79 |
|
80 |
* Sun Nov 18 2007 Dag Wieers <dag@wieers.com> - 1.6.0-1 |
81 |
- Updated to release 1.6.0. |
82 |
|
83 |
* Sat Nov 5 2005 Dries Verachtert <dries@ulyssis.org> - 1.5.1-1 |
84 |
- Updated to release 1.5.1. |
85 |
|
86 |
* Wed Dec 08 2004 Dries Verachtert <dries@ulyssis.org> - 1.5.0 |
87 |
- Initial package. |