1 |
vip-ire |
1.1 |
Name: perl-Socket |
2 |
|
|
Version: 2.021 |
3 |
vip-ire |
1.2 |
Release: 1%{?dist} |
4 |
vip-ire |
1.1 |
Summary: Networking constants and support functions |
5 |
|
|
License: GPL+ or Artistic |
6 |
|
|
Group: Development/Libraries |
7 |
|
|
URL: http://search.cpan.org/dist/Socket/ |
8 |
|
|
Source0: http://www.cpan.org/authors/id/P/PE/PEVANS/Socket-%{version}.tar.gz |
9 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
10 |
|
|
BuildRequires: perl >= 0:5.006001 |
11 |
|
|
BuildRequires: perl(ExtUtils::MakeMaker) |
12 |
|
|
BuildRequires: perl(ExtUtils::Constant) >= 0.23 |
13 |
|
|
BuildRequires: perl(ExtUtils::CBuilder) |
14 |
|
|
BuildRequires: perl(Test::More) |
15 |
|
|
BuildRequires: /usr/bin/rename |
16 |
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) |
17 |
|
|
|
18 |
|
|
%description |
19 |
|
|
This module provides a variety of constants, structure manipulators and |
20 |
|
|
other functions related to socket-based networking. The values and |
21 |
|
|
functions provided are useful when used in conjunction with Perl core |
22 |
|
|
functions such as socket(), setsockopt() and bind(). It also provides |
23 |
|
|
several other support functions, mostly for dealing with conversions of |
24 |
|
|
network addresses between human-readable and native binary forms, and for |
25 |
|
|
hostname resolver operations. |
26 |
|
|
|
27 |
|
|
%prep |
28 |
|
|
%setup -q -n Socket-%{version} |
29 |
|
|
|
30 |
|
|
%build |
31 |
|
|
%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS" |
32 |
|
|
make %{?_smp_mflags} |
33 |
|
|
|
34 |
|
|
%install |
35 |
|
|
rm -rf $RPM_BUILD_ROOT |
36 |
|
|
|
37 |
|
|
make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT |
38 |
|
|
|
39 |
|
|
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \; |
40 |
|
|
find $RPM_BUILD_ROOT -type f -name '*.bs' -size 0 -exec rm -f {} \; |
41 |
|
|
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \; |
42 |
|
|
|
43 |
|
|
/usr/bin/rename .3pm -%{version}.3pm %{buildroot}%{_mandir}/man3/*.3pm |
44 |
|
|
|
45 |
|
|
%{_fixperms} $RPM_BUILD_ROOT/* |
46 |
|
|
|
47 |
|
|
%check |
48 |
|
|
make test |
49 |
|
|
|
50 |
|
|
%clean |
51 |
|
|
rm -rf $RPM_BUILD_ROOT |
52 |
|
|
|
53 |
|
|
%files |
54 |
|
|
%defattr(-,root,root,-) |
55 |
|
|
%doc Artistic Changes Copying LICENSE META.json |
56 |
|
|
%{perl_vendorarch}/auto/* |
57 |
|
|
%{perl_vendorarch}/Socket* |
58 |
|
|
%{_mandir}/man3/* |
59 |
|
|
|
60 |
|
|
%changelog |
61 |
|
|
* Tue Feb 09 2016 Daniel Berteaud <daniel@firewall-services.com> 2.021-1 |
62 |
|
|
- First build using cpanspec |