1 |
vip-ire |
1.1 |
Name: perl-Time-Local |
2 |
|
|
Version: 1.2300 |
3 |
|
|
Release: 1%{?dist} |
4 |
|
|
Summary: Efficiently compute time from local and GMT time |
5 |
|
|
License: GPL+ or Artistic |
6 |
|
|
Group: Development/Libraries |
7 |
|
|
URL: http://search.cpan.org/dist/Time-Local/ |
8 |
|
|
Source0: http://www.cpan.org/authors/id/D/DR/DROLSKY/Time-Local-%{version}.tar.gz |
9 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
10 |
|
|
BuildArch: noarch |
11 |
|
|
BuildRequires: perl(Carp) |
12 |
|
|
BuildRequires: perl(Config) |
13 |
|
|
BuildRequires: perl(constant) |
14 |
|
|
BuildRequires: perl(Exporter) |
15 |
|
|
BuildRequires: perl(ExtUtils::MakeMaker) |
16 |
|
|
BuildRequires: perl(Test::More) >= 0.88 |
17 |
|
|
BuildRequires: /usr/bin/rename |
18 |
|
|
Requires: perl(Carp) |
19 |
|
|
Requires: perl(Config) |
20 |
|
|
Requires: perl(constant) |
21 |
|
|
Requires: perl(Exporter) |
22 |
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) |
23 |
|
|
|
24 |
|
|
%description |
25 |
|
|
This module provides functions that are the inverse of built-in perl |
26 |
|
|
functions localtime() and gmtime(). They accept a date as a six-element |
27 |
|
|
array, and return the corresponding time(2) value in seconds since the |
28 |
|
|
system epoch (Midnight, January 1, 1970 GMT on Unix, for example). This |
29 |
|
|
value can be positive or negative, though POSIX only requires support for |
30 |
|
|
positive values, so dates before the system's epoch may not work on all |
31 |
|
|
operating systems. |
32 |
|
|
|
33 |
|
|
%prep |
34 |
|
|
%setup -q -n Time-Local-%{version} |
35 |
|
|
|
36 |
|
|
%build |
37 |
|
|
%{__perl} Makefile.PL INSTALLDIRS=vendor |
38 |
|
|
make %{?_smp_mflags} |
39 |
|
|
|
40 |
|
|
%install |
41 |
|
|
rm -rf $RPM_BUILD_ROOT |
42 |
|
|
|
43 |
|
|
make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT |
44 |
|
|
|
45 |
|
|
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \; |
46 |
|
|
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \; |
47 |
|
|
|
48 |
|
|
# Rename man pages so they won't conflict with the main perl package |
49 |
|
|
/usr/bin/rename .3pm -%{version}.3pm %{buildroot}%{_mandir}/man3/*.3pm |
50 |
|
|
|
51 |
|
|
%{_fixperms} $RPM_BUILD_ROOT/* |
52 |
|
|
|
53 |
|
|
%check |
54 |
|
|
make test |
55 |
|
|
|
56 |
|
|
%clean |
57 |
|
|
rm -rf $RPM_BUILD_ROOT |
58 |
|
|
|
59 |
|
|
%files |
60 |
|
|
%defattr(-,root,root,-) |
61 |
|
|
%doc Changes dist.ini LICENSE META.json README |
62 |
|
|
%{perl_vendorlib}/* |
63 |
|
|
%{_mandir}/man3/* |
64 |
|
|
|
65 |
|
|
%changelog |
66 |
|
|
* Tue Feb 09 2016 Daniel Berteaud <daniel@firewall-services.com> 1.2300-1 |
67 |
|
|
- First build using cpanspec |