1 |
jpp |
1.1 |
Name: perl-WWW-CSRF |
2 |
|
|
Version: 1.00 |
3 |
|
|
Release: 0.beta1%{?dist} |
4 |
|
|
Summary: Generate and check tokens to protect against CSRF attacks |
5 |
|
|
License: CHECK(Distributable) |
6 |
|
|
Group: Development/Libraries |
7 |
|
|
URL: http://search.cpan.org/dist/WWW-CSRF/ |
8 |
|
|
Source0: http://www.cpan.org/authors/id/S/SE/SESSE/WWW-CSRF-%{version}.tar.gz |
9 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
10 |
|
|
BuildArch: noarch |
11 |
|
|
BuildRequires: perl(Bytes::Random::Secure) |
12 |
|
|
BuildRequires: perl(Digest::HMAC_SHA1) |
13 |
|
|
BuildRequires: perl(ExtUtils::MakeMaker) |
14 |
|
|
BuildRequires: perl(Test::More) |
15 |
|
|
Requires: perl(Bytes::Random::Secure) |
16 |
|
|
Requires: perl(Digest::HMAC_SHA1) |
17 |
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) |
18 |
|
|
|
19 |
|
|
%description |
20 |
|
|
This module generates tokens to help protect against a website attack known |
21 |
|
|
as Cross-Site Request Forgery (CSRF, also known as XSRF). CSRF is an attack |
22 |
|
|
where an attacker fools a browser into make a request to a web server for |
23 |
|
|
which that browser will automatically include some form of credentials |
24 |
|
|
(cookies, cached HTTP Basic authentication, etc.), thus abusing the web |
25 |
|
|
server's trust in the user for malicious use. |
26 |
|
|
|
27 |
|
|
%prep |
28 |
|
|
%setup -q -n WWW-CSRF-%{version} |
29 |
|
|
|
30 |
|
|
%build |
31 |
|
|
%{__perl} Makefile.PL INSTALLDIRS=vendor |
32 |
|
|
make %{?_smp_mflags} |
33 |
|
|
|
34 |
|
|
%install |
35 |
|
|
rm -rf $RPM_BUILD_ROOT |
36 |
|
|
|
37 |
|
|
make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT |
38 |
|
|
|
39 |
|
|
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \; |
40 |
|
|
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \; |
41 |
|
|
|
42 |
|
|
%{_fixperms} $RPM_BUILD_ROOT/* |
43 |
|
|
|
44 |
|
|
%check |
45 |
|
|
make test |
46 |
|
|
|
47 |
|
|
%clean |
48 |
|
|
rm -rf $RPM_BUILD_ROOT |
49 |
|
|
|
50 |
|
|
%files |
51 |
|
|
%defattr(-,root,root,-) |
52 |
|
|
%doc Changes META.json |
53 |
|
|
%{perl_vendorlib}/* |
54 |
|
|
%{_mandir}/man3/* |
55 |
|
|
|
56 |
|
|
%changelog |
57 |
|
|
* Mon Oct 08 2018 Daniel Berteaud <daniel@firewall-services.com> - 1.00-1 |
58 |
|
|
- First build using cpanspec |