1 |
unnilennium |
1.1 |
%define peardir /usr/share/pear |
2 |
|
|
%define xmldir /var/lib/pear |
3 |
unnilennium |
1.2 |
%{!?pear_metadir: %global pear_metadir %{pear_phpdir}} |
4 |
|
|
%{!?__pear: %global __pear %{_bindir}/pear} |
5 |
|
|
%global pear_name Horde_ActiveSync |
6 |
|
|
%global pear_channel pear.horde.org |
7 |
unnilennium |
1.1 |
|
8 |
|
|
Summary: PEAR: Horde ActiveSync Server Library |
9 |
|
|
Name: php-horde-Horde-ActiveSync |
10 |
|
|
Version: 2.34.0 |
11 |
|
|
Release: 1%{?dist} |
12 |
|
|
License: GPL-2.0 |
13 |
|
|
Group: Development/Libraries |
14 |
|
|
Source0: http://pear.horde.org/get/Horde_ActiveSync-%{version}.tgz |
15 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n) |
16 |
|
|
URL: http://pear.horde.org/package/Horde_ActiveSync |
17 |
|
|
BuildRequires: php-pear(PEAR) >= 1.4.7 |
18 |
|
|
BuildRequires: php-channel(pear.horde.org) |
19 |
unnilennium |
1.2 |
Requires: php-horde-Horde_Role >= 1.0.0 |
20 |
|
|
Requires: php-horde-Horde_Compress >= 2.0.0 |
21 |
|
|
Requires: php-horde-Horde_Compress < 3.0.0alpha1 |
22 |
|
|
Requires: php-horde-Horde_Date >= 2.0.0 |
23 |
|
|
Requires: php-horde-Horde_Date < 3.0.0alpha1 |
24 |
|
|
Requires: php-horde-Horde_Exception >= 2.0.0 |
25 |
|
|
Requires: php-horde-Horde_Exception < 3.0.0alpha1 |
26 |
|
|
Requires: php-horde-Horde_Icalendar >= 2.0.0 |
27 |
|
|
Requires: php-horde-Horde_Icalendar < 3.0.0alpha1 |
28 |
|
|
Requires: php-horde-Horde_Mapi >= 1.0.0 |
29 |
|
|
Requires: php-horde-Horde_Mapi < 2.0.0alpha1 |
30 |
|
|
Requires: php-horde-Horde_Mime >= 2.0.0 |
31 |
|
|
Requires: php-horde-Horde_Mime < 3.0.0alpha1 |
32 |
|
|
Requires: php-horde-Horde_Stream >= 1.4.0 |
33 |
|
|
Requires: php-horde-Horde_Stream < 2.0.0alpha1 |
34 |
|
|
Requires: php-horde-Horde_Support >= 2.0.0 |
35 |
|
|
Requires: php-horde-Horde_Support < 3.0.0alpha1 |
36 |
|
|
Requires: php-horde-Horde_Util >= 2.0.0 |
37 |
|
|
Requires: php-horde-Horde_Util < 3.0.0alpha1 |
38 |
unnilennium |
1.1 |
Requires: php-pear(PEAR) >= 1.7.0 |
39 |
|
|
Requires: php-channel(pear.horde.org) |
40 |
|
|
BuildArch: noarch |
41 |
unnilennium |
1.2 |
BuildRequires: php-horde-Horde-Role |
42 |
|
|
#BuildRequires: php-phpunit-PHPUnit |
43 |
unnilennium |
1.1 |
Provides: %{name} = %{version} |
44 |
|
|
|
45 |
|
|
%description |
46 |
|
|
Libraries for implementing an ActiveSync server. |
47 |
|
|
|
48 |
|
|
%prep |
49 |
unnilennium |
1.2 |
%setup -q -c |
50 |
|
|
|
51 |
|
|
cd %{pear_name}-%{version} |
52 |
|
|
|
53 |
|
|
# Don't install .po and .pot files |
54 |
|
|
# Remove checksum for .mo, as we regenerate them |
55 |
|
|
sed -e '/%{pear_name}.po/d' \ |
56 |
|
|
-e '/Horde_Other.po/d' \ |
57 |
|
|
-e '/%{pear_name}.mo/s/md5sum="[^"]*"//' \ |
58 |
|
|
../package.xml >%{name}.xml |
59 |
|
|
touch -r ../package.xml %{name}.xml |
60 |
|
|
|
61 |
unnilennium |
1.1 |
|
62 |
|
|
%build |
63 |
unnilennium |
1.2 |
cd %{pear_name}-%{version} |
64 |
|
|
|
65 |
|
|
# Regenerate the locales |
66 |
|
|
for po in $(find locale -name \*.po) |
67 |
|
|
do |
68 |
|
|
msgfmt $po -o $(dirname $po)/$(basename $po .po).mo |
69 |
|
|
done |
70 |
|
|
|
71 |
unnilennium |
1.1 |
|
72 |
|
|
%install |
73 |
unnilennium |
1.2 |
cd %{pear_name}-%{version} |
74 |
|
|
%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml |
75 |
|
|
|
76 |
unnilennium |
1.1 |
# Clean up unnecessary files |
77 |
unnilennium |
1.2 |
rm -rf %{buildroot}%{pear_metadir}/.??* |
78 |
unnilennium |
1.1 |
|
79 |
unnilennium |
1.2 |
# Install XML package description |
80 |
|
|
mkdir -p %{buildroot}%{pear_xmldir} |
81 |
|
|
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir} |
82 |
unnilennium |
1.1 |
|
83 |
unnilennium |
1.2 |
# Locales |
84 |
|
|
for loc in locale/{??,??_??} |
85 |
|
|
do |
86 |
|
|
lang=$(basename $loc) |
87 |
|
|
test -d %{buildroot}%{pear_datadir}/%{pear_name}/$loc \ |
88 |
|
|
&& echo "%%lang(${lang%_*}) %{pear_datadir}/%{pear_name}/$loc" |
89 |
|
|
done | tee ../%{pear_name}.lang |
90 |
|
|
|
91 |
|
|
|
92 |
|
|
%check |
93 |
|
|
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g) |
94 |
|
|
#%{_bindir}/phpunit --verbose . |
95 |
|
|
|
96 |
|
|
#if which php70; then |
97 |
|
|
# php70 %{_bindir}/phpunit --verbose . |
98 |
|
|
#fi |
99 |
unnilennium |
1.1 |
|
100 |
|
|
|
101 |
|
|
%post |
102 |
unnilennium |
1.2 |
%{__pear} install --nodeps --soft --force --register-only \ |
103 |
|
|
%{pear_xmldir}/%{name}.xml >/dev/null || : |
104 |
unnilennium |
1.1 |
|
105 |
|
|
%postun |
106 |
unnilennium |
1.2 |
if [ $1 -eq 0 ] ; then |
107 |
|
|
%{__pear} uninstall --nodeps --ignore-errors --register-only \ |
108 |
|
|
%{pear_channel}/%{pear_name} >/dev/null || : |
109 |
unnilennium |
1.1 |
fi |
110 |
|
|
|
111 |
unnilennium |
1.2 |
|
112 |
|
|
%files -f %{pear_name}.lang |
113 |
|
|
%doc %{pear_docdir}/%{pear_name} |
114 |
|
|
%{pear_xmldir}/%{name}.xml |
115 |
|
|
#%dir %{pear_phpdir}/Horde/Service |
116 |
|
|
#%{pear_phpdir}/Horde/Service/ActiveSync |
117 |
|
|
#%{pear_phpdir}/Horde/Service/ActiveSync.php |
118 |
|
|
%dir %{pear_datadir}/%{pear_name} |
119 |
|
|
%dir %{pear_datadir}/%{pear_name}/locale |
120 |
|
|
%{pear_testdir}/%{pear_name} |
121 |
|
|
#%{pear_hordedir}/themes |
122 |
|
|
#%dir /usr/share/pear-data/Horde_ActiveSync |
123 |
|
|
#%dir /usr/share/pear-data/Horde_ActiveSync/migration/ |
124 |
|
|
/usr/share/pear-data/Horde_ActiveSync/migration/* |
125 |
|
|
/usr/share/pear/Horde/* |
126 |
|
|
#/usr/share/pear/Horde/ActiveSync/* |
127 |
unnilennium |
1.1 |
|
128 |
|
|
%changelog |
129 |
|
|
* Tue Jun 7 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.34.0-1 |
130 |
|
|
- Updated to 2.33.3 |
131 |
|
|
|
132 |
|
|
* Wed Apr 27 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.31.9-1 |
133 |
|
|
- Updated to 2.31.9 |
134 |
|
|
|
135 |
|
|
* Sat Mar 26 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.31.8-1 |
136 |
|
|
- Updated to 2.31.8 |
137 |
|
|
|
138 |
|
|
* Wed Feb 24 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.31.5-1 |
139 |
|
|
- Updated to 2.31.5 |
140 |
|
|
|
141 |
|
|
* Sun Jan 31 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.30.6-1 |
142 |
|
|
- Updated to 2.30.6 |
143 |
|
|
|
144 |
|
|
* Mon Jan 18 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.30.5-1 |
145 |
|
|
- Updated to 2.30.5 |
146 |
|
|
|
147 |
|
|
* Sat Dec 26 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.30.3-1 |
148 |
|
|
- Updated to 2.30.3 |
149 |
|
|
|
150 |
|
|
* Sat Dec 26 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.30.3-1 |
151 |
|
|
- Updated to 2.30.3 |
152 |
|
|
|
153 |
|
|
* Wed Nov 25 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.30.2-1 |
154 |
|
|
- Updated to 2.30.2 |
155 |
|
|
|
156 |
|
|
* Wed Oct 28 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.30.1-1 |
157 |
|
|
- Updated to 2.30.1 |
158 |
|
|
|
159 |
|
|
* Fri Oct 23 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.30.0-1 |
160 |
|
|
- Updated to 2.30.0 |
161 |
|
|
|
162 |
|
|
* Tue Sep 22 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.29.2-1 |
163 |
|
|
- Updated to 2.29.2 |
164 |
|
|
|
165 |
|
|
* Fri Sep 4 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.29.1-1 |
166 |
|
|
- Updated to 2.29.1 |
167 |
|
|
|
168 |
|
|
* Sat Aug 1 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.28.6-1 |
169 |
|
|
- Updated to 2.28.6 |
170 |
|
|
|
171 |
|
|
* Mon Jun 15 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.28.5-1 |
172 |
|
|
- Updated to 2.28.5 |
173 |
|
|
|
174 |
|
|
* Wed Jun 3 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.28.4-1 |
175 |
|
|
- Updated to 2.28.4 |
176 |
|
|
|
177 |
|
|
* Sat May 2 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.27.1-1 |
178 |
|
|
- Updated to 2.27.1 |
179 |
|
|
|
180 |
|
|
* Sat Apr 4 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.27.0-1 |
181 |
|
|
- Updated to 2.27.0 |
182 |
|
|
|
183 |
|
|
* Sat Mar 7 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.26.1-1 |
184 |
|
|
- Updated to 2.26.1 |
185 |
|
|
|
186 |
|
|
* Wed Feb 25 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.26.0-1 |
187 |
|
|
- Updated to 2.26.0 |
188 |
|
|
|
189 |
|
|
* Fri Feb 6 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.24.1-1 |
190 |
|
|
- Updated to 2.24.1 |
191 |
|
|
|
192 |
|
|
* Sat Jan 10 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.24.0-1 |
193 |
|
|
- Updated to 2.24.0 |
194 |
|
|
|
195 |
|
|
* Sun Dec 28 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.23.0-1 |
196 |
|
|
- Updated to 2.23.0 |
197 |
|
|
|
198 |
|
|
* Thu Dec 12 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.21.0-1 |
199 |
|
|
- Updated to 2.21.0 |
200 |
|
|
|
201 |
|
|
* Tue Dec 9 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.20.5-1 |
202 |
|
|
- Updated to 2.20.4 |
203 |
|
|
|
204 |
|
|
* Tue Oct 21 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.19.4-1 |
205 |
|
|
- Updated to 2.19.4 |
206 |
|
|
|
207 |
|
|
* Tue Oct 07 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.19.3-1 |
208 |
|
|
- Updated to 2.19.3 |
209 |
|
|
|
210 |
|
|
* Sat Sep 20 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.19.1-1 |
211 |
|
|
- Updated to 2.19.1 |
212 |
|
|
|
213 |
|
|
* Wed Sep 3 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.18.1-1 |
214 |
|
|
- Updated to 2.18.1 |
215 |
|
|
|
216 |
|
|
* Wed Aug 27 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.18.0-1 |
217 |
|
|
- Updated to 2.18.0 |
218 |
|
|
|
219 |
|
|
* Tue Aug 13 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.17.0-1 |
220 |
|
|
- Updated to 2.17.0 |
221 |
|
|
|
222 |
|
|
* Sun Jul 13 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.16.11-1 |
223 |
|
|
- Updated to 2.16.11 |
224 |
|
|
|
225 |
|
|
* Wed Jun 25 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.16.7-1 |
226 |
|
|
- Updated to 2.16.7 |
227 |
|
|
|
228 |
|
|
* Tue Apr 29 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.14.1-1 |
229 |
|
|
- Updated to 2.14.1 |
230 |
|
|
|
231 |
|
|
* Thu Apr 3 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.13.4-1 |
232 |
|
|
- Updated to 2.13.4 |
233 |
|
|
|
234 |
|
|
* Mon Mar 24 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.13.3-1 |
235 |
|
|
- Updated to 2.13.3 |
236 |
|
|
|
237 |
|
|
* Sun Mar 16 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.13.2-1 |
238 |
|
|
- Updated to 2.13.2 |
239 |
|
|
|
240 |
|
|
* Tue Mar 11 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.13.1-1 |
241 |
|
|
- Updated to 2.13.1 |
242 |
|
|
|
243 |
|
|
* Sat Feb 8 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.12.4-1 |
244 |
|
|
- Updated to 2.12.4 |
245 |
|
|
- added Horde_Mapi requirement. New for 2.12 release |
246 |
|
|
|
247 |
|
|
* Wed Nov 20 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.9.1-1 |
248 |
|
|
- Updated to 2.9.1 |
249 |
|
|
|
250 |
|
|
* Tue Nov 19 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.9.0-1 |
251 |
|
|
- Updated to 2.9.0 |
252 |
|
|
|
253 |
|
|
* Thu Oct 24 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.8.5-1 |
254 |
|
|
- Updated to 2.8.5 |
255 |
|
|
|
256 |
|
|
* Fri Sep 6 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.7.3-1 |
257 |
|
|
- Updated to 2.7.3 |
258 |
|
|
|
259 |
|
|
* Sun Jul 21 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.5.6-1 |
260 |
|
|
- Updated to 2.5.6 |
261 |
|
|
|
262 |
|
|
* Mon Jun 3 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.3.6-1 |
263 |
|
|
- Initial release for SME Server |
264 |
|
|
- Original build from pear make-rpm-spec |
265 |
|
|
|