/[smeserver]/rpms/php-horde-Horde-ActiveSync/sme10/Horde_Activesync.spec
ViewVC logotype

Annotation of /rpms/php-horde-Horde-ActiveSync/sme10/Horde_Activesync.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Thu Jun 16 18:52:20 2016 UTC (7 years, 11 months ago) by unnilennium
Branch: MAIN
CVS Tags: php-horde-Horde-ActiveSync-2_34_0-2_el7_sme
Changes since 1.2: +21 -4 lines
* Thu Jun 16 2016 Jean-Philipe Pialasse <tests@pialasse.com> 2.34.0-2.sme
- new spec file to build in SME buildsys
- inspired from Remi Collet php-horde-Service-Weather
- [SME: 9602]

1 unnilennium 1.1 %define peardir /usr/share/pear
2     %define xmldir /var/lib/pear
3 unnilennium 1.2 %{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
4     %{!?__pear: %global __pear %{_bindir}/pear}
5     %global pear_name Horde_ActiveSync
6     %global pear_channel pear.horde.org
7 unnilennium 1.3 %define name php-horde-Horde-ActiveSync
8     %define version 2.34.0
9     %define release 2
10    
11     Name: %{name}
12     Version: %{version}
13     Release: %{release}%{?dist}
14 unnilennium 1.1 Summary: PEAR: Horde ActiveSync Server Library
15     License: GPL-2.0
16     Group: Development/Libraries
17     Source0: http://pear.horde.org/get/Horde_ActiveSync-%{version}.tgz
18     BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n)
19     URL: http://pear.horde.org/package/Horde_ActiveSync
20     BuildRequires: php-pear(PEAR) >= 1.4.7
21     BuildRequires: php-channel(pear.horde.org)
22 unnilennium 1.2 Requires: php-horde-Horde_Role >= 1.0.0
23     Requires: php-horde-Horde_Compress >= 2.0.0
24     Requires: php-horde-Horde_Compress < 3.0.0alpha1
25     Requires: php-horde-Horde_Date >= 2.0.0
26     Requires: php-horde-Horde_Date < 3.0.0alpha1
27     Requires: php-horde-Horde_Exception >= 2.0.0
28     Requires: php-horde-Horde_Exception < 3.0.0alpha1
29     Requires: php-horde-Horde_Icalendar >= 2.0.0
30     Requires: php-horde-Horde_Icalendar < 3.0.0alpha1
31     Requires: php-horde-Horde_Mapi >= 1.0.0
32     Requires: php-horde-Horde_Mapi < 2.0.0alpha1
33     Requires: php-horde-Horde_Mime >= 2.0.0
34     Requires: php-horde-Horde_Mime < 3.0.0alpha1
35     Requires: php-horde-Horde_Stream >= 1.4.0
36     Requires: php-horde-Horde_Stream < 2.0.0alpha1
37     Requires: php-horde-Horde_Support >= 2.0.0
38     Requires: php-horde-Horde_Support < 3.0.0alpha1
39     Requires: php-horde-Horde_Util >= 2.0.0
40     Requires: php-horde-Horde_Util < 3.0.0alpha1
41 unnilennium 1.1 Requires: php-pear(PEAR) >= 1.7.0
42     Requires: php-channel(pear.horde.org)
43     BuildArch: noarch
44 unnilennium 1.2 BuildRequires: php-horde-Horde-Role
45 unnilennium 1.3 BuildRequires: gettext
46     # To run unit tests
47 unnilennium 1.2 #BuildRequires: php-phpunit-PHPUnit
48 unnilennium 1.3 #BuildRequires: php-pear(%{pear_channel}/Horde_Date) >= 2.0.0
49     #BuildRequires: php-pear(%{pear_channel}/Horde_Http) >= 2.0.0
50     #BuildRequires: php-pear(%{pear_channel}/Horde_Serialize) >= 2.0.0
51     #BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
52     #BuildRequires: php-pear(%{pear_channel}/Horde_Url) >= 2.0.0
53    
54    
55 unnilennium 1.1 Provides: %{name} = %{version}
56    
57     %description
58     Libraries for implementing an ActiveSync server.
59    
60     %prep
61 unnilennium 1.2 %setup -q -c
62    
63     cd %{pear_name}-%{version}
64    
65     # Don't install .po and .pot files
66     # Remove checksum for .mo, as we regenerate them
67     sed -e '/%{pear_name}.po/d' \
68     -e '/Horde_Other.po/d' \
69     -e '/%{pear_name}.mo/s/md5sum="[^"]*"//' \
70     ../package.xml >%{name}.xml
71     touch -r ../package.xml %{name}.xml
72    
73 unnilennium 1.1
74     %build
75 unnilennium 1.2 cd %{pear_name}-%{version}
76    
77     # Regenerate the locales
78     for po in $(find locale -name \*.po)
79     do
80     msgfmt $po -o $(dirname $po)/$(basename $po .po).mo
81     done
82    
83 unnilennium 1.1
84     %install
85 unnilennium 1.2 cd %{pear_name}-%{version}
86     %{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
87    
88 unnilennium 1.1 # Clean up unnecessary files
89 unnilennium 1.2 rm -rf %{buildroot}%{pear_metadir}/.??*
90 unnilennium 1.1
91 unnilennium 1.2 # Install XML package description
92     mkdir -p %{buildroot}%{pear_xmldir}
93     install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
94 unnilennium 1.1
95 unnilennium 1.2 # Locales
96     for loc in locale/{??,??_??}
97     do
98     lang=$(basename $loc)
99     test -d %{buildroot}%{pear_datadir}/%{pear_name}/$loc \
100     && echo "%%lang(${lang%_*}) %{pear_datadir}/%{pear_name}/$loc"
101     done | tee ../%{pear_name}.lang
102    
103    
104     %check
105     cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
106     #%{_bindir}/phpunit --verbose .
107    
108     #if which php70; then
109     # php70 %{_bindir}/phpunit --verbose .
110     #fi
111 unnilennium 1.1
112    
113     %post
114 unnilennium 1.2 %{__pear} install --nodeps --soft --force --register-only \
115     %{pear_xmldir}/%{name}.xml >/dev/null || :
116 unnilennium 1.1
117     %postun
118 unnilennium 1.2 if [ $1 -eq 0 ] ; then
119     %{__pear} uninstall --nodeps --ignore-errors --register-only \
120     %{pear_channel}/%{pear_name} >/dev/null || :
121 unnilennium 1.1 fi
122    
123 unnilennium 1.2
124     %files -f %{pear_name}.lang
125     %doc %{pear_docdir}/%{pear_name}
126     %{pear_xmldir}/%{name}.xml
127     #%dir %{pear_phpdir}/Horde/Service
128     #%{pear_phpdir}/Horde/Service/ActiveSync
129     #%{pear_phpdir}/Horde/Service/ActiveSync.php
130     %dir %{pear_datadir}/%{pear_name}
131     %dir %{pear_datadir}/%{pear_name}/locale
132     %{pear_testdir}/%{pear_name}
133     #%{pear_hordedir}/themes
134     #%dir /usr/share/pear-data/Horde_ActiveSync
135     #%dir /usr/share/pear-data/Horde_ActiveSync/migration/
136     /usr/share/pear-data/Horde_ActiveSync/migration/*
137     /usr/share/pear/Horde/*
138     #/usr/share/pear/Horde/ActiveSync/*
139 unnilennium 1.1
140     %changelog
141 unnilennium 1.3 * Thu Jun 16 2016 Jean-Philipe Pialasse <tests@pialasse.com> 2.34.0-2.sme
142     - new spec file to build in SME buildsys
143     - inspired from Remi Collet php-horde-Service-Weather
144     - [SME: 9602]
145    
146 unnilennium 1.1 * Tue Jun 7 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.34.0-1
147     - Updated to 2.33.3
148    
149     * Wed Apr 27 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.31.9-1
150     - Updated to 2.31.9
151    
152     * Sat Mar 26 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.31.8-1
153     - Updated to 2.31.8
154    
155     * Wed Feb 24 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.31.5-1
156     - Updated to 2.31.5
157    
158     * Sun Jan 31 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.30.6-1
159     - Updated to 2.30.6
160    
161     * Mon Jan 18 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.30.5-1
162     - Updated to 2.30.5
163    
164     * Sat Dec 26 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.30.3-1
165     - Updated to 2.30.3
166    
167     * Sat Dec 26 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.30.3-1
168     - Updated to 2.30.3
169    
170     * Wed Nov 25 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.30.2-1
171     - Updated to 2.30.2
172    
173     * Wed Oct 28 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.30.1-1
174     - Updated to 2.30.1
175    
176     * Fri Oct 23 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.30.0-1
177     - Updated to 2.30.0
178    
179     * Tue Sep 22 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.29.2-1
180     - Updated to 2.29.2
181    
182     * Fri Sep 4 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.29.1-1
183     - Updated to 2.29.1
184    
185     * Sat Aug 1 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.28.6-1
186     - Updated to 2.28.6
187    
188     * Mon Jun 15 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.28.5-1
189     - Updated to 2.28.5
190    
191     * Wed Jun 3 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.28.4-1
192     - Updated to 2.28.4
193    
194     * Sat May 2 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.27.1-1
195     - Updated to 2.27.1
196    
197     * Sat Apr 4 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.27.0-1
198     - Updated to 2.27.0
199    
200     * Sat Mar 7 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.26.1-1
201     - Updated to 2.26.1
202    
203     * Wed Feb 25 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.26.0-1
204     - Updated to 2.26.0
205    
206     * Fri Feb 6 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.24.1-1
207     - Updated to 2.24.1
208    
209     * Sat Jan 10 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.24.0-1
210     - Updated to 2.24.0
211    
212     * Sun Dec 28 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.23.0-1
213     - Updated to 2.23.0
214    
215     * Thu Dec 12 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.21.0-1
216     - Updated to 2.21.0
217    
218     * Tue Dec 9 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.20.5-1
219     - Updated to 2.20.4
220    
221     * Tue Oct 21 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.19.4-1
222     - Updated to 2.19.4
223    
224     * Tue Oct 07 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.19.3-1
225     - Updated to 2.19.3
226    
227     * Sat Sep 20 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.19.1-1
228     - Updated to 2.19.1
229    
230     * Wed Sep 3 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.18.1-1
231     - Updated to 2.18.1
232    
233     * Wed Aug 27 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.18.0-1
234     - Updated to 2.18.0
235    
236     * Tue Aug 13 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.17.0-1
237     - Updated to 2.17.0
238    
239     * Sun Jul 13 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.16.11-1
240     - Updated to 2.16.11
241    
242     * Wed Jun 25 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.16.7-1
243     - Updated to 2.16.7
244    
245     * Tue Apr 29 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.14.1-1
246     - Updated to 2.14.1
247    
248     * Thu Apr 3 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.13.4-1
249     - Updated to 2.13.4
250    
251     * Mon Mar 24 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.13.3-1
252     - Updated to 2.13.3
253    
254     * Sun Mar 16 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.13.2-1
255     - Updated to 2.13.2
256    
257     * Tue Mar 11 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.13.1-1
258     - Updated to 2.13.1
259    
260     * Sat Feb 8 2014 John H. Bennett III <bennettj@johnbennettservices.com> - 2.12.4-1
261     - Updated to 2.12.4
262     - added Horde_Mapi requirement. New for 2.12 release
263    
264     * Wed Nov 20 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.9.1-1
265     - Updated to 2.9.1
266    
267     * Tue Nov 19 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.9.0-1
268     - Updated to 2.9.0
269    
270     * Thu Oct 24 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.8.5-1
271     - Updated to 2.8.5
272    
273     * Fri Sep 6 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.7.3-1
274     - Updated to 2.7.3
275    
276     * Sun Jul 21 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.5.6-1
277     - Updated to 2.5.6
278    
279     * Mon Jun 3 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.3.6-1
280     - Initial release for SME Server
281     - Original build from pear make-rpm-spec
282    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed