1 |
unnilennium |
1.1 |
%define peardir /usr/share/pear |
2 |
|
|
%define xmldir /var/lib/pear |
3 |
|
|
|
4 |
|
|
Summary: PEAR: Horde Facebook client |
5 |
|
|
Name: php-horde-Horde-Service-Facebook |
6 |
|
|
Version: 2.0.9 |
7 |
|
|
Release: 1%{?dist} |
8 |
|
|
License: BSD-2-Clause |
9 |
|
|
Group: Development/Libraries |
10 |
|
|
Source0: http://pear.horde.org/get/Horde_Service_Facebook-%{version}.tgz |
11 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n) |
12 |
|
|
URL: http://pear.horde.org/package/Horde_Service_Facebook |
13 |
|
|
BuildRequires: php-pear(PEAR) >= 1.4.7 |
14 |
|
|
BuildRequires: php-channel(pear.horde.org) |
15 |
|
|
Requires: Horde_Role >= 1.0.0 |
16 |
|
|
Requires: Horde_Exception >= 2.0.0 |
17 |
|
|
Requires: Horde_Exception < 3.0.0alpha1 |
18 |
|
|
Requires: Horde_Http >= 2.0.0 |
19 |
|
|
Requires: Horde_Http < 3.0.0alpha1 |
20 |
|
|
Requires: Horde_Translation >= 2.0.0 |
21 |
|
|
Requires: Horde_Translation < 3.0.0alpha1 |
22 |
|
|
Requires: Horde_Support >= 2.0.0 |
23 |
|
|
Requires: Horde_Support < 3.0.0alpha1 |
24 |
|
|
Requires: php-pear(PEAR) >= 1.7.0 |
25 |
|
|
Requires: php-channel(pear.horde.org) |
26 |
|
|
BuildArch: noarch |
27 |
|
|
|
28 |
|
|
Provides: %{name} = %{version} |
29 |
|
|
|
30 |
|
|
%description |
31 |
|
|
Client libraries for the Facebook REST API. |
32 |
|
|
|
33 |
|
|
%prep |
34 |
|
|
%setup -c -T |
35 |
|
|
pear -v -c pearrc \ |
36 |
|
|
-d php_dir=%{peardir} \ |
37 |
|
|
-d doc_dir=%{pear_docdir} \ |
38 |
|
|
-d bin_dir=%{_bindir} \ |
39 |
|
|
-d data_dir=%{peardir}/data \ |
40 |
|
|
-d test_dir=%{peardir}/tests \ |
41 |
|
|
-d ext_dir=%{_libdir} \ |
42 |
|
|
-d horde_dir=%{pear_hordedir} \ |
43 |
|
|
-s |
44 |
|
|
|
45 |
|
|
%build |
46 |
|
|
|
47 |
|
|
%install |
48 |
|
|
rm -rf %{buildroot} |
49 |
|
|
pear -c pearrc install --nodeps --packagingroot %{buildroot} %{SOURCE0} |
50 |
|
|
|
51 |
|
|
# Clean up unnecessary files |
52 |
|
|
rm pearrc |
53 |
|
|
rm %{buildroot}/%{peardir}/.filemap |
54 |
|
|
rm %{buildroot}/%{peardir}/.lock |
55 |
|
|
rm -rf %{buildroot}/%{peardir}/.registry |
56 |
|
|
rm -rf %{buildroot}%{peardir}/.channels |
57 |
|
|
rm %{buildroot}%{peardir}/.depdb |
58 |
|
|
rm %{buildroot}%{peardir}/.depdblock |
59 |
|
|
|
60 |
|
|
#mv %{buildroot}/docs . |
61 |
|
|
|
62 |
|
|
|
63 |
|
|
# Install XML package description |
64 |
|
|
mkdir -p %{buildroot}%{xmldir} |
65 |
|
|
tar -xzf %{SOURCE0} package.xml |
66 |
|
|
cp -p package.xml %{buildroot}%{xmldir}/Horde_Service_Facebook.xml |
67 |
|
|
|
68 |
|
|
%clean |
69 |
|
|
rm -rf %{buildroot} |
70 |
|
|
|
71 |
|
|
%post |
72 |
|
|
pear install --nodeps --soft --force --register-only %{xmldir}/Horde_Service_Facebook.xml >/dev/null || : |
73 |
|
|
|
74 |
|
|
%postun |
75 |
|
|
if [ "$1" -eq "0" ]; then |
76 |
|
|
pear uninstall --nodeps --ignore-errors --register-only pear.horde.org/Horde_Service_Facebook >/dev/null || : |
77 |
|
|
fi |
78 |
|
|
|
79 |
|
|
%files |
80 |
|
|
%defattr(-,root,root) |
81 |
|
|
#%doc docs/Horde_Service_Facebook/* |
82 |
|
|
%{peardir}/* |
83 |
|
|
%{xmldir}/Horde_Service_Facebook.xml |
84 |
|
|
|
85 |
|
|
%changelog |
86 |
|
|
* Tue Apr 5 2016 John H. Bennett III <bennettj@johnbennettservices.com> - 2.0.9-1 |
87 |
|
|
- Updated to 2.0.9 |
88 |
|
|
|
89 |
|
|
* Sat May 2 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.0.8-1 |
90 |
|
|
- Updated to 2.0.8 |
91 |
|
|
|
92 |
|
|
* Sat Jan 10 2015 John H. Bennett III <bennettj@johnbennettservices.com> - 2.0.7-1 |
93 |
|
|
- Updated to 2.0.7 |
94 |
|
|
|
95 |
|
|
* Wed Oct 16 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.0.6-1 |
96 |
|
|
- Updated to 2.0.6 |
97 |
|
|
|
98 |
|
|
* Fri Aug 30 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.0.5-1 |
99 |
|
|
- Updated to 2.0.5 |
100 |
|
|
|
101 |
|
|
* Tue Jun 4 2013 John H. Bennett III <bennettj@johnbennettservices.com> - 2.0.4-1 |
102 |
|
|
- Initial release for SME Server |
103 |
|
|
- Original build from pear make-rpm-spec |