1 |
unnilennium |
1.1 |
# remirepo/fedora spec file for php-horde-horde |
2 |
|
|
# |
3 |
|
|
# Copyright (c) 2012-2016 Remi Collet |
4 |
|
|
# License: CC-BY-SA |
5 |
|
|
# http://creativecommons.org/licenses/by-sa/4.0/ |
6 |
|
|
# |
7 |
|
|
# Please, preserve the changelog entries |
8 |
|
|
# |
9 |
|
|
%{!?__pear: %global __pear %{_bindir}/pear} |
10 |
|
|
%global pear_name horde |
11 |
|
|
%global pear_channel pear.horde.org |
12 |
|
|
# To use system js |
13 |
|
|
%global with_sysjs 0 |
14 |
|
|
|
15 |
|
|
Name: php-horde-horde |
16 |
|
|
Version: 5.2.11 |
17 |
|
|
Release: 1%{?dist} |
18 |
|
|
Summary: Horde Application Framework |
19 |
|
|
|
20 |
|
|
Group: Development/Libraries |
21 |
|
|
License: LGPLv2 |
22 |
|
|
URL: http://www.horde.org/apps/horde |
23 |
|
|
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz |
24 |
|
|
Source2: horde.conf |
25 |
|
|
Source3: horde-logrotate |
26 |
|
|
|
27 |
|
|
BuildArch: noarch |
28 |
|
|
BuildRequires: gettext |
29 |
|
|
BuildRequires: php(language) >= 5.3.0 |
30 |
|
|
BuildRequires: php-pear(PEAR) >= 1.7.0 |
31 |
|
|
BuildRequires: php-channel(%{pear_channel}) |
32 |
|
|
BuildRequires: php-pear(%{pear_channel}/Horde_Role) >= 1.0.0 |
33 |
|
|
|
34 |
|
|
Requires(post): %{__pear} |
35 |
|
|
Requires(postun): %{__pear} |
36 |
|
|
# Web stuff |
37 |
|
|
Requires: mod_php |
38 |
|
|
Requires: httpd |
39 |
|
|
Requires: %{_sysconfdir}/logrotate.d |
40 |
|
|
%if %{with_sysjs} |
41 |
|
|
Requires: prototype-httpd |
42 |
|
|
Requires: scriptaculous-httpd |
43 |
|
|
Requires: syntaxhighlighter-httpd |
44 |
|
|
Requires: ckeditor |
45 |
|
|
%else |
46 |
|
|
Requires: horde-prototype |
47 |
|
|
Requires: horde-scriptaculous |
48 |
|
|
Requires: horde-syntaxhighlighter |
49 |
|
|
Requires: horde-ckeditor |
50 |
|
|
%endif |
51 |
|
|
# PHP stuff, from package.xml |
52 |
|
|
Requires: php(language) >= 5.3.0 |
53 |
|
|
Requires: php-filter |
54 |
|
|
Requires: php-gettext |
55 |
|
|
Requires: php-hash |
56 |
|
|
Requires: php-pear(PEAR) >= 1.7.0 |
57 |
|
|
Requires: php-channel(%{pear_channel}) |
58 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Role) >= 1.0.0 |
59 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Alarm) >= 2.1.0 |
60 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Alarm) < 3.0.0 |
61 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Argv) >= 2.0.0 |
62 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Argv) < 3.0.0 |
63 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Auth) >= 2.0.0 |
64 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Auth) < 3.0.0 |
65 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Autoloader) >= 2.1.0 |
66 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Autoloader) < 3.0.0 |
67 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Browser) >= 2.0.0 |
68 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Browser) < 3.0.0 |
69 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Core) >= 2.12.0 |
70 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Core) < 3.0.0 |
71 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Date) >= 2.0.0 |
72 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Date) < 3.0.0 |
73 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0 |
74 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0 |
75 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Form) >= 2.0.0 |
76 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Form) < 3.0.0 |
77 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Group) >= 2.0.0 |
78 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Group) < 3.0.0 |
79 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Http) >= 2.0.0 |
80 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Http) < 3.0.0 |
81 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Image) >= 2.0.0 |
82 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Image) < 3.0.0 |
83 |
|
|
Requires: php-pear(%{pear_channel}/Horde_LoginTasks) >= 2.0.0 |
84 |
|
|
Requires: php-pear(%{pear_channel}/Horde_LoginTasks) < 3.0.0 |
85 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Mail) >= 2.0.0 |
86 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Mail) < 3.0.0 |
87 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Mime) >= 2.0.0 |
88 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Mime) < 3.0.0 |
89 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Nls) >= 2.0.0 |
90 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Nls) < 3.0.0 |
91 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Perms) >= 2.1.5 |
92 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Perms) < 3.0.0 |
93 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Prefs) >= 2.0.0 |
94 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Prefs) < 3.0.0 |
95 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Rpc) >= 2.0.0 |
96 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Rpc) < 3.0.0 |
97 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Serialize) >= 2.0.0 |
98 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Serialize) < 3.0.0 |
99 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0 |
100 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Support) < 3.0.0 |
101 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Text_Diff) >= 2.0.0 |
102 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Text_Diff) < 3.0.0 |
103 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Token) >= 2.0.0 |
104 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Token) < 3.0.0 |
105 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Text_Filter) >= 2.0.0 |
106 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Text_Filter) < 3.0.0 |
107 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Tree) >= 2.0.0 |
108 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Tree) < 3.0.0 |
109 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Url) >= 2.0.0 |
110 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Url) < 3.0.0 |
111 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0 |
112 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0 |
113 |
|
|
Requires: php-pear(%{pear_channel}/Horde_View) >= 2.0.0 |
114 |
|
|
Requires: php-pear(%{pear_channel}/Horde_View) < 3.0.0 |
115 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Vfs) >= 2.0.0 |
116 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Vfs) < 3.0.0 |
117 |
|
|
# Optional |
118 |
|
|
Requires: php-pear(File_Find) |
119 |
|
|
Requires: php-pear(File_Fstab) |
120 |
|
|
Requires: php-pear(Console_Getopt) |
121 |
|
|
Requires: php-pear(Console_Table) |
122 |
|
|
Requires: php-pear(Net_DNS2) |
123 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Feed) >= 2.0.0 |
124 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Feed) < 3.0.0 |
125 |
|
|
Requires: php-pear(%{pear_channel}/Horde_OpenXchange) >= 1.0.0 |
126 |
|
|
Requires: php-pear(%{pear_channel}/Horde_OpenXchange) < 2.0.0 |
127 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Service_Weather) >= 2.2.0 |
128 |
|
|
Requires: php-pear(%{pear_channel}/Horde_Service_Weather) < 3.0.0 |
129 |
|
|
# Optional but implicitly required |
130 |
|
|
# Horde_Db, Horde_Oauth, Horde_SyncMl |
131 |
|
|
# Optional but TODO |
132 |
|
|
# Horde_Service_Facebook |
133 |
|
|
# Horde_Service_Twitter |
134 |
|
|
# From phpcompatinfo report for version 5.1.6 |
135 |
|
|
Requires: php-calendar |
136 |
|
|
Requires: php-date |
137 |
|
|
Requires: php-fileinfo |
138 |
|
|
Requires: php-iconv |
139 |
|
|
Requires: php-json |
140 |
|
|
Requires: php-libxml |
141 |
|
|
Requires: php-pcre |
142 |
|
|
Requires: php-posix |
143 |
|
|
Requires: php-session |
144 |
|
|
Requires: php-soap |
145 |
|
|
Requires: php-spl |
146 |
|
|
|
147 |
|
|
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version} |
148 |
|
|
Provides: php-composer(horde/horde) = %{version} |
149 |
|
|
Obsoletes: horde < 5 |
150 |
|
|
Provides: horde = %{version} |
151 |
|
|
|
152 |
|
|
|
153 |
|
|
%description |
154 |
|
|
The Horde Application Framework is a flexible, modular, general-purpose web |
155 |
|
|
application framework written in PHP. It provides an extensive array of |
156 |
|
|
components that are targeted at the common problems and tasks involved in |
157 |
|
|
developing modern web applications. It is the basis for a large number of |
158 |
|
|
production-level web applications, notably the Horde Groupware suites. For |
159 |
|
|
more information on Horde or the Horde Groupware suites, visit |
160 |
|
|
http://www.horde.org. |
161 |
|
|
|
162 |
|
|
%prep |
163 |
|
|
%setup -q -c |
164 |
|
|
cd %{pear_name}-%{version} |
165 |
|
|
|
166 |
|
|
# Don't install .po and .pot files |
167 |
|
|
# Remove checksum for .mo, as we regenerate them |
168 |
|
|
sed -e '/%{pear_name}\.po/d' \ |
169 |
|
|
-e '/htaccess/d' \ |
170 |
|
|
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \ |
171 |
|
|
../package.xml >%{name}.xml |
172 |
|
|
touch -r ../package.xml %{name}.xml |
173 |
|
|
|
174 |
|
|
|
175 |
|
|
%build |
176 |
|
|
cd %{pear_name}-%{version} |
177 |
|
|
|
178 |
|
|
# Regenerate the locales |
179 |
|
|
for po in $(find locale -name \*.po) |
180 |
|
|
do |
181 |
|
|
msgfmt $po -o $(dirname $po)/$(basename $po .po).mo |
182 |
|
|
done |
183 |
|
|
|
184 |
|
|
|
185 |
|
|
%install |
186 |
|
|
cd %{pear_name}-%{version} |
187 |
|
|
%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml |
188 |
|
|
|
189 |
|
|
# Clean up unnecessary files |
190 |
|
|
rm -rf %{buildroot}%{pear_metadir}/.??* |
191 |
|
|
|
192 |
|
|
# Install XML package description |
193 |
|
|
mkdir -p %{buildroot}%{pear_xmldir} |
194 |
|
|
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir} |
195 |
|
|
|
196 |
|
|
# Move configuration to /etc |
197 |
|
|
mkdir -p %{buildroot}%{_sysconfdir} |
198 |
|
|
mv %{buildroot}%{pear_hordedir}/config \ |
199 |
|
|
%{buildroot}%{_sysconfdir}/horde |
200 |
|
|
ln -s %{_sysconfdir}/horde %{buildroot}%{pear_hordedir}/config |
201 |
|
|
|
202 |
|
|
install -Dpm 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/httpd/conf.d/%{name}.conf |
203 |
|
|
%if ! %{with_sysjs} |
204 |
|
|
sed -e '\:horde/js:d' \ |
205 |
|
|
-e '\:Javascript:d' \ |
206 |
|
|
-i %{buildroot}%{_sysconfdir}/httpd/conf.d/%{name}.conf |
207 |
|
|
%endif |
208 |
|
|
|
209 |
|
|
# Log |
210 |
|
|
install -dm 770 %{buildroot}%{_localstatedir}/log/horde |
211 |
|
|
cat <<EOF | tee -a %{buildroot}%{_sysconfdir}/horde/conf.php.dist |
212 |
|
|
\$conf['log']['name'] = '/var/log/horde/horde.log'; |
213 |
|
|
\$conf['log']['params']['append'] = true; |
214 |
|
|
\$conf['log']['params']['format'] = 'default'; |
215 |
|
|
\$conf['log']['type'] = 'file'; |
216 |
|
|
\$conf['log']['enabled'] = true; |
217 |
|
|
EOF |
218 |
|
|
# Cache |
219 |
|
|
install -dm 770 %{buildroot}%{_localstatedir}/lib/horde/cache |
220 |
|
|
cat <<EOF | tee -a %{buildroot}%{_sysconfdir}/horde/conf.php.dist |
221 |
|
|
\$conf['cache']['default_lifetime'] = 86400; |
222 |
|
|
\$conf['cache']['params']['dir'] = '/var/lib/horde/cache'; |
223 |
|
|
\$conf['cache']['params']['sub'] = 0; |
224 |
|
|
\$conf['cache']['driver'] = 'File'; |
225 |
|
|
\$conf['cache']['use_memorycache'] = ''; |
226 |
|
|
EOF |
227 |
|
|
# Static |
228 |
|
|
mv %{buildroot}%{pear_hordedir}/static \ |
229 |
|
|
%{buildroot}%{_localstatedir}/lib/horde/static |
230 |
|
|
ln -s %{_localstatedir}/lib/horde/static \ |
231 |
|
|
%{buildroot}%{pear_hordedir}/static |
232 |
|
|
|
233 |
|
|
# Logrotate |
234 |
|
|
install -Dm 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/logrotate.d/horde |
235 |
|
|
|
236 |
|
|
# Configuration |
237 |
|
|
cp %{buildroot}%{_sysconfdir}/horde/conf.php.dist \ |
238 |
|
|
%{buildroot}%{_sysconfdir}/horde/conf.php |
239 |
|
|
|
240 |
|
|
# Locales |
241 |
|
|
for loc in locale/{??,??_??} |
242 |
|
|
do |
243 |
|
|
lang=$(basename $loc) |
244 |
|
|
test -d %{buildroot}%{pear_hordedir}/$loc \ |
245 |
|
|
&& echo "%%lang(${lang%_*}) %{pear_hordedir}/$loc" |
246 |
|
|
done | tee ../%{pear_name}.lang |
247 |
|
|
|
248 |
|
|
|
249 |
|
|
%pretrans |
250 |
|
|
if [ -d %{pear_hordedir}/static -a ! -L %{pear_hordedir}/static ] |
251 |
|
|
then |
252 |
|
|
save=%{pear_hordedir}/static.rpmsave |
253 |
|
|
while [ -e $save ] |
254 |
|
|
do save=${save}_ |
255 |
|
|
done |
256 |
|
|
mv %{pear_hordedir}/static $save |
257 |
|
|
fi |
258 |
|
|
|
259 |
|
|
|
260 |
|
|
%post |
261 |
|
|
%{__pear} install --nodeps --soft --force --register-only \ |
262 |
|
|
%{pear_xmldir}/%{name}.xml >/dev/null || : |
263 |
|
|
|
264 |
|
|
%postun |
265 |
|
|
if [ $1 -eq 0 ] ; then |
266 |
|
|
%{__pear} uninstall --nodeps --ignore-errors --register-only \ |
267 |
|
|
%{pear_channel}/%{pear_name} >/dev/null || : |
268 |
|
|
fi |
269 |
|
|
|
270 |
|
|
|
271 |
|
|
%files -f %{pear_name}.lang |
272 |
|
|
%doc %{pear_docdir}/%{pear_name} |
273 |
|
|
%config(noreplace) %{_sysconfdir}/httpd/conf.d/%{name}.conf |
274 |
|
|
%config(noreplace) %{_sysconfdir}/logrotate.d/horde |
275 |
|
|
%attr(0770,apache,apache) %dir %{_sysconfdir}/horde |
276 |
|
|
%attr(0770,apache,apache) %dir %{_sysconfdir}/horde/registry.d |
277 |
|
|
%attr(0640,apache,apache) %config %{_sysconfdir}/horde/*.dist |
278 |
|
|
%attr(0660,apache,apache) %config(noreplace) %{_sysconfdir}/horde/*.php |
279 |
|
|
%attr(0660,apache,apache) %config %{_sysconfdir}/horde/*.xml |
280 |
|
|
%attr(0640,apache,apache) %{_sysconfdir}/horde/registry.d/README |
281 |
|
|
%{pear_xmldir}/%{name}.xml |
282 |
|
|
%{_bindir}/horde-* |
283 |
|
|
%{pear_hordedir}/*php |
284 |
|
|
%{pear_hordedir}/admin |
285 |
|
|
%{pear_hordedir}/config |
286 |
|
|
%{pear_hordedir}/install |
287 |
|
|
%{pear_hordedir}/lib |
288 |
|
|
%dir %{pear_hordedir}/locale |
289 |
|
|
%{pear_hordedir}/rpc |
290 |
|
|
%{pear_hordedir}/services |
291 |
|
|
%{pear_hordedir}/static |
292 |
|
|
%{pear_hordedir}/templates |
293 |
|
|
%{pear_hordedir}/themes |
294 |
|
|
%{pear_hordedir}/util |
295 |
|
|
%{pear_hordedir}/js/plupload |
296 |
|
|
%{pear_hordedir}/js/*.js |
297 |
|
|
%{pear_datadir}/%{pear_name} |
298 |
|
|
%attr(750,apache,root) %dir %{_localstatedir}/log/horde |
299 |
|
|
%attr(750,apache,root) %dir %{_localstatedir}/lib/horde |
300 |
|
|
%attr(750,apache,root) %dir %{_localstatedir}/lib/horde/cache |
301 |
|
|
%attr(750,apache,root) %dir %{_localstatedir}/lib/horde/static |
302 |
|
|
%{_localstatedir}/lib/horde/static/README |
303 |
|
|
|
304 |
|
|
|
305 |
|
|
%changelog |
306 |
|
|
* Sat Jul 02 2016 Remi Collet <remi@fedoraproject.org> - 5.2.11-1 |
307 |
|
|
- Update to 5.2.11 |
308 |
|
|
- drop dependency on php-pear-Services-Weather which is |
309 |
|
|
optional, and dead project |
310 |
|
|
|
311 |
|
|
* Mon Mar 21 2016 Remi Collet <remi@fedoraproject.org> - 5.2.10-1 |
312 |
|
|
- Update to 5.2.10 |
313 |
|
|
|
314 |
|
|
* Tue Feb 9 2016 Remi Collet <remi@fedoraproject.org> - 5.2.9-1 |
315 |
|
|
- Update to 5.2.9 |
316 |
|
|
|
317 |
|
|
* Wed Oct 21 2015 Remi Collet <remi@fedoraproject.org> - 5.2.8-1 |
318 |
|
|
- Update to 5.2.8 |
319 |
|
|
|
320 |
|
|
* Sat Aug 01 2015 Remi Collet <remi@fedoraproject.org> - 5.2.7-1 |
321 |
|
|
- Update to 5.2.7 |
322 |
|
|
- raise dependency on Horde_Perms 2.1.5 |
323 |
|
|
|
324 |
|
|
* Thu Jun 18 2015 Remi Collet <remi@fedoraproject.org> - 5.2.6-1 |
325 |
|
|
- Update to 5.2.6 |
326 |
|
|
|
327 |
|
|
* Wed Apr 29 2015 Remi Collet <remi@fedoraproject.org> - 5.2.5-1 |
328 |
|
|
- Update to 5.2.5 |
329 |
|
|
|
330 |
|
|
* Tue Feb 10 2015 Remi Collet <remi@fedoraproject.org> - 5.2.4-1 |
331 |
|
|
- Update to 5.2.4 |
332 |
|
|
- provides php-composer(horde/horde) |
333 |
|
|
|
334 |
|
|
* Wed Dec 03 2014 Remi Collet <remi@fedoraproject.org> - 5.2.3-1 |
335 |
|
|
- Update to 5.2.3 |
336 |
|
|
|
337 |
|
|
* Wed Oct 29 2014 Remi Collet <remi@fedoraproject.org> - 5.2.2-1 |
338 |
|
|
- Update to 5.2.2 |
339 |
|
|
|
340 |
|
|
* Tue Sep 23 2014 Remi Collet <remi@fedoraproject.org> - 5.2.1-2 |
341 |
|
|
- don't use system javascript libraries as this breaks horde |
342 |
|
|
and its cache system |
343 |
|
|
- use /var/log/horde for logging |
344 |
|
|
- use /var/lib/horde/cache for caching |
345 |
|
|
- use /var/lib/horde/static for js and css cache |
346 |
|
|
- fix regex filter, fix missing horde-power*.png |
347 |
|
|
|
348 |
|
|
* Mon Aug 04 2014 Remi Collet <remi@fedoraproject.org> - 5.2.1-1 |
349 |
|
|
- Update to 5.2.1 |
350 |
|
|
|
351 |
|
|
* Wed Jul 23 2014 Remi Collet <remi@fedoraproject.org> - 5.2.0-1 |
352 |
|
|
- Update to 5.2.0 |
353 |
|
|
- raise dep on Horde_Alarm, Horde_Autoloader, Horde_Core |
354 |
|
|
and Horde_Service_Weather |
355 |
|
|
- use bundled ckeditor |
356 |
|
|
- add optional dep on Horde_OpenXchange |
357 |
|
|
|
358 |
|
|
* Mon Jul 07 2014 Remi Collet <remi@fedoraproject.org> - 5.1.7-1 |
359 |
|
|
- Update to 5.1.7 |
360 |
|
|
|
361 |
|
|
* Tue Apr 29 2014 Remi Collet <remi@fedoraproject.org> - 5.1.6-3 |
362 |
|
|
- obsoletes horde only in f21 and epel7 |
363 |
|
|
|
364 |
|
|
* Sun Apr 13 2014 Remi Collet <remi@fedoraproject.org> - 5.1.6-2 |
365 |
|
|
- comments from review #949038 |
366 |
|
|
- missing dep on php-filter and php-json |
367 |
|
|
|
368 |
|
|
* Fri Mar 07 2014 Remi Collet <remi@fedoraproject.org> - 5.1.6-1 |
369 |
|
|
- Update to 5.1.6 |
370 |
|
|
- raide dependency: Horde_Core >= 2.11.0 |
371 |
|
|
|
372 |
|
|
* Tue Oct 29 2013 Remi Collet <remi@fedoraproject.org> - 5.1.5-1 |
373 |
|
|
- Update to 5.1.5 |
374 |
|
|
- raide dependency: Horde_Core >= 2.10.0 |
375 |
|
|
|
376 |
|
|
* Sun Sep 08 2013 Remi Collet <remi@fedoraproject.org> - 5.1.4-1 |
377 |
|
|
- Update to 5.1.4 |
378 |
|
|
|
379 |
|
|
* Tue Aug 27 2013 Remi Collet <remi@fedoraproject.org> - 5.1.3-1 |
380 |
|
|
- Update to 5.1.3 |
381 |
|
|
- raise dependency Horde_Core >= 2.7.0 |
382 |
|
|
|
383 |
|
|
* Wed Jul 17 2013 Remi Collet <remi@fedoraproject.org> - 5.1.2-1 |
384 |
|
|
- Update to 5.1.2 |
385 |
|
|
|
386 |
|
|
* Tue Jun 18 2013 Remi Collet <remi@fedoraproject.org> - 5.1.1-1 |
387 |
|
|
- Update to 5.1.1 |
388 |
|
|
|
389 |
|
|
* Wed Jun 05 2013 Remi Collet <remi@fedoraproject.org> - 5.1.0-1 |
390 |
|
|
- Update to 5.1.0 |
391 |
|
|
- raise dependency on Horde_Core 2.5.0 |
392 |
|
|
- drop dependency on Horde_Template |
393 |
|
|
|
394 |
|
|
* Fri May 31 2013 Remi Collet <remi@fedoraproject.org> - 5.0.5-1 |
395 |
|
|
- Update to 5.0.5 |
396 |
|
|
- switch from Conflicts to Requires |
397 |
|
|
|
398 |
|
|
* Fri Apr 5 2013 Remi Collet <remi@fedoraproject.org> - 5.0.4-2 |
399 |
|
|
- improves optional dependencies |
400 |
|
|
|
401 |
|
|
* Tue Feb 12 2013 Remi Collet <remi@fedoraproject.org> - 5.0.4-1 |
402 |
|
|
- Update to 5.0.4 |
403 |
|
|
|
404 |
|
|
* Thu Jan 24 2013 Remi Collet <remi@fedoraproject.org> - 5.0.3-3 |
405 |
|
|
- define Alias for JavaScript Libraries |
406 |
|
|
|
407 |
|
|
* Sun Jan 13 2013 Remi Collet <remi@fedoraproject.org> - 5.0.3-2 |
408 |
|
|
- obsoletes/provides horde |
409 |
|
|
|
410 |
|
|
* Thu Jan 10 2013 Remi Collet <remi@fedoraproject.org> - 5.0.3-1 |
411 |
|
|
- Update to 5.0.3 |
412 |
|
|
- use local script instead of find_lang |
413 |
|
|
- add more optional requires |
414 |
|
|
|
415 |
|
|
* Mon Nov 19 2012 Remi Collet <remi@fedoraproject.org> - 5.0.2-2 |
416 |
|
|
- fix apache config and rename to php-horde-horde.conf |
417 |
|
|
|
418 |
|
|
* Thu Nov 15 2012 Remi Collet <remi@fedoraproject.org> - 5.0.2-1 |
419 |
|
|
- update to 5.0.2 |
420 |
|
|
|
421 |
|
|
* Wed Nov 7 2012 Remi Collet <remi@fedoraproject.org> - 5.0.1-1 |
422 |
|
|
- update to 5.0.1 |
423 |
|
|
|
424 |
|
|
* Sun Nov 4 2012 Remi Collet <remi@fedoraproject.org> - 5.0.0-2 |
425 |
|
|
- fix locale |
426 |
|
|
|
427 |
|
|
* Sun Nov 4 2012 Remi Collet <remi@fedoraproject.org> - 5.0.0-1 |
428 |
|
|
- Initial package |