1 |
%define peardir %(pear config-get php_dir 2> /dev/null || echo %{_datadir}/pear) |
2 |
%define xmldir /var/lib/pear |
3 |
%global pear_name Date_Holidays_France |
4 |
%define name php-pear-Date-Holidays-France |
5 |
%define version 0.1.0 |
6 |
%define release 4 |
7 |
|
8 |
Summary: Driver based class to calculate holidays in France |
9 |
Name: %{name} |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
Summary: Driver based class to calculate holidays in France |
13 |
License: PHP License |
14 |
Group: Development/Libraries |
15 |
Source0: http://pear.php.net/get/Date_Holidays_France-%{version}.tgz |
16 |
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n) |
17 |
URL: http://pear.php.net/package/Date_Holidays_France |
18 |
|
19 |
BuildRequires: php-pear(PEAR) >= 1.4.7 |
20 |
Requires: php-pear(Date_Holidays) >= 0.18.0 |
21 |
Requires: php-pear(PEAR) >= 1.4.0b1 |
22 |
Provides: php-pear(%{pear_name}) = %{version} |
23 |
|
24 |
#BuildRequires: PEAR::PEAR >= 1.4.7 |
25 |
#Requires: PEAR::Date_Holidays >= 0.18.0 |
26 |
#Requires: PEAR::PEAR >= 1.4.0b1 |
27 |
|
28 |
BuildArch: noarch |
29 |
|
30 |
%description |
31 |
Date_Holidays helps you calculate the dates and titles of holidays and |
32 |
other special celebrations. This is the driver for calculating holidays in |
33 |
France. |
34 |
|
35 |
%prep |
36 |
%setup -c -T |
37 |
pear -v -c pearrc \ |
38 |
-d php_dir=%{peardir} \ |
39 |
-d doc_dir=/docs \ |
40 |
-d bin_dir=%{_bindir} \ |
41 |
-d data_dir=%{peardir}/data \ |
42 |
-d test_dir=%{peardir}/tests \ |
43 |
-d ext_dir=%{_libdir} \ |
44 |
-s |
45 |
|
46 |
%build |
47 |
|
48 |
%install |
49 |
rm -rf %{buildroot} |
50 |
pear -c pearrc install --nodeps --packagingroot %{buildroot} %{SOURCE0} |
51 |
|
52 |
# Clean up unnecessary files |
53 |
rm pearrc |
54 |
rm -rf %{buildroot}/%{peardir}/.filemap |
55 |
rm -rf %{buildroot}/%{peardir}/.lock |
56 |
rm -rf %{buildroot}/%{peardir}/.registry |
57 |
rm -rf %{buildroot}%{peardir}/.channels |
58 |
|
59 |
rm -rf %{buildroot}/%{xmldir}/.filemap |
60 |
rm -rf %{buildroot}/%{xmldir}/.lock |
61 |
rm -rf %{buildroot}/%{xmldir}/.registry |
62 |
rm -rf %{buildroot}/%{xmldir}/.channels |
63 |
if [[ -f %{buildroot}%{xmldir}/.depdb ]] ;then |
64 |
rm -rf %{buildroot}%{xmldir}/.depdb |
65 |
fi |
66 |
if [[ -f %{buildroot}{xmldir}/.depdblock ]] ;then |
67 |
rm -rf %{buildroot}%{xmldir}/.depdblock |
68 |
fi |
69 |
|
70 |
|
71 |
# Install XML package description |
72 |
mkdir -p %{buildroot}%{xmldir} |
73 |
tar -xzf %{SOURCE0} package.xml |
74 |
cp -p package.xml %{buildroot}%{xmldir}/Date_Holidays_France.xml |
75 |
|
76 |
%clean |
77 |
rm -rf %{buildroot} |
78 |
|
79 |
%post |
80 |
pear install --nodeps --soft --force --register-only %{xmldir}/Date_Holidays_France.xml >/dev/null || : |
81 |
|
82 |
%postun |
83 |
if [ "$1" -eq "0" ]; then |
84 |
pear uninstall --nodeps --ignore-errors --register-only pear.php.net/Date_Holidays_France >/dev/null || : |
85 |
fi |
86 |
|
87 |
%files |
88 |
%defattr(-,root,root) |
89 |
|
90 |
%{peardir}/* |
91 |
%{xmldir}/Date_Holidays_France.xml |
92 |
|
93 |
%changelog |
94 |
* Mon Jul 25 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1.0-4.sme |
95 |
- fix Summury refering to a different country than France. |
96 |
|
97 |
* Sun Jul 24 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1.0-3.sme |
98 |
- rebuild |
99 |
|
100 |
* Thu Jun 16 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1.0-1.sme |
101 |
- importing to buildsys pear packages for Horde [SME: 9600] |