1 |
slords |
1.1 |
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}} |
2 |
|
|
%define pear_name Log |
3 |
|
|
|
4 |
|
|
Summary: Abstracted logging facility for PHP |
5 |
|
|
Summary(fr): Abstraction des outils d'enregistrement de traces pour PHP |
6 |
|
|
Name: php-pear-Log |
7 |
|
|
Version: 1.9.13 |
8 |
|
|
Release: 1%{?dist} |
9 |
|
|
License: PHP |
10 |
|
|
Group: Development/Libraries |
11 |
|
|
Source: http://pear.php.net/get/Log-%{version}.tgz |
12 |
|
|
Source2: xml2changelog |
13 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
14 |
|
|
URL: http://pear.php.net/package/Log |
15 |
|
|
|
16 |
|
|
BuildArch: noarch |
17 |
|
|
BuildRequires: php-pear >= 1:1.4.9-1.2 |
18 |
|
|
Requires: php-pear(PEAR) >= 1.4.9 |
19 |
|
|
Requires: php-pear(DB) >= 1.3 |
20 |
|
|
Requires: php-pear(MDB2) >= 2.0.0 |
21 |
|
|
Requires(post): %{__pear} |
22 |
|
|
Requires(postun): %{__pear} |
23 |
|
|
Provides: php-pear(Log) = %{version} |
24 |
|
|
|
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
The Log framework provides an abstracted logging system. |
28 |
|
|
It supports logging to console, file, syslog, SQL, Sqlite, mail, and mcal |
29 |
|
|
targets. It also provides a subject - observer mechanism. |
30 |
|
|
|
31 |
|
|
php-pear-Log can optionally use package "php-pear-DB" (version >= 1.3) |
32 |
|
|
and "php-pear-MDB2" (version >= 2.0.0RC1). |
33 |
|
|
|
34 |
|
|
|
35 |
|
|
%description -l fr |
36 |
|
|
L'extension "log" fournit un sytème d'abstraction des enregistrements |
37 |
|
|
de traces. Il gère l'affichage sur la console, l'enregistrement dans un |
38 |
|
|
fichier, dans le "syslog", dans une base SQL ou Sqlite, l'envoi de mails |
39 |
|
|
ou la création d'évenements à un calendrier "mcal". |
40 |
|
|
|
41 |
|
|
php-pear-Log peut optionellement utiliser les extensions |
42 |
|
|
"php-pear-DB" (version >= 1.3) et "php-pear-MDB2" (version >= 2.0.0RC1). |
43 |
|
|
|
44 |
|
|
|
45 |
|
|
%prep |
46 |
|
|
%setup -c -q |
47 |
|
|
%{_bindir}/php -n %{SOURCE2} package.xml >CHANGELOG |
48 |
|
|
mv package.xml %{pear_name}-%{version}/%{pear_name}.xml |
49 |
|
|
|
50 |
|
|
|
51 |
|
|
%build |
52 |
|
|
# Empty build section |
53 |
|
|
|
54 |
|
|
|
55 |
|
|
%install |
56 |
|
|
rm -rf %{buildroot} docdir |
57 |
|
|
|
58 |
|
|
pushd Log-%{version} |
59 |
|
|
%{__pear} install --nodeps --packagingroot %{buildroot} %{pear_name}.xml |
60 |
|
|
|
61 |
|
|
# Clean up unnecessary files |
62 |
|
|
rm -rf %{buildroot}%{pear_phpdir}/.??* |
63 |
|
|
|
64 |
|
|
# Install XML package description |
65 |
|
|
%{__mkdir_p} %{buildroot}%{pear_xmldir} |
66 |
|
|
%{__install} -pm 644 Log.xml %{buildroot}%{pear_xmldir} |
67 |
|
|
|
68 |
|
|
popd |
69 |
|
|
# Sort out documentation |
70 |
|
|
mv %{buildroot}%{pear_docdir}/%{pear_name}/docs docdir |
71 |
|
|
|
72 |
|
|
|
73 |
|
|
%clean |
74 |
|
|
rm -rf %{buildroot} |
75 |
|
|
|
76 |
|
|
|
77 |
|
|
%check |
78 |
|
|
lst=$(find %{buildroot}%{pear_phpdir} -exec grep -q %{buildroot} {} \; -print) |
79 |
|
|
[ ! -z "$lst" ] && echo "Reference to BUILDROOT in $lst" && exit 1; |
80 |
|
|
|
81 |
|
|
# For documentation purpose only |
82 |
|
|
# After install, as root : |
83 |
|
|
# pear run-tests -p Log |
84 |
|
|
# Should return |
85 |
|
|
# 14 PASSED TESTS |
86 |
|
|
# 2 SKIPPED TESTS |
87 |
|
|
|
88 |
|
|
|
89 |
|
|
%post |
90 |
|
|
%{__pear} install --nodeps --soft --force --register-only %{pear_xmldir}/%{pear_name}.xml >/dev/null || : |
91 |
|
|
|
92 |
|
|
|
93 |
|
|
%postun |
94 |
|
|
if [ "$1" -eq "0" ]; then |
95 |
|
|
%{__pear} uninstall --nodeps --ignore-errors --register-only %{pear_name} >/dev/null || : |
96 |
|
|
fi |
97 |
|
|
|
98 |
|
|
|
99 |
|
|
%files |
100 |
|
|
%defattr(-,root,root,-) |
101 |
|
|
%doc CHANGELOG docdir/* |
102 |
|
|
%{pear_phpdir}/Log |
103 |
|
|
%{pear_phpdir}/Log.php |
104 |
|
|
%{pear_testdir}/Log |
105 |
|
|
%{pear_datadir}/Log |
106 |
|
|
%{pear_xmldir}/%{pear_name}.xml |
107 |
|
|
|
108 |
|
|
|
109 |
|
|
%changelog |
110 |
|
|
* Thu Dec 13 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.13-1 |
111 |
|
|
- update to 1.9.13 |
112 |
|
|
- add documentation in %%check (post install only) |
113 |
|
|
|
114 |
|
|
* Wed Dec 12 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.12-1 |
115 |
|
|
- update to 1.9.12 |
116 |
|
|
|
117 |
|
|
* Fri Aug 24 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.11-2 |
118 |
|
|
- Fix License |
119 |
|
|
|
120 |
|
|
* Sat May 02 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.11-1 |
121 |
|
|
- update to 1.9.11 |
122 |
|
|
|
123 |
|
|
* Mon Feb 12 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.10-1 |
124 |
|
|
- update to 1.9.10 |
125 |
|
|
- All tests succeed with php-5.2.x : http://pear.php.net/bugs/bug.php?id=9023 |
126 |
|
|
|
127 |
|
|
* Sat Oct 28 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.9-1 |
128 |
|
|
- update to 1.9.9 |
129 |
|
|
|
130 |
|
|
* Sat Sep 16 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-6 |
131 |
|
|
- add CHANGELOG to %%doc |
132 |
|
|
|
133 |
|
|
* Fri Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-5.fc5.1 |
134 |
|
|
- rebuild for FC5 |
135 |
|
|
|
136 |
|
|
* Thu Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-5 |
137 |
|
|
- BR php-pear >= 1:1.4.9-1.2 |
138 |
|
|
|
139 |
|
|
* Thu Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-4 |
140 |
|
|
- last template.spec |
141 |
|
|
|
142 |
|
|
* Mon Sep 04 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-3 |
143 |
|
|
- new and simpler %%prep and %%install |
144 |
|
|
|
145 |
|
|
* Sat Sep 02 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-2 |
146 |
|
|
- failsafe scriplet |
147 |
|
|
|
148 |
|
|
* Tue Aug 01 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-1 |
149 |
|
|
- update to 1.9.8 |
150 |
|
|
|
151 |
|
|
* Tue Jul 11 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.7-1 |
152 |
|
|
- update to 1.9.7 |
153 |
|
|
- use new macros from /etc/rpm/macros.pear |
154 |
|
|
|
155 |
|
|
* Tue May 30 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.6-1 |
156 |
|
|
- install Licence in prep |
157 |
|
|
- update to 1.9.6 |
158 |
|
|
|
159 |
|
|
* Mon May 15 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-3 |
160 |
|
|
- Require pear >= 1.4.9 |
161 |
|
|
- Requires(hint): (only comment actually) + description |
162 |
|
|
- bundle the v3.01 PHP LICENSE file (as in php-pear) |
163 |
|
|
- use --packagingroot (instead of -R) |
164 |
|
|
- check from install to check (as in php-pear) |
165 |
|
|
|
166 |
|
|
* Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-2 |
167 |
|
|
- cleanning (description-line-too-long) |
168 |
|
|
|
169 |
|
|
* Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-1 |
170 |
|
|
- use %%{_datadir}/pear/.pkgxml for XML (Bug #190252) |
171 |
|
|
- update to 1.9.5 |
172 |
|
|
- workaround for buggy pear 1.4.6 installer |
173 |
|
|
|
174 |
|
|
* Thu Apr 27 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.4-1 |
175 |
|
|
- spec for extras |
176 |
|
|
- add french summary & description |
177 |
|
|
|
178 |
|
|
* Wed Apr 26 2006 Remi Collet <rpms@FamilleCollet.com> 1.9.4-1.fc{3,4,5}.remi |
179 |
|
|
- update to 1.9.4 |
180 |
|
|
|
181 |
|
|
* Thu Apr 06 2006 Remi Collet <rpms@FamilleCollet.com> 1.9.3-1.fc{3,4,5}.remi |
182 |
|
|
- initial RPM |