1 |
slords |
1.1 |
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}} |
2 |
|
|
%define pear_name Log |
3 |
|
|
|
4 |
|
|
Summary: Abstracted logging facility for PHP |
5 |
|
|
Summary(fr): Abstraction des outils d'enregistrement de traces pour PHP |
6 |
|
|
Name: php-pear-Log |
7 |
|
|
Version: 1.9.13 |
8 |
snetram |
1.2 |
Release: 2%{?dist} |
9 |
slords |
1.1 |
License: PHP |
10 |
|
|
Group: Development/Libraries |
11 |
|
|
Source: http://pear.php.net/get/Log-%{version}.tgz |
12 |
|
|
Source2: xml2changelog |
13 |
snetram |
1.2 |
Patch0: php-pear-Log-1.9.13-prevent-deprecated-messages.patch |
14 |
|
|
Patch1: php-pear-Log-1.9.13-update-checksum.patch |
15 |
slords |
1.1 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
16 |
|
|
URL: http://pear.php.net/package/Log |
17 |
|
|
|
18 |
|
|
BuildArch: noarch |
19 |
|
|
BuildRequires: php-pear >= 1:1.4.9-1.2 |
20 |
|
|
Requires: php-pear(PEAR) >= 1.4.9 |
21 |
|
|
Requires: php-pear(DB) >= 1.3 |
22 |
|
|
Requires: php-pear(MDB2) >= 2.0.0 |
23 |
|
|
Requires(post): %{__pear} |
24 |
|
|
Requires(postun): %{__pear} |
25 |
|
|
Provides: php-pear(Log) = %{version} |
26 |
|
|
|
27 |
|
|
|
28 |
|
|
%description |
29 |
|
|
The Log framework provides an abstracted logging system. |
30 |
|
|
It supports logging to console, file, syslog, SQL, Sqlite, mail, and mcal |
31 |
|
|
targets. It also provides a subject - observer mechanism. |
32 |
|
|
|
33 |
|
|
php-pear-Log can optionally use package "php-pear-DB" (version >= 1.3) |
34 |
|
|
and "php-pear-MDB2" (version >= 2.0.0RC1). |
35 |
|
|
|
36 |
|
|
|
37 |
|
|
%description -l fr |
38 |
|
|
L'extension "log" fournit un sytème d'abstraction des enregistrements |
39 |
|
|
de traces. Il gère l'affichage sur la console, l'enregistrement dans un |
40 |
|
|
fichier, dans le "syslog", dans une base SQL ou Sqlite, l'envoi de mails |
41 |
|
|
ou la création d'évenements à un calendrier "mcal". |
42 |
|
|
|
43 |
|
|
php-pear-Log peut optionellement utiliser les extensions |
44 |
|
|
"php-pear-DB" (version >= 1.3) et "php-pear-MDB2" (version >= 2.0.0RC1). |
45 |
|
|
|
46 |
|
|
|
47 |
|
|
%prep |
48 |
|
|
%setup -c -q |
49 |
|
|
%{_bindir}/php -n %{SOURCE2} package.xml >CHANGELOG |
50 |
|
|
mv package.xml %{pear_name}-%{version}/%{pear_name}.xml |
51 |
snetram |
1.2 |
%patch0 -p1 |
52 |
|
|
%patch1 -p1 |
53 |
slords |
1.1 |
|
54 |
|
|
|
55 |
|
|
%build |
56 |
|
|
# Empty build section |
57 |
|
|
|
58 |
|
|
|
59 |
|
|
%install |
60 |
|
|
rm -rf %{buildroot} docdir |
61 |
|
|
|
62 |
|
|
pushd Log-%{version} |
63 |
|
|
%{__pear} install --nodeps --packagingroot %{buildroot} %{pear_name}.xml |
64 |
|
|
|
65 |
|
|
# Clean up unnecessary files |
66 |
|
|
rm -rf %{buildroot}%{pear_phpdir}/.??* |
67 |
|
|
|
68 |
|
|
# Install XML package description |
69 |
|
|
%{__mkdir_p} %{buildroot}%{pear_xmldir} |
70 |
|
|
%{__install} -pm 644 Log.xml %{buildroot}%{pear_xmldir} |
71 |
|
|
|
72 |
|
|
popd |
73 |
|
|
# Sort out documentation |
74 |
|
|
mv %{buildroot}%{pear_docdir}/%{pear_name}/docs docdir |
75 |
|
|
|
76 |
|
|
|
77 |
|
|
%clean |
78 |
|
|
rm -rf %{buildroot} |
79 |
|
|
|
80 |
|
|
|
81 |
|
|
%check |
82 |
|
|
lst=$(find %{buildroot}%{pear_phpdir} -exec grep -q %{buildroot} {} \; -print) |
83 |
|
|
[ ! -z "$lst" ] && echo "Reference to BUILDROOT in $lst" && exit 1; |
84 |
|
|
|
85 |
|
|
# For documentation purpose only |
86 |
|
|
# After install, as root : |
87 |
|
|
# pear run-tests -p Log |
88 |
|
|
# Should return |
89 |
|
|
# 14 PASSED TESTS |
90 |
|
|
# 2 SKIPPED TESTS |
91 |
|
|
|
92 |
|
|
|
93 |
|
|
%post |
94 |
|
|
%{__pear} install --nodeps --soft --force --register-only %{pear_xmldir}/%{pear_name}.xml >/dev/null || : |
95 |
|
|
|
96 |
|
|
|
97 |
|
|
%postun |
98 |
|
|
if [ "$1" -eq "0" ]; then |
99 |
|
|
%{__pear} uninstall --nodeps --ignore-errors --register-only %{pear_name} >/dev/null || : |
100 |
|
|
fi |
101 |
|
|
|
102 |
|
|
|
103 |
|
|
%files |
104 |
|
|
%defattr(-,root,root,-) |
105 |
|
|
%doc CHANGELOG docdir/* |
106 |
|
|
%{pear_phpdir}/Log |
107 |
|
|
%{pear_phpdir}/Log.php |
108 |
|
|
%{pear_testdir}/Log |
109 |
|
|
%{pear_datadir}/Log |
110 |
|
|
%{pear_xmldir}/%{pear_name}.xml |
111 |
|
|
|
112 |
|
|
|
113 |
|
|
%changelog |
114 |
snetram |
1.2 |
* Mon Sep 19 2011 Jonathan Martens <smeserver-bugzilla@snetram.nl> 1.9.13-2 |
115 |
|
|
- Prevent deprecated messages when using PHP 5.3+ [SME: 6726] |
116 |
|
|
|
117 |
slords |
1.1 |
* Thu Dec 13 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.13-1 |
118 |
|
|
- update to 1.9.13 |
119 |
|
|
- add documentation in %%check (post install only) |
120 |
|
|
|
121 |
|
|
* Wed Dec 12 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.12-1 |
122 |
|
|
- update to 1.9.12 |
123 |
|
|
|
124 |
|
|
* Fri Aug 24 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.11-2 |
125 |
|
|
- Fix License |
126 |
|
|
|
127 |
|
|
* Sat May 02 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.11-1 |
128 |
|
|
- update to 1.9.11 |
129 |
|
|
|
130 |
|
|
* Mon Feb 12 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.10-1 |
131 |
|
|
- update to 1.9.10 |
132 |
|
|
- All tests succeed with php-5.2.x : http://pear.php.net/bugs/bug.php?id=9023 |
133 |
|
|
|
134 |
|
|
* Sat Oct 28 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.9-1 |
135 |
|
|
- update to 1.9.9 |
136 |
|
|
|
137 |
|
|
* Sat Sep 16 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-6 |
138 |
|
|
- add CHANGELOG to %%doc |
139 |
|
|
|
140 |
|
|
* Fri Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-5.fc5.1 |
141 |
|
|
- rebuild for FC5 |
142 |
|
|
|
143 |
|
|
* Thu Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-5 |
144 |
|
|
- BR php-pear >= 1:1.4.9-1.2 |
145 |
|
|
|
146 |
|
|
* Thu Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-4 |
147 |
|
|
- last template.spec |
148 |
|
|
|
149 |
|
|
* Mon Sep 04 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-3 |
150 |
|
|
- new and simpler %%prep and %%install |
151 |
|
|
|
152 |
|
|
* Sat Sep 02 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-2 |
153 |
|
|
- failsafe scriplet |
154 |
|
|
|
155 |
|
|
* Tue Aug 01 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-1 |
156 |
|
|
- update to 1.9.8 |
157 |
|
|
|
158 |
|
|
* Tue Jul 11 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.7-1 |
159 |
|
|
- update to 1.9.7 |
160 |
|
|
- use new macros from /etc/rpm/macros.pear |
161 |
|
|
|
162 |
|
|
* Tue May 30 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.6-1 |
163 |
|
|
- install Licence in prep |
164 |
|
|
- update to 1.9.6 |
165 |
|
|
|
166 |
|
|
* Mon May 15 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-3 |
167 |
|
|
- Require pear >= 1.4.9 |
168 |
|
|
- Requires(hint): (only comment actually) + description |
169 |
|
|
- bundle the v3.01 PHP LICENSE file (as in php-pear) |
170 |
|
|
- use --packagingroot (instead of -R) |
171 |
|
|
- check from install to check (as in php-pear) |
172 |
|
|
|
173 |
|
|
* Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-2 |
174 |
|
|
- cleanning (description-line-too-long) |
175 |
|
|
|
176 |
|
|
* Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-1 |
177 |
|
|
- use %%{_datadir}/pear/.pkgxml for XML (Bug #190252) |
178 |
|
|
- update to 1.9.5 |
179 |
|
|
- workaround for buggy pear 1.4.6 installer |
180 |
|
|
|
181 |
|
|
* Thu Apr 27 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.4-1 |
182 |
|
|
- spec for extras |
183 |
|
|
- add french summary & description |
184 |
|
|
|
185 |
|
|
* Wed Apr 26 2006 Remi Collet <rpms@FamilleCollet.com> 1.9.4-1.fc{3,4,5}.remi |
186 |
|
|
- update to 1.9.4 |
187 |
|
|
|
188 |
|
|
* Thu Apr 06 2006 Remi Collet <rpms@FamilleCollet.com> 1.9.3-1.fc{3,4,5}.remi |
189 |
|
|
- initial RPM |