1 |
slords |
1.1 |
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}} |
2 |
|
|
%define pear_name Log |
3 |
|
|
|
4 |
|
|
Summary: Abstracted logging facility for PHP |
5 |
|
|
Summary(fr): Abstraction des outils d'enregistrement de traces pour PHP |
6 |
|
|
Name: php-pear-Log |
7 |
slords |
1.3 |
Version: 1.11.6 |
8 |
|
|
Release: 1%{?dist} |
9 |
|
|
License: MIT |
10 |
slords |
1.1 |
Group: Development/Libraries |
11 |
|
|
Source: http://pear.php.net/get/Log-%{version}.tgz |
12 |
|
|
Source2: xml2changelog |
13 |
slords |
1.3 |
|
14 |
slords |
1.1 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
15 |
|
|
URL: http://pear.php.net/package/Log |
16 |
|
|
|
17 |
|
|
BuildArch: noarch |
18 |
|
|
BuildRequires: php-pear >= 1:1.4.9-1.2 |
19 |
|
|
Requires: php-pear(PEAR) >= 1.4.9 |
20 |
|
|
Requires: php-pear(DB) >= 1.3 |
21 |
|
|
Requires: php-pear(MDB2) >= 2.0.0 |
22 |
slords |
1.3 |
Requires: php-pear(Mail) |
23 |
slords |
1.1 |
Requires(post): %{__pear} |
24 |
|
|
Requires(postun): %{__pear} |
25 |
|
|
Provides: php-pear(Log) = %{version} |
26 |
|
|
|
27 |
|
|
|
28 |
|
|
%description |
29 |
|
|
The Log framework provides an abstracted logging system. |
30 |
|
|
It supports logging to console, file, syslog, SQL, Sqlite, mail, and mcal |
31 |
|
|
targets. It also provides a subject - observer mechanism. |
32 |
|
|
|
33 |
|
|
php-pear-Log can optionally use package "php-pear-DB" (version >= 1.3) |
34 |
|
|
and "php-pear-MDB2" (version >= 2.0.0RC1). |
35 |
|
|
|
36 |
|
|
|
37 |
|
|
%description -l fr |
38 |
|
|
L'extension "log" fournit un sytème d'abstraction des enregistrements |
39 |
|
|
de traces. Il gère l'affichage sur la console, l'enregistrement dans un |
40 |
|
|
fichier, dans le "syslog", dans une base SQL ou Sqlite, l'envoi de mails |
41 |
|
|
ou la création d'évenements à un calendrier "mcal". |
42 |
|
|
|
43 |
|
|
php-pear-Log peut optionellement utiliser les extensions |
44 |
|
|
"php-pear-DB" (version >= 1.3) et "php-pear-MDB2" (version >= 2.0.0RC1). |
45 |
|
|
|
46 |
|
|
|
47 |
|
|
%prep |
48 |
|
|
%setup -c -q |
49 |
|
|
%{_bindir}/php -n %{SOURCE2} package.xml >CHANGELOG |
50 |
slords |
1.3 |
mv package.xml %{pear_name}-%{version}/%{name}.xml |
51 |
slords |
1.1 |
|
52 |
|
|
|
53 |
|
|
%build |
54 |
|
|
# Empty build section |
55 |
|
|
|
56 |
|
|
|
57 |
|
|
%install |
58 |
|
|
rm -rf %{buildroot} docdir |
59 |
|
|
|
60 |
|
|
pushd Log-%{version} |
61 |
slords |
1.3 |
%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml |
62 |
slords |
1.1 |
|
63 |
|
|
# Clean up unnecessary files |
64 |
|
|
rm -rf %{buildroot}%{pear_phpdir}/.??* |
65 |
|
|
|
66 |
|
|
# Install XML package description |
67 |
|
|
%{__mkdir_p} %{buildroot}%{pear_xmldir} |
68 |
slords |
1.3 |
%{__install} -pm 644 %{name}.xml %{buildroot}%{pear_xmldir} |
69 |
slords |
1.1 |
|
70 |
|
|
popd |
71 |
|
|
# Sort out documentation |
72 |
|
|
mv %{buildroot}%{pear_docdir}/%{pear_name}/docs docdir |
73 |
slords |
1.3 |
mv %{buildroot}%{pear_docdir}/%{pear_name}/examples docdir/examples |
74 |
slords |
1.1 |
|
75 |
|
|
|
76 |
|
|
%clean |
77 |
|
|
rm -rf %{buildroot} |
78 |
|
|
|
79 |
|
|
|
80 |
|
|
%check |
81 |
|
|
lst=$(find %{buildroot}%{pear_phpdir} -exec grep -q %{buildroot} {} \; -print) |
82 |
|
|
[ ! -z "$lst" ] && echo "Reference to BUILDROOT in $lst" && exit 1; |
83 |
|
|
|
84 |
|
|
# For documentation purpose only |
85 |
|
|
# After install, as root : |
86 |
|
|
# pear run-tests -p Log |
87 |
slords |
1.3 |
# Should return (1.11.6) |
88 |
|
|
# 19 PASSED TESTS |
89 |
slords |
1.1 |
# 2 SKIPPED TESTS |
90 |
|
|
|
91 |
|
|
|
92 |
|
|
%post |
93 |
slords |
1.3 |
%{__pear} install --nodeps --soft --force --register-only %{pear_xmldir}/%{name}.xml >/dev/null || : |
94 |
slords |
1.1 |
|
95 |
|
|
|
96 |
|
|
%postun |
97 |
|
|
if [ "$1" -eq "0" ]; then |
98 |
|
|
%{__pear} uninstall --nodeps --ignore-errors --register-only %{pear_name} >/dev/null || : |
99 |
|
|
fi |
100 |
|
|
|
101 |
|
|
|
102 |
|
|
%files |
103 |
|
|
%defattr(-,root,root,-) |
104 |
|
|
%doc CHANGELOG docdir/* |
105 |
|
|
%{pear_phpdir}/Log |
106 |
|
|
%{pear_phpdir}/Log.php |
107 |
|
|
%{pear_testdir}/Log |
108 |
|
|
%{pear_datadir}/Log |
109 |
slords |
1.3 |
%{pear_xmldir}/%{name}.xml |
110 |
slords |
1.1 |
|
111 |
|
|
|
112 |
|
|
%changelog |
113 |
slords |
1.3 |
* Sat Dec 26 2009 Remi Collet <Fedora@FamilleCollet.com> 1.11.6-1 |
114 |
|
|
- update to 1.11.6 |
115 |
|
|
|
116 |
|
|
* Sat Aug 08 2009 Remi Collet <Fedora@FamilleCollet.com> 1.11.5-1 |
117 |
|
|
- update to 1.11.5 |
118 |
|
|
- rename Log.xml to php-pear-Log.xml |
119 |
|
|
|
120 |
|
|
* Sat Nov 22 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.3-1 |
121 |
|
|
- update to 1.11.3 |
122 |
|
|
|
123 |
|
|
* Fri Sep 05 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.2-1 |
124 |
|
|
- update to 1.11.2 |
125 |
|
|
|
126 |
|
|
* Wed Aug 06 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.1-1 |
127 |
|
|
- update to 1.11.1 |
128 |
|
|
|
129 |
|
|
* Sat Jun 28 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.0-1 |
130 |
|
|
- update to 1.11.0 : switch from PHP to MIT license |
131 |
|
|
|
132 |
|
|
* Thu May 08 2008 Remi Collet <Fedora@FamilleCollet.com> 1.10.1-1 |
133 |
|
|
- update to 1.10.1 |
134 |
|
|
|
135 |
|
|
* Sat Jan 26 2008 Remi Collet <Fedora@FamilleCollet.com> 1.10.0-1 |
136 |
|
|
- update to 1.10.0 |
137 |
|
|
- add Requires php-pear(Mail) (new handler) |
138 |
|
|
- remove levels.patch (merged upstream) |
139 |
|
|
|
140 |
|
|
* Sat Jan 26 2008 Remi Collet <Fedora@FamilleCollet.com> 1.9.16-1 |
141 |
|
|
- update to 1.9.16 |
142 |
|
|
- add examples in documentation |
143 |
|
|
- add levels.patch http://pear.php.net/bugs/bug.php?id=12933 |
144 |
|
|
|
145 |
|
|
* Wed Jan 02 2008 Remi Collet <Fedora@FamilleCollet.com> 1.9.14-1 |
146 |
|
|
- update to 1.9.14 |
147 |
snetram |
1.2 |
|
148 |
slords |
1.1 |
* Thu Dec 13 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.13-1 |
149 |
|
|
- update to 1.9.13 |
150 |
|
|
- add documentation in %%check (post install only) |
151 |
|
|
|
152 |
|
|
* Wed Dec 12 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.12-1 |
153 |
|
|
- update to 1.9.12 |
154 |
|
|
|
155 |
|
|
* Fri Aug 24 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.11-2 |
156 |
|
|
- Fix License |
157 |
|
|
|
158 |
|
|
* Sat May 02 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.11-1 |
159 |
|
|
- update to 1.9.11 |
160 |
|
|
|
161 |
|
|
* Mon Feb 12 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.10-1 |
162 |
|
|
- update to 1.9.10 |
163 |
|
|
- All tests succeed with php-5.2.x : http://pear.php.net/bugs/bug.php?id=9023 |
164 |
|
|
|
165 |
|
|
* Sat Oct 28 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.9-1 |
166 |
|
|
- update to 1.9.9 |
167 |
|
|
|
168 |
|
|
* Sat Sep 16 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-6 |
169 |
|
|
- add CHANGELOG to %%doc |
170 |
|
|
|
171 |
|
|
* Fri Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-5.fc5.1 |
172 |
|
|
- rebuild for FC5 |
173 |
|
|
|
174 |
|
|
* Thu Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-5 |
175 |
|
|
- BR php-pear >= 1:1.4.9-1.2 |
176 |
|
|
|
177 |
|
|
* Thu Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-4 |
178 |
|
|
- last template.spec |
179 |
|
|
|
180 |
|
|
* Mon Sep 04 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-3 |
181 |
|
|
- new and simpler %%prep and %%install |
182 |
|
|
|
183 |
|
|
* Sat Sep 02 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-2 |
184 |
|
|
- failsafe scriplet |
185 |
|
|
|
186 |
|
|
* Tue Aug 01 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-1 |
187 |
|
|
- update to 1.9.8 |
188 |
|
|
|
189 |
|
|
* Tue Jul 11 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.7-1 |
190 |
|
|
- update to 1.9.7 |
191 |
|
|
- use new macros from /etc/rpm/macros.pear |
192 |
|
|
|
193 |
|
|
* Tue May 30 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.6-1 |
194 |
|
|
- install Licence in prep |
195 |
|
|
- update to 1.9.6 |
196 |
|
|
|
197 |
|
|
* Mon May 15 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-3 |
198 |
|
|
- Require pear >= 1.4.9 |
199 |
|
|
- Requires(hint): (only comment actually) + description |
200 |
|
|
- bundle the v3.01 PHP LICENSE file (as in php-pear) |
201 |
|
|
- use --packagingroot (instead of -R) |
202 |
|
|
- check from install to check (as in php-pear) |
203 |
|
|
|
204 |
|
|
* Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-2 |
205 |
|
|
- cleanning (description-line-too-long) |
206 |
|
|
|
207 |
|
|
* Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-1 |
208 |
|
|
- use %%{_datadir}/pear/.pkgxml for XML (Bug #190252) |
209 |
|
|
- update to 1.9.5 |
210 |
|
|
- workaround for buggy pear 1.4.6 installer |
211 |
|
|
|
212 |
|
|
* Thu Apr 27 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.4-1 |
213 |
|
|
- spec for extras |
214 |
|
|
- add french summary & description |
215 |
|
|
|
216 |
|
|
* Wed Apr 26 2006 Remi Collet <rpms@FamilleCollet.com> 1.9.4-1.fc{3,4,5}.remi |
217 |
|
|
- update to 1.9.4 |
218 |
|
|
|
219 |
|
|
* Thu Apr 06 2006 Remi Collet <rpms@FamilleCollet.com> 1.9.3-1.fc{3,4,5}.remi |
220 |
|
|
- initial RPM |